#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:13 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:18)
    1. colindixon (colindixon, 17:00:20)
    2. ChrisPrice (ChrisPriceAB, 17:00:28)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2015/tcc/opendaylight-meeting-tcc.2015-06-04-16.59.html last week’s meeting minutes (colindixon, 17:00:43)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-05-28-16.59.html the week before’s meeting minutes because we didn’t do action items last week (colindixon, 17:00:57)
    5. mohnish anumala (mohnish, 17:01:02)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=31181 today’s agenda as it was when the meeting started (colindixon, 17:01:16)
    7. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (colindixon, 17:01:49)
    8. LuisGomez (LuisGomez, 17:02:47)
    9. ACTION: ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and (colindixon, 17:03:08)
    10. dlenrow (dlenrow, 17:03:49)
    11. ACTION: colindixon to draft changes to language around project lifecycles (colindixon, 17:04:11)
    12. ACTION: phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for (colindixon, 17:04:31)
    13. ACTION: gzhao and phrobb1 to find suitable times for Lithium release reviews (colindixon, 17:04:43)
    14. ACTION: colindixon to bump and branch docs (colindixon, 17:04:52)
    15. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=743945554 <--- release review sign up sheet (gzhao, 17:05:17)
    16. alagalah for jmedved (alagalah, 17:06:41)

  2. Updates from the Board on Increased Coverage for Fixing Issues (tbachman, 17:07:13)
    1. Neelajacques says the request came through to the board and the Linux Foundation for increased support coverage outside of US hours (tbachman, 17:08:27)
    2. edwarnicke (edwarnicke, 17:08:32)
    3. Neelajacques had a talk with the CIO, who has hired a LF resource in Australia (though not yet trained on OpenDaylight Infra and tools), who can take a subset of requests (tbachman, 17:09:00)
    4. Neelajacques says they’re also working on a more explicit document to have a clear escalation plan for developers/users anywhere in the world (tbachman, 17:09:41)
    5. Neelajacques says if there’s still an unfulfilled need beyond that, it would require a significant outlay of funds (tbachman, 17:10:11)
    6. Youcef Laribi (Youcef, 17:11:16)

  3. Event Updates (tbachman, 17:11:18)
    1. http://www.opendaylight.org/news/events/ (colindixon, 17:11:30)
    2. phrobb1 says that the ONS is next week (tbachman, 17:11:36)
    3. colindixon says the ONS will have tutorials on Sunday and a developer track on Monday (tbachman, 17:12:26)
    4. https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 please register for the developer forum if you haven’t already (colindixon, 17:12:30)
    5. the OpenDaylight summit is later in July (colindixon, 17:13:24)

  4. Lithium updates (colindixon, 17:13:29)
    1. zxiiro says today is the RC1 cutoff; is doing a test build right now, will have results in ~3hrs (tbachman, 17:14:03)
    2. zxiiro says that most projects have version bumped and branched; the persistence project hasn’t done it yet (Defense4All and docs also haven’t yet) (tbachman, 17:14:43)
    3. zxiiro trying to figure out if there is a probem with how autorelease builds dlux (colindixon, 17:14:49)
    4. ACTION: gzhao and dlenrow to hunt down the persistence project (colindixon, 17:15:31)
    5. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current “weather" (colindixon, 17:16:05)
    6. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 Blocking Bugs (tbachman, 17:16:09)
    7. colindixon says that we did merge the enforcing of IPv6 to stable/lithium, but nothing broke in stable/lithium (tbachman, 17:16:38)
    8. colindixon asks if anyone can shed light on the Neutron Northbound bug (tbachman, 17:17:17)
    9. edwarnicke says this bug comes down to when we get a port that corresponds to a floating IP, there’s no Tenant ID with it (and it should) (tbachman, 17:17:36)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=3656 is a blucking bug which edwarnicke is currently hunting and should be resolved soon (colindixon, 17:17:50)
    11. edwarnicke says that he’s demonstrated that when we get it from neutron to opendaylight, the tenant isn’t there (tbachman, 17:17:54)
    12. edwarnicke says that by the time our ML2 driver has it, it doesn’t have the tenant ID (tbachman, 17:18:05)
    13. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 zxiiro and harman are huting this issue in dlux (colindixon, 17:18:07)
    14. edwarnicke says he sees the tenant ID in an add-port, but not in the floating IP command (tbachman, 17:18:37)
    15. edwarnicke isn’t sure if this is an issue with the CLI command, or if it’s an issue with how the command is being used (tbachman, 17:18:51)
    16. https://bugs.opendaylight.org/show_bug.cgi?id=3368 edwarnicke and regXboi are hunting a bug where neturon isn’t giving tenant IDs for floating bugs (colindixon, 17:18:53)
    17. colindixon says gzhao, et. al. are trying to schedule release reviews (tbachman, 17:19:33)
    18. https://lists.opendaylight.org/pipermail/release/2015-June/002655.html this is gzhao’s mail (colindixon, 17:19:51)
    19. colindixon urges projects to sign up for slots as soon as possible (tbachman, 17:20:14)
    20. gzhao says if you haven’t picked a slot by Friday, you’ll get one assigned to you (colindixon, 17:20:46)
    21. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?usp=sharing RC0 testing spreadsheet (tbachman, 17:20:57)
    22. colindixon says if you haven’t already tested your project against the RC0 product, please do and log any blocking bugs and put it in the spreadsheet (tbachman, 17:21:51)
    23. ACTION: gzhao to hunt people for RC0 reports (colindixon, 17:22:34)
    24. ACTION: gzhao to add tony as an editor for blocking bugs (colindixon, 17:22:47)
    25. LuisGomez asks for those projects not part of the release, what should we do for RC1 (tbachman, 17:23:48)
    26. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1360517736 we’re tracking RC0 issues (not just reports) here (colindixon, 17:23:52)
    27. zxiiro says he believes SNMP4SDN could be added, as they’ve added their code back in (tbachman, 17:24:09)
    28. LuisGomez asks how we should add them; normally the projects push patches to add themselves to integration# (tbachman, 17:24:25)
    29. ACTION: zxiiro and LuisGomez to make sure we add projects that aren’t in integration that don’t break things (colindixon, 17:24:43)
    30. colindixon says if they’ve fixed their issue, we probably should push a patch that adds them back to integration (on their behalf) (tbachman, 17:25:08)
    31. ACTION: gzhao and phrobb1 to reach to projects that can’t be put back in and let them know they will be dropped from the release (colindixon, 17:25:17)
    32. colindixon asks if any of the projects can’t be added back in (tbachman, 17:25:26)
    33. zxiiro says as far as he knows, he can build all the projects (tbachman, 17:25:33)

  5. System Integration and Test (tbachman, 17:26:27)
    1. LuisGomez says no major things have been found other than what’s been reported so far (tbachman, 17:26:47)
    2. LuisGomez says they’ve only received 1 or 2 feedback items from the 40+ projects (tbachman, 17:27:02)
    3. LuisGomez says they can speak about some of the projects (e.g. openflowplugin), but they can’t speak to the quality of the other projects (tbachman, 17:27:29)
    4. VOTE: Voted on "Should the TSC reserve the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th?" Results are, +1: 8 (tbachman, 17:33:28)
    5. AGREED: The TSC reserves the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th? +1, 0, -1 (tbachman, 17:33:31)
    6. ACTION: gzhao to send email to release telling them that the TSC reserves the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th (tbachman, 17:34:09)
    7. ACTION: LuisGomez and tykeal and jamoluhrsen to work out getting a patch merged in openstack to view all historical performance data (colindixon, 17:34:24)

  6. Infrastructure (tbachman, 17:34:33)
    1. tykeal says they’re awaare that the queues are running long (tbachman, 17:34:43)
    2. tykeal says the plugin managing their slaves has gotten jammed up b/c the API behind the slaves has returned junk under load (tbachman, 17:35:15)
    3. tykeal says the 2 projects admitted last week have had their resources built out (tbachman, 17:35:27)

  7. Creation Review for SDK for SDN Apps (tbachman, 17:36:02)
    1. https://wiki.opendaylight.org/view/Project_Proposals:SDNApp-SDK the proposal (colindixon, 17:36:13)
    2. https://wiki.opendaylight.org/view/File:ODL-Be-Incubation-SDNAppSDK-May182015.pdf the slides (colindixon, 17:36:54)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-May/000317.html email for project proposal request (tbachman, 17:37:28)
    4. The current approach for developing apps for SDN is missing a framework, which allows reusability for interfaces and database services (tbachman, 17:38:40)
    5. There also currently aren’t any libs for validation, or audit management for apps (tbachman, 17:39:18)
    6. Developers, Operators, and Security all have different approaches and needs, all of which would benefit from an SDN SDK (tbachman, 17:40:08)
    7. The propsal is a model-driven approach where app developers will write a model object for development (tbachman, 17:41:04)
    8. The framework will provide inspection API for third party tools (tbachman, 17:41:19)
    9. The framework provides start/stop/audit services for application management (tbachman, 17:43:04)
    10. rovarga_ says he’s a bit unclear what the OpenDaylight NB API is (tbachman, 17:43:52)
    11. rovarga_ asks if the applications would be deployed inside the controller, or is this a set of infrastructure outside the controller using RESTCONF (tbachman, 17:44:18)
    12. This would be for applications that live outside of the controller (tbachman, 17:44:35)
    13. rovarga_ asks if these would be an external process to the controller itself (tbachman, 17:45:03)
    14. This will be external to the controller (tbachman, 17:45:11)
    15. dlenrow says he doesn’t think that will work, as the Intent engine is the NB for the controller, which requires it to run on the controller (tbachman, 17:45:36)
    16. edwarnicke says he’s having trouble figuring out what the scope of this project is, and how its well defined and not overly broad (tbachman, 17:46:51)
    17. colindixon asks how is this noticeably different than building a second opendaylight outside of opendaylight (tbachman, 17:48:18)
    18. Their aim is to just be an enabler for things not in ODL — like third party tools (tbachman, 17:49:23)
    19. colindixon says ODL is an extensible framework for people to come in create applications (tbachman, 17:49:56)
    20. rovarga_ notes that a lot of the pieces in the architecture diagram are already pieces in the controller (tbachman, 17:50:36)
    21. edwarnicke says if the project was well scoped, he would feel much better (tbachman, 17:52:21)
    22. ACTION: colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope (tbachman, 17:53:15)
    23. edwarnicke makes it clear that his issue is not with repliating functionality, but that the scope is overly broad (colindixon, 17:53:55)
    24. Sumit says that his experience is that he had a lot of things that he had to do that ODL didnt’ do and this was trying to make that easier (colindixon, 17:57:35)
    25. ACTION: alagalah to work with Sumit and his team to present something at a TWS session (tbachman, 17:59:12)
    26. alagalah to work with Sumit to schedule a TWS call to hear more (alagalah, 17:59:13)
    27. ACTION: colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS (colindixon, 17:59:21)

  8. cookies (tbachman, 18:00:05)


Meeting ended at 18:00:19 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium
  2. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  3. colindixon to draft changes to language around project lifecycles
  4. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
  5. gzhao and phrobb1 to find suitable times for Lithium release reviews
  6. colindixon to bump and branch docs
  7. gzhao and dlenrow to hunt down the persistence project
  8. gzhao to hunt people for RC0 reports
  9. gzhao to add tony as an editor for blocking bugs
  10. zxiiro and LuisGomez to make sure we add projects that aren’t in integration that don’t break things
  11. gzhao and phrobb1 to reach to projects that can’t be put back in and let them know they will be dropped from the release
  12. gzhao to send email to release telling them that the TSC reserves the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th
  13. LuisGomez and tykeal and jamoluhrsen to work out getting a patch merged in openstack to view all historical performance data
  14. colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope
  15. alagalah to work with Sumit and his team to present something at a TWS session
  16. colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS


Action items, by person

  1. alagalah
    1. alagalah to work with Sumit and his team to present something at a TWS session
    2. colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
  2. ChrisPriceAB
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  3. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium
    2. colindixon to draft changes to language around project lifecycles
    3. colindixon to bump and branch docs
    4. colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope
    5. colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
  4. dlenrow
    1. gzhao and dlenrow to hunt down the persistence project
  5. gzhao
    1. gzhao and phrobb1 to find suitable times for Lithium release reviews
    2. gzhao and dlenrow to hunt down the persistence project
    3. gzhao to hunt people for RC0 reports
    4. gzhao to add tony as an editor for blocking bugs
    5. gzhao and phrobb1 to reach to projects that can’t be put back in and let them know they will be dropped from the release
    6. gzhao to send email to release telling them that the TSC reserves the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th
  6. LuisGomez
    1. zxiiro and LuisGomez to make sure we add projects that aren’t in integration that don’t break things
    2. LuisGomez and tykeal and jamoluhrsen to work out getting a patch merged in openstack to view all historical performance data
  7. phrobb
    1. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
  8. phrobb1
    1. gzhao and phrobb1 to find suitable times for Lithium release reviews
    2. gzhao and phrobb1 to reach to projects that can’t be put back in and let them know they will be dropped from the release
    3. colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope
    4. colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
  9. tykeal
    1. LuisGomez and tykeal and jamoluhrsen to work out getting a patch merged in openstack to view all historical performance data


People present (lines said)

  1. tbachman (104)
  2. colindixon (53)
  3. odl_meetbot (13)
  4. phrobb1 (12)
  5. alagalah (9)
  6. ChrisPriceAB (8)
  7. dfarrell07 (5)
  8. rovarga_ (4)
  9. edwarnicke (4)
  10. gzhao (3)
  11. cdub (3)
  12. mohnish (3)
  13. dlenrow (2)
  14. Youcef (2)
  15. LuisGomez (2)
  16. Neelajacques (2)
  17. abhijitkumbhare (2)
  18. ebrjohn (1)
  19. snoble (1)
  20. tykeal (1)
  21. phrobb (0)


Generated by MeetBot 0.1.4.