17:00:27 <colindixon> #startmeeting tsc
17:00:27 <odl_meetbot> Meeting started Thu Jun 18 17:00:27 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:27 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:27 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:36 <colindixon> #topic roll call and agenda bashing
17:00:48 <colindixon> #chair phrobb phrobb- dfarrell07 tbachman
17:00:48 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb phrobb- tbachman
17:00:55 <colindixon> #info colindixon
17:01:07 * tbachman is in-flight wifi
17:01:26 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=31552#Agenda the agenda in it’s usual place
17:01:39 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-06-11-17.00.html last week’s meeting minutes
17:01:48 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium
17:01:57 <cdub> #info Chris Wright
17:02:00 <LuisGomez> #info LuisGomez
17:02:33 <colindixon> #action ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
17:02:39 <colindixon> #acction colindixon to draft changes to language around project lifecycles
17:02:58 <colindixon> cdub: https://git.opendaylight.org/gerrit/#/c/22848
17:03:00 <ChrisPriceAB> #info Chris Price
17:03:13 <colindixon> #action phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
17:03:15 * cdub looks
17:03:20 <Youcef> #info Youcef Laribi
17:03:23 <LuisGomez> cudb, we need that patch before next RC creation
17:03:53 <mohnish> #info Mohnish Anumala (irc only)
17:04:04 <jmedved> #info jmedved (irc only)
17:04:25 <dfarrell07> cdub: here's the patch in question, FYI https://git.opendaylight.org/gerrit/#/c/22848/
17:04:38 <phrobb> FYI we have quorum
17:04:52 <cdub> dfarrell07: thanks
17:05:18 <edwarnicke> #info edwarnicke
17:05:25 <colindixon> #action colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope
17:05:56 <colindixon> #action alagalah to work with Sumit and his team to present something at a TWS session for the SDN SDK
17:06:11 <colindixon> #undo
17:06:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19b31d0>
17:06:16 <colindixon> #action colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
17:07:22 <colindixon> all TSC members please vote on committers on the TSC list
17:08:25 <colindixon> #topic events
17:08:35 <colindixon> #link http://www.opendaylight.org/news/events/ the events page
17:09:03 <colindixon> #info people are at ONS with tutorials on wednedsay and a developer track on Monday with 100-150 people at the beginning, all went pretty well
17:09:35 <colindixon> #info the ODL summit is coming up at the end of July
17:10:04 <phrobb> #link https://wiki.opendaylight.org/view/Events:Main#OpenDaylight_Developer_Forum_-_Santa_Clara.2C_CA_July_30th_and_31st.2C_2015 Please add topics that you
17:10:14 <colindixon> #action phrobb will create a page for us to aggregate topics for the design forum
17:10:18 <colindixon> #undo
17:10:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1bab190>
17:10:19 <colindixon> #Undo
17:10:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19c1290>
17:10:31 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#OpenDaylight_Developer_Forum_-_Santa_Clara.2C_CA_July_30th_and_31st.2C_2015 Please add topics that you want to discuss at the developer forum
17:10:38 <colindixon> #action phrobb will create a page for us to aggregate topics for the developer design forum
17:10:57 <colindixon> #info EVERYONE REGISTER FOR THE DEV FORUM IF YOU WANT TO ATTEND, IT WILL “SELL” OUT
17:11:02 <alagalah> #info alagalah for jmedved
17:11:04 <dfarrell07> lol
17:11:26 <jmedved> #info alagalah will be jmedved’s proxy on this TSC
17:11:35 <colindixon> #link https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 register for the developer forum here if you need to
17:11:37 <dfarrell07> #info Question about having a Summit in the UK or Europe
17:11:47 <colindixon> alagalah, jmedved: noted and thanks!
17:11:58 <colindixon> thanks dfarrell07
17:12:21 <dfarrell07> #info Phil points out that attendance may be lower in Europe, so maybe not full summit, maybe something smaller?
17:13:21 <dfarrell07> #info edwarnicke points out that many Open Source projects grow distributed events by starting an expected-smaller *-<some place> and growing it slowly
17:13:21 <tykeal> heh
17:13:45 <colindixon> #topic Lithium
17:14:00 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?pli=1#gid=676729675 bloging bugs
17:14:24 <tykeal> our bugs are blogging now?
17:14:27 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?pli=1#gid=1757763090 we have the vast majority of projects reporting RC1 test results (but not all)
17:14:34 <colindixon> #undo
17:14:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b987d0>
17:14:35 <colindixon> #undo
17:14:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b98f10>
17:14:44 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?pli=1#gid=676729675 blocking bugs
17:14:49 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?pli=1#gid=1757763090 we have the vast majority of projects reporting RC1 test results (but not all)
17:15:08 <dfarrell07> George sounds underwater to me, not sure I can pull a #info from that
17:15:16 <colindixon> #info gzhao says we really need people to mark the “to be verified” bugs as “verified” quickly
17:15:56 <dfarrell07> #info OFPlugin and GPB were in red, colindixon asks if they would still be red in RC2
17:16:02 <gzhao> let me info in
17:16:05 <gzhao> dfarrell07: sorry abou tthat
17:16:19 <gzhao> #info there are 5 projects still haven't completed RC1 testing
17:16:20 <dfarrell07> np, it may be on my end gzhao
17:16:36 <gzhao> #info AAA and OVSDB send email response that testing is uderway
17:17:30 <gzhao> #info L2swtich, topoporcessing and Persistence still waiting for response
17:18:04 <dfarrell07> #info LuisGomez points out that Integration's yellow status isn't a release-blocker, but of course it would be nice to not require the Internet
17:18:06 <colindixon> #info it sounds like the two current blcoking bugs right now that aren’t believed to be fixed are: 3656 (blocking on an odlparent merge) and 3548 (blocking on an openflowplug merge)
17:18:13 <gzhao> #info RC2 will be cut at UTC 11:59 today
17:18:34 <phrobb> FYI on the Webex the person who is "call-in User_4" was causing distortion on the line so I muted you.  If you would like to talk please let me know via IRC
17:18:38 <gzhao> LuisGomez: let me know if you need me to do a rebuild
17:20:42 <colindixon> #agreed we wil cut another RC1 daily tonight (instead of RC2) if those two bugs (3656 and 3548) aren’t belived to be fixed
17:22:41 <colindixon> #info colindixon asks if we should make RC2 just -Lithium insead of -Lithium-RC2 so that we don’t have to worry about the fact that re-spinning it to remove -RC2 would require *more* testing since it would not necessarily be the same
17:23:16 <snoble> that is how I find it
17:23:31 <alagalah> why not weather page ?
17:23:37 <alagalah> edwarnicke: colindixon weather page ?
17:23:40 <dfarrell07> #info zxiiro has been sending release artifacts links to the release list
17:23:51 <edwarnicke> alagalah: Weather page sounds brilliant :)
17:24:02 <colindixon> #action zxiiro to add a link to the top of the weather page and the top of the RCX release report google sheet to point to the current most recent Lithium RC
17:24:12 <snoble> I do agree with having a page to go to to get the latest bits
17:24:42 <edwarnicke> snoble: I suspect you too have gone "Where do I find this?"
17:25:52 <gzhao> yes, we did this in Helium
17:26:57 <colindixon> #agreed assuming zxiiro doesn’t have any strong reason to not do this, we wil have RC2 builds be with the only -Lithium so we can release one once we are happy with how it tests (this is how we did things in Helium and other making sure you have URL and sha1 it worked well)
17:26:59 <snoble> ed: I also sent mail to a few people asking and got no response, so I think combined with oversubscription, it's a good idea
17:27:19 <gzhao> colindixon: edwarnicke can we build Lithium on UTC 6/22, that will give people a weekend to fix RC1, while we continue to do daily RC1
17:28:48 <colindixon> #action snoble to create a bug around topology not showing up that seems to be new in RC1 and add it to the blocking issues
17:29:30 <colindixon> #action snoble will file a bug for not being able to scroll the topology (but not make it blocking)
17:30:24 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current weather report for those who are interested
17:30:46 <dfarrell07> cdub: I used your perma-stand-in rights delegation to vote on the committer promotion threads
17:32:01 <colindixon> #info phrobb asks how confident we are in shipping Lithium on Thursday, 6/25 so that the PR folks can prep, even if we say it is high, they plan to announce things on Monday, 6/28
17:32:38 <colindixon> #info rovarga says that he things he’s good to go for all of his projects
17:33:06 <gzhao> colindixon: my connection is bad but can respond through IRC
17:33:15 <cdub> dfarrell07: ack
17:33:54 <colindixon> #info colindixon says that his broad reading of things is that other than waiting on RC1 feedback from some projects (most notably ovsdb and aaa), things look pretty good to release on 6/25
17:34:15 <gzhao> phrobb: colindixon if we can have the two blocking bug resolved, I am pretty confident release on 6/25
17:34:16 <colindixon> #info edwarnicke says that he feels good from a blocking bug list, but he would need more input from individual projects
17:35:12 <gzhao> I will do RC2 with go and no go.
17:35:23 * dfarrell07 has promotion review vote/agree/etc things queued up
17:35:28 <dfarrell07> phrobb, colindixon^^
17:35:30 <colindixon> #action LuisGomez and gzhao to make the options for RC2 to be go/no-go as far as releases
17:35:40 <colindixon> dfarrell07: awesome
17:36:00 <dfarrell07> gzhao: much better
17:36:08 <colindixon> #info gzhao says “if we can have the two blocking bug resolved, I am pretty confident release on 6/25”
17:37:00 <colindixon> #info Prem_ says from vpnservice it’s a go
17:37:13 <colindixon> #info ebrjohn says sfc says he’s a go
17:37:23 <colindixon> #info abhijitkumbhare barring the blocking bug, ofplugin is a go
17:37:35 <alagalah> colindixon: I'm here
17:37:38 <gzhao> #info gzhao USC is a go
17:37:39 <alagalah> colindixon: waiting in line
17:37:40 <vina_ermagan> #info Vina for lispflowmapping
17:37:48 <colindixon> #undo
17:37:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b7d110>
17:38:07 <alagalah> #info GBP is a go.
17:38:28 <hideyuki_> #info VTN is go.
17:38:42 <ttkacik> #info Controller is go.
17:40:40 <phrobb> #info if we get fixes merged for the blocking bugs before tonight's build, we will call tonight's build RC2 and that version will stay as the true candidate release bits and we will finish our testing on that version until a new blocking bug is reported
17:41:54 <alagalah> colindixon: Ok I'm confused... if we spin tonight then that's it then right ?
17:42:06 <ebrjohn> alagalah: apparently so
17:42:09 <alagalah> colindixon: Why is this a question ?
17:42:14 <colindixon> #info colindixon says to be very clear, if we get all blocking bugs belived to be fixed by midnight UTC tonight, we will cut RC2 and we will only respin it if there is a *blocking* bug found, so only fixes in my midnight UTC tonight will be guaranteed to make the cut
17:42:15 <colindixon> alagalah: yes
17:43:38 <colindixon> #action at this point all project should only merge blocking bug fixes to stable/lithium at this point
17:43:55 <colindixon> #undo
17:43:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1821fd0>
17:47:05 <tykeal> shouldn't code freeze mean code freeze except for blocking bugs?
17:48:07 <dfarrell07> +1 to all of that colindixon
17:50:36 <gzhao> tykeal: well RC also means release candidate. -:)
17:50:53 <dfarrell07> colindixon: it looks like there are 5 +1s on all threads
17:51:05 <tykeal> gzhao: I'm aware, I'm just asking since we're supposed to be in a code freeze ;)
17:51:24 <gzhao> tykeal: agree with you.
17:52:51 <colindixon> #agreed the TSC encourages all projects to excercise *extreme* caution in merging patches to stabe/lihtium as they may cause the release to regess and thus be delayed, the *only* clear reason to merge a patch is to fix a blocking bug, in other cases projects are encouraged to use their judgment with extreme caution
17:53:04 <colindixon> #action gzhao to send out the caution about merging to stable/lihtium to the release list
17:53:34 <colindixon> #topic NetIDE project proposal
17:53:39 <colindixon> #info this will be tabled to next week
17:53:43 <colindixon> #topic Be release plan
17:54:58 <colindixon> #info timing-wise, ttkacik asks if we can push M2 (for all projects) to be after the develper design forum so release plans can incorpoarte feedback from the desigin forum
17:55:10 <colindixon> #info colindixon says that make sense to him and he was planning to make that modification
17:55:45 <colindixon> #info rovarga asks if we’re willing to mandate JDK8 compliance in Beryllium
17:56:48 <dfarrell07> #info rovarga and edwarnicke clarify that we're talking about supporting JDK8 and later
17:57:08 <edwarnicke> #info which would imply *not* supporting JDK 7 in Beryllium
17:57:41 <colindixon> #info edwarnicke asks if we’re saying that we need to support JKD7 and JDK8 or move completely to JDK8
17:58:03 * dfarrell07 knows of no reason to support JDK7
17:58:05 <colindixon> #info tykeal notes that JDK7 isn’t even available in modern distros on many platforms
17:58:53 <dfarrell07> just #agree it, imho
17:58:59 <tykeal> lol
17:59:00 <ChrisPriceAB> Yup
17:59:17 <edwarnicke> JDK7 is dead, long live JDK8 :)
17:59:19 <dfarrell07> lol
17:59:21 <colindixon> #agreed barring sombody asking for JDK7 support prior to offset 0 M1 of the Beryllium release plan, we will move to JDK8+ starting with Beryllium\
17:59:22 <dfarrell07> huzzah!
17:59:42 <phrobb> One minute cookie break
18:00:01 <colindixon> #topic cookies
18:00:09 <tykeal> are we going to see cookies at the Summit that look like this? http://www.ikontronics.com/images/source/cr2032_4.jpg
18:00:11 <colindixon> #endmeeting