#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:14 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:20)
    1. colindixon (colindixon, 17:00:24)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=32699#Agenda the snapshot of today’s agenda on the wiki (colindixon, 17:01:00)
    3. edwarnicke (edwarnicke, 17:01:06)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-06-18-17.00.html last week’s meeting minutes (colindixon, 17:01:37)
    5. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1) (colindixon, 17:01:56)
    6. ACTION: ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and (colindixon, 17:02:10)
    7. ACTION: phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for (colindixon, 17:02:19)
    8. jmedved (jmedved, 17:03:22)
    9. dfarrell07_pto for Red Hat, irc only atm (dfarrell07_pto, 17:03:36)
    10. https://wiki.opendaylight.org/view/Events:Main#OpenDaylight_Developer_Forum_-_Santa_Clara.2C_CA_July_30th_and_31st.2C_2015 Put your design forum topics here. We will probably also create one or more sub-pages as more topics are added (phrobb, 17:03:57)
    11. mohnish anumala (mohnish, 17:04:17)
    12. catohornet carolsanders (catohornet, 17:04:24)

  2. events (colindixon, 17:04:55)
    1. http://www.opendaylight.org/news/events/ the events list (colindixon, 17:05:12)
    2. major event next is the ODL summit (colindixon, 17:05:19)
    3. https://wiki.opendaylight.org/view/Events:Main#OpenDaylight_Developer_Forum_-_Santa_Clara.2C_CA_July_30th_and_31st.2C_2015 Put your design forum topics here. We will probably also create one or more sub-pages as more topics are added (colindixon, 17:05:34)
    4. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Hackathons/IETFPrague15 (alagalah, 17:05:45)
    5. chris price (ChrisPriceAB, 17:05:54)
    6. https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 please register for dev/design forum (colindixon, 17:05:57)
    7. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Hackathons/IETFPrague15 IETF hacakathon in prague in on July 18th and 19th (GBP and SFC in particular) (colindixon, 17:06:39)
    8. there will be other folks from ODL there as well, it should be a good time (colindixon, 17:06:56)

  3. infrastructure (colindixon, 17:07:42)
    1. zxiiro says things look great at the moment (colindixon, 17:07:50)

  4. Lithium Release (colindixon, 17:07:56)
    1. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 no active blocking bugs (colindixon, 17:08:24)
    2. colindixon Notest that we have no blocking bugs.. (phrobb, 17:08:42)
    3. colindixon notes one issue in OpenStack and has been moved from blocking to deferred given the fix needs to be done in OpenStack (phrobb, 17:09:17)
    4. OPFLEX artifacts are not in Nexus and it's being worked. It is not considered to be a blocker (phrobb, 17:09:42)
    5. documentation, and release notes are still being worked on and will probably be done so up until our official announcement on Monday (phrobb, 17:10:49)
    6. colindixon notes that making adjustments to release notes between now Monday is fine... at some point colindixon will cobble the wiki contents up into an asciidoc so get your last modifications in sooner rather than later (phrobb, 17:12:49)
    7. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=478292312 of the 41 projects listed there, d4a is not actually in Lithium and they know that, otherwise all projects have voted go (colindixon, 17:14:09)
    8. defense4all has stepped out of the release due to their own development issues. As a free-standing app, there is no other impact on the Li release (phrobb, 17:14:39)
    9. Youcef Laribi (Youcef, 17:14:45)
    10. All other projects have voted "go" so we are ready to go re Li (phrobb, 17:15:09)
    11. https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1074/org/opendaylight/integration/distribution-karaf/0.3.0-Lithium/ this is the lithium release distribution which everyone has tested (colindixon, 17:15:27)
    12. core tutorials voted n/a because there’s only one small piece included which is only used by integration (colindixon, 17:15:47)
    13. VOTE: Voted on "Shall the TSC approve the Release of Lithium?" Results are, +1: 7 (phrobb, 17:16:46)
    14. note that Uri and Youcef vote +1 as well (colindixon, 17:17:13)
    15. AGREED: Liithum is released re the artifacts located here: https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1074/org/opendaylight/integration/distribution-karaf/0.3.0-Lithium/ (phrobb, 17:17:27)
    16. colindixon congratules for first on time Opendaylight major release with 40+ projects (gzhao, 17:17:56)
    17. colindixon says everyone should go and celebrate!!!! (gzhao, 17:18:21)
    18. zxiiro notes that the release engineering team will be tagging and bumping versions as part of the release (colindixon, 17:19:11)
    19. zxiiro asks project don't merge patches on stable/lithium (gzhao, 17:19:22)
    20. https://lists.opendaylight.org/pipermail/release/2015-June/002990.html the e-mail explaining the details (colindixon, 17:20:54)
    21. edwarnicke asks how long version bumping and patches will take, Thanh says today, colin says it will take at least 8 hours, colindixon says it’s going to take maybe closer to a few days (colindixon, 17:22:42)
    22. colindixon says early next week is a resonable estimate for when it could be done (colindixon, 17:22:58)

  5. Martin Sunal as a comitter on SXP (colindixon, 17:24:05)
    1. TSC tabling SXP committer discussion until SXP members present (phrobb, 17:24:32)

  6. creation review fro NetIDE (colindixon, 17:24:40)
    1. https://wiki.opendaylight.org/view/Project_Proposals:NetIDE the project proposal (colindixon, 17:24:53)
    2. https://wiki.opendaylight.org/images/9/9c/NetIDE_ODL_proposal.pdf slides at the bottom of the proposal (colindixon, 17:25:10)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-June/000318.html proposed on May 19th, so much more than two weeks ago (colindixon, 17:25:40)
    4. NetIDE consortium is broader than just Intel, many other academics and companies (colindixon, 17:26:10)
    5. looking to create an IDE for SDN applications (colindixon, 17:26:38)
    6. https://github.com/fp7-netide it’s already an open source project on github (colindixon, 17:27:22)
    7. it’s already under the EPL (colindixon, 17:27:35)
    8. colindixon notes that they have 4 repos on github, but would likely only get one repo in ODL, will that be an issue? (colindixon, 17:28:50)
    9. alec says he doesn’t think so, because not all of the stuff on github will be migrated to ODL (colindixon, 17:29:17)
    10. jmedved asks if this is targeting apps that use the REST API or the ones that are plugings, Alec says ideally both (colindixon, 17:29:58)
    11. two main parts: network engine and IDE (colindixon, 17:30:23)

  7. NetIDE network engine (colindixon, 17:30:30)
    1. starts on slide 7 (colindixon, 17:30:38)
    2. the architecture has a notion of a client SDN controller and server SDN controller using backends and shims for them to be layered (colindixon, 17:31:12)
    3. Alec says he can run a demo of this on mininet using ODL as the server SDN controller with Floodlight, Pyretic, and Rya as client SDN controllers (colindixon, 17:32:46)
    4. demo app is branch office connectivity (colindixon, 17:32:53)
    5. the language being used between the shims and the backends (glue between client and server SDN controllers) is currently the pyretic language (colindixon, 17:33:19)
    6. the pyretic language for now is OpenFlow 1.0 only, which has limitations (colindixon, 17:33:36)
    7. jmedved asks if this is OpenFlow specific, Alec says yes for now (colindixon, 17:33:55)
    8. jmedved asks what they mean by supporting NETCONF, Alec says that they would think about forking Pyretic to add in 1.3 and some new features, e.g., NETCONF messages (colindixon, 17:34:42)
    9. jmedved says that things aren’t very useful with OpenFlow alone, Alec says maybe, but there are lots of OpenFlow controllers out there and this enables those to run on topo of ODL (colindixon, 17:35:38)
    10. edwarnicke asks about the value of using pyretic messages vs. translating directly to models for ODL (colindixon, 17:36:37)
    11. Alec answers because there is another shim for Ryu and pox (it’s not just ODL) (colindixon, 17:36:54)
    12. edwarnicke notes that that he believes that using pyretic as the carrier message will result in pain since it is “semantically poor” when compared to OpenDaylight’s models (colindixon, 17:39:52)
    13. colindixon makes sure to note that this technical discussion is good and important, but the technical discussion will not much (if any) bearing on whether the TSC approves the project and should be taken as engineer-to-engineer feedback (colindixon, 17:40:50)
    14. there is conversation about openflow-only vs. more general (colindixon, 17:41:13)
    15. to be clear, Alec says that their plans with the pyretic language would be to try to incorporate things back to the main project (colindixon, 17:44:04)
    16. edwarnicke asks how the pyretic guys are feeling about these modifications and extensions, Alec says generally thats’s a good relationship (colindixon, 17:44:46)
    17. zxiiro and dfarrell07_pto brought up the question about forking pyretic, not me just to give credit where credit is due (colindixon, 17:45:27)
    18. jmedved points out that different controllers have different clustering/HA models, Alec says they haven’t looked at that yet (colindixon, 17:45:52)

  8. the NetIDE IDE (colindixon, 17:46:35)
    1. starts on slide 10 (colindixon, 17:47:00)

  9. this is a suite of plugins to Eclipse (colindixon, 17:47:18)
    1. shows a screenshot of an interface GUI with switches, hosts, etc. (colindixon, 17:47:41)
    2. this then auto-generates the relevant code using Django to generate python for Ryu in the screentshot (colindixon, 17:48:11)
    3. this could be done with YANG and Java in a similar way for OpenDaylight (colindixon, 17:48:22)
    4. another tool they aren’t showing, allows you to take an ODL topology and then deploy it in mininet to check your real topology in simulation (colindixon, 17:49:13)
    5. Just to make sure it gets in the notes (regarding Pyretic fork), dfarrell07_pto notes that long-lived forks are typically harder to integrate than working upstream initially, and suggests that Pyretic committer rights seem appropriate for people doing such substantial refactoring (dfarrell07_pto, 17:50:18)
    6. the scope seems to be NetIDE consortium’s shim and backend for allowing the client/server SDN controller architecture and Eclipse-based IDE tools to help developers (colindixon, 17:52:29)
    7. jmedved says we could expand things if we could consider topology stacks beyond the typical L2/L3, openflow scope (colindixon, 17:53:40)
    8. Alec says he’s open to that (colindixon, 17:53:45)
    9. VOTE: Voted on "Shall the TSC approve NETIDE?" Results are, +1: 8 (dfarrell07_pto, 17:55:36)
    10. note that Uri_ also voted +1 (colindixon, 17:55:45)
    11. AGREED: The TSC vote above was to move the NetIDE project to incubation (dfarrell07_pto, 17:57:04)

  10. Lith cookies! (dfarrell07_pto, 17:58:55)
    1. ACTION: me to send a mail (ChrisPriceAB, 17:59:20)


Meeting ended at 17:59:52 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
  2. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  3. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
  4. me to send a mail


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
  3. jmedved
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  4. phrobb
    1. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
  5. rovarga
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and


People present (lines said)

  1. colindixon (91)
  2. dfarrell07_pto (25)
  3. alagalah (22)
  4. odl_meetbot (17)
  5. ChrisPriceAB (16)
  6. phrobb (13)
  7. tykeal (10)
  8. gzhao (8)
  9. ebrjohn (7)
  10. edwarnicke (7)
  11. zxiiro (5)
  12. catohornet (4)
  13. mohnish (4)
  14. jmedved (3)
  15. Youcef (3)
  16. abhijitkumbhare (3)
  17. drizzt__ (3)
  18. rovarga (1)
  19. odl-casey (1)
  20. uri_ (1)


Generated by MeetBot 0.1.4.