17:00:21 <colindixon> #startmeeting tsc
17:00:21 <odl_meetbot> Meeting started Thu Jul 23 17:00:21 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:21 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:21 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:25 <colindixon> #topic roll call and agenda bashing
17:00:32 <colindixon> #chair dfarrell07 phrobb gzhao
17:00:32 <odl_meetbot> Current chairs: colindixon dfarrell07 gzhao phrobb
17:00:38 <colindixon> #info colindixon
17:00:45 <colindixon> TSC members please #info in
17:01:03 <edwarnicke> #info edwarnicke
17:01:12 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=33950#Agenda the agenda in it’s usual place
17:01:23 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-07-16-17.00.html meeting minutes from last time
17:01:34 <dfarrell07> #info dfarrell07 for cdub/Red Hat
17:02:26 <abhijitkumbhare> #info abhijitkumbhare for ChrisPriceAB / Ericsson
17:03:04 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
17:03:12 <LuisGomez> #info LuisGomez
17:03:13 <colindixon> #action ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
17:03:33 <dfarrell07> 5 TSC members
17:03:40 <colindixon> dfarrell07: thanks!
17:04:01 <mohnish> #info mohnish anumala
17:04:05 <dfarrell07> 6
17:04:29 <colindixon> dfarrell07: that’s quorum
17:04:49 <colindixon> #action gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t
17:05:01 <colindixon> #action phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
17:05:25 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:05:41 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:06:16 <colindixon> #action tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
17:07:13 <colindixon> #topic events
17:07:22 <Youcef> #info Youcef Laribi
17:07:25 <colindixon> #link http://www.opendaylight.org/news/events/ the usual events page
17:07:30 <dfarrell07> 7 TSC members
17:07:46 <colindixon> #info the ODL summit is next week, phil is putting the topics into the developer deisgn forum
17:08:06 <colindixon> #link https://wiki.opendaylight.org/view/Events:Be_Dev_Forum if you wanted to add a topic to the deisgn forum, get it here in the next few hours
17:08:34 <colindixon> #link https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 if you still haven’t registered for the design forum and would like to come, sign up *now*
17:09:32 <ebrjohn> The IETF Prague hackfest finishes today
17:09:43 <colindixon> #info there was an IETF hackfest a few days back on SFC/GBP, Jan, Tony, ChrisP and others say it went well
17:10:03 <colindixon> #topic Be, stable/He, and stable/Li updates
17:11:00 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-July/003272.html there was a regression in l2switch’s behavior the Helium-SR4 release candidate
17:11:58 <colindixon> #info LuisGomez says that this issue is easy for us to reproduce in the release, hard to reproduce in the stable/helium branch, and hard to reproduce locally
17:13:14 <dneary> 194 548 370 isn't working as meeting code
17:13:30 <colindixon> dneary: Meeting number: 194 548 370
17:13:32 <tykeal> that's the meeting code
17:13:33 <colindixon> huh
17:13:36 <colindixon> that is it
17:13:38 <tykeal> but it wouldn't work for me in the app either
17:13:39 <colindixon> webex is being bad
17:13:45 <tykeal> I had to just call in...
17:13:51 <dneary> Dialling a local French number I found on webex.com
17:14:18 <colindixon> #action LuisGomez is looking into whether this is a regression from SR2/SR3 or not, if it’s not and we can find a workout, we might just ship it, otherwise we need a workaround
17:14:30 <dneary> App never works for me (error 31001 every time)
17:14:32 <gzhao> dneary: 194 548 370 for me
17:14:44 <dneary> I'll ring the US number
17:15:33 * regXboi pads in
17:15:39 <colindixon> #action ttkacik will stay in touch with LuisGomez and try to look into things, it appears that this is new to SR4, but is alos not present in the snapshots
17:16:04 * regXboi pads in as IRC only
17:16:37 <dneary> On now
17:17:07 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#M1:_Joining_the_Release template for M1 status reports, offset 0 ones are due today
17:17:46 <colindixon> #info technically, all new project proposals are supposed to be in by today, but I believe the TSC will make exceptions for interesting projects that come out of the summit if they want to join beryllium
17:18:39 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-July/003198.html the cutoff time and dates for Liithium-SR1
17:19:12 <regXboi> colindixon: typo in that link description?
17:19:32 <colindixon> regXboi: how so?
17:19:38 <regXboi> Liithium?
17:19:42 <colindixon> #undo
17:19:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b782d0>
17:19:48 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-July/003198.html the cutoff time and dates for Lithium-SR1
17:19:50 <regXboi> :)
17:19:52 <colindixon> #topic infrastructure
17:20:12 <colindixon> #info tykeal is back and nothing is broken, zxiiro did an awesome job
17:20:23 <colindixon> #info tykeal will be starting upgrades of the environment after the summit
17:20:35 <regXboi> what *kinds* of upgrades?
17:20:42 <colindixon> #info phrobb says we’re in the final steps of getting a trial JIRA up and running
17:21:04 <regXboi> #info regXboi asks (on irc) what *kinds* of upgrades?
17:21:24 <colindixon> #info tykeal says all kinds of upgrades, gerrit, jenkins, nexus, underlying slaves—basically everything but sonar
17:21:39 <regXboi> thx
17:22:23 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-July/003512.html please submit your GPG keys for the keysigning
17:23:03 <colindixon> #topic events (again)
17:23:24 <colindixon> #info there is an OPNFV hackfest on Thursday and Friday, there will be some time for overlap on Thursday morning
17:23:52 <colindixon> #info the ETSi NFV folks are also in town, but at a different location, they will be coming to the OPNFV things on Thursday morning, for which we are also invited
17:24:49 <colindixon> #info these topics will be looking at the SDN parts of the OPNFV and ETSI activities
17:24:55 <colindixon> #topic Future TSC meetings
17:25:07 <colindixon> #info  No meeting next week (7/30/2015) because of the summit
17:27:37 <dfarrell07> It's fine with me
17:27:43 <dfarrell07> ^^2 hours
17:27:48 <mohnish> fine with me
17:27:57 <colindixon> #agreed there will be a 2 hour TSC call on August 6th
17:28:03 <abhijitkumbhare> fine with me (as ChrisPriceAB ) :)
17:28:24 <colindixon> #action colindixon to send mail about extending the 2 hour TSC calls past 8/6 with broader TSC members being aware
17:29:02 <colindixon> #topic Fabric as a Service creation review
17:29:20 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-July/003528.html the tail of the discussion on the malling list
17:32:11 <colindixon> #action colindixon will start a vote when the scoping questions have at least been answered
17:32:34 <colindixon> #topic OF circuit switching creation review
17:32:45 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Openflowplugin-extension-circuitsw the proposal
17:33:36 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-April/000305.html  proposed on 4/3/2015
17:35:25 <colindixon> #link https://www.opennetworking.org/images/stories/downloads/sdn-resources/onf-specifications/openflow/Optical_Transport_Protocol_Extensions_V1.0.pdf ONF’s Optical Transport Protocol Extensions spec
17:36:47 <mohnish> abhijit: what other OF extensions that are currently supported?
17:37:01 <colindixon> #link https://wiki.opendaylight.org/images/1/1d/OCS_OF_Protocol_Extensions_Rev._0.4.pdf Circuit Switching OF extensions from Calient
17:38:07 <abhijitkumbhare> mohnish: Nicira extensions are supported
17:38:08 <icbts> i can hear you
17:38:58 <ebrjohn> the audio just got very bad
17:38:58 <ebrjohn> Is it just me, or are others having problems with the audio?
17:39:00 <colindixon> #info colindixon asks if the circuit switching spec is something that people are working with the ONF
17:39:05 <abhijitkumbhare> The scope of the project is:
17:39:15 <colindixon> ebrjohn: not for me
17:39:22 <abhijitkumbhare> Design and Implementation of the OpenFlow Protocol Extensions for the Circuit Switches in the openflowjava
17:39:22 <abhijitkumbhare> Design and Implementation of the Yang models for the Circuit Flows(cross-connects), Ports, Cirucit Flow and Port Statistics
17:39:23 <abhijitkumbhare> Design and Implementation of the OpenFlow Protocol Extensions for the Circuit Switches in the openflowplugin 1.0
17:39:48 <colindixon> #info Aneesha says the answer is they are not working with the ONF at the moment
17:39:56 <ebrjohn> colindixon: thanks, I can hear better now, but the webex window froze :(
17:40:39 <colindixon> #info colindixon points out that the topology supports multi-level modeling, so that should enable publishing optical circuit topologies into the topology model as Aneesha says they’d like to
17:41:01 <colindixon> #info colindixon also points out that the inventory model might be deprecated in Beryllium as it gets folded into the topology model
17:41:19 <colindixon> #info mohnish asks if modifications to openflow{plugin,java} are needed or if this will be separate
17:41:52 <gzhao> Aneesha: could you add email address to your project proposal resource committed and initial committers sections
17:41:57 <colindixon> #info the answer seems to be yes, modifications and/or extensions will be needed, and edwarnicke says he’ll help with his openflowplugin committer hat on
17:42:45 <colindixon> #action Aneesha to add an e-mail address or committed resources and initial committers
17:43:22 * dfarrell07 has a vote queued up if you want it, colindixon
17:43:30 <colindixon> dfarrell07: thanks!
17:44:07 <colindixon> #info abhijitkumbhare says that experimental matches and experimental actions are there, but experimental multipart messages aren’t there yet and Aneesha would like to help build that
17:44:25 <colindixon> Aneesha: the scope doesn’t mention optical, it’s just circuit switching
17:44:38 <colindixon> Aneesha: also do you want to only have one committer
17:45:01 <colindixon> #info edwarnicke says that he’d like to see the multi-part message (or the fact that it needs to be there) likely shouldn’t be exposed out the top of the protocol
17:45:08 <colindixon> #undo
17:45:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cb9390>
17:45:11 <colindixon> #info edwarnicke says that he’d like to see the multi-part message (or the fact that it needs to be there) likely shouldn’t be exposed out the top of the protocol protocol
17:45:44 * tbachman comes into the room
17:46:33 <colindixon> #info colindixon asks if it makes sense to have more committers
17:46:39 <colindixon> #info Aneesha says for now she’s all there is
17:47:18 <colindixon> #info colindixon asks does it make sense for this to be it’s own project, or just a new effort inside openflow{java,plugin}
17:47:50 <tykeal> "loves" webex hehe
17:48:04 <tbachman> lol
17:48:07 <ebrjohn> lol
17:48:44 <dfarrell07> tykeal: yeah, Colin's tone on that was perfect, voice actor for sarcasm/loathing webex
17:48:54 <tykeal> :)
17:49:18 <colindixon> #info Aneesha says she would like her own project for this effort
17:49:41 <tbachman> #info colindixon says the project says circuit switches, but doesn’t metnion optical
17:49:57 <dfarrell07> colindixon: was there an answer to that "more committers" question?
17:50:13 <tbachman> #info Aneesha says they meant to mention optical in the scope
17:50:27 <colindixon> #action Aneesha to put optical in the scope if that was the intent
17:50:40 * tbachman pictures gerrit
17:51:05 <tbachman> WebEx glare
17:51:27 <tykeal> *blink* I didn't get that
17:51:30 <tbachman> lol
17:51:34 <ebrjohn> *bleeeep*
17:51:50 <tbachman> #info edwarnicke says there’s a standing set of guidelines for repo names — want ones suitable for use as a java identifier
17:51:54 <tykeal> sort of require it actually
17:51:59 <colindixon> #info colindixon asks if we should have a long reponame like openflowplugin-extension-circuitsw instead of something simple like ofocs
17:52:52 <dneary> Dropping... family stuff
17:52:54 <colindixon> #info edwarnicke and tykeal notes that dashes in the repo name will cause issues with things like maven groupIds
17:52:58 <colindixon> dneary: enjoy
17:53:02 <tbachman> #info LuisGomez asks if Aneesha considered collaboration for a cycle with OpenFlow plugin first, and then possibly migrate to a new project
17:53:12 <edwarnicke> dneary: I would counsel not dropping your family from to great a height...
17:53:18 <tbachman> edwarnicke: lol
17:54:17 <tbachman> #info abhijitkumbhare asks TSC if  all the experimenter extensions be in a single place or scattered in projects.
17:54:17 <colindixon> #info LuisGomez points out that running an ODL project is a lot of work and she will likely want help. Aneesha agrees.
17:54:39 <tbachman> #info edwarnicke feels it’s critically important to be able to have extensions outside of the openflowplugin
17:54:42 <tykeal> maybe we need an extensions metaproject?
17:54:53 <colindixon> metaprojects have a history of failing
17:54:57 <tbachman> #info mohnish asks if that would encourage reuse of extensions if they aren’t centralized
17:55:00 <colindixon> with one notably exception
17:55:03 <abhijitkumbhare> +1 to tykeal  - extensions metaproject
17:55:14 <tykeal> meta project in the gerrit sense ;) like releng/
17:55:20 <colindixon> ah
17:55:21 <tbachman> #info edwarnicke says there’s a distinction of “can” and “should” — we “should” allow it, lacking a good extension repo
17:55:21 <colindixon> I see
17:56:21 <tbachman> #info colindixon notes that it’s also possible to fold code from the project ot the openflowplugin if that’s more desireable in the future
17:56:23 * ebrjohn who's going to ask? "Are you sure you're sure????"
17:56:31 <tbachman> ebrjohn: :)
17:56:44 <edwarnicke> ebrjohn: I am uncertain
17:56:59 <edwarnicke> ebrjohn: As to *who* will say "Are you sure you're sure????" ;)
17:57:14 * tbachman is sure of nothing
17:57:33 <ebrjohn> edwarnicke: :)
17:57:38 <colindixon> #info it sounds like there’s loose agreement that maybe we should make the name ofextensions/circuitsw
17:58:10 <tykeal> groupID would end up being org.opendaylight.ofextensions.circuitsw in that case
17:58:34 <colindixon> #info tykeal notes that groupId would end up being org.opendaylight.ofextensions.circuitsw in that case
17:58:46 <abhijitkumbhare> +1 to ofextensions/circuitsw colindixon
17:59:15 <colindixon> should it be ofextensions or openflowextensions?
17:59:29 * dfarrell07 hearts short names
17:59:38 * tykeal agrees with dfarrell07
17:59:40 <colindixon> ofext/circuitsw
18:00:36 <tbachman> #info colindixon asks if there’s a preference for the naming?  His is ofextensions
18:00:43 <colindixon> #action Aneesha to rename the repository name to ofextensions/circuitsw
18:01:04 * dfarrell07 doesn't have that vote
18:01:13 <dfarrell07> trying
18:01:22 <tbachman> what are the changes again?
18:01:24 * tykeal is home ;)
18:01:31 * ebrjohn me too ;)
18:01:45 <colindixon> (1) add email address, (2) change repo name, (3) add optical to the scope
18:02:03 <dfarrell07> #startvote Shall the TSC approve the project under review with the required changes 1) add email address 2) change repo name 3) address scope project thto Incubation? -1, 0, +1
18:02:03 <odl_meetbot> Begin voting on: Shall the TSC approve the project under review with the required changes 1) add email address 2) change repo name 3) address scope project thto Incubation? Valid vote options are -1, 0, +1.
18:02:03 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:02:07 <dfarrell07> is that good?
18:02:07 <tbachman> dfarrell07: thx!
18:02:10 <dfarrell07> enough
18:02:14 <colindixon> #vote +1
18:02:17 <edwarnicke> #vote +1
18:02:17 <abhijitkumbhare> #vote +1
18:02:19 <mohnish> #vote +1
18:02:20 <Youcef> #vote +1
18:02:23 <dfarrell07> #vote +1
18:02:23 <LuisGomez> #vote +1
18:02:31 <colindixon> #endvote
18:02:31 <odl_meetbot> Voted on "Shall the TSC approve the project under review with the required changes 1) add email address 2) change repo name 3) address scope project thto Incubation?" Results are
18:02:31 <odl_meetbot> +1 (7): LuisGomez, dfarrell07, edwarnicke, mohnish, colindixon, abhijitkumbhare, Youcef
18:02:37 <dfarrell07> Sorry for the rushed vote
18:02:59 <colindixon> #agreed the openflow optical circuit switch OF extensions project is moved to incubation
18:03:10 <colindixon> #topic cookies
18:03:32 <colindixon> #endmeeting