17:00:26 <colindixon> #startmeeting tsc
17:00:26 <odl_meetbot> Meeting started Thu Aug 6 17:00:26 2015 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:26 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:47 <alagalah> colindixon: no audio for me as yet, OTP with UA sorting out something heinous...
17:01:08 * ChrisPriceAB will have audio in t-5 mins
17:01:30 <colindixon> #topic agenda bashing and roll call
17:01:30 <colindixon> #info colindixon
17:02:02 <ChrisPriceAB> #info Chris Price
17:03:54 <colindixon> #info colindixon
17:04:03 <tykeal> thank you webex for not letting me connect with your app :-/
17:04:14 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-07-23-17.00.html last week’s meeting minutes
17:04:21 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=34720#Agenda today’s agenda
17:04:28 <LuisGomez> #info LuisGomez
17:04:40 <edwarnicke> #info edwarnicke
17:04:49 <colindixon> #action gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t
17:05:00 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
17:05:26 <colindixon> #action ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and other things?
17:05:34 <ChrisPriceAB> Yo dudue!
17:05:37 <colindixon> #action phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
17:05:47 <mohnish> #info mohnish anumala
17:05:47 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:05:53 <dlenrow> #info dlenrow
17:06:01 <ebrjohn> ChrisPriceAB: do you have audio yet? colindixon was asking you something on the call
17:06:07 * dfarrell07 is now here
17:06:13 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:06:19 <colindixon> #chair dfarrell07
17:06:19 <odl_meetbot> Current chairs: colindixon dfarrell07
17:06:31 <colindixon> #action tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
17:06:32 <ChrisPriceAB> Can we close the action for infra. Dan Farrel is working with us on setting up a project to resolve this.
17:06:54 <dfarrell07> #info dfarrell07 for cdub/Red Hat
17:07:36 <colindixon> we have quorum
17:07:37 <kluehrs> #info kluehrs for CableLabs - UNIMgr project proposal
17:07:37 <abhijitkumbhare> welcome back dlenrow (assuming you were on a vacation since you were not at the summit)
17:08:20 * ChrisPriceAB has audio.
17:08:23 <dlenrow> abhijitkumbhare: Thx. Yes. Awesome vacation off grid. Back to work
17:08:30 <colindixon> #info edwarnicke says he’s working on getting jacoco reporting through sonoar if you use the MD-SAL IT parent pom, whcih would be awesome
17:08:37 <colindixon> #undo
17:08:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a8cbd0>
17:08:39 <colindixon> #undo
17:08:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1aa2310>
17:08:42 <colindixon> #info edwarnicke says he’s working on getting jacoco reporting through sonoar if you use the MD-SAL IT parent pom, whcih would be awesome
17:09:27 <colindixon> #topic events
17:09:48 <colindixon> #Undo
17:09:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1aa2310>
17:10:13 <colindixon> #info dfarrell07, ChrisPriceAB, and others have good plans around using OPNFV resources to help with various testing
17:10:17 <colindixon> #topic events
17:10:42 <colindixon> #link https://www.opendaylight.org/global-events
17:11:34 <colindixon> #info there will be a CFP for 1.5 days of content at the SDN & OpenFlow world congress in dusseldorf on 10/12-10/15
17:11:42 <colindixon> #link https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress more info on that here
17:12:02 <tykeal> two weeks
17:12:35 <colindixon> #link https://www.opendaylight.org/events/2015-08-16-000000/software-defined-networking-opendaylight-linuxcon-seattle SDN and with ODL at LinuxCon Seattle in two weeks on 8/16
17:12:38 <edwarnicke> Do we want to talk about possible hackfests?
17:13:15 <colindixon> #info edwarnicke asks if we want to talk about when to do our hackfests
17:13:16 <dlenrow> #info late agenda item: We don't have a NIC PTL for M1 due to recent resignation of D Bainbridge. Wish to join Be, but don't have PTL
17:13:28 <ChrisPriceAB> OPNFV Summit in November might work!!!
17:13:48 <edwarnicke> Where?
17:14:03 <colindixon> dlenrow: that should be fine, send the M1 now and say you’re working on electing a new one
17:14:16 <ChrisPriceAB> that's in California.
17:14:20 <ChrisPriceAB> Bay area
17:14:32 <gzhao> edwarnicke: burlingame
17:14:38 <colindixon> #info OPNFV summit in the bay area in November might be good colocate with
17:14:39 <gzhao> edwarnicke: close to airport
17:15:00 <edwarnicke> gzhao: Whats the date?
17:15:01 <colindixon> #action edwarnicke and phrobb- to send out a mails for candidate dates for hackfest
17:15:13 <gzhao> #link http://events.linuxfoundation.org/events/opnfv-summit <-- opnfv summit link
17:15:19 <edwarnicke> gzhao: And how does it line up with our release plan milestones?
17:15:26 <colindixon> #topic beryllium
17:15:53 <colindixon> gzhao: do you have a link?
17:16:12 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Participating_Projects participating projects so far
17:17:04 <colindixon> #action gzhao to put the link for the tracking spreadsheet here https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Project_Status
17:17:22 <gzhao> #link https://docs.google.com/spreadsheets/d/1o9L1q5OYl9T6ZwBEkAuPSoostFMIsjp4mh2FDawuk20/edit#gid=0 <-- Beryllium tracking
17:18:19 <gzhao> #info 6 offset 0 projects, 11 offset 1 projects and 15 offset 2 projects right now
17:18:30 <colindixon> #info it seem like the Beryllium release plan participating projects section is not yet up to date
17:18:35 <gzhao> #info there are 16 pending TSC approval projects
17:19:00 <colindixon> #topic stable/lithium
17:20:06 <colindixon> #info the schedule says that SR1 is supposed to happen next week
17:21:31 <colindixon> #action colindixon and gzhao to send a mail saying that we’re going to delay Lithium-SR1 by at least a week and seek feedback from projects, also set a cutoff for the build
17:22:08 <colindixon> #topic system integration and test
17:22:08 <alagalah> Has anyone noticed of late that gerrit, when reviewing the diff, keeps popping back to the top of frame mid scroll making it impossible to review patches more than one screen long ?
17:22:44 <colindixon> #info LuisGomez says that integration is looking to split into two projects
17:22:54 <tykeal> alagalah: can't say I've experienced that, but it might fix itself after Saturday ;)
17:22:56 <colindixon> #info they are planning and making sure that things are happening well
17:23:11 <alagalah> tykeal: :)
17:23:44 <jamoluhrsen> the split is in to three projects, not two.
17:23:55 <colindixon> #info colindixon says that the review would be in two weeks, which is 8/20
17:24:01 <colindixon> #Info jamoluhrsen says that it’s actually 3 weeks
17:24:08 <colindixon> #topic infrastructure
17:24:36 <abhijitkumbhare> colindixon: jamoluhrsen is saying its actually 3 projects (not 3 weeks)
17:24:42 <colindixon> #info tykeal scheduled updates for saturday (moring in the US), zxiiro will update the jobs
17:24:43 <colindixon> #undo
17:24:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bac210>
17:24:44 <colindixon> #undo
17:24:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1bacfd0>
17:24:46 <ChrisPriceAB> says the pot to the kettles
17:24:48 <colindixon> #undo
17:24:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1baced0>
17:24:54 <colindixon> #Info jamoluhrsen says that it’s actually 3 projects
17:24:56 * edwarnicke is getting much better
17:24:57 <colindixon> #topic infrastructure
17:25:02 <colindixon> #info tykeal scheduled updates for saturday (moring in the US), zxiiro will update the jobs
17:25:09 <dfarrell07> #info Integration is splitting into 3 projects in 2 weeks (corrections to last section)
17:25:19 <colindixon> #info there’s a meeting with rackspace about private cloud
17:25:38 <colindixon> #info edwarnicke asks about ODL forge
17:26:38 <colindixon> #info a few things put on the back burner: (1) infra issues with Lithium, (2) LF is moving to puppet 4
17:26:59 <colindixon> #Info tykeal says that it should come up soon, but he can’t give a date
17:27:03 * ChrisPriceAB thinks people should wear shoes to stop toe stubbing...
17:27:09 * edwarnicke hates shoes
17:27:13 <ChrisPriceAB> :D
17:27:19 <colindixon> #info tykeal says that moving into a rackspace private cloud will also help
17:29:14 <colindixon> #info phrobb- says that they’re looking to maybe hire another LF admin for ODL
17:29:26 <tykeal> ... hard to hear...
17:29:35 <tykeal> heard you, but it's hard
17:30:59 <dfarrell07> #info dfarrell07 continues to advocate for hiring more LF admins. They are epic, but a bottleneck b/c numbers imho
17:31:11 <colindixon> #info tykeal we have a part time admin for us who is there only for escalations overnight
17:31:11 <colindixon> #info LuisGomez asks how to do that?
17:31:46 <colindixon> #info tykeal says that the biggest change will be that somebody will be watching the queues while zxiiro and tykeal sleep
17:32:04 <colindixon> #info phrobb- sent out escalation instructions to all PTLs which you can look for, but he’ll send them again
17:32:14 <colindixon> #action phrobb- will send out escalation instructions again
17:33:11 <dfarrell07> colindixon: gtg
17:33:14 <dfarrell07> Good*
17:33:50 <colindixon> #topic FaaS creation review (round 2)
17:34:09 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:FaaS updated proposal
17:34:35 <colindixon> #info the scope has been updated
17:34:51 <colindixon> #info they say that they’re are only doing ACL policies, but relying on other projects for fancier things
17:35:03 <colindixon> #info also the scope is limited to L2/L3 network creations
17:35:24 <colindixon> #info in Beryllium the plan would be to support OpenFlow/OVSDB SB and GBP NB
17:37:44 <colindixon> #info mohnish asks if they talked about being a sub-project for GBP or NIC instead of a new project, xingjun says yes they talked about how to interact, but not about it being a sub-projecct
17:38:02 <colindixon> #startvote shall the FaaS project be moved into being an incubation project? -1, 0 +1
17:38:02 <odl_meetbot> Begin voting on: shall the FaaS project be moved into being an incubation project? Valid vote options are -1, 0, +1.
17:38:02 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:38:15 <LuisGomez> #vote +1
17:38:16 <dfarrell07> #vote +1
17:38:17 <colindixon> #vote +1
17:38:27 <ChrisPriceAB> #vote +1
17:38:29 <edwarnicke> #vote +1
17:38:33 <colindixon> dlenrow,
17:38:40 <mohnish> #vote +1
17:40:42 <colindixon> #endvote
17:40:42 <odl_meetbot> Voted on "shall the FaaS project be moved into being an incubation project?" Results are
17:40:42 <odl_meetbot> +1 (6): ChrisPriceAB, LuisGomez, edwarnicke, dfarrell07, mohnish, colindixon
17:40:53 <Uri_> +1
17:41:15 <colindixon> #agreed adding Uri’s +1 as well, we move FaaS to being an incubation project
17:41:36 <mohnish> 10 TSC members based on - https://www.opendaylight.org/governance
17:42:01 <gzhao> 6 is majority
17:42:58 <colindixon> #topic YANG PUBSUB creation review
17:43:47 <dlenrow> #vote +1
17:44:07 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000349.html proposed on 7/16/2015
17:44:13 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:YANG_PUBSUB
17:44:27 <dlenrow> Vote stuck through no covered zone
17:46:16 <colindixon> #info this is a project to help support a standards track set of work in the IETF as part of the I2RS working group
17:46:40 <colindixon> draft-ietf-netconf-push?
17:47:03 <colindixon> dfarrell07: I can’t see slides, so if you could add some notes, that would help a lot
17:48:00 <colindixon> #link https://tools.ietf.org/html/draft-clemm-netconf-yang-push-01 IETF draft
17:48:04 <xingjun> Thanks all to TSC members who voted for FaaS. looking foward to working with everybody. :)
17:48:26 <colindixon> xingjun: congrats!
17:48:39 <xingjun> Thanks Colin
17:48:43 <colindixon> #info shows a demo of pubsub working
17:49:03 <colindixon> #info it’s possible to do multiple subscriptions at once, which you can’t do with just YANG notifications
17:50:45 <colindixon> #Info colindixon asks if this should be a separate project or just part of the NETCONF project?
17:52:20 <colindixon> #info the answer is that they might want support other transports, which means that they’d like to be a separate project
17:52:22 <colindixon> just lost auido
17:52:24 <colindixon> rejoining
17:53:48 <Uri_> but it seems like there is some interdependence
17:55:09 <colindixon> #info LuisGomez says it’s not clear to him that the scope spans beyond netconf, the response is that
17:55:14 <ChrisPriceAB> would like to see some discussion first as well
17:57:16 <colindixon> #info colindixon, and many other TSC members say they’d like to see the discussion happen between the netconf project and this project
17:57:56 <colindixon> #action YANG PUBSUB project will reach out to the netconf project and we’ll discuss more based on the outcome of that
17:58:19 <colindixon> #info colindixon notes that this seems like a really cool project and that he things ODL definitely needs the technology and support
17:58:35 <edwarnicke> Do you guys hear me?
17:58:40 <edwarnicke> I have been asking a question
17:58:45 <mohnish> I can't
17:58:46 <einarnn> no, we don't
17:58:48 <edwarnicke> Question
17:58:51 <edwarnicke> To Eric
17:58:52 <xingjun> no
17:59:01 <edwarnicke> Does this project intend to participate in Beryllium
17:59:11 <tykeal> edwarnicke: no, I can't hear you
17:59:15 <edwarnicke> Question
17:59:17 <edwarnicke> To the TSC
17:59:22 <edwarnicke> I heard the answer
17:59:24 <colindixon> #info edwarnicke asks if the project intends to participate in Beryllium
17:59:30 <colindixon> #info Eric answers yes, it does
17:59:43 <edwarnicke> To the TSC: How does delaying this review interact with participation in Beryllium?
18:00:18 * edwarnicke is glad to know he remembers correctly :)
18:01:32 <colindixon> #inofo edwarnicke asks if the delay badly interacts with joining Beryllium, colindixon says no
18:01:49 <colindixon> #topic Messaging4Transport creation review
18:03:03 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Messaging4Transport
18:03:14 * tykeal notes he hasn't been having a good day with WebEx today either
18:03:15 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000338.html proposed on 7/8/2015
18:03:57 <pradeeban> https://wiki.opendaylight.org/images/9/90/Messaging4Transport.pdf
18:04:21 <edwarnicke> #link https://wiki.opendaylight.org/images/9/90/Messaging4Transport.pdf
18:05:42 * icbts hopes their is a Camel Component Integration for M4T :)
18:08:10 <colindixon> #Info icbts says that the hopes that there is a Camel Component Integration for M4T
18:11:01 <colindixon> I cant get to the slides, so if somebody else could take notes, that woudl be great
18:11:32 <colindixon> #info M4T is a binding for AMQP (and other message-oriented middleware) for the MD-SAL
18:12:31 <colindixon> #info this was presented at the design forum last week
18:13:53 <colindixon> #link http://opendaylightsummit2015.sched.org/event/19c5979c504fcfaa5035230635e718bf the presentation ad the design forum
18:14:23 <colindixon> when there’s time, I’m curious how this will interact with being secured by AAA?
18:15:55 <mohnish> #info Multiple controllers can be federated for messaging.
18:16:05 <colindixon> #Info this can allow for controller federation through standardized message brokers where each controller can publish and subscribe to each other’s information
18:16:48 <icbts> #info follow http://camel.apache.org/writing-components.html - once this is under camel we’ll have binding independance to all of Camel’s other endpoints
18:17:35 <colindixon> #info based on feedback from the design forum, they made sure that it could be independent of partiuclar bindings
18:18:08 <colindixon> #info mohnish asks what the MD-SAL bindings in question are
18:18:51 <colindixon> #info the answer is “whatever can be passed through the RESTCONF interface, should also be exposed through this"
18:19:14 <colindixon> #info data tree, notifications, and RPCs
18:20:01 * icbts from an EIP point of view, this sounds completely reasonable :)
18:20:29 <colindixon> #Info mohnish says he has other questions, but they’re mainly technical and so they could likely be deferred
18:21:25 <colindixon> #info colindixon asks if this will be protected by AAA?
18:21:36 <icbts> #info Camel would provide authentication, etc for messaging http://camel.apache.org/camel-security.html
18:21:42 <pradeeban> http://code.google.com/p/kryo/
18:22:39 <colindixon> #Info the answer is that it will protect itself in the same way RESTCONF does using AAA
18:22:51 <colindixon> #Info the code is in progress and on github
18:23:34 <colindixon> #info tykeal says any incoming code will have to go through IPR, but that happens after we approve it
18:24:02 <colindixon> #info edwarnicke asks if the intent is to participate in Beryllium
18:24:13 <pradeeban> I said, we hope to go with the Boron release.
18:24:25 <colindixon> #info pradeeban says no, but he hopes to participate in Boron
18:24:28 <mohnish> Boron???
18:25:24 <pradeeban> mohnish: Boron is the next release.
18:25:30 <pradeeban> of OpenDaylight
18:25:38 <colindixon> #startvote shall the TSC move the Messaging4Transport project to incubation? -1, 0, +1
18:25:38 <odl_meetbot> Begin voting on: shall the TSC move the Messaging4Transport project to incubation? Valid vote options are -1, 0, +1.
18:25:38 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:25:42 <dfarrell07> #vote +1
18:25:43 <ChrisPriceAB> #vote +1
18:25:43 <edwarnicke> #vote +1
18:25:44 <colindixon> #vote +1
18:25:49 <mohnish> #vote +1
18:25:58 <Uri_> +1
18:26:08 <LuisGomez> #vote +1
18:26:14 <ChrisPriceAB> # vote Uri
18:26:23 <Uri_> #vote +1 (sorry)
18:26:23 <odl_meetbot> Uri_: +1 (sorry) is not a valid option. Valid options are -1, 0, +1.
18:26:26 <colindixon> #endvote
18:26:26 <odl_meetbot> Voted on "shall the TSC move the Messaging4Transport project to incubation?" Results are
18:26:26 <odl_meetbot> +1 (6): ChrisPriceAB, LuisGomez, edwarnicke, dfarrell07, mohnish, colindixon
18:26:29 <ChrisPriceAB> lol
18:26:34 <tykeal> hehe
18:26:47 <ChrisPriceAB> we missed Uri_ 's sorry vote :D
18:26:55 <Uri_> lol
18:27:04 <colindixon> #agreed the Messaging4Transport project is moved to incubation, note Uri_ and colindixon also voted +1
18:27:21 <pradeeban> Thanks a lot everyone who voted and gave constructive feedback and questions. Appreciate a lot.
18:27:24 <gzhao> (sorry) is not a valid option lol
18:27:58 <colindixon> #topic controller shield
18:28:46 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Controller_Shield
18:28:52 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-June/000322.html proposed on 6/8/2015
18:30:26 <colindixon> and I just got all the IRC messages :p
18:32:49 * ChrisPriceAB needs to jump off the call, abhijitkumbhare will stand in for me for the rest of the call. Sorry to run, later folks.
18:33:26 <ChrisPriceAB> coindixon: now that you are back I will jump off the call abhijitkumbhare will stand in for me.
18:52:36 <mohnish> #info Colin notes that SDNi wrapper interaction with Controller shield may be out of scope.
18:53:32 <mohnish> #info TSC members are asking for clarification of scope.
18:57:39 <mohnish> #info Helen Chen notes the possible overlap with Unified Secure Channel goals.
18:59:21 <gzhao> #info dfarrell07 +1
18:59:39 <gzhao> #info colidixon +1
18:59:42 <mohnish> #info mohnish +1
18:59:47 <LuisGomez> #info LuisGomez +1
19:00:02 <abhijitkumbhare> #info abhijitkumbhare +1
19:00:44 <gzhao> #info edwarnicke +1
19:01:21 <gzhao> #info congratulations to controller shield project
19:01:27 <pradeeban> Thank you.
19:01:27 <mohnish> #agreed Controller Shield is approved for incubation.
19:02:05 * gzhao thinks colin needs to end the meeting.
19:02:32 <gzhao> pradeeban: please subscribe release, tsc mailing list.
19:03:14 <gzhao> pradeeban: preferable send email to formally joins beryllium and report M1 status.
19:03:21 <gzhao> pradeeban: congratulations again.
19:03:44 <pradeeban> gzhao: I have subscribed to the tsc list already. I will subscribe to the release list. Thanks.
19:04:15 <gzhao> pradeeban: cool
19:04:36 <tykeal> #endmeeting