#opendaylight-meeting: tsc

Meeting started by phrobb at 17:01:12 UTC (full logs).

Meeting summary

    1. LuisGomez (LuisGomez, 17:01:42)

  1. roll call and agenda bashing (colindixon, 17:02:13)
    1. colindixon (colindixon, 17:02:16)
    2. mohnish anumala (mohnish, 17:02:29)
    3. TSC members please #info in (phrobb, 17:02:30)
    4. dfarrell07 (dfarrell07, 17:02:42)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=35078#Agenda the agenda for today (colindixon, 17:02:44)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-06-17.00.html last weeks meeting minutes for action items (colindixon, 17:02:55)
    7. Chris Price (ChrisPriceAB, 17:04:45)
    8. edwarnicke (edwarnicke, 17:05:01)
    9. ACTION: gzhao to send out exact cutoff dates/times for Lithium SRs past SR-1 (colindixon, 17:05:27)
    10. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) (colindixon, 17:05:38)
    11. ACTION: phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours (colindixon, 17:06:02)
    12. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:06:14)
    13. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:06:26)
    14. https://lists.opendaylight.org/pipermail/release/2015-August/003411.html <-- SR1 date proposal for TSC (gzhao, 17:06:28)
    15. ACTION: tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting (colindixon, 17:06:34)
    16. edwarnicke sasy that current sonar/jacoco coverage is not reporting stuff for IT as well as UT (colindixon, 17:07:33)
    17. ACTION: edwarnicke and phrobb- to send out a mails for candidate dates for hackfest (colindixon, 17:07:51)
    18. https://meetings.webex.com/collabs/#/meetings/detail?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB&rnd=674952.90619 (dfarrell07, 17:08:46)
    19. ACTION: phrobb- will send out escalation instructions again (colindixon, 17:09:00)
    20. jmedved (jmedved, 17:09:39)
    21. AGREED: this meeting will be two hours (colindixon, 17:10:56)

  2. mailing list votes (colindixon, 17:11:07)
    1. first vote is on the way that a project can change it’s scope (colindixon, 17:11:29)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html starting the thread in July (colindixon, 17:11:39)
    3. https://lists.opendaylight.org/pipermail/tsc/2015-August/003564.html continueing in August (colindixon, 17:11:52)
    4. https://lists.opendaylight.org/pipermail/tsc/2015-August/003590.html 2 hour TSC meetings until we no longer need them (colindixon, 17:12:40)

  3. events (colindixon, 17:13:11)
    1. https://www.opendaylight.org/global-events (colindixon, 17:13:26)
    2. we openstack in october (colindixon, 17:13:35)
    3. there will be a CFP for the mini-summit with SDN/OF world conference in dusseldorf will be out today (colindixon, 17:14:02)

  4. stable/lithium (colindixon, 17:14:15)
    1. the cutoff date for patches is 11:59p UTC on Sunday (colindixon, 17:14:37)
    2. we’ll hopefully vote on artifacts next week assuming we don’t have problems (this is all for Lithium-SR1) (colindixon, 17:14:58)
    3. this is one week behind the original plan (colindixon, 17:15:09)
    4. https://git.opendaylight.org/gerrit/25167/ this is a controller patch zxiiro needs before Lithium-SR1 so auto-release will run (colindixon, 17:15:46)

  5. beryllium (colindixon, 17:16:06)
    1. https://docs.google.com/spreadsheets/d/1o9L1q5OYl9T6ZwBEkAuPSoostFMIsjp4mh2FDawuk20/edit?pli=1#gid=0 <-- Beryllium status spreadsheet. (gzhao, 17:16:09)
    2. we have 44 participating so far and 11 awaing approval (colindixon, 17:16:35)
    3. https://lists.opendaylight.org/pipermail/release/2015-August/003402.html (gzhao, 17:17:50)
    4. https://lists.opendaylight.org/pipermail/release/2015-August/003402.html some projects that we might have expected to join Beryllium, have not yet done so (colindixon, 17:18:09)
    5. tykeal notes that maple _still_ hasn't passed all points needed for getting resources (colindixon, 17:19:01)
    6. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current weather (colindixon, 17:19:26)
    7. colindixon notes that the netconf feature is likely to move soon, and projects should be getting ready (colindixon, 17:19:43)

  6. community manager (colindixon, 17:20:44)
    1. we have some development on finding a community manager (colindixon, 17:21:14)
    2. over the next few weeks we’ll be transitioning where gzhao will be moving into a community manager role, while a new huawei person takes over for him as a release manager (colindixon, 17:21:42)

  7. system integration test (colindixon, 17:23:43)
    1. LuisGomez says nothing this week (colindixon, 17:23:50)

  8. infrastructure (colindixon, 17:24:01)
    1. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.releng.builder/master/ zxiiro has been workign on getting maven sites work and they will provide demos for projects on how to do this soon (colindixon, 17:24:49)
    2. zxiiro says they plan to make shorter links (colindixon, 17:25:34)
    3. https://lists.opendaylight.org/pipermail/tsc/2015-August/003559.html mailing list thread on forge authors (colindixon, 17:26:19)
    4. zxiiro says this allows for permission to push a patch on another person’s behalf (that is while leaving them as the formal Author in git) (colindixon, 17:26:47)
    5. we current allow this for committers on a given project (colindixon, 17:27:02)
    6. edwarnicke says he uses this on projects where he’s a committer to do simple rebases and other simple fixes (colindixon, 17:27:34)
    7. https://wiki.opendaylight.org/view/Documentation/Tools#Updating_an_Existing_Patch there is a hack-around to this listed here, but it’s a bit ugly as you “steal” credit (colindixon, 17:28:45)
    8. mohnish asks if there’s a way to tell if something was forged (colindixon, 17:29:18)
    9. tykeal says yes, but only in the gerrit UI, but not in git itself (colindixon, 17:29:32)
    10. tykeal says the only way to be able to tell from git alone would be to have people GPG sign their commits, but he doesn’t know how it works (colindixon, 17:29:53)
    11. edwarnicke would like to allow projects to opt out of this (colindixon, 17:30:40)
    12. VOTE: Voted on "shall we enable forge-authors for everyone as the default with the option for projects to opt-out if the want?" Results are, +1: 7 (colindixon, 17:31:57)
    13. AGREED: we will allow forge-authors by default (colindixon, 17:32:09)

  9. commmitter promotions (colindixon, 17:32:21)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-August/003623.html ryan gourdling on AAA (colindixon, 17:32:33)
    2. VOTE: Voted on "shall we make Ryan Goulding a committer on AAA?" Results are, +1: 8 (colindixon, 17:33:57)
    3. AGREED: with 7 votes (note Ambika is not a TSC member) Ryan Gouding is a committer on AAA (colindixon, 17:34:23)

  10. YANG PUB SUB vote (colindixon, 17:34:45)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-August/003632.html communtcation between YANG PUB SUB and NETCONF (colindixon, 17:35:10)
    2. https://wiki.opendaylight.org/view/Project_Proposals:YANG_PUBSUB the origitnal proposal for which the only real critique was that they talk to NETCONF to see if a new projet was the right approach (colindixon, 17:35:51)
    3. the communication says that a new project does make sense (colindixon, 17:36:01)
    4. ACTION: Ambika will add the two missing ODL user IDs for committers (colindixon, 17:36:39)
    5. ACTION: Ambika to fix the link to the preseentation at the bottom (colindixon, 17:37:07)
    6. VOTE: Voted on "shall we move the YANG PUBSUB project to incubation?" Results are, +1: 7 (colindixon, 17:39:12)
    7. AGREED: congratulations to the YANG PUBSUB project on moving to incubation (colindixon, 17:39:28)

  11. UNIMgr creation review (colindixon, 17:40:01)
    1. https://wiki.opendaylight.org/images/c/c8/UNI_Manager_Project_Proposal_to_OpenDaylight.pptx the presention (colindixon, 17:40:41)
    2. https://wiki.opendaylight.org/view/Project_Proposals:UNIMgr project proposal (colindixon, 17:41:13)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000361.html proposed on 7/24/2015 (colindixon, 17:41:26)
    4. this project is seeking to provide new features along standards in the metro ethernet forum (colindixon, 17:41:57)
    5. problem statement is around the fact that it’s hard to deploy carrier ethernet services, OpenDaylight could help make this eaiser and compensate for devices that dont’ support everything (colindixon, 17:43:28)
    6. Project goal: Investigate and identify means to facilitate fulfillment of Ethernet/connectivity services using virtualization technologies (SDN and NFV) and open source SDN controller. (colindixon, 17:44:00)
    7. Current objectives: (1) Develop information models and open standard APIs (2) Compliant with MEF-defined Carrier Ethernet Service (3) Enable applications to leverage OpenDaylight capabilities to configure network components and connections (colindixon, 17:44:46)
    8. ACTION: KevinLuehrs to add ODL user IDs for committers listed without them (colindixon, 17:46:27)
    9. slide 5 shows the high-level, layered architectured (colindixon, 17:46:52)
    10. KevinLuehrs says that they already have a prototype (colindixon, 17:47:10)
    11. slide 6 shows the information model that they’re use (colindixon, 17:47:29)
    12. slide 7 shows the PoC they have: creating a tunnel of virtual ehternet (colindixon, 17:48:33)
    13. colindixon asks if the info model is in YANG? the answer is it’s in UML now and they have a very simple subset of that in YANG (colindixon, 17:49:42)
    14. part 2 of the answer is that MEF (metro ethernet model) has a much more full-featured version of the YANG model (colindixon, 17:50:11)
    15. colindixon asks if there’s a tool to translate from UML to YANG? KevinLuehrs says yes, but they’re likely to use the MEF version (colindixon, 17:50:40)
    16. jmedved asks how specifc to the ovsdb plugin is it? KevinLuehrs says that the current demo/PoC is dependent on that, but the intent is to be plugin agnostic (colindixon, 17:52:05)
    17. jmedved says that what would be really cool is if we had a YANG model of what feautres you actually need and then you can provide plugins for that model so that it’s as device agnostic as possible (colindixon, 17:53:02)
    18. KevinLuehrs says he agrees (colindixon, 17:53:07)
    19. edwarnicke says that using the ideas from GBP and SFC around renderers and maybe the current work on overlay layers, might be very useful for this project (colindixon, 17:55:11)
    20. https://lists.opendaylight.org/pipermail/discuss/2015-August/005478.html discussion around overlay manager layer (as well as Honeycomb and App Coexistence) (edwarnicke, 17:56:23)
    21. Mufaddal Makati says they already have a lot of what jmedved suggests in terms of being device agnostic  (colindixon, 17:56:24)
    22. KevinLuehrs says the initial use case is ethernet private ethernet line service (colindixon, 17:57:19)
    23. this requires creation of UNIs, creating of connections between pairs (colindixon, 17:57:46)
    24. this is the building blocks of going from point-to-point, to point-to-multipoint, to multipoint-to-multipoint (colindixon, 17:58:10)
    25. they walk through the demo showing classes of service, e.g., gold, silver, and bronze (colindixon, 17:58:37)
    26. jmedved asks if this GUI will come to DLUX (colindixon, 17:58:45)
    27. KevinLuehrs says right now the GUI is just for testing and it’s in OPNFV (colindixon, 17:59:05)
    28. KevinLuehrs says that it’s not their intent to build a GUI, but they wouldn’t oppose it if somebody really wanted it (or better yet to buid it) (colindixon, 17:59:33)
    29. KevinLuehrs says their focus in reality is just for the APIs and the minimum amout of stuff around that to do the demos (colindixon, 18:00:03)
    30. ACTION: KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models (colindixon, 18:04:36)
    31. ACTION: KevinLuehrs to link to the powerpoint slides from the proposal page (colindixon, 18:05:45)
    32. VOTE: Voted on "shall we move the UNI Manger Plugin project to incubation?" Results are, +1: 6 (colindixon, 18:06:22)
    33. AGREED: the UNI Manager plugin project is moved to incubation (colindixon, 18:06:35)

  12. OFCONFIG creation review (colindixon, 18:07:11)
    1. https://wiki.opendaylight.org/view/Project_Proposals:OF-CONFIG the project proposal (colindixon, 18:07:18)
    2. https://wiki.opendaylight.org/view/File:Presentation-config-proposal-review.pdf the presentation (colindixon, 18:07:34)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000333.html proposed on 7/3/2015 (colindixon, 18:07:47)
    4. for those who don’t know, OFCONFIG is the ONF spec to enable the remote configuration of OpenFLow datapaths (colindixon, 18:09:34)
    5. OFCONFIG configures OpenFlow Capable Swichtes and OpenFlow Configuration Points, while the OpenFlow protocol controls OpenFlow Logical switches (colindixon, 18:10:22)
    6. OFCONFIG is based ON NETCONF (colindixon, 18:10:30)
    7. the proposal is to add thre logical blocks to OpenDaylight: (1) any apps that want to use OFCONFIG, (2) and OFCONFIG API, and (3) and OFCONFIG plugin (colindixon, 18:12:37)
    8. jmedved asks why do you need a separate plugin from NETCONF? (colindixon, 18:13:52)
    9. ChrisPriceAB, jmedved, and abhijitkumbhare say that they’re understanding is just implementing the OF-CONFIG model and they don’t need a new plugin (colindixon, 18:14:21)
    10. https://github.com/openvswitch/of-config#architectural-overview mohnish points out that in fact, the offical diagram shows it using NETCONF (colindixon, 18:15:45)
    11. jmedved would like to see a common model across OFCONFIG and OVSDB (colindixon, 18:16:05)
    12. everyone says that this is a really cool stuff, but that it likely makes sense to just use the existing NETCONF plugin (colindixon, 18:17:29)
    13. colindixon would like to note that he thinks having OF-CONFIG would be useful regardless and we should not gate things on having a unfied interface between OVSDB and OF-CONFIG (colindixon, 18:20:41)
    14. ChrisPriceAB, colindixon, abhijitkumbhare, and mohnish say they think we we should let them have the project and give them technical advice as it get started rather than blocking the project until they work them out (colindixon, 18:22:42)
    15. ChrisPriceAB points out that if they decide they really need their own NETCONF plugin, that’s likely fine, but he thinks it’s a bad idea that will cost them a lot of time (colindixon, 18:23:15)
    16. jmedved says that he would love to help work on the architecture so that it can leverage the existing NETCONF plugin if anyone wants (colindixon, 18:24:33)
    17. gzhao suggests that they contact the NETCONF committers and possibly add them as contributor or committer (colindixon, 18:25:21)
    18. ACTION: OF-CONFIG project will add ODL user IDs for the committers to the project proposal (colindixon, 18:25:45)
    19. ACTION: OF-CONFIG project will reach to the NETCONF project to see how they can best interact (colindixon, 18:26:12)
    20. jmedved says he’s strongly encorage us to do a bit more architectural work before we approve a proposal (colindixon, 18:28:09)
    21. colindixon says he’s not sure that we actually have the power to reject something based on technical/engineering issues (colindixon, 18:30:18)
    22. edwarnicke seconds colindixon’s understanding (colindixon, 18:30:41)
    23. dfarrell07 says we should defer it to the mailing list (colindixon, 18:30:53)
    24. Wei Meng says he’s not sure that the NETCONF plugin can do what he needs (colindixon, 18:33:27)
    25. ACTION: colindixon to start a thread on the tsc mailing list about approving the OF-CONFIG project (colindixon, 18:34:04)

  13. Centinel creation review (colindixon, 18:34:24)
    1. https://wiki.opendaylight.org/view/File:Centinel-08132015.pdf the presentation (colindixon, 18:34:44)
    2. https://wiki.opendaylight.org/view/Project_Proposals:Centinel the project proposal (colindixon, 18:34:52)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-May/000317.html originally proposed as the SDN App SDK on 5/19/2015 (colindixon, 18:35:14)
    4. centinel aims to proivde a distributed, reliable framework for efficienty collecting, aggregating, and sinking steaming data across the persistence DB and stream analyzers (colindixon, 18:36:28)
    5. the scope is two things: (1) stream collector, (2) log service (colindixon, 18:36:55)
    6. stream collector sources include SDN ecosystem things (controllers, plugins, apps), general info (switches/routers), third-party tools (nagios, ganglia) etc. (colindixon, 18:37:36)
    7. input/output formats could be unstructured, semi-structured, or structured (colindixon, 18:37:53)
    8. the goal is to then sink them to the persistence DB project (colindixon, 18:38:07)
    9. also to push these streams out to stream processors if desired (colindixon, 18:38:30)
    10. the log service is a specifc set of plugins targeting streams of logs to provide alerts, troubleshooting, etc. (colindixon, 18:40:59)
    11. scope in beryllium: stream collector bases on flume and sqoop with a focus on ODL logs, log service using graylog to do analysis including events/alerts, a web interface, to leverage the TSDR persitence service (colindixon, 18:45:53)
    12. mohnish says the centinel team had a very good discussion with the TSDR team about how they would integrate (colindixon, 18:47:46)
    13. mohnish says kibana seems interesting to both centinel and TSDR, but that’s moot about the voting (colindixon, 18:48:25)
    14. mohnish points out that the TSDR dashboard isn’t in DLUX (colindixon, 18:49:17)
    15. jmedved asks if the intent to go toward being in DLUX? mohnish says yes, he’d like to see that (colindixon, 18:49:33)
    16. the centinel project says they intend to put things in DLUX (colindixon, 18:49:44)
    17. jmedved suggests that maybe using the event topic broker APIs that were recently created would make people’s lives easier in Centinel (colindixon, 18:50:40)
    18. sumit_kapoor says that he will consider that broker (colindixon, 18:51:11)
    19. yuling says that when TSDR and Centinel talked, their hope is that they can find common elements and the share them (colindixon, 18:52:49)
    20. jmedved says that’s a good points out that there is some willingness to change APIs for the event topic broker if it’s useful (colindixon, 18:53:21)
    21. VOTE: Voted on "shall we move the Centinel project to incubation?" Results are, +1: 7 (colindixon, 18:54:32)
    22. AGREED: the Centinel projec is moved to incubation (colindixon, 18:54:45)

  14. NeXt UI toolkit (colindixon, 18:55:33)
    1. https://wiki.opendaylight.org/view/Project_Proposals:NeXt_UI_Toolkit project proposal (colindixon, 18:55:52)
    2. https://wiki.opendaylight.org/view/File:ODL_new_project_proposal_20150813.ppt.pdf presentation (colindixon, 18:56:04)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000365.html proposed on 7/31/2015 (colindixon, 18:56:14)
    4. NeXt has done lots of work on javascript-based rendering of topologys with expanding and collapsing nodes, switching different layouts (colindixon, 18:56:55)
    5. http://devnet-stage.kpimdp.com/site/neXt/ (Aikepaer, 18:57:15)
    6. dfarrell07 notes really cool demo videos linked from the proposals (colindixon, 18:57:26)
    7. http://devnet-stage.kpimdp.com/site/neXt/ the NeXt developer site (colindixon, 18:57:43)
    8. plan is to augment DLUX to just render topologies (colindixon, 18:58:01)
    9. there are a number of apps being developed (some with jmedved ) that are already working on top of NeXt (colindixon, 18:58:21)
    10. please add email for all initial committers (gzhao, 18:58:27)
    11. ACTION: Aikepaer please add comitters (colindixon, 18:58:47)
    12. VOTE: Voted on "shall we move the NeXt UI toolkit project to incubation?" Results are, +1: 6 (colindixon, 18:59:21)
    13. AGREED: NeXt Ui toolkit is a incubation project (colindixon, 18:59:32)

  15. cookies (colindixon, 18:59:38)


Meeting ended at 18:59:46 UTC (full logs).

Action items

  1. gzhao to send out exact cutoff dates/times for Lithium SRs past SR-1
  2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2)
  3. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
  4. phrobb to keep working on JIRA and let us know when we can use it
  5. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  6. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
  7. edwarnicke and phrobb- to send out a mails for candidate dates for hackfest
  8. phrobb- will send out escalation instructions again
  9. Ambika will add the two missing ODL user IDs for committers
  10. Ambika to fix the link to the preseentation at the bottom
  11. KevinLuehrs to add ODL user IDs for committers listed without them
  12. KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models
  13. KevinLuehrs to link to the powerpoint slides from the proposal page
  14. OF-CONFIG project will add ODL user IDs for the committers to the project proposal
  15. OF-CONFIG project will reach to the NETCONF project to see how they can best interact
  16. colindixon to start a thread on the tsc mailing list about approving the OF-CONFIG project
  17. Aikepaer please add comitters


Action items, by person

  1. Aikepaer
    1. Aikepaer please add comitters
  2. Ambika
    1. Ambika will add the two missing ODL user IDs for committers
    2. Ambika to fix the link to the preseentation at the bottom
  3. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2)
    2. colindixon to start a thread on the tsc mailing list about approving the OF-CONFIG project
  4. edwarnicke
    1. edwarnicke and phrobb- to send out a mails for candidate dates for hackfest
  5. gzhao
    1. gzhao to send out exact cutoff dates/times for Lithium SRs past SR-1
  6. phrobb
    1. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
    2. phrobb to keep working on JIRA and let us know when we can use it
    3. edwarnicke and phrobb- to send out a mails for candidate dates for hackfest
    4. phrobb- will send out escalation instructions again
  7. zxiiro
    1. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  8. UNASSIGNED
    1. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
    2. KevinLuehrs to add ODL user IDs for committers listed without them
    3. KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models
    4. KevinLuehrs to link to the powerpoint slides from the proposal page
    5. OF-CONFIG project will add ODL user IDs for the committers to the project proposal
    6. OF-CONFIG project will reach to the NETCONF project to see how they can best interact


People present (lines said)

  1. colindixon (197)
  2. odl_meetbot (35)
  3. dfarrell07 (31)
  4. edwarnicke (22)
  5. ChrisPriceAB (20)
  6. mohnish (12)
  7. gzhao (11)
  8. tykeal (10)
  9. jmedved (10)
  10. LuisGomez (7)
  11. zxiiro (6)
  12. dneary (5)
  13. phrobb (4)
  14. alagalah (4)
  15. vina_ermagan (4)
  16. abhijitkumbhare (4)
  17. Ambika (3)
  18. odl-casey (2)
  19. Aikepaer (2)
  20. jamoluhrsen (2)
  21. uri_ (1)
  22. tbachman (0)


Generated by MeetBot 0.1.4.