#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:08 UTC (full logs).

Meeting summary

  1. rol call and agenda bashing (colindixon, 17:00:14)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=35398 the agenda for today (colindixon, 17:00:50)
    2. Chris Price (ChrisPriceAB, 17:00:53)
    3. edwarnicke (edwarnicke, 17:00:55)
    4. colindixon (colindixon, 17:00:55)
    5. ACTION: OF-CONFIG project will add ODL user IDs for the committers to the project proposal (colindixon, 17:03:01)
    6. ACTION: KevinLuehrs to add ODL user IDs for committers listed without them (colindixon, 17:03:19)
    7. ACTION: KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models (colindixon, 17:03:20)
    8. ACTION: KevinLuehrs to link to the powerpoint slides from the proposal page (colindixon, 17:03:21)
    9. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (colindixon, 17:03:50)
    10. ACTION: phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours (colindixon, 17:04:29)
    11. dfarrell07_con (dfarrell07_con, 17:04:55)
    12. phrobb notes is that we should not wake up Thanh and Andy after hours immediately now as we now have staff in australia, please use the escalation process as usual to do that (colindixon, 17:05:13)
    13. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:05:40)
    14. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:05:58)
    15. ACTION: tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting (colindixon, 17:06:07)
    16. LuisGomez (LuisGomez, 17:07:27)
    17. jmedved (jmedved, 17:08:50)
    18. mohnish anumala (mohnish, 17:09:17)
    19. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-13-17.01.html last week’s minutes, we already got all the actions (colindixon, 17:09:45)
    20. adding integration split to the agenda (colindixon, 17:11:02)

  2. mailing list votes (colindixon, 17:11:11)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html this process to change a project’s scope (colindixon, 17:11:29)
    2. AGREED: this is the policy for a project to extend or reduce the scope of a project https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html (colindixon, 17:19:23)

  3. events (colindixon, 17:19:25)
    1. https://www.opendaylight.org/global-events the events page (colindixon, 17:19:32)
    2. the current plan for a hackfest is to be colocated with the OPFNV summit, 11/9-11/10 at the Hyatt Regency San Francisco Airport (colindixon, 17:20:22)
    3. http://events.linuxfoundation.org/events/opnfv-summit < -- opnfv summit (gzhao, 17:20:41)
    4. this is the last call for objections, all feedback so far has been positive (colindixon, 17:20:52)
    5. https://lists.opendaylight.org/pipermail/tsc/2015-August/003653.html mailing list thread (colindixon, 17:21:13)
    6. ChrisPriceAB says he thinks it’s a great idea (colindixon, 17:21:39)
    7. phrobb will lock down the venue (colindixon, 17:21:56)
    8. SDN OpenFlow world congress in dusseldorf has it’s CFP out now (colindixon, 17:22:44)
    9. https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress (abhijitkumbhare, 17:22:47)
    10. https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress (abhijitkumbhare, 17:22:52)
    11. happy birthday to ChrisPriceAB! (colindixon, 17:23:13)

  4. Lithium-SR1 (colindixon, 17:23:52)
    1. https://docs.google.com/spreadsheets/d/1udOk9ZmOCeMjpI-wl0zjLO_AXgO8wYrDjKiPQWkXKb4/edit#gid=0 these are the test failures that we had with Lithium-SR1, all projects have said they are expected/non-regressions/non-blocking (colindixon, 17:24:44)
    2. https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1083/org/opendaylight/integration/distribution-karaf/0.3.1-Lithium-SR1/ this is the relevant artifacts (colindixon, 17:25:50)
    3. LuisGomez says there are no regressions to his knowledge (colindixon, 17:26:13)
    4. gzhao suggests Lithium SR1 is a go (gzhao, 17:26:47)
    5. VOTE: Voted on "shall the TSC approve these as the Lithium-SR1 artifacts: https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1083/ ?" Results are, +1: 6 (colindixon, 17:27:28)
    6. AGREED: Lithium-SR1 is a go (colindixon, 17:27:38)

  5. Beryllium (colindixon, 17:28:14)
    1. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current weather report (colindixon, 17:29:01)
    2. gzhao says the problem is that we have lots of new projects that are spinning up as fast as they can (colindixon, 17:29:16)
    3. george says that as he steps down, the new person is stepping up but there will be an announcement as they come up to speed (colindixon, 17:31:55)
    4. edwarnicke suggests to give the new person some airtime to make it clear that people pay careful attention to their mails when they come (colindixon, 17:32:25)
    5. gzhao is actually worried about M2 and M3 more than M1 and so new projects may need more help then (colindixon, 17:33:44)
    6. ACTION: colindixon to see if anyone wants to write survival guides for M2 and M3 (colindixon, 17:34:32)
    7. https://lists.opendaylight.org/pipermail/tsc/2015-August/003702.html gzhao had a question about how to acknowledge dependencies (colindixon, 17:35:23)
    8. gzhao would like to thank phrobb and edwarnicke for their help and support for working as RM. (gzhao, 17:36:40)

  6. infrastructure (colindixon, 17:37:40)
    1. the dial-in numbers for all WebEx meetings hosted by the LF changed, if you haven’t updated them, please check to make sure they’re right (colindixon, 17:38:49)
    2. odl-casey did a lot of that on the meetings page and updated the calendar (colindixon, 17:39:42)
    3. abhijitkumbhare asks if we can help to have recordings from meetings that overlap (colindixon, 17:40:07)
    4. phrobb asks if we want to consider moving off WebEx (colindixon, 17:40:27)
    5. ACTION: phrobb to start a discussion on the idea of moving from WebEx to something else (colindixon, 17:40:48)
    6. jmedved (jmedved, 17:41:08)

  7. continuation of the OF-CONFIG creation review (colindixon, 17:42:11)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-August/003706.html lots of discussion happened here (colindixon, 17:42:25)
    2. https://wiki.opendaylight.org/view/Project_Proposals:OF-CONFIG the revised proposal (colindixon, 17:42:52)
    3. VOTE: Voted on "shall we move the OF-CONFIG project to incubatin?" Results are, +1: 7 (colindixon, 17:43:37)
    4. AGREED: the OF-CONFIG project is moved to incubation (colindixon, 17:43:46)

  8. Armoury creation review (colindixon, 17:44:35)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Armoury (colindixon, 17:45:00)
    2. https://wiki.opendaylight.org/images/c/c0/Armoury_Proposal.pdf the presentation (colindixon, 17:45:18)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-August/000367.html proposed on 8/5/2015 (colindixon, 17:45:38)
    4. there is no way for OpenDaylight today ask for resources from a VM provisiioning service, e.g., OpenDaylight (colindixon, 17:46:48)
    5. it’s all requests from the VM provisioning system to OpenDaylight for networking (colindixon, 17:47:07)
    6. Armoury Overview: Just as compute needs to make requests to the controller to get networking resources in order to provide its services, so too does the controller sometimes need to make requests of the workload manager to get compute resources and/or network function (NF) (physical or virtual) orchestration to provide its services. (colindixon, 17:48:13)
    7. Uri says while the need for this is clear, it’s not clear to him whether this request should orginate from ODL or some orchestrator further north (colindixon, 17:49:13)
    8. edwarnicke says that there was a lot of this discussion at the summit which produced ths project proposal, and one thing that came out was that you need to have some way to hand off ODL-specific information to an orchestrator (colindixon, 17:50:51)
    9. AMOURY SCOPE (colindixon, 17:52:01)
    10. 1. A registry or catalog of the necessary information (images, metadata, templatized day 0 config, how to communicate with the NF, etc) to describe the NF to the workload manager and/or network function (NF) (physical or virtual) orchestration. (colindixon, 17:52:13)
    11. 2. The most minimal possible API to allow applications to request that the workload manager start/stop/etc the NF and some information from the workload manager/nf orchestrator about the state of the NF. (colindixon, 17:52:28)
    12. 3. Example Drivers to talk to various workload managers (OpenStack/Meseophere/Docker/Kubernetes/etc). (colindixon, 17:52:37)
    13. jmedved and adetalhouet say that this is aimed at both physical NFs and virtual NFs (colindixon, 17:53:03)
    14. tony asks if the scope is bascially to prove a facade to abstract the interface to different orchestrators? (colindixon, 17:53:51)
    15. jmedved says yes, but adetalhouet seems to be unable to get a word in edgewise over edwarnicke and jmedved. (colindixon, 17:55:09)
    16. https://wiki.openstack.org/wiki/Tacker (colindixon, 17:56:08)
    17. uri and edwarnicke go back and forth about where the relevant responsibilites should reside (colindixon, 17:57:26)
    18. ChrisPriceAB and Uri both say we should be clear that responsiblity should be alloacated between compute and/or (V)NF manager and that the amoutn in each place might vary (colindixon, 18:02:33)
    19. abhijitkumbhare asks what’s in OpenDaylight, adetalhouet says everything in orange boxes on slide 8 (colindixon, 18:04:09)
    20. workloadproviders are drivers for different providers, e.g., mesosphere, docker, openstack (colindixon, 18:04:45)
    21. the workload manager is the thing which provides the ODL interfact to spin things up and down (colindixon, 18:04:59)
    22. jmedved asks where NF images are going to be stored? (colindixon, 18:05:23)
    23. adetalhouet says that woudl be stored in the NF Repository (colindixon, 18:05:34)
    24. colindixon says slide 9 says it’s actually going to be metadata or pointers to NFs that are in the NF repository, not the actual images (colindixon, 18:06:17)
    25. ChrisPriceAB needs to drop, abhijitkumbhare will stand in for me for the rest of the call. (ChrisPriceAB, 18:08:31)
    26. Prem_ and mohnish asks how this expands out to dealing with longer workflow, adetalhouet says that this would be the responsiblity of the ODL applicatin and/or orchestrator, not Armoury itself (colindixon, 18:08:57)
    27. https://wiki.openstack.org/wiki/Tacker colindixon asks if there’s a plan to interact with Tacker (colindixon, 18:12:28)
    28. there are no current plans, but it could be a workload provider to provide Armoury functionality (colindixon, 18:14:14)
    29. afewell notes that tacker has a broader scope as it plans to be VNF manager, which includes more functions like lifecycle-managmement (colindixon, 18:15:00)
    30. edwarnicke says that a key element is avoiding welding us to a given provider (colindixon, 18:15:35)
    31. jmedved says it’s also the only thing he knows of that controls both physical and virtual NFs (colindixon, 18:16:35)
    32. mohnish says he likes the idea, but he’s curious how much it overlaps and how it fits in with other similar ideas and architecture diagrams, e.g., ETSi (colindixon, 18:17:26)
    33. https://www.ietf.org/proceedings/92/slides/slides-92-nfvrg-7.pdf (mohnish, 18:19:19)
    34. https://www.ietf.org/proceedings/92/slides/slides-92-nfvrg-7.pdf if you look at the last slide here, they have the VNF manager is above OpenStack (colindixon, 18:20:51)
    35. mohnish asks where Armoury fits in the diagram (colindixon, 18:21:06)
    36. edwarnicke says he can’t imagine drawing Armoury in this diagram because it doesn’t have a network controller (colindixon, 18:22:48)
    37. edwarnicke says that if you chose openmano as your workload provider, then Armoury would make requests to it about what (V)NFs it needs, it woudl be allowed to either meet that request, not meet it, or return something it things was a better decision (colindixon, 18:24:31)
    38. VOTE: Voted on "shall we move Armoury to incubation?" Results are, +1: 7 (colindixon, 18:26:36)
    39. Uri also votes +1 (colindixon, 18:26:44)
    40. AGREED: the Armoury project is moved to incubation (colindixon, 18:26:53)

  9. integration split (colindixon, 18:27:04)
    1. https://lists.opendaylight.org/pipermail/project-proposals/2015-August/000369.html (colindixon, 18:27:29)
    2. https://wiki.opendaylight.org/view/Project_Proposals:Integration_Test (colindixon, 18:28:03)
    3. https://wiki.opendaylight.org/view/Project_Proposals:Integration_Distribution (colindixon, 18:28:07)
    4. https://wiki.opendaylight.org/view/Project_Proposals:Integration_Packaging (colindixon, 18:28:13)
    5. the TSC considers that for this special case the new projects have met the requirement for 2 weeks of public reviews, despite not being sent to project-proposals (all projects in the future are still expected to send mail to project-proposals) (colindixon, 18:29:12)
    6. https://lists.opendaylight.org/pipermail/integration-dev/2015-August/003976.html (afewell, 18:29:22)
    7. LuisGomez says there were always three folders in integration: test, distribution, and packaging, but there was no need to have separate proejcts (colindixon, 18:30:40)
    8. they are now big enoguh that they would like to split (colindixon, 18:31:00)
    9. also, it will enable faster movement because building each one will be faster than building all of them (colindixon, 18:31:28)
    10. https://lists.opendaylight.org/pipermail/integration-dev/2015-August/003976.html the explanation of the split (colindixon, 18:32:16)
    11. https://wiki.opendaylight.org/view/Project_list (abhijitkumbhare, 18:37:17)
    12. was thre a methodology for coming up with the committers on the new projects? (colindixon, 18:37:29)
    13. all existing committers were offered to be on whatever projects they wanted, others were added if they felt it was required (colindixon, 18:37:53)
    14. the only committer here that wasn’t on integration is Thanh on packaging (colindixon, 18:38:12)
    15. zxiro has a large contribution history to integration: https://git.opendaylight.org/gerrit/#/q/owner:thanh.ha%2540linuxfoundation.org+project:integration (edwarnicke, 18:38:56)
    16. The git history will be preserved after the split (dfarrell07_con, 18:39:13)
    17. colindixon asks what will happen to the current integration repo (colindixon, 18:39:20)
    18. LuisGomez the current repo will effectively archived as soon as that makes sense (colindixon, 18:39:42)
    19. colindixon asks if the integration project voted to archive the original project, dfarrell07_con and LuisGomez say that it was implicit in the decision to split (colindixon, 18:41:22)
    20. VOTE: Voted on "shall we move the three new integration projects splitting out from integration?" Results are, +1: 6 (colindixon, 18:43:08)
    21. Uri also votes +1 (colindixon, 18:43:15)
    22. AGREED: the three new integration subprojects are moved to incubation (colindixon, 18:43:27)

  10. next week (colindixon, 18:45:12)
    1. colindixon says next week will return to the normal 1 hour meeting (colindixon, 18:45:24)

  11. cookies (colindixon, 18:45:32)


Meeting ended at 18:45:36 UTC (full logs).

Action items

  1. OF-CONFIG project will add ODL user IDs for the committers to the project proposal
  2. KevinLuehrs to add ODL user IDs for committers listed without them
  3. KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models
  4. KevinLuehrs to link to the powerpoint slides from the proposal page
  5. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  6. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
  7. phrobb to keep working on JIRA and let us know when we can use it
  8. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  9. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
  10. colindixon to see if anyone wants to write survival guides for M2 and M3
  11. phrobb to start a discussion on the idea of moving from WebEx to something else


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
    2. colindixon to see if anyone wants to write survival guides for M2 and M3
  2. phrobb
    1. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
    2. phrobb to keep working on JIRA and let us know when we can use it
    3. phrobb to start a discussion on the idea of moving from WebEx to something else
  3. UNASSIGNED
    1. OF-CONFIG project will add ODL user IDs for the committers to the project proposal
    2. KevinLuehrs to add ODL user IDs for committers listed without them
    3. KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models
    4. KevinLuehrs to link to the powerpoint slides from the proposal page
    5. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
    6. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting


People present (lines said)

  1. colindixon (169)
  2. odl_meetbot (34)
  3. dfarrell07_con (28)
  4. ChrisPriceAB (18)
  5. afewell (17)
  6. gzhao (11)
  7. abhijitkumbhare (11)
  8. edwarnicke (10)
  9. mohnish (10)
  10. jmedved (9)
  11. LuisGomez (9)
  12. phrobb (2)
  13. adetalhouet (1)
  14. Prem_ (1)
  15. uri_ (1)
  16. jamoluhrsen (1)


Generated by MeetBot 0.1.4.