17:00:18 <colindixon> #startmeeting tsc
17:00:18 <odl_meetbot> Meeting started Thu Aug 27 17:00:18 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:18 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:23 <colindixon> #topic roll call and agenda bashing
17:00:25 <colindixon> #info colindixon
17:00:25 <dfarrell07> #info dfarrell07
17:00:30 <mohnish_> #info mohnish anumala
17:00:32 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=35733#Agenda the agenda for today
17:00:38 <dlenrow> #info dlenrow
17:00:43 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-20-17.00.html last week’s meeting minutes
17:02:05 <colindixon> #action OF-CONFIG project will add ODL user IDs for the committers to the project proposal
17:02:14 <colindixon> #action colindixon to see if anyone wants to write survival guides for M2 and M3
17:02:25 <dfarrell07> phrobb: the webex phone numbers on the GCal (at least) haven't been updated, FYI
17:02:26 <LuisGomez_> #info LuisGomez
17:02:38 <colindixon> #action phrobb to start a discussion on the idea of moving from WebEx to something else
17:02:51 <colindixon> #action dfarrell07 to work with odlcasey to get the gcal webex numbers fixed
17:02:57 <edwarnicke> #info edwarnicke
17:02:58 <dfarrell07> colindixon: ACK
17:03:03 <colindixon> #action tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
17:03:06 * tykeal mutters imprecations webex
17:03:46 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:03:59 <dfarrell07> odlcasey: I see you have edit permissions on the GCal. Is that working?
17:04:02 <abhijitkumbhare> #info abhijitkumbhare
17:04:06 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:04:14 <dneary_> Hi all
17:04:17 * edwarnicke warns tykeal to be cautious of his invocations lest he invoke the elder conferences...
17:04:18 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:04:24 <dfarrell07> odlcasey: at least the Integration and TSC meeting phone numbers need to be updated
17:04:57 <abhijitkumbhare> So some of us can drop :)
17:05:19 <colindixon> #topic events
17:05:25 <colindixon> #chair phrobb dfarrell07
17:05:25 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb
17:05:34 <colindixon> #link www.opendaylight.org/news/events/ events page
17:06:08 <colindixon> #link https://docs.google.com/forms/d/1p23KWqRIMf1utxr3z5YXho_DrlY8wur-ogFhuIDS5c4/viewform the CFP for dusseldorf closes at EoB tomororw
17:06:09 * edwarnicke bows to phrobb's powers of intention ;)
17:06:27 <gzhao> #info Phil asks people to do CFP quick to avoid last minute flush
17:06:49 <colindixon> #link https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress The OpenDaylight Mini-Summit will take place on Wednesday and Thursday, October 14 and 15, 2015.
17:07:53 <colindixon> #info uri asks who you should be representing, phrobb says hopefully OpenDaylight, but if you’re not a vendor or a telco, you need to be a sponsor to talk
17:08:41 <colindixon> #info ODL hackfest will be colocated with the OPFNV summit, 11/9-11/10 at the Hyatt Regency San Francisco Airport
17:11:12 <colindixon> #info dlenrow asks about slots at the duesseldorf layer123 thing, do the ODL slots count against company slots? phrobb says we have our own track with our own slots, but the rules about speaker eligibility stil apply.
17:11:50 <colindixon> #info openstack summit in Tokyo at the end of Ocotober, accept/reject for proposals should have gone out
17:12:15 <colindixon> #info dlenrow says he got one talking with “some people talking about some kind of policy intent sorta thing"
17:12:19 <colindixon> dlenrow: always eloquent
17:12:27 <dneary_> phrobb: rejected :-(
17:13:05 <jmedved> #info jmedved
17:13:09 <colindixon> #topic new release manager
17:13:28 <abhijitkumbhare> Welcome An Ho
17:13:45 <abhijitkumbhare> what is the IRC handle?
17:13:47 <colindixon> #info An Ho will be workign with gzhao and others on doing release management
17:13:59 <dfarrell07> +1, to IRC handles please
17:14:07 <kzhang> hi
17:14:13 <colindixon> #info kzhang (Katie Zhang) is also helping
17:14:17 <kzhang> this is katie from huawei
17:14:21 <anipbu> anipbu
17:14:22 <gzhao> kzhang: anipbu : welcom
17:14:28 <dneary_> Hi kzhang!
17:14:35 <colindixon> #info An Ho == anipbu
17:14:40 <dneary_> And hi anipbu
17:14:42 <kzhang> hi to everybody
17:14:51 <kzhang> glad to join opendaylight
17:14:52 <edwarnicke> Katie Zhang or Kathy Zhang?
17:15:01 <kzhang> katie zhang
17:15:03 <colindixon> Katie I’m pretty sure
17:15:07 <gzhao> edwarnicke: Katie
17:15:09 <colindixon> #topic beryllium
17:15:12 <edwarnicke> colindixon: Cool :)
17:16:28 <colindixon> #Info anipbu says things are mostly gpoing well, he’s reaching out to slow projects, we have 55 projects so far in Beryllium
17:16:44 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather
17:17:30 <dlenrow> Fun fact: Future TSC topics list Madhu talking about renaming OVSDB project
17:17:37 <colindixon> dlenrow: :p
17:18:04 <colindixon> #info there are changes coming to two of the most important models in OpenDaylight during Beryllium
17:18:28 <colindixon> #info during Beryllium the plan is to deprecate the inventory model and move to using the topology model instead
17:19:22 <colindixon> #info the topology model is strictly richer version of inventory, for details ask
17:19:57 <colindixon> #info there is also a newer version of our topology models which breaks things apart into a network (which is closer to inventory) and topology (which adds links)
17:20:29 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-08-25-16.23.html some more information is here
17:21:12 <colindixon> #link https://wiki.opendaylight.org/view/Topology_Processing_Framework:Main the topology procesing framework has some nice thigns for working with topologies
17:22:43 <colindixon> #link https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call the 9/9/2015 call here will be covering this topic if people want participate and/or find out more
17:23:05 <colindixon> #undo
17:23:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1cb9a90>
17:23:13 <colindixon> #link https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call the September 8th, 2015 call here will be covering this topic if people want participate and/or find out more
17:23:33 <colindixon> #topic stable/lithium
17:24:01 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-August/003523.html newly proposed dates for Lithium SRs
17:25:14 <snoble> yes you are audible ;)
17:26:01 <dfarrell07> colindixon: I don't know of any issues, fine to vote imho
17:26:48 <colindixon> #info abhijitkumbhare asks to move SR2 out from 10/1 to 10/8
17:28:14 <colindixon> #startvote shall the TSC move the LIthium SR dates (at least tenatively) to the following SR2: 10/8, SR3: 11/12, SR4: 2/25? -1, 0, +1
17:28:14 <odl_meetbot> Begin voting on: shall the TSC move the LIthium SR dates (at least tenatively) to the following SR2: 10/8, SR3: 11/12, SR4: 2/25? Valid vote options are -1, 0, +1.
17:28:14 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:28:34 <abhijitkumbhare> #vote +1
17:28:37 <colindixon> #vote +1
17:28:44 <dlenrow> #vote +1
17:28:44 <dfarrell07> #vote +1
17:28:46 <jmedved> #vote +1
17:28:47 <mohnish_> #vote +1
17:28:48 <edwarnicke> #vote +1
17:28:56 <colindixon> #endvote
17:28:56 <odl_meetbot> Voted on "shall the TSC move the LIthium SR dates (at least tenatively) to the following SR2: 10/8, SR3: 11/12, SR4: 2/25?" Results are
17:28:56 <odl_meetbot> +1 (7): dlenrow, jmedved, dfarrell07, edwarnicke, colindixon, mohnish_, abhijitkumbhare
17:29:06 <colindixon> #agree  the LIthium SR dates (at least tenatively) to the following SR2: 10/8, SR3: 11/12, SR4: 2/25
17:30:49 <colindixon> #action colindixon to discuss on the mailing list if we need to move LIhtium-SR3 again
17:31:22 <colindixon> #topic system integration and test
17:32:09 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003730.html integration split has new PTLs
17:32:25 <colindixon> #info jamoluhrsen will be doing system integration and test readouts
17:32:38 <colindixon> #info - integration/test: Jamo Luhrsen
17:32:41 <colindixon> #info - integration/distribution: Ed Warnicke
17:32:43 <colindixon> #info - integration/packaging: Daniel Farrell
17:33:31 <dfarrell07> #info Huge *thank you* to LuisGomez_ for running ODL Integration as the PTL for so long and doing such a good job!
17:33:39 <colindixon> #info +100 to that!
17:33:40 <abhijitkumbhare> Thanks LuisGomez_ for all the work over these years
17:33:43 <tykeal> agreed
17:33:54 <jamoluhrsen> +101 for LuisGomez_
17:34:18 <jmedved> Thanks Luis :-)
17:34:23 <dfarrell07> lol
17:34:27 <gzhao> that is the most important things
17:34:32 <gzhao> we still have Luis
17:34:34 <mohnish_> Thanks Luis.
17:34:37 <colindixon> #topic infrastructure
17:34:39 <dfarrell07> gzhao: +1
17:34:59 <colindixon> #info tykeal says thanks for all the new project buildouts, the six ones from the last two weeks are done
17:35:05 <colindixon> #info tykeal is workign with integration splitout
17:35:30 <colindixon> #info new versions of slaves and and ubuntu shoudl be coming
17:35:38 <colindixon> #info ubunto thanks to some code from edwarnicke
17:35:43 <colindixon> #Undo
17:35:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cb7210>
17:35:48 <colindixon> #info ubuntu thanks to some code from edwarnicke
17:36:01 <colindixon> #info almost getting our own private cloud at rackspace
17:37:08 <colindixon> #info as part of that, we will get better networking, we will get 10 Gbps backend and the control over what’s using the network, so we can do better controlled performance testing
17:37:32 <mohnish_> awesome :-)
17:37:37 <colindixon> #info we will also eventually be able to use OpenDaylight to control our network there if we choose to (yay dogfood)
17:39:18 * edwarnicke trusts dfarrell07
17:39:22 <uri_> will be great to see that
17:40:00 <colindixon> #topic committer promotion on FaaS
17:40:12 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003735.html they asked to add an initial committer
17:41:14 <colindixon> #info in essence, they are asking for another initial committer, they have no code yet, so it seems like it might be a fine exception
17:42:15 <colindixon> #startvote shall the TSC make Alex Zhang as an initial committer on FaaS without setting precedent? -1, 0, +1
17:42:15 <odl_meetbot> Begin voting on: shall the TSC make Alex Zhang as an initial committer on FaaS without setting precedent? Valid vote options are -1, 0, +1.
17:42:15 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:42:25 <colindixon> #vote +1
17:42:26 <dfarrell07> #vote +1
17:42:28 <dlenrow> #vote +1
17:42:28 <edwarnicke> #vote +1
17:42:31 <abhijitkumbhare> #vote +1
17:42:31 <mohnish_> #vote +1
17:42:33 <uri_> #vote +1
17:42:36 <jmedved> #vote +1
17:42:38 <colindixon> #endvote
17:42:38 <odl_meetbot> Voted on "shall the TSC make Alex Zhang as an initial committer on FaaS without setting precedent?" Results are
17:42:38 <odl_meetbot> +1 (8): dlenrow, jmedved, dfarrell07, edwarnicke, uri_, colindixon, mohnish_, abhijitkumbhare
17:42:42 <tykeal> so it shall be
17:42:45 <dfarrell07> lol
17:42:51 <colindixon> #agree Alex Zhang is an initial committer on FaaS
17:43:04 <colindixon> #topic moving projects to mature
17:43:05 <gzhao> thank you all, this is part of our overlook didn't include him at the first place.
17:44:00 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-July/003511.html colindixon started a thead on possible clarifications to becoming mature
17:44:33 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features stable feature definition
17:46:05 * tykeal waves magic wand and makes Alex Zhang a committer on FaaS
17:47:07 * dfarrell07 loves tykeal's admin jokes
17:47:18 <tykeal> ;)
17:50:50 <dfarrell07> #info Ongoing conversation about results of being a stable feature. For example, edwarnicke highlighted extracting logic as maybe being more complex after being stable, colindixon clarifies that since it's new fn, would be okay
17:51:10 <phrobb> #info edwarnicke  asks "what does 'feature was present in the previous release' mean in the context of refactoring for a 'more sane' set of features?... Answer from colindixon  is that such refactoring of existing features should be recognized as being present in the previous release by the TSC
17:54:59 <colindixon> #info uri_ asks what the relationship is between mature projects and stable feature, colindixon says that stable features are the “mature” parts of mature projects, so that mature projects can still have experimental compoents
17:56:39 <colindixon> #info uri_ would like to explore creating a distribution of OpenDaylight that’s easy to use, deploy, etc.
17:57:05 <abhijitkumbhare> After this discussion is done: about: “All committers must have a GPG key” - it might make sense to make it as “at least one committer must have a GPG key”. It will be hard to make all the committers to have a GPG key - due to the requirements of physically being present for GPG signing & some committers will never be able to make it to conferences/hackfests where there is a GPG signing.
17:57:12 <colindixon> #info edwarnicke says he’s going to try to get working on creating the stable distribution ASAP so we can start figuring out where this works and where it stops
17:57:20 <dlenrow> Pipeline of usability!!!!!
17:58:23 <tykeal> abhijitkumbhare: part of that is modeled after the Linux kernel community requirements around certain things. It's feasible to meet that requirement, it just takes some work
18:00:02 <colindixon> #info mohnish_ asks how this will work if most (or maybe all) of our user facing applications are not mature/stable?
18:00:13 <dlenrow> Make them "extra stable" :)
18:01:51 <dlenrow> Stable release of unstable features?
18:01:53 <uri_> the key idea is to move netVirt and SFC to this "stable" state
18:02:39 <dlenrow> Implying most of.platform is unstable is bad marketing
18:03:19 <colindixon> #action colindixon to start a thread on starting mature/stable processes so we can collect information and discuss things
18:03:31 <colindixon> #action edwarnicke will create a stable distribution and we can start to push people toward taht
18:03:41 <mohnish_> I think it might give enough incentive for projects to work towards stability ...
18:03:42 <uri_> this notion is out there. we need to test together a known set and show it is useful an painless and feature rich and reliable hence S3P
18:04:06 * tykeal is working on it!!
18:04:11 <uri_> and what mohnish is saying it true too, imho
18:04:16 <abhijitkumbhare> dlenrow: it might make sense to use a different word than “stable” - if only offset 0 projects are allowed
18:04:20 <dlenrow> So current lithium stable release is unstable?
18:04:48 <colindixon> #topic cookies
18:04:49 <hideyuki_> abhijitkumbhare: +1
18:04:53 <colindixon> #endmeeting