17:00:29 <colindixon> #startmeeting TSC
17:00:29 <odl_meetbot> Meeting started Thu Sep 24 17:00:29 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:29 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:31 <tykeal> hehe
17:00:40 <colindixon> #topic roll call and agenda bashing
17:00:46 <colindixon> #info will TSC members please #info in
17:00:47 <colindixon> #info colindixon
17:00:51 <edwarnicke> #info edwarnicke
17:01:15 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36941#Agenda today’s agenda in the usual place
17:01:37 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-17-17.00.html last week’s meeting minutes
17:01:49 <phrobb> #info request agenda items 1) new process definition when/for using Jira, and 2) deletion of old meeting recordings
17:01:52 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:02:18 <dfarrell07> #info Daniel Farrell
17:02:19 <alagalah> #info alagalah (jmedved's proxy)
17:02:41 <colindixon> #action edwarnicke to start a conversation on the list about how we should manage groupIds for integration
17:02:57 <dfarrell07> colindixon: I hear you and ed
17:02:57 <colindixon> it appears as though my auido died?
17:03:06 <tykeal> I hear both as well
17:03:11 <colindixon> I can’t hear Ed
17:03:12 <colindixon> dialing in
17:04:50 <dlenrow> #info dlenrow
17:05:14 <mohnish_> #info mohnish anumala
17:05:25 <ChrisPriceAB> #info Chris Price
17:05:56 <ghall> #info ghall ( Luis Gomez' proxy )
17:06:24 <colindixon> #info edwarnicke says integration that they have worked it out internally and it should be good w.r.t. integration groupIds
17:07:00 <colindixon> #action phrobb will send the detailed language about how at-large elections and platinum appointees interact
17:07:04 <phrobb> #link https://lists.opendaylight.org/pipermail/tsc/2014-July/001366.html <- Link to thread on TSC charter and Bylaws that contain the new provisions to allow the Board to waive the requirement that a platinum designate step down from the TSC in the event another member of their organization joins the TSC either through the At-Large Committer election, or as a PTL of a core project.
17:08:26 <colindixon> #topic events
17:08:38 <colindixon> #link https://www.opendaylight.org/global-events events in their usual place
17:09:03 <colindixon> #info dusseldorf sdn/openflow world congresss on 10/12 with a mini-summit and dinner
17:09:12 <colindixon> #info openstack summit the last week fo october in tokyo
17:09:22 <colindixon> #info hackfest with OPNFV summit the week of 11/9 in the bay area
17:09:23 * tykeal supposes he should arrange for another GPG keysigning at the hackfest
17:09:42 <colindixon> #info week after that there is an opportunity to participate in a MEF hackfest
17:09:55 <colindixon> #topic Beryllium
17:09:58 * ChrisPriceAB wants tykeal to invite OPNFV people if that's not extending beyond propriety
17:10:10 <tykeal> ChrisPriceAB: it doesn't hurt
17:10:19 <colindixon> #info all offset 0 projects have reported M3, a couple didn’t send in their system test plan templates
17:10:43 <colindixon> #info we still have one project which hasn’t given us the M2 status: SNBI, they said they’d get it done this week
17:10:56 <edwarnicke> phrobb: Looking at the changes you linked for the waiving of platinum designates stepping down... this is actually even better done than I recall ;)
17:11:00 <colindixon> #info the autorelease beryllium build is still broken, zxiiro and anipbu are hunting it
17:11:34 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather page, note things about migration of code for MDSAL and NETCONF
17:11:52 <colindixon> #topic stable/lithium
17:12:09 <colindixon> #info autorelease was failing because of a VTN issue, but it’s now fixed again thanks to VTN and zxiiro
17:12:20 <colindixon> #topic system integration and testing
17:12:53 <colindixon> #info as far a system test waivers, there were 11 projects that asked for exceptions
17:13:04 <colindixon> #info only two were granted, what happens for the other 9?
17:13:48 <colindixon> #info jamoluhrsen says that he would like to have some requirements here
17:14:57 <colindixon> #info edwarnicke, dfarrell07, jamoluhrsen, colindixon and others basically say that we should strongly encourage people to do this and we’ll cross the bridge of forcing people when we get to it
17:15:07 <colindixon> #info two projects that were debating
17:15:34 <colindixon> #info NETCONF asked for a waiver, but they think it might just be a typo; ttkacik says that was just a typo
17:15:55 <colindixon> #topic infrastructure
17:16:21 <colindixon> #info zxiiro has been upgrading our slave systems to EL7 and moving to ubuntu systems for a few setups
17:16:32 <colindixon> #info moving to ubuntu for mininet systems for example
17:16:43 * edwarnicke excited :)
17:17:20 <colindixon> #link https://jira.opendaylight.org/secure/Dashboard.jspa we have a working JIRA instance, bugs were moved over last night, took about 2 hours and are now out-of-date
17:17:46 <colindixon> #info tykeal notes that workflows don’t migrate easily if you had special workflows
17:17:50 <ChrisPriceAB> There are some good intro movies and presentations on getting started with Jira if anyone is interested from OPNFV on our youtube
17:18:09 <colindixon> #info we also need to projcts to make sure that any fields they care about were migrated
17:18:35 <colindixon> #info tykeal notes that integration with mailing lists isn’t pefect, e.g., when people moved from watchers to owners
17:19:04 <colindixon> #info people should go play around, but know it’s a just a playground for now as it’s already out-of-date
17:19:14 <colindixon> #info colindixon, dfarrell07, and others all say awesome!
17:19:55 * ChrisPriceAB is listening, right or wrong chris?
17:20:19 <colindixon> #info phrobb says that in order to apply for an open source licences for JIRA, we had to stand one up, we now have that and we are well on our way to getting the application
17:20:39 * edwarnicke is anti-flailing
17:21:14 <colindixon> #info phrobb notes that we still need to figure out how to migrate, e.g., will everyone move to JIRA, what features will we enable, how will we get people trained
17:22:00 <colindixon> #info phrobb advocates creating some kind of work group to figure out what the transition plan looks like
17:22:30 <colindixon> #info edwarnicke also notes that the timing of the transition is also critical
17:23:35 <colindixon> #info ChrisPriceAB says that JIRA is really good, but you have to get into it slowly, it was really painful for everyone to jump in with OPNFV
17:24:43 <colindixon> #action colindixon to help get people together to talk through this including rovarga, edwarnicke, tykeal, ChrisPriceAB and others
17:24:59 <colindixon> #info dfarrell07 asks if we can migrate project-by-project, tykeal says yes
17:28:19 <colindixon> #info ttkacik asks if PTLs can get administrator access, tykeal says that he is plannign to give project committers project owner rights later on today
17:28:23 <dfarrell07> tykeal: feel free to use int/pack as a beta testing project :)
17:28:47 <edwarnicke> tykeal: int/dist is probably also a nice small project for testing as well :)
17:29:14 <dfarrell07> lol
17:29:23 * tykeal just reminds that when we "go forward" we'll be doing a drop and re-import from bugzilla
17:29:57 <colindixon> #info phrobb notes that we have a webex account which is currently bumping up against our 20 GB of webex recording space
17:30:25 <colindixon> #info phrobb says his proposal is to delete the recordings before the Helium release
17:31:19 <colindixon> #info alternately, phrobb and casey could try to manutally download and store them somewhere (which is maunually intensive)
17:31:39 <colindixon> #info we could also increase the webex storage space, which has addional cost
17:32:13 <colindixon> #info if we delete them, we would give advanced warning for people to come download them and store them
17:32:41 * tykeal has never listened to them because he can't on Linux :D
17:32:47 <dfarrell07> phrobb: the way to re-watch them on Linux is either impossible or very, very complex, so I rarely use the recordings :(
17:33:31 <colindixon> #info colindixon hates saying it, but his general impression is that losing it will not be a huge loss
17:35:55 <colindixon> #action phrobb will reach out to other users of OpenDaylight’s webex to ask whether they would object
17:36:34 <colindixon> #info edwarnicke asks if we’re at it, we should probably set a rolling expiration policy, phrobb says the release before last would be his take or maybe older than a year
17:37:10 * ChrisPriceAB is happy promoting moving away from meetings all together.
17:37:20 * ChrisPriceAB well within reason
17:37:27 <mohnish_> +1
17:37:42 * edwarnicke has similar feelings to ChrisPriceAB, but also understands that sometimes calls are quite valuable ;)
17:37:43 <dlenrow> Why aren't we a shell script away from nearly free storage? 20 gig was big in 1990:)
17:37:56 <edwarnicke> dlenrow: Will you take the #action ? ;)
17:37:58 <ChrisPriceAB> ack edwarnicke
17:38:34 <colindixon> #startvote shall the TSC vote to say that we may or may not delete meetings that are older than two releases ago, e.g., Helium now, and older than a year? -1, 0, +1
17:38:34 <odl_meetbot> Begin voting on: shall the TSC vote to say that we may or may not delete meetings that are older than two releases ago, e.g., Helium now, and older than a year? Valid vote options are -1, 0, +1.
17:38:34 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:38:38 * ChrisPriceAB wonders if HP has a lot of storage to spare..
17:38:56 <ChrisPriceAB> #vote +1
17:38:57 <mohnish_> #vote +1
17:38:59 <dlenrow> I don't care that much, but storage is nearly free, except at webex:)
17:39:01 <colindixon> #vote +1
17:39:07 <ChrisPriceAB> hehe...
17:39:10 <dlenrow> #vote 0
17:39:13 <edwarnicke> #vote  +1
17:39:40 <dfarrell07> #info +1
17:39:40 <ChrisPriceAB> dlenrow: I wonder what value the archives contain after a year or so...
17:40:22 <colindixon> ghall or somebody else?
17:40:44 <dlenrow> Phrobb: got it.
17:40:52 <alagalah> #info +1
17:40:52 <colindixon> ghall or alagalah?
17:40:59 <dfarrell07> #vote +1
17:41:01 <alagalah> #vote +1
17:41:06 <colindixon> #endvote
17:41:06 <odl_meetbot> Voted on "shall the TSC vote to say that we may or may not delete meetings that are older than two releases ago, e.g., Helium now, and older than a year?" Results are
17:41:06 <odl_meetbot> 0 (1): dlenrow
17:41:06 <odl_meetbot> +1 (6): ChrisPriceAB, dfarrell07, edwarnicke, colindixon, mohnish_, alagalah
17:41:10 <alagalah> doh, I was following dfarrell07 's lead :)
17:41:16 <alagalah> Which is generally a good strategy
17:41:17 * ChrisPriceAB can finally relax about those rude comments made back in 2013...
17:41:19 <edwarnicke> alagalah: usually that's a good move ;)
17:41:23 * dfarrell07 was just making a dumb mistake, leading alagalah wrong ;)
17:41:35 <ChrisPriceAB> :)
17:41:49 * ChrisPriceAB thinks dfarrell07 was being nefarious
17:41:55 <abhijitkumbhare> ChrisPriceAB: those rude comments have been permanently recorded :)
17:41:55 <dfarrell07> ChrisPriceAB: ;)
17:41:56 <alagalah> colindixon, I'm paying attention, just spaced I had to vote :D
17:42:05 <alagalah> I want to read dlenrow book :D
17:42:10 * edwarnicke is pretty sure dfarrell07 doesn't have a nefarious bone in his body ;)
17:42:24 <colindixon> #agreed the TSC empowers phrobb and others to delete WebEx meetings older than two releases ago (e.g., the helium release at this point) and older than a year with notice that it’s happening for anyone to download copies
17:42:26 * dfarrell07 *evil laugh*
17:42:35 <ChrisPriceAB> lol
17:42:39 <dlenrow> #vote +1
17:42:56 <ChrisPriceAB> that be lag!
17:43:12 <colindixon> #topic committer promotions
17:43:21 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003847.html Vratko Polák as a committer on releng/builder
17:43:48 <colindixon> #startvote shall the TSC move Vratko Polák to a committer on releng/builder? -1, 0, +1
17:43:48 <odl_meetbot> Begin voting on: shall the TSC move Vratko Polák to a committer on releng/builder? Valid vote options are -1, 0, +1.
17:43:48 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:43:50 <ChrisPriceAB> #vote +1
17:43:52 * dfarrell07 has already +1'd on mailing list, for the log, but will vote again here
17:43:59 <dfarrell07> #vote +1
17:43:59 <edwarnicke> #vote +1
17:43:59 <colindixon> #vote +1
17:44:03 <alagalah> #vote +1
17:44:03 <dlenrow> #vote +1
17:44:14 <colindixon> #endmeeting