#opendaylight-meeting: tsc

Meeting started by colindixon at 16:59:37 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 16:59:43)
    1. TSC members please #info in (colindixon, 16:59:53)
    2. colindixon (colindixon, 16:59:55)
    3. mohnish anumala (mohnish_, 17:00:39)
    4. Daniel Farrell (dfarrell07, 17:00:53)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=37106#Agenda the agenda in it's usual place (colindixon, 17:01:05)
    6. Greg Hall proxy for Luis G P (ghall, 17:01:12)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-24-17.00.html last week's minutes part 1 (colindixon, 17:01:24)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-24-17.44.html last weeks minutes part 2 (colindixon, 17:01:45)
    9. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (colindixon, 17:02:15)
    10. Chris Price (ChrisPriceAB, 17:02:40)
    11. dlenrow (dlenrow, 17:02:43)
    12. add committer-at-large discussion to the agenda (phrobb, 17:03:14)
    13. edwarnicke (edwarnicke, 17:04:08)
    14. https://lists.opendaylight.org/pipermail/tsc/2015-September/003889.html colindixon started a thread on JIRA, he's waitin on interested parties to pick it up (colindixon, 17:04:39)

  2. events (colindixon, 17:05:13)
    1. https://www.opendaylight.org/global-events the events page in it's usual place (colindixon, 17:05:26)
    2. https://www.opendaylight.org/events/2015-11-09-000000-2015-11-10-000000/opendaylight-hackfest register for the hackfest near SFO on 11/9/2015 (colindixon, 17:06:04)
    3. dfarrell07 has an ODL talk at LinuxCon EU next week (dfarrell07, 17:06:04)
    4. other information and details are on the page above (colindixon, 17:06:15)
    5. The OPNFV dev summit will likely include Jira training for users and project planners, ODL members welcome (ChrisPriceAB, 17:06:41)

  3. beryllium (colindixon, 17:06:47)
    1. anipbu M3 offset 1 is due today, we have some things coming in (colindixon, 17:07:13)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=4371 Alto bug blocking beryllium build (zxiiro, 17:07:37)
    3. alto is breaking the build, has been removed from the autorelease until it's fixed (colindixon, 17:07:46)

  4. beryllium weather (colindixon, 17:08:25)
    1. some jobs were stalling during feature tests and it seems like TomP and zxiiro have fixed it (colindixon, 17:09:02)
    2. it appears as though it may have been related to the new yang parser (colindixon, 17:09:14)
    3. https://wiki.opendaylight.org/view/Weather#2015-09-29_YANG_Parser_implementation_switch this appears to be related to this weather event (colindixon, 17:09:29)
    4. mohnish_ says he definitely ran into these issues, he's now able to build this morning, but seeing lots more warnings (colindixon, 17:10:24)
    5. ttkacik says the new warnings are because the new parser is a bit stricter (colindixon, 17:10:51)
    6. ttkacik says he thinks two projects actually had failed builds because of this, e.g., Armoury and NIC (colindixon, 17:12:00)
    7. colindixon says that the most important thing here is to just make sure make sure to respect developer time and expectations, so saying that you failed to write valid yang even though we accepted it in the past makes it your fault is probably not the right approach (colindixon, 17:15:12)
    8. colindixon notes that the performance issues reported about the weather event were noted only 2 hours before the patches were merged despite many people asking about possible issues many times (colindixon, 17:16:50)
    9. https://lists.opendaylight.org/pipermail/release/2015-October/003838.html discussion on the mailing list (colindixon, 17:17:14)
    10. to get around this, rovarga says we need either (i) a staging pipeline to test a set of patches across projects together, and (ii) continuous release in some form (colindixon, 17:19:32)
    11. cdub agrees about continuous release, colindixon notes that there are efforts and we should talk about it boron (colindixon, 17:22:26)
    12. https://wiki.opendaylight.org/view/Weather#Upstream_version_upgrades upstream version upgrades (colindixon, 17:22:44)
    13. there's a process of upgrading external dependencies to get security patches and bug fixes (colindixon, 17:23:22)
    14. a lot of attention is going into making sure this is a painless as possible, but it's possible unexpected things could happen (colindixon, 17:24:00)
    15. this was discussed on the TWS call on Monday and there was a recording, we've done 5 of 11 upgrades, the next one is Karaf which is happening on Monday next week (colindixon, 17:24:54)

  5. Stable Li (phrobb, 17:27:07)
    1. Li SR2 cutoff is this coming Sunday at midnight UTC (phrobb, 17:28:57)
    2. question, did we skip over "Timing of branch cutting" for Be? (ghall, 17:29:05)
    3. colindixon notes that we will need to vote on the timing of branch cutting within two weeks and we will continue the discussion on the thread. (phrobb, 17:37:05)

  6. System Integration and Testing (phrobb, 17:37:30)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-September/003879.html Thread about version bumping, please comment in the next week or so (dfarrell07, 17:37:42)

  7. Infrastructure (phrobb, 17:38:10)
    1. tykeal said Jira is running but need people feedback (gzhao, 17:38:53)
    2. testing of Ubuntu images ongoing.... Jira site got running last week and Andy hasn't heard anything from anyone yet (phrobb, 17:39:00)
    3. zxiiro is going to be on vacation (gzhao, 17:39:40)
    4. the info in Jira is over a week old and getting stale... *if* we choose to go with Jira we will be deleting everything in the current instance... this is just a "test" instance (phrobb, 17:39:49)
    5. Rackspace private cloud making progress.. no more details there yet (phrobb, 17:40:22)

  8. committer-at-large elections (colindixon, 17:40:57)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-October/003903.html phrobb's mail on the topic and colin's clarifications (colindixon, 17:42:47)
    2. colindixon says his memory from last week was that we decide the pros of extending the waiver outweighed the cons (colindixon, 17:43:15)
    3. VOTE: Voted on "shall the TSC formally ask the board to extend the waiver for another year for platinum appointed TSC members to remain on the TSC even if at-large members also represent their organziation?" Results are, +1: 8 (colindixon, 17:45:25)
    4. AGREED: the TSC will ask the board to extend the waiver around platinum appointed TSC members (colindixon, 17:45:46)
    5. note that ghall votes +1 for LuisGomez as well (colindixon, 17:47:04)

  9. mature projects/stable features (colindixon, 17:48:54)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-September/003783.html a lenghty thread on graduation reviews (colindixon, 17:49:25)
    2. https://wiki.opendaylight.org/view/Graduation_Reviews/Template the draft template for graduation reviews (colindixon, 17:49:41)
    3. VOTE: Voted on "the TSC would like to use this template for graudation reviews and invidual members can vote their conscience based on the information in the thread discussion it https://wiki.opendaylight.org/view/Graduation_Reviews/Template ?" Results are, +1: 8 (colindixon, 17:53:20)
    4. AGREED: the TSC is now open to accepting requests for graudation reviews based on this template: https://wiki.opendaylight.org/view/Graduation_Reviews/Template (colindixon, 17:53:38)

  10. boron planning (colindixon, 17:54:15)
    1. colindixon asks if there are focus ares people are interested in and/or would like to see in Boron (colindixon, 17:56:14)
    2. colindixon has heard from people that they'd be interested in a bunch of things including (colindixon, 17:56:55)
    3. continous release (colindixon, 17:57:01)
    4. faster than 6-month reelase cadence (colindixon, 17:57:18)
    5. lighter-weight process (colindixon, 17:57:47)
    6. scale improvments (colindixon, 17:57:53)
    7. alagalah asks that we have a round table of Advisory Group members and a good group of PTLs to discuss Boron planning (phrobb, 17:58:08)
    8. cross-release compatibility, e.g., boron openflow plugin could run in an otherwise-beryllium controller (colindixon, 17:58:22)
    9. ACTION: colindixon to reach out to the advisory gorup for input on Boron (colindixon, 17:59:11)
    10. ACTION: alagalah to organize a panel/mailing list thead for the PTLs to also provide info on Boron (colindixon, 18:00:12)
    11. If CR or any other solution can provide stability for projects which depend on yang/netconf/restconf/mdsal/aaa as those projects get big changes ... then that's a priority. (ghall, 18:00:20)
    12. ACTION: colindixon to see if we can find some time for the advisory group on the TSC call in the future (colindixon, 18:00:34)
    13. colindixon notes that ramp up time for somethings like moving to CI/CB and migration strategies is needed hence the reason to getting the Boron discussions going on now (phrobb, 18:00:44)

  11. cookies (colindixon, 18:01:22)


Meeting ended at 18:01:25 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  2. colindixon to reach out to the advisory gorup for input on Boron
  3. alagalah to organize a panel/mailing list thead for the PTLs to also provide info on Boron
  4. colindixon to see if we can find some time for the advisory group on the TSC call in the future


Action items, by person

  1. alagalah
    1. alagalah to organize a panel/mailing list thead for the PTLs to also provide info on Boron
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
    2. colindixon to reach out to the advisory gorup for input on Boron
    3. colindixon to see if we can find some time for the advisory group on the TSC call in the future


People present (lines said)

  1. colindixon (64)
  2. phrobb (14)
  3. odl_meetbot (14)
  4. ChrisPriceAB (13)
  5. dfarrell07 (11)
  6. ghall (5)
  7. edwarnicke (5)
  8. mohnish_ (3)
  9. uri_ (3)
  10. alagalah (3)
  11. gzhao (2)
  12. dneary (2)
  13. dlenrow (2)
  14. cdub (2)
  15. zxiiro (1)
  16. phrobb- (0)
  17. tbachman (0)
  18. anipbu (0)


Generated by MeetBot 0.1.4.