17:02:10 <colindixon> #startmeeting tsc
17:02:10 <odl_meetbot> Meeting started Thu Oct 15 17:02:10 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:10 <odl_meetbot> The meeting name has been set to 'tsc'
17:02:17 <colindixon> #topic roll call and agenda bashing
17:02:27 <colindixon> TSC members please #info in
17:02:28 * tykeal notes he just sent out a tickler for GPG keysigning (wee!)
17:02:36 <edwarnicke> #info edwarnicke
17:02:36 <mohnish_> #info mohnish anumala
17:02:49 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=37552#Agenda the agenda in it's usual place
17:03:04 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-10-08-17.00.html last week's meeting minutes
17:03:12 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR3) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:03:15 <dlenrow> #info dlenrow
17:03:18 <dfarrell07> #info Daniel Farrell
17:03:38 <colindixon> #info colindixon is planning to present Advisory Group about Boron on next week on 10/22
17:04:07 <colindixon> #info colindixon
17:04:19 <alagalah> colindixon, I know I sent my email late but any time for the 2 items I'd like to bring up ?
17:05:05 <alagalah> colindixon, Could handle one of them under " Dealing upstream/downstream breakages (All, 10 minutes) "
17:05:07 <jmedved> #info jmedved
17:05:17 <alagalah> colindixon, And the other under " Boron Planning (Colin, remaining time) "
17:05:38 <LuisGomez> #info LuisGomez
17:06:42 <colindixon> #action ttcacik and zxiiro to work on getting feature-level code coverage numbers
17:06:43 <phrobb_> We have quorum
17:07:04 <colindixon> #action colindixon to figure out where we lost action items, e.g., feature-level code coverage and make sure we didn't lose any others
17:08:00 <abhijitkumbhare> #info abhijitkumbhare
17:08:11 <colindixon> #topic TSC at-large Elections
17:08:55 <colindixon> #action phrobb to send a mail trying to come up with a responsible way to extend the exemption for platinum designates, but not forever
17:09:03 <colindixon> #topic events
17:09:10 <colindixon> #link https://www.opendaylight.org/global-events
17:09:57 <colindixon> #info phrobb (and other folks) are at the dusseldorf ODL mini-summit, it seems like the different mini summits got much less attendance
17:10:07 <dfarrell07> #info dfarrell07 gave an ODL talk (the only one) at LinuxCon EU, full session, pretty user-focused and well-received
17:10:28 <colindixon> #info phrobb says it seems to be less about technical things this time, and more about sales people and customers
17:10:51 <colindixon> #link https://www.opendaylight.org/events/2015-11-09-000000-2015-11-10-000000/opendaylight-hackfest-opnfv-summit register for the 11/9 and 11/10 hackfest
17:11:13 <colindixon> #link https://www.opendaylight.org/events/2015-11-16-000000-2015-11-18-000000/mef-lso-hackathon MEF hackfest on 11/16 to 11/18
17:11:17 <dlenrow> Was that meth event?
17:11:24 <dfarrell07> dlenrow: rof
17:11:30 <dfarrell07> rofl*
17:11:49 <colindixon> #info phrobb to get details about design summit sometime in the end of February and plan around that
17:11:55 * dfarrell07 heard meth too, not sure what the name was
17:12:03 <abhijitkumbhare> MEF :)
17:12:21 <colindixon> #topic beryllium
17:12:29 <anipbu> #info M3 for offset 2 and M4 for offset 0 are due today.
17:12:34 <colindixon> anipbu: thanks
17:13:00 <anipbu> #link potential performance problem in OpenFlow plugin SR2 (Lithium design)
17:13:08 <anipbu> #undo
17:13:08 <colindixon> #undo
17:13:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1aa2310>
17:13:16 <colindixon> #chair anipbu phrobb
17:13:16 <odl_meetbot> Current chairs: anipbu colindixon phrobb
17:13:26 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-daily-beryllium/229/org.opendaylight.mdsal$mdsal-binding-generator-impl/
17:13:53 <colindixon> #info anipbu is working with ttkacik and tykeal to resolve autorelease issues
17:17:30 <colindixon> #info colindixon asks if we should try to have two autorelease jobs one stable and one that's less stable so that we can try to maximize our visibility into what's going on
17:18:21 <dlenrow> At a minimum breaking autorelease in the release candidate stage should have consequences
17:20:06 <phrobb_> #info colindixon notes that if we run two autorelease streams (autorelease-stable, and autorelease-everything) if a project is not in "stable" it will not necessarilty be dropped from the release now, but it could be in the future.  Projects need to actively work to stay properly executing in autorelease throughout the build cycle... Further discussion is needed here on the mailing list.
17:20:19 <colindixon> #action colindixon to start an e-mail offline around these issues, there's a broader question about minimum requirements and when projects to meet them to be in the SR
17:21:45 <colindixon> #topic branch cutting for Beryllium
17:22:25 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003879.html thread on branch cutting timing and strategy
17:23:37 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-October/003984.html newer proposals
17:36:17 <dfarrell07> edwarnicke: we need to vote today, think fast ;)
17:36:49 <ghall_> Explain what happens to pre-boron/master next ...
17:40:34 <edwarnicke> #link https://docs.google.com/presentation/d/1snubwW6M8q6jo4laLvZ0WEVtaM783Qc6Gf4qe7UQZtw/edit#slide=id.p <- attempt to sketch
17:41:31 <ghall_> edwarnikie: ^lithium^beryllium ?
17:42:56 <edwarnicke> ghall_: Thanks :) Dont' know why I have Li on the brain today :)
17:43:42 <alagalah> edwarnicke, Can you add some version numbers on here like A, A+1, A+2 ???
17:44:09 <colindixon> #info rovarga asks if this happens, then how can you move in-flight patches on pre-boron to master in an automated way?
17:44:19 <alagalah> Cos my assumption is at M5 offset0, master goes from A to A+1, and preboron is A+2 ?
17:44:39 * dfarrell07 's understanding of this is the same as at the start, so that's a good sign
17:44:48 * dfarrell07 is ready to vote
17:45:19 <alagalah> Or master stays A and preboron is a+2 and m5 offset2 is stable/be goes to A and master then is  a+1 and preboron is at a+2 ?
17:46:02 <colindixon> alagalah: on creating branches master is A until M5 offset 2
17:46:03 <abhijitkumbhare> edwarnicke: can you replicate the branch lines to indicate 2 possible project types? one project type is actively developing on pre-boron and other project is developing on master only.
17:46:14 <colindixon> alagalah: then it's A + 0.1.0
17:46:28 <colindixon> alagalah: pre-boron is always A + 0.1.0
17:46:31 <alagalah> colindixon, ok thanks, so preboron ia a+0.2.0 ?
17:46:37 <alagalah> colindixon, anyway, I'll ask on list... got it
17:46:46 <alagalah> colindixon, Thanks
17:47:21 <colindixon> alagalah: stable/beryllium will be bumped by 0.0.01 after beryllium release
17:47:25 <colindixon> so A + 0.0.1
17:48:41 <ghall_> So we're talking about trading off pain upstream and pain downstream
17:50:02 <alagalah> ghall_, :)
17:52:21 <ghall_> It seems we want to delay the branching of offset 1 &2 until they are stable, while accelerate the branching of offset 0 which off course need to be stable first so downstream projects can finish.
17:52:36 * dfarrell07 is for a vote
17:54:51 <ghall_> Why is "simultaneous" release of all projects so important ... isn't that behind this issue?
17:55:44 <colindixon> what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 0 M5 with pre-boron? 1, 2, 3, 4
17:55:50 <edwarnicke> ghall_: You sort of have to have lived through the carnage of the alternative to understand ;)
17:55:58 <dlenrow> Ghali: we've discussed this . Making every project release as SR is flawed long term
17:57:18 <ttkacik1> dlenrow: +1 - across 52 projects it is hard
17:57:31 <alagalah> ttkacik1, dlenrow  :)
17:57:54 <edwarnicke> Would like to point out the Eclipse does it for a much larger number of projects ;)
17:57:54 <dlenrow> If we had core that would SR and offset 1 & 2 would release as they choose on stable core
17:58:17 <rovarga> dlenrow: agreed, but that is a wildly more complex conversation ;)
17:58:24 <colindixon> #startvote what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 0 M5 with pre-boron, (5) abstain? 1, 2, 3, 4, 5
17:58:24 <odl_meetbot> Begin voting on: what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 0 M5 with pre-boron, (5) abstain? Valid vote options are 1, 2, 3, 4, 5.
17:58:24 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:58:41 <dfarrell07> #vote 4
17:58:42 <colindixon> #vote 4
17:58:45 <abhijitkumbhare> #vote 4
17:58:47 <LuisGomez> #vote 4
17:58:48 <mohnish_> #vote 4
17:58:52 <dlenrow> #vite 4
17:59:02 <dlenrow> #vote 4
17:59:04 <alagalah> aqua vite
17:59:06 <alagalah> :)
17:59:23 <colindixon> #endvote
17:59:23 <odl_meetbot> Voted on "what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 0 M5 with pre-boron, (5) abstain?" Results are
17:59:23 <odl_meetbot> 4 (6): dlenrow, LuisGomez, dfarrell07, colindixon, mohnish_, abhijitkumbhare
17:59:37 <dlenrow> Alagalah::)
17:59:46 <alagalah> colindixon, I'll bring my stuff up to the TSC list
17:59:51 * dfarrell07 is so glad to have this vote done :)
18:00:40 <colindixon> #agreed the we will cut stable/beryllium branch at offset 2 M5, we will create pre-boron branches for everyone at offest 0 M5 if there is any interest, if there is literally zero interest, we don't have to
18:01:29 <LuisGomez> yes dfarrell07, i did not expect this level of agreement
18:02:20 <colindixon> #startvote what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 2 M5 with pre-boron, (5) abstain? 1, 2, 3, 4, 5
18:02:20 <odl_meetbot> Begin voting on: what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 2 M5 with pre-boron, (5) abstain? Valid vote options are 1, 2, 3, 4, 5.
18:02:20 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:02:23 <colindixon> #vote 4
18:02:29 <abhijitkumbhare> #vote 4
18:02:34 <LuisGomez> #vote 4
18:02:35 <dfarrell07> #vote 4
18:02:36 <dlenrow> #vote 4
18:02:40 <mohnish_> #vote 4
18:02:46 <colindixon> #endvote
18:02:46 <odl_meetbot> Voted on "what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 2 M5 with pre-boron, (5) abstain?" Results are
18:02:46 <odl_meetbot> 4 (6): dlenrow, LuisGomez, dfarrell07, colindixon, mohnish_, abhijitkumbhare
18:03:09 <colindixon> #info the second vote was to correct a mistake the phrasing of the first vote, and now agrees with #agree statement
18:03:33 <dfarrell07> thanks @ all :)
18:03:38 <colindixon> #action colindixon to send mail about possibly having two hour meetings to deal with our backlog
18:03:40 <colindixon> #topic cookies
18:03:43 <colindixon> #endmeeting