#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:45 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 18:00:53)
    1. edwarnicke (edwarnicke, 18:00:59)
    2. colindixon (colindixon, 18:01:01)
    3. Daniel Farrell (dfarrell07, 18:01:03)
    4. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=38891#Agenda the agenda in it's usual place (colindixon, 18:01:30)
    5. Chris Price (ChrisPriceAB, 18:02:34)
    6. mohnish anumala (mohnish_, 18:03:13)
    7. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium? (colindixon, 18:04:05)
    8. ACTION: zxiiro to open a bug against releng/builder about figuring out a process to get feature-level code coverage (colindixon, 18:05:29)
    9. ACTION: rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages (colindixon, 18:05:38)
    10. ACTION: LuisGomez to give an estimate for a drop-dead date on when we'd need to decide if we actually need a stable distribution (colindixon, 18:05:48)
    11. ACTION: phrobb to poll the PTLs about hackfest attendance (colindixon, 18:06:25)
    12. ACTION: jamoluhrsen to figure out how to start doing testing with JDK8 (colindixon, 18:06:53)
    13. edwarnicke says his gut is that we're past the drop-dead date for having a stable distribution (colindixon, 18:08:10)
    14. ACTION: colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible (colindixon, 18:09:23)

  2. events (colindixon, 18:10:01)
    1. https://www.opendaylight.org/global-events the events page (colindixon, 18:10:12)
    2. OpenDaylight user group, Stockholm chapter had an inaugural meet-up last night. (ChrisPriceAB, 18:10:44)
    3. phrobb says the current plan is have a design forum for boron in the first week of march in the bay area (colindixon, 18:11:10)
    4. ChrisPriceAB said one of the topics at the Stockholm ODLUG was the hard ramp up for ODL, there was the idea of doing a boot camp in Europe, akin to the application tutorial that was done at the OpenDaylight summit (colindixon, 18:12:46)
    5. ACTION: colindixon to send a mail with some ideas about running tutorials with new known knows (colindixon, 18:15:22)
    6. ChrisPriceAB sasy that SDN Hub OpenDaylight tutorials were referenced a lot, but maybe not idea for us (colindixon, 18:15:55)
    7. ACTION: phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp (colindixon, 18:16:42)

  3. beryllium (colindixon, 18:18:45)
    1. today is M5 for offset 0 and M4 for offset 2 (colindixon, 18:19:04)
    2. autrelease was broken by SNBI, fixed, but is now broken by OVSDB but it's been looked it (colindixon, 18:19:34)
    3. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather upcoming (colindixon, 18:19:49)
    4. there are some thigns coming up, please go look at them (colindixon, 18:20:03)
    5. the big one that's coming is removing AD-SAL (colindixon, 18:20:23)
    6. https://docs.google.com/spreadsheets/d/1Kfp5HVQGydNegEjp6dD2V3XsUnqpice0bysWbdxABA4/edit#gid=1862710416 the beryllium status (colindixon, 18:20:51)
    7. zxiiro says he's going to be creating per-boron branches today (colindixon, 18:21:10)
    8. https://lists.opendaylight.org/pipermail/release/2015-November/004645.html pre-boron branch cutting (zxiiro, 18:22:24)

  4. stable/lithium (colindixon, 18:22:34)
    1. https://docs.google.com/spreadsheets/d/1ktL11ElNdf4D3RUeRNUd8SPnYO0to0DxzSZGst0KdMQ/edit#gid=1055423260 (anipbu, 18:22:40)
    2. it looks like Lithium-SR3 is ready to go (the above sheet shows every issue signed off by the relevant project) (colindixon, 18:22:59)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Lithium_SR3_Download (anipbu, 18:23:37)
    4. VOTE: Voted on "shall the TSC bless teh SR3 artifacts as describe above?" Results are, +1: 6 (colindixon, 18:24:27)
    5. AGREED: we will promote the staging repo and release Lithium-SR3 (colindixon, 18:24:39)

  5. infrastructure (colindixon, 18:25:14)
    1. rackspace has provided us the new private cloud, we're still working on getting the VPN link up and working, then we'll start kicking the tires, and start moving into it in the next month or so (colindixon, 18:25:41)
    2. colindixon asks if this would enable us to install our own hardware in the infrastructure, tykeal says no, it has to be rackspace-offered hardware (colindixon, 18:26:47)

  6. kafka producer creation review (colindixon, 18:28:31)
    1. andrew will post slides after the call (colindixon, 18:28:38)
    2. https://wiki.opendaylight.org/view/Project_Proposals:Kafkaproducer project proposal (colindixon, 18:28:46)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2015-November/000377.html proposed on 11/16/2015 (colindixon, 18:29:03)
    4. ACTION: colindixon to add instructions to upload materials before creation reviews to the proposal instructions (colindixon, 18:29:44)
    5. andrew says that this is something they've already built for another thing, but there was enough interest that they thought they would bring it here (colindixon, 18:30:10)
    6. it's a way to push ODL data to a Kafka cluster (colindixon, 18:30:30)
    7. supports compression (gzip and snappy now), supports codec types (raw and avro now), supports sycn and async (colindixon, 18:30:59)
    8. currently pulls data from the event topic broker, but going forward could pull data from other places in ODL (colindixon, 18:31:19)
    9. right now there are two things that publish to the Event Topic Broker: NETCONF connector and a hweventsource for other things (colindixon, 18:31:57)
    10. right now it works with stable/lithium, but obviously would roll forward on joining (colindixon, 18:32:09)
    11. have working code, willing committers, looking to update, looking for new ideas and/or suggestions (colindixon, 18:32:59)
    12. abhijitkumbhare asks what the relationship between this Kafka cluster and Akka cluster (colindixon, 18:33:23)
    13. andrew answers no relationship now (colindixon, 18:34:13)
    14. colindixon asks what Kafka is, Willis says that it's a scale-out messaging system, designed to do very high throughput messaing in a pub-sub, reliable system (colindixon, 18:35:03)
    15. basically this is a way to get data/events out of ODL to an off-the-shelf, popular, easy-to-install message bus (colindixon, 18:36:57)
    16. Willis says that one reason Kafka is more interesting than RabbitMQ or others is because it's able to elastically scale-out (colindixon, 18:37:26)
    17. mohnish_ asks what data they're looking to expose, andrew answers mostly telemetry from southbound devices for now (colindixon, 18:37:56)
    18. https://wiki.opendaylight.org/view/Messaging4Transport:Main colindixon asks what the relationsihp is between this and the messaging4transport project which seemingly does this with AMQP (colindixon, 18:39:26)
    19. andrew says his impression was that M4T was more of a message bus and had more stuf in the controller, this las less stuff (colindixon, 18:40:32)
    20. edwarnicke says his take is that M4T is trying to do things for *all* the messages/events in the MD-SAL vs. this which is looking to just do it for specific things, e.g,, event topic broker (colindixon, 18:42:13)
    21. ACTION: Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed (phrobb_, 18:43:57)
    22. https://wiki.opendaylight.org/view/Project_Proposals:Kafkaproducer#Scope (colindixon, 18:44:08)
    23. colindixon says the first paragaph of the description reads like the scope (colindixon, 18:45:13)
    24. ACTION: Andrew McLachlan to add presented slides and initial committers to the wiki proposal page: <= https://wiki.opendaylight.org/view/Project_Proposals:Kafka_Transport (gzhao, 18:46:30)
    25. andrew says the plan is to possibly expand beyond just the event topic broker in the future (colindixon, 18:48:44)
    26. VOTE: Voted on "shall the TSC move the kafkaproducer project to incubation?" Results are, +1: 6 (colindixon, 18:49:30)
    27. AGREED: the kafkaproducer project will be moved to incubation after incoming code review (colindixon, 18:49:46)

  7. TSC make up and elections (colindixon, 18:50:14)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-October/004026.html (colindixon, 18:50:46)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-November/004101.html (colindixon, 18:51:04)
    3. https://lists.opendaylight.org/pipermail/tsc/2015-December/004298.html (colindixon, 18:51:16)
    4. the above three links are the thread about how to change the TSC make up and eleections across three months (colindixon, 18:51:42)
    5. dfarrell07 says this started to avoid the waiver enabling platinum designates to sit even if another person from their compnay was elected (colindixon, 18:52:10)
    6. most proposals seem to do this by eleminating platinum designates (colindixon, 18:52:28)
    7. dfarrell07 says he thinks of this as having a list of represented groups, then you do STV (single transferrable votes) elections per group (colindixon, 18:53:10)
    8. groups serve two purposes: one to balance different views within opendaylight, and to provide incentives for projets to do things like move to mature (colindixon, 18:53:41)
    9. there are discussion about what the represented groups should be, e.g,, just one big group, lifecycle state, project type (kernel, apps, protocol), etc. (colindixon, 18:54:29)
    10. there's also a question of if we want to limit the number of elected people from a single company (colindixon, 18:55:11)
    11. colindixon asks if there is anyone that objects to removing platinum designates (colindixon, 18:58:22)
    12. uri says yes, as long as that's coupled with projects moving thorugh the maturity states (colindixon, 18:58:36)
    13. colindixon says he thinks there are three or four main decisions points: (i) do we want to have per-company cap on representatives (ii) do we want to have both project leads and committers at large on the TSC, (iii) will we eliminate platinum designates,, (iv) do we want to do this now or in a year (colindixon, 19:03:57)
    14. dfarrell07 just suggested compiling governance (edwarnicke, 19:04:17)
    15. ACTION: dfarrell07 to try to drive this to a vote (colindixon, 19:04:41)
    16. edwarnicke points out that per-company caps need to have a clear mechanism if we adopt them, colindixon says there have been some proposals for that on th elist (colindixon, 19:06:16)
    17. mohnish_ suggested we also look at how the transition will work (edwarnicke, 19:06:34)
    18. mohnish_ asks if there's a plan for a transition, and or discussion of the size (colindixon, 19:06:34)
    19. colindixon says the transition would likely be aided by people showing up and continuing to speak their minds even if votes transition quickly (colindixon, 19:07:04)
    20. I think the thread suggeted sizes of ~8-15 members (colindixon, 19:07:13)

  8. cookies (colindixon, 19:07:46)
    1. that's from odl-casey (colindixon, 19:08:56)


Meeting ended at 19:09:08 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium?
  2. zxiiro to open a bug against releng/builder about figuring out a process to get feature-level code coverage
  3. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  4. LuisGomez to give an estimate for a drop-dead date on when we'd need to decide if we actually need a stable distribution
  5. phrobb to poll the PTLs about hackfest attendance
  6. jamoluhrsen to figure out how to start doing testing with JDK8
  7. colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
  8. colindixon to send a mail with some ideas about running tutorials with new known knows
  9. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  10. colindixon to add instructions to upload materials before creation reviews to the proposal instructions
  11. Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed
  12. Andrew McLachlan to add presented slides and initial committers to the wiki proposal page: <= https://wiki.opendaylight.org/view/Project_Proposals:Kafka_Transport
  13. dfarrell07 to try to drive this to a vote


Action items, by person

  1. ChrisPriceAB
    1. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium?
    2. colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
    3. colindixon to send a mail with some ideas about running tutorials with new known knows
    4. colindixon to add instructions to upload materials before creation reviews to the proposal instructions
  3. dfarrell07
    1. dfarrell07 to try to drive this to a vote
  4. gzhao
    1. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  5. phrobb
    1. phrobb to poll the PTLs about hackfest attendance
    2. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  6. zxiiro
    1. zxiiro to open a bug against releng/builder about figuring out a process to get feature-level code coverage
  7. UNASSIGNED
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
    2. LuisGomez to give an estimate for a drop-dead date on when we'd need to decide if we actually need a stable distribution
    3. jamoluhrsen to figure out how to start doing testing with JDK8
    4. Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed
    5. Andrew McLachlan to add presented slides and initial committers to the wiki proposal page: <= https://wiki.opendaylight.org/view/Project_Proposals:Kafka_Transport


People present (lines said)

  1. colindixon (99)
  2. odl_meetbot (14)
  3. ChrisPriceAB (11)
  4. edwarnicke (9)
  5. dfarrell07 (4)
  6. gzhao (3)
  7. phrobb_ (3)
  8. uri (3)
  9. zxiiro (3)
  10. odl-casey (3)
  11. mohnish_ (3)
  12. anipbu (2)
  13. rovarga_ (1)
  14. phrobb (0)


Generated by MeetBot 0.1.4.