#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:23 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:29)
    1. colindixon (colindixon, 18:00:42)
    2. edwarnicke (edwarnicke, 18:01:25)
    3. Daniel Farrell (dfarrell07, 18:01:44)
    4. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=39484 agenda in it's usual place (colindixon, 18:02:10)
    5. dlenrow (dlenrow, 18:02:15)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-12-10-17.59.html last week's minutes (colindixon, 18:02:35)
    7. ACTION: colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible (colindixon, 18:03:02)
    8. LuisGomez (LuisGomez, 18:03:06)
    9. ACTION: phrobb to poll the PTLs about Hackfest attendance (colindixon, 18:03:29)
    10. ACTION: phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp (colindixon, 18:03:37)
    11. abhijitkumbhare for ChrisPriceAB (abhijitkumbhare, 18:04:15)
    12. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 18:04:16)
    13. ACTION: colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows (colindixon, 18:04:30)
    14. ACTION: colindixon to add instructions to upload materials before creation reviews to the proposal instructions (colindixon, 18:04:38)
    15. ACTION: rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages (colindixon, 18:04:46)
    16. ACTION: dfarrell07 will drive Pre-M1, bi-election discussion (colindixon, 18:05:11)
    17. ACTION: colindixon to try to bump boron planning back up the prioirty list (colindixon, 18:06:25)
    18. mohnish anumala (mohnish_, 18:06:40)

  2. events (colindixon, 18:06:43)
    1. https://www.opendaylight.org/global-events (colindixon, 18:06:48)
    2. ACTION: phrobb to make sure ONS is listed under ODL's events page (colindixon, 18:07:15)
    3. we're locking in our boron design forum on 2/29-3/1 at a hotel near the airprot (colindixon, 18:07:42)
    4. Open Networkign Summit (now a LF event) has it's CFP up (colindixon, 18:07:56)
    5. there's a modeling forum in the denver area looking at how to integrate SDO effots and Open Source efforts when it comes to models and the like with respect to NFV (colindixon, 18:08:39)
    6. if you're interested in the above, then talk to phrobb, it's happening on 1/5 (colindixon, 18:08:56)
    7. dlenrow will also be there, alongside phrobb (colindixon, 18:09:04)
    8. https://lists.opendaylight.org/pipermail/tsc/2015-December/004433.html discussion on the design forum for boron (colindixon, 18:09:35)
    9. http://opennetsummit.org/program/ <-- link to ONS CFP (phrobb_, 18:09:58)
    10. jmedved (jmedved, 18:10:58)
    11. colindixon talks about presenting at the Future Network Forum in Nanjing last week (colindixon, 18:11:46)
    12. https://fosdem.org/2016/ (tykeal, 18:12:58)
    13. https://fosdem.org/2016/ dnear says FOSDEM last weekend of January in Brussels there's a track on Sunday on SDN/NFV that loks cool (colindixon, 18:13:31)

  3. pre-boron (colindixon, 18:13:57)
    1. zxiiro has nothing to report here, a few projects seem to be using it, but not many (colindixon, 18:14:22)
    2. https://lists.opendaylight.org/pipermail/release/2015-November/004645.html branch cutting strategy (zxiiro, 18:14:39)
    3. please read the above to understand the plan for branch cutting at offest 2 M5 (colindixon, 18:15:09)

  4. beryllium (colindixon, 18:15:18)
    1. missing status updates from 8 projects, they've been contacted (colindixon, 18:15:36)
    2. M5 for offset 1 is today (colindixon, 18:15:41)
    3. autorelease has generated the first staging repo with a complete release (colindixon, 18:15:56)
    4. all projects but 4 projects in autorelease: CAPWAP, OpFlex, NEXT, and SNMP4SDM (colindixon, 18:16:24)
    5. those are all expected except SNMP4SDN; CAPWAP dropped from Be, OpFlex doesn't ship with Karaf, NEXT has no features yet, (colindixon, 18:17:11)
    6. they have all been contacted (colindixon, 18:17:32)
    7. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report weather report (colindixon, 18:17:52)
    8. anipbu says please don't disable license header checks in your build, also notes there were some issues on the weather, but they've been fixed (colindixon, 18:18:13)
    9. enforcement of config=false was merged, which caused now-fixed problems in LISP (colindixon, 18:19:24)
    10. mandatory=true enforcement will happen on 1/5 and might cause some issues, but trying to minimize them, fixed some in BGPCEP (colindixon, 18:20:11)

  5. stable/lithium (colindixon, 18:20:26)
    1. none for now (colindixon, 18:20:32)

  6. system integration and testing (colindixon, 18:20:43)
    1. JamO's not here today, no real updates (colindixon, 18:21:13)
    2. we'll plan to have a graduation review for integration/test as well as OVSDB netvirt when we get back (colindixon, 18:23:03)

  7. infrastructure (colindixon, 18:23:04)
    1. queues are really large, we don't quite know how to fix it yet (colindixon, 18:23:14)
    2. tykeal is still working on private cloud, migrations should start in January (colindixon, 18:23:26)
    3. he's working though a few enivironmental issues found while kicking the tires (colindixon, 18:23:38)
    4. edwarnicke asked if the issue with queues is just that we're running out of issues, tykeal says yes and asking for a bigger quota is what will fix it, but that will take 2-4 weeks (colindixon, 18:25:07)
    5. tykeal says he's not 100% sure what's causing the long queues, it was the longer jobs, but that's mostly fixed, now it's less clear, maybe just more projects and more tests (colindixon, 18:25:32)
    6. tykeal says they talked on the integration call and one problem is that ever merge runs all CSIT jobs (colindixon, 18:27:15)
    7. colindixon asks if there's a way to create a singleton-task pattern to just run CSIT onces at a time to test all the merges since it was last run (colindixon, 18:28:53)
    8. zxiiro suggested maybe running CSIT just off the dailies and factor faster integration smoke tests that can run on every merge (colindixon, 18:29:39)
    9. ACTION: zxiiro to lead a discussion on how we might reduce our load and thus queue sizes with these ideas (colindixon, 18:31:02)
    10. rovarga says we could maybe run singlefeaturetests first and allfeaturestests second only if the first start (colindixon, 18:31:58)
    11. https://git.opendaylight.org/gerrit/#/c/31512/ example of it taking 20 minutes to kick off a verify job (colindixon, 18:34:38)
    12. tykeal says the UI is really slow because of the design of jenkins, no easy weay to fix it (colindixon, 18:35:50)
    13. rovarga says that even getting the logs for failed verify jobs, for example, takes too long to be useful (colindixon, 18:38:25)
    14. edwarnicke asks how bad things have gotten (colindixon, 18:38:45)
    15. zxiiro has noticed that it's gotten slow to interact with jenkins recently, but seems less overall less worried than rovarga (colindixon, 18:39:28)
    16. ttkacik1 says in his mind that jenkins is unusable at this point, it actaully caused a scheduled weather event to be delayed by a week (colindixon, 18:40:30)
    17. ACTION: zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed (colindixon, 18:44:17)
    18. it sounds like the first stab is to run CSIT jobs on daily rather than every merge, then go from there (colindixon, 18:46:31)
    19. in lispflowmapping we also mostly end up ignoring csit results because of the delay recently . I also think Robert's suggestion on pending csit for 3 node pending single node passing would probably be a big help (vina_ermagan, 18:48:04)
    20. https://issues.jenkins-ci.org/browse/JENKINS-20046 tracks the jenkins scalability issue (rovarga, 18:49:15)

  8. TSC elections (colindixon, 18:51:15)
    1. https://wiki.opendaylight.org/view/TSC:Election_Proposal#Scaled_Popularity this is the summary that dfarrell07 provided (colindixon, 18:53:14)
    2. dfarrell07 says that we really need new blood in the discussion at this point (colindixon, 18:54:02)
    3. edwarnicke and dfarrell07 suggest that we start having a discussion on the list with links to the wiki to help out (colindixon, 18:54:26)
    4. the wiki is the right place to start now as it summarizes everything but maybe the last 5 or so posts (colindixon, 18:54:44)
    5. so, you won't need to read everything (colindixon, 18:54:57)
    6. ACTION: dfarrell07 to start a new thread pointing just to the wiki summary and the longer thread if people want to read it (colindixon, 18:56:12)
    7. it would be good to get input on this over the time between now ant 1/7 (colindixon, 19:00:21)

  9. cookies (colindixon, 19:00:58)


Meeting ended at 19:01:00 UTC (full logs).

Action items

  1. colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
  2. phrobb to poll the PTLs about Hackfest attendance
  3. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  4. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  5. colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows
  6. colindixon to add instructions to upload materials before creation reviews to the proposal instructions
  7. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  8. dfarrell07 will drive Pre-M1, bi-election discussion
  9. colindixon to try to bump boron planning back up the prioirty list
  10. phrobb to make sure ONS is listed under ODL's events page
  11. zxiiro to lead a discussion on how we might reduce our load and thus queue sizes with these ideas
  12. zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed
  13. dfarrell07 to start a new thread pointing just to the wiki summary and the longer thread if people want to read it


Action items, by person

  1. abhijitkumbhare
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  2. alagalah
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  3. colindixon
    1. colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
    2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    3. colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows
    4. colindixon to add instructions to upload materials before creation reviews to the proposal instructions
    5. colindixon to try to bump boron planning back up the prioirty list
  4. dfarrell07
    1. dfarrell07 will drive Pre-M1, bi-election discussion
    2. dfarrell07 to start a new thread pointing just to the wiki summary and the longer thread if people want to read it
  5. edwarnicke
    1. zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed
  6. LuisGomez
    1. zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed
  7. rovarga
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
    2. zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed
  8. tbachman
    1. colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows
  9. tykeal
    1. zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed
  10. zxiiro
    1. zxiiro to lead a discussion on how we might reduce our load and thus queue sizes with these ideas
    2. zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed
  11. UNASSIGNED
    1. phrobb to poll the PTLs about Hackfest attendance
    2. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
    3. phrobb to make sure ONS is listed under ODL's events page


People present (lines said)

  1. colindixon (81)
  2. alagalah (10)
  3. tbachman (6)
  4. tykeal (5)
  5. dneary (4)
  6. dfarrell07 (4)
  7. abhijitkumbhare (4)
  8. zxiiro (3)
  9. odl_meetbot (3)
  10. vina_ermagan (3)
  11. LuisGomez (2)
  12. phrobb_ (2)
  13. rovarga (1)
  14. dlenrow (1)
  15. jmedved (1)
  16. edwarnicke (1)
  17. mohnish_ (1)


Generated by MeetBot 0.1.4.