17:00:16 <colindixon> #startmeeting tws
17:00:16 <odl_meetbot> Meeting started Mon May 11 17:00:16 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:16 <odl_meetbot> The meeting name has been set to 'tws'
17:00:22 <colindixon> #topic agenda bashing
17:01:01 <colindixon> #link https://wiki.opendaylight.org/index.php?title=Tech_Work_Stream:Main&oldid=30240#Upcoming_Meeting_Agendas today’s meeting will be Sharon covering how to figure out who’s using what schema fragments in the MD-SAL
17:01:14 <colindixon> #info the agenda is open for future meetings
17:06:20 <colindixon> #topic demo of how to use XSQL to query the MD-SAL for schema things
17:06:24 <colindixon> #undo
17:06:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x19e1d90>
17:06:26 <colindixon> #topic background
17:06:48 <colindixon> #info Sharon basically says XSQL is trying to provide an easier XSQL interface on top of the MD-SAL
17:08:28 <colindixon> #info he says that until a month ago, it was very buggy, but there’s been a lot of work in the last month to make it more real
17:08:58 <colindixon> #info it basically shows each MD-SAL schema level as an SQL table
17:09:34 <colindixon> #info shows “list vfields nodes/node/table/flow” which shosw shte proprties of a flow
17:10:25 <colindixon> #info shows “select * from nodes/node;” and gets the list of the nodes
17:11:36 <colindixon> #info shows a simple query builder where you can get control-space context-senseitive auto-completion for writing queries which is really pretty cool
17:12:33 <dbainbri> any thoughts about making the query builder web based and part of the ODL distribution?
17:12:46 <colindixon> dbainbri: good question
17:12:48 <colindixon> feel free to speak up
17:12:54 <colindixon> or I can when there’s a lull
17:15:11 <colindixon> #info dbainbri asks if there is a plan to turn this into a web-based tool and release it as part of the normal distribution
17:17:03 <colindixon> #info Sharon says that he couldn’t get it to work the web-based thing and the REST RPC call for some reason and so he fell back to making a Java/swing app
17:17:32 <colindixon> #topic demo of working with Pentaho Report Designer
17:17:38 <dbainbri> very cool!!!
17:18:24 <colindixon> #info shows how to generate reports including PDF output
17:18:42 <colindixon> #topic binding aware code
17:19:12 <colindixon> #info the big new feature is that you can do an XSQL query and then get back the BindingAware java objects directly
17:19:18 <dbainbri> don't want to interrupt flow of demo, any plans to get this to work with the time series work as well?
17:19:49 <colindixon> #info shows ToasterProviderModule in org.opendaylight.controller.config.yang.config.toaster_provider.impl
17:22:02 * colindixon adds dbainbri’s question to his mental queue
17:23:22 <colindixon> #info you should be able to produce an instance identifier from the results to be able to do get where it actually is in the backing store
17:23:25 <colindixon> pretty cool
17:23:56 <dbainbri> or really any metric data queries might be able to mine some pretty useful information and or make pretty charts
17:25:25 <colindixon> #info dbainbri asks if you can also query TSDR, the answers is not right now, but it’s doable
17:27:23 <colindixon> #info currently when it gets the data, it does full table scans which is potentially slow
17:28:10 <colindixon> #info Sharon has been thinking about how to construct indices and make things faster, Sharon says he could use help here
17:29:36 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-May/009214.html Sharon’s request for help
17:31:40 <colindixon> https://wiki.opendaylight.org/view/InternProjects:Main
17:32:26 <colindixon> #topic forums to get help
17:34:10 <phudgins> We might get better attendance if we quit using the "No TWS meeting today" subject in subsequent meeting announcements
17:36:52 <colindixon> #info colindixon points out that calls for help sent to controller-dev, which is somewhat of a black hole these days
17:39:10 <colindixon> #info figuring out how to bring topics up that have broad interest is hard and something we’re bad at as a community
17:39:21 <colindixon> #info the TSC call and TWS call are good for things that need to be a discussion
17:39:41 <colindixon> #action colindixon says he’ll bring up the topic of XSQL help at the TSC meeting on Thursday
17:40:02 <colindixon> #action dbainbri to bring a few slides around threading modules, load balancing, etc. for next week
17:40:25 <colindixon> #topic can you query who uses a given grouping (the original question)?
17:40:33 <colindixon> #info the answer is not yet, but it shoudl be doable
17:44:05 <colindixon> #topic security in ODL
17:44:22 <colindixon> #Info Sharon asks about security in ODL and gets a bunch of pointers
17:56:58 <hideyuki> colindixon: I think we didn't do #endmeeting yet. (I'm not sure if I have the right to do #endmeeting.)
17:57:08 <colindixon> #endmeeting