21:00:14 <KLuehrs> #startmeeting UNI Manager
21:00:14 <odl_meetbot> Meeting started Wed Dec 16 21:00:14 2015 UTC.  The chair is KLuehrs. Information about MeetBot at http://ci.openstack.org/meetbot.html.
21:00:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:14 <odl_meetbot> The meeting name has been set to 'uni_manager'
21:00:21 <KLuehrs> #chair KLuehrs
21:00:21 <odl_meetbot> Current chairs: KLuehrs
21:00:39 <KLuehrs> #topic Feasibility of using the OVS QoS 'MaxRate' parameter to implement UNI Speed attribute
21:06:34 <KLuehrs> #info Confirmed OVS support MaxRate, QoS has been added to OVS project and it has been merged.
21:07:08 <KLuehrs> #info ODL support for QoS - model has been updated. No code exists yet.
21:08:27 <KLuehrs> #info Gabriel will check with QoS developer to learn when code will be available.
21:09:09 <KLuehrs> #info When code is in OVSDB it should be fairly simple to translate MaxRate to UNI Manager speed attribute.
21:09:46 <KLuehrs> #topic Unit Test Development techniques
21:11:51 <KLuehrs> #info We currently do not have resources available to develop unit tests. The project may be able to get a waiver.
21:12:26 <KLuehrs> #info Inocybe may be able to add some test classes and some example functions to the UNI Manager code, to make it easier for someone to follow.
21:13:35 <KLuehrs> #topic OPNFV Brahamaputra release
21:44:43 <KLuehrs> #info OPNFV release team has asked about potential conflicts with ODL karaf, e.g.,  Is the UNI-mgr karaf feature able to run coexistent with the required karaf features used in OPNFV? (do they collide with net-virt or sfc for instance or are they able to run at the same time?)
21:47:16 <KLuehrs> #info Gabriel thinks the information they are looking for is (1) What URLs and JSON payload does LSO API use when calling ODL UNI Manager plug-in, and (2) is there, or is there potential for, a port conflict between ODL karaf (8080, 8181) and Tomcat as used by LSOAPI?
21:47:43 <KLuehrs> #info Currently our implementation of the OPNFV LSOAPI uses port 9090 so there should be no conflict.
21:48:27 <KLuehrs> #action Gabriel will find out when ODL QoS implementation (code) will be done.
21:49:19 <KLuehrs> #action Inocybe will create basic test framework for UNI Manager unit tests: test classes and one or two sample functions for reference.
21:51:24 <KLuehrs> #agreed Next week's meeting (December 23) is cancelled due to holidays. The next UNI Manager project meeting will be held at the regularly scheduled time December 30.
21:51:28 <KLuehrs> #endmeeting