14:31:59 <gzhao> #startmeeting weekly irc sync
14:31:59 <odl_meetbot> Meeting started Wed Jun  3 14:31:59 2015 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:59 <odl_meetbot> The meeting name has been set to 'weekly_irc_sync'
14:32:19 <phrobb1> Good morning gzhao
14:32:22 <tbachman> #info tbachman for GBP
14:32:29 <regXboi> #info regXboi for neutron northbound
14:32:31 <anipbu> #info anipbu for usc
14:32:34 <tbachman> phrobb: gzhao  regXboi  good morning :)
14:32:54 <phrobb1> Good morning tbachman
14:32:56 * regXboi quips "heck it's almost afternoon"
14:32:56 <LuisGomez1> #info LuisGomez1 integration
14:32:58 <gzhao> regXboi: I seem to have problem with internet speed.
14:33:08 <lori> #info lori for lispflowmapping
14:33:20 <hideyuki> #info Hideyuki for VTN
14:33:34 <regXboi> are we expecting colindixon?
14:33:37 <gzhao> #info gzhao for release USC
14:33:48 * regXboi has a simple process question (smile)
14:33:53 <ttkacik> #info ttkacik for yangtools and controller
14:33:59 <gzhao> #chair phrobb1 regXboi
14:33:59 <odl_meetbot> Current chairs: gzhao phrobb1 regXboi
14:34:05 <regXboi> uh?
14:34:07 <odlcasey> #info odlcasey for ODL
14:34:17 * regXboi wonders what he did to deserve that
14:34:33 <phrobb1> gzhao:  you might want to chair tbachman too… :-)
14:34:39 * tbachman hides
14:34:40 <regXboi> #chair tbachman
14:34:40 <odl_meetbot> Current chairs: gzhao phrobb1 regXboi tbachman
14:34:41 <tbachman> lol
14:34:44 <tbachman> darn it!
14:34:45 <phrobb1> lol
14:34:45 <tbachman> ;)
14:34:46 <tbachman> lol
14:34:48 * regXboi spreads the wealth/pain
14:34:55 <gzhao> #chair tbachman
14:34:55 <odl_meetbot> Current chairs: gzhao phrobb1 regXboi tbachman
14:35:05 <tbachman> now I’m double-chaired
14:35:08 <zxiiro> #info Thanh
14:35:15 * tbachman wonders what extra powers that gives him
14:35:30 * regXboi tells tbachman to calm down - chairing is idempotent
14:35:36 <tbachman> lol
14:35:39 <tbachman> PUT, not POST
14:35:44 <regXboi> :)
14:36:11 <gzhao> #topic blocking issues
14:36:23 <tbachman> btw — was RC0 ever cut?
14:36:36 * regXboi isn't sure ...
14:36:58 <phrobb1> fyi colindixon sent a note saying his internet is flaky on him today, so he may not be able to join
14:37:05 <gzhao> #undo
14:37:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1944810>
14:37:20 <gzhao> #topic RC0 and branching, version bump
14:37:34 <phrobb1> zxiro, can you give us an update on RC0?
14:37:58 <zxiiro> Yes, I'm still trying to get a build going
14:38:15 <zxiiro> latest attempt will be build 15 which i'm starting shortly.
14:38:34 <zxiiro> I had to disable snmp4sdn this morning though as they have deleted all the code in their repo
14:38:34 <phrobb1> #info zxiiro says he's still trying to get an RC0 build going… he's on attempt #15
14:39:02 <zxiiro> snmp4sdn concerning patch https://git.opendaylight.org/gerrit/#/c/21747/
14:39:38 <regXboi> I'll note that if we cut RC0 right now, we'll need an RC1
14:39:40 <gzhao> shall we go for RC1 directly, because RC1 is scheduled on 6/4
14:40:21 <LuisGomez1> makes sense
14:40:29 <regXboi> I discovered yesterday that NN is missing a couple of pieces of it's northbound connections to OpenStack
14:40:40 * regXboi has to file a bug on that
14:41:04 * regXboi has to then get the bug closed
14:41:27 <phrobb1> zxiiro:  Anything else blocking RC0/1?  Is there anything this group can do to help?
14:41:56 <gzhao> I think first we need to get RC build successful, then all projects need to complete branch cutting and version bump
14:41:57 <tbachman> #info regXboi says Neutron Northbound s missing a couple of pieces of it's northbound connections to OpenStack
14:42:27 <regXboi> #info regXboi wonders how to handle this situation because its not precisely covered in the API waiver process
14:42:34 <tbachman> #info phrobb1 asks if there’s anything else blocking RC0/1?  Is there anything this group can do to help?
14:42:41 <zxiiro> at the moment I don't see any issues. We'll know in ~6 hrs after build 15 runs if there's any new issues that pop up but so far I've been able to open bugs and submit patches to projects when issues appear
14:42:46 <tbachman> #info gzhao says  we need to get RC build successful, then all projects need to complete branch cutting and version bump
14:43:25 <phrobb1> zxiiro:  and all projects are being responsive to your patches?
14:43:31 <zxiiro> phrobb1: yes
14:43:35 <phrobb1> cool!
14:43:44 <gzhao> #info there still 6-7 projects haven't completed branching and version bump
14:43:57 <regXboi> who do I talk to about getting versions added to a product/component in our bugzilla?
14:44:17 <phrobb1> OK, gzhao shall we move to blocking bugs?
14:44:25 <tbachman> regXboi: helpdesk
14:44:28 <gzhao> #topic Blocking bugs
14:44:34 <odlcasey> zxiiro: Is the Lithium Project Status spreadsheet accurate?
14:44:41 <zxiiro> odlcasey: yes
14:44:47 <phrobb1> regXboi:  I expect that would be a request to helpdesk
14:44:50 <zxiiro> odlcasey: i've been keeping it updated daily
14:44:57 <odlcasey> Ok, thanks.  :)
14:44:58 <gzhao> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 < -- current blocking bugs
14:45:13 * tbachman notes that he has to be careful when tabbing out odlcasey’s nic… odl_meetbot is just *too close* :0
14:46:03 <tykeal> regXboi: a helpdesk ticket. It's possible to grant some amount of power to committers of a given project to manage that themselves as well, I just need to know who wants it as I can't use the LDAP groups to grant the rights in bugzilla :(
14:46:42 <regXboi> tykeal: filed the ticket, but if you can grant me that power, I'll be less likely to bug folks (sorry for the pun)
14:46:44 <odlcasey> tbachman: :)  Maybe I should change it.
14:46:50 <tykeal> hehe
14:46:52 <tbachman> #info odlcasey asks if the  Lithium Project Status spreadsheet is accurate
14:47:14 <tbachman> #info zxiiro says he’s been keeping it updated daily
14:47:33 <regXboi> so... I have a comment on the blocking bugs
14:47:35 <tbachman> odlcasey: :)
14:48:01 <regXboi> #info regXboi notes that the bugs being filed don't necessarily contain enough useful information to triage
14:48:06 <tbachman> I’ll try and be extra careful (tbachman already makes *enough* bugaroos in minutes, as it is)
14:49:54 <gzhao> regXboi: do you want to create a bug template? with reproduce steps etc.
14:50:14 <regXboi> gzhao: that's really up to each project
14:50:15 <ttkacik1> hideyuki: good news - found root cuase for that blocker - was able to have unit test reproduce it...
14:50:25 <regXboi> so I'm going to create a template for NN bugs
14:50:38 <hideyuki> ttkacik1: Great news!
14:50:49 <gzhao> regXboi: thanks
14:50:50 <hideyuki> ttkacik1: Thanks a lot!
14:51:19 <gzhao> hideyuki: could you info that in
14:51:23 <regXboi> gzhao: but that will apply *ONLY* to NN bugs
14:51:39 <gzhao> regXboi: we can use that as example at least
14:52:03 * tbachman reads scrollback
14:52:03 <regXboi> #action regXboi to create template for NN bugs in NN wiki
14:52:14 <gzhao> any projects have blocking bugs?
14:52:37 <edwarnicke> #link https://wiki.opendaylight.org/view/Weather#Blocking_Bugs
14:53:04 <edwarnicke> regXboi: Could you pick up blocking bug: https://bugs.opendaylight.org/show_bug.cgi?id=3368
14:53:37 <regXboi> edwarnicke: that's what led to my earlier comment about not having enough info and subsequent action item for a NN template
14:53:42 <hideyuki> #info Tony found the root cause of the bug 3344, and it was able to have unit test reproduce it. https://bugs.opendaylight.org/show_bug.cgi?id=3344
14:53:56 <edwarnicke> regXboi: What info is missing?
14:53:58 <abhijitkumbhare> #info abhijitkumbhare OpenFlow plugin
14:54:04 <abhijitkumbhare> sorry got held up in traffic
14:54:16 <tbachman> #link https://bugs.opendaylight.org/show_bug.cgi?id=3344 blocker bug for VTN, which ttkacik recently found the source of and fixed
14:54:18 <regXboi> edwarnicke: in general I'd like the source JSON
14:54:23 <regXboi> call me picky
14:54:24 * tbachman looks for gerrit to point to
14:54:38 <edwarnicke> regXboi: Comment and ask for them
14:54:39 <ttkacik1> will be soon
14:54:40 <edwarnicke> regXboi: That said
14:54:45 <ttkacik1> need to write good commit message
14:54:57 <regXboi> edwarnicke: already asked for it on the neutron channel
14:55:00 <regXboi> so it's in the works
14:55:03 <edwarnicke> :)
14:55:39 <hideyuki> tbachman:  your info for bug 3344 is better :)
14:56:21 <gzhao> #topic RC1
14:56:27 <tbachman> hideyuki: just like to capture those with the #link option
14:56:32 <tbachman> was looking for the corresponding gerrit
14:56:38 <tbachman> ttkacik: do you have the gerrit for the fix?
14:56:41 <tbachman> (or is there one yet)
14:57:30 <tbachman> ah — sorry ttkacik… missed your  message above
14:57:35 * tbachman was too eager :)
14:57:51 <gzhao> #info RC1 is scheduled 6/4 tomorrow
14:58:34 <gzhao> any issues people like to raise
14:58:48 <regXboi> I have a process question
14:59:01 <edwarnicke> I have a question... did we build an RC0?
14:59:08 <gzhao> edwarnicke: not yet
14:59:44 <edwarnicke> OK... so to my understanding the purpose of RC# is to have images to test with... so the question becomes... can we really have an RC1 if we never built RC0...
14:59:49 <gzhao> edwarnicke: still in progress, but once it is done, it will be RC1. current zxiiro said it took about 6 hours
15:00:07 <edwarnicke> gzhao: 6 hours sounds actually faster than I expected ;)
15:00:08 <phrobb1> edwarnicke:  RC0 info is in the meeting log… we're on attempt 15 and will know if it works in ~6 hours
15:00:41 <gzhao> edwarnicke: so we should still call it RC0
15:00:53 <tbachman> #info edwarnicke asks if  the purpose of RC# is to have images to test with... so the question becomes... can we really have an RC1 if we never built RC0...
15:01:07 <edwarnicke> I guess my point is, we should discuss how many RCs we need to go through for the release... if we are fine skipping RC0 that's fine, but it materially means that we've cut off a third of our RC testing
15:01:10 <zxiiro> I kicked off build 15 as RC0
15:01:23 <zxiiro> but if that fails i can call it RC1 if we want or i can keep trying to build RC0
15:01:43 <tbachman> #info edwarnicke notes that skipping RC0 materially means that we've cut off a third of our RC testing
15:01:59 <edwarnicke> zxiiro: My personal gut tendency would be to call it RC0... but that's not well thought out on my part, and is just *my* gut
15:02:12 <gzhao> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-lithium/15/ <--current RC0 build
15:02:58 <tbachman> #info zxiiro says there’s an RC0 build underway, and should be available in ~6 hours
15:03:09 <gzhao> do we have any other blocking issues?
15:03:31 <gzhao> 3
15:03:37 <edwarnicke> So I have an odd one
15:03:37 <gzhao> 2
15:03:45 <gzhao> 1
15:03:47 <edwarnicke> Because its not *quite* in odl repos
15:04:00 <edwarnicke> But we do have a blocking issue around the odl-networking not passing SG and SGR objects to ODL
15:04:05 <ttkacik1> Tony: https://git.opendaylight.org/gerrit/21791
15:04:15 <edwarnicke> Do folks have suggestions as to how to register that as a blocking bug?
15:04:22 <edwarnicke> Given that the code lives in stackforge?
15:04:33 <tbachman> edwarnicke: you mean openstack networking_odl?
15:04:40 <edwarnicke> tbachman: Yes
15:04:42 <tbachman> ah
15:05:05 <edwarnicke> tbachman: Without it, nobody in ODL can do SecGroups correctly
15:05:14 <edwarnicke> (you can kind of fake them a bit, but not do them correctly)
15:05:28 <tbachman> #info edwarnicke asks about a blocking issue related to security groups in the stackforge networking_odl project — and how we can track dependencies against it
15:05:31 <edwarnicke> regXboi: Thoughts?
15:05:35 <alagalah_> edwarnicke: We don't get updates AFAIK thats the real issue
15:05:42 <alagalah_> edwarnicke: wasn't this going to be done last week ?
15:05:46 <edwarnicke> alagalah_: That matches my understanding
15:05:58 <regXboi> edwarnicke: that's outside our scope
15:05:58 <tbachman> #info alagalah_ says the issue is that security group updates aren’t being sent
15:06:03 <edwarnicke> alagalah_: flaviof has been working it somewhat, among other things.  I'm starting to look at it
15:06:08 <alagalah_> https://review.openstack.org/#/q/status:open+project:stackforge/networking-odl,n,z
15:06:09 <tbachman> #info regXboi says that’s outside of scope
15:06:20 * edwarnicke does not recognize scope boundaries well ;)
15:06:29 <alagalah_> regXboi: Who's scope is it in then?
15:06:47 <alagalah_> regXboi: Not throwing stones at you mate, just want to understand
15:06:49 <regXboi> as soon as you say stackforge, I say openstack
15:07:07 <gzhao> zxiiro: I have a question if not all projects are on stable/lithium, will it cause tagging issues after RC build?
15:07:15 <edwarnicke> regXboi: Yes... but we are the ones who care
15:07:15 <alagalah_> regXboi: Yes, but then is it the impl of Neutron NB responsibility? That means potentially 3-4 folks pinging them.
15:07:26 <edwarnicke> regXboi: I'm not trying to push this on neutron northbound
15:07:35 <regXboi> edwarnicke: it sure sounds like it
15:07:36 <tbachman> #info alagalah_ asks regXboi what’s in scope then?
15:07:37 <edwarnicke> regXboi: I'm just trying to figure out how we should record the issue in our blocking bugs
15:07:45 <tbachman> #info regXboi says stackforge is openstack scope
15:07:53 <zxiiro> gzhao: tagging no. but we should have stable/lithium in order to tag otherwise they won't have a lithium stream once tagging completes
15:08:04 <edwarnicke> regXboi: Apologies if it sounded like I was trying to push this on neutron northbound
15:08:23 <edwarnicke> regXboi: My interest starts with 'lets record this is a blocking bug so we can track it' and ends with 'this is fixed on our OS driver'
15:08:25 <zxiiro> gzhao: so process wise i say we shouldn't tag unless all projects have stable/lithium
15:08:30 <alagalah_> regXboi: Neither was I.. .just, where do we go ?
15:08:40 <tbachman> #info gzhao asks if not all projects are on stable/lithium, will it cause tagging issues after RC build?
15:08:42 <alagalah_> regXboi: TSC ?
15:08:51 <gzhao> zxiiro: ok, thanks
15:08:56 <tbachman> #info zxiiro says tagging no. but we should have stable/lithium in order to tag otherwise they won't have a lithium stream once tagging completes
15:09:10 <edwarnicke> zxiiro: gzhao What is the link for the branch cutting spreadsheet (I know you've got it somewhere up log... but could I get it here)?
15:09:16 <phrobb1> alagalah_:  regXboi edwarnicke is the stackforge bug truly a blocker?… ie we wouldn't ship Li without it being fixed?
15:09:24 <regXboi> edwarnicke, regXboi: going to TSC won't help
15:09:37 <regXboi> these are bugs that need to be filed on openstack and the ODL ML2 driver
15:09:37 <edwarnicke> phrobb1: Well, its really a question of whether we are supporting basic neutron L2 or not
15:09:43 <regXboi> yes we should file them
15:09:51 <edwarnicke> phrobb1: If we are comfortable not actually supporting basic neutron L2, its not a blocker
15:09:58 <regXboi> and heck, volunteers can be good citizens and fix them
15:10:01 <edwarnicke> phrobb1: But if you *actually* want to support neutron L2, you need it
15:10:09 <regXboi> but they are bugs *ON* the openstack code base, not the ODL code base
15:10:17 <regXboi> and that's my point
15:10:44 <phrobb1> edwarnicke:  and that's on the shipping release of Kilo for OpenStack?
15:10:59 <phrobb1> … ie we would need to wait for an update to Kilo?
15:11:19 <regXboi> phrobb1: that's likely for individual folks to decide :(
15:11:28 <edwarnicke> phrobb1: My understanding is that the drivers evolve independently of the broader neutron
15:11:53 <alagalah_> regXboi: ... and if we weren't two weeks away from our own release, I'd definitely pony up and give it a try
15:11:55 <edwarnicke> phrobb1: But the net net is we can't even *know* if we can support neutron L2 all the way without those objects coming down to us
15:12:18 <tbachman> #info regXboi says that these are bugs that need to be filed on openstack and the ODL ML2 driver
15:12:34 <edwarnicke> phrobb1: There were bugs fixed in ML2 in Kilo to *enable* us to do this in our driver
15:12:50 <tbachman> #info phrobb1 asks if the stackforge bug truly a blocker?… ie we wouldn't ship Li without it being fixed?
15:13:01 <regXboi> #info - I know this is a bit of a regression, but I'm not convinced that 3368 is a blocking bug
15:13:08 <tbachman> #Info edwarnicke says its really a question of whether we are supporting basic neutron L2 or not
15:13:14 <phrobb1> For me, it doesn't sound like a blocker but instead a severe bug that we document, then update with a version identifier on Kilo/driver/whatever if/when the issue is fixed in OpenStack
15:13:41 <tbachman> #info phrobb1 says that to him, it doesn't sound like a blocker but instead a severe bug that we document, then update with a version identifier on Kilo/driver/whatever if/when the issue is fixed in OpenStack
15:14:21 <edwarnicke> phrobb1: Well... do we just say that we don't support L2 and SG then in our release notes?
15:14:27 <edwarnicke> phrobb1: Because this is *that* fundamental
15:14:46 <edwarnicke> phrobb1: I had thought that 'neutron support was the most important thing' and it doesn't get more fundamental to providing that support than this
15:14:50 <regXboi> edwarnicke: we say we support SG as much as openstack does
15:14:58 <edwarnicke> regXboi: But we don't
15:15:08 <edwarnicke> regXboi: We support them way less than OS does
15:15:23 <regXboi> edwarnicke: if the drivers to us don't send information then we are done
15:15:26 <regXboi> file the bug there
15:15:30 <tbachman> #info edwarnicke asks if we just say that we don't support L2 and SG then in our release notes?
15:15:33 <edwarnicke> regXboi: Because if I change a SG, I have to teardown and restand up *all* the VMs that impacts in order to reflect that change
15:15:41 <tbachman> #info regXboi says we say we support SG as much as openstack does
15:15:47 <regXboi> #undo
15:15:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1aa8710>
15:15:53 <tbachman> :)
15:16:02 <edwarnicke> regXboi: Or simply have the user silently not get the SG they thought they were getting for existing ports
15:16:03 <regXboi> #info regXboi says that all we can do is say we support SG as much as openstack does
15:16:08 <tbachman> regXboi: thx!
15:16:11 <edwarnicke> (which is a major major security hole in my mind)
15:16:34 <tbachman> #info edwarnicke notes that  if I change a SG, I have to teardown and restand up *all* the VMs that impacts in order to reflect that
15:16:35 <edwarnicke> #info we don't support SG as much as OS does, but instead substantially less... entirely because of this bug in our OS driver
15:16:38 <regXboi> edwarnicke: I continue to fail to see how this is the right forum for this
15:16:45 <tbachman> edwarnicke: thx!
15:16:49 <edwarnicke> regXboi: Because we need to get it fixed before the release
15:16:49 <phrobb1> edwarnicke:  That makes sense to me.  Regardless of the codebase where the bug resides, do we know who the logical people are to fix it?… ie is it someone from the ODL community who has been working in OpenStack?… or is there someone in OpenStack we need to work with to get it fixed?
15:17:03 <edwarnicke> phrobb1: flaviof has been poking at it
15:17:11 <tbachman> #info phrobb1 asks if regardless of the codebase where the bug resides, do we know who the logical people are to fix it?… ie is it someone from the ODL community who has been working in OpenStack?… or is there someone in OpenStack we need to work with to get it fixed?
15:17:24 <edwarnicke> phrobb1: mestery has been giving it best effort (which is kind of him, but he's very busy)
15:17:30 <regXboi> edwarnicke: so let me boil this down to the bottom line
15:17:32 <edwarnicke> phrobb1: I've started looking at it as well
15:17:50 <regXboi> edwarnicke: you are saying that without this patch to OS, *we don't have a Lithium release, period*
15:18:02 <tbachman> #info edwarnicke notes that mestery has been giving it as much effort as he can, but he’s very busy; flaviof has also been looking at it
15:18:14 <edwarnicke> mestery: We were just singing songs of you valiant attempt to help us get our OS ML2 driver to send SG and SGR objects... and lamenting that you are so busy ;)
15:18:26 <regXboi> #info regXboi askes if edwarnicke is saying that without the SG patch to OS, then *we don't have a Lithium release, period*
15:18:47 <edwarnicke> regXboi: Well, the call in my mind is really between these two choices:
15:19:01 <edwarnicke> 1)  Get this fixed, and make sure projects handle the fix correctly and claim OS support
15:19:08 <regXboi> #info regXboi notes that this feels like this is setitng both a bad precedent and is engaging in serious scope creep
15:19:10 <edwarnicke> 2)  Don't, and don't really have neutron support in Li
15:19:13 <edwarnicke> Pick one
15:19:27 <phrobb1> regXboi:  and edwarnicke, Ultimately, the TSC decides when the release is ready to ship.  edwarnicke has a really good argument that the OpenStack bug is a blocker for ODL, particularly if we have the resources/ability to fix it regardless of code base.
15:19:36 <tbachman> #info edwarnicke says to him there are two choices: 1)  Get this fixed, and make sure projects handle the fix correctly and claim OS support; : 2)  Don't, and don't really have neutron support in Li
15:19:37 <edwarnicke> phrobb1: No disagreement there at all
15:19:44 <edwarnicke> phrobb1: Its entirely the TSC's call
15:19:57 <tbachman> #info phrobb1 says ultimately, the TSC decides when the release is ready to ship.  edwarnicke has a really good argument that the OpenStack bug is a blocker for ODL, particularly if we have the resources/ability to fix it regardless of code base.
15:19:58 <edwarnicke> phrobb1: I am just trying to get this listed on the blocking bugs for tracking
15:20:05 <regXboi> edwarnicke and phrobb1: I will remind both of you that the TSC does not allocate resources
15:20:22 <edwarnicke> phrobb1: And understand very well that when the rubber hits the road, the TSC decides whether or not to ship with a particular blocking bug outstanding
15:20:28 <edwarnicke> regXboi: I know that better than most :)
15:21:01 <gzhao> #action project: CCFT, D4A, DIDM, Doc, NIC, Persistence, Reservation, SNBI, SNMP4SDN need to complete stable/lithium branching and version bump ASAP
15:21:09 <gzhao> just want to put that in the meeting minutes
15:21:15 <edwarnicke> phrobb1: I will note though, that generally while the TSC does decide which blocking bugs to ship with or not, historically its left it to folks to decide what to *list* as blocking bugs (which has worked really really well so far ;) )
15:21:17 <tbachman> #info regXboi points out that the TSC doesn’t allocate resources
15:21:28 <edwarnicke> gzhao: Thank you :)
15:21:39 <gzhao> edwarnicke: https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 zxiiro added two columns, branching and version bump
15:21:45 <phrobb1> regXboi:  but they do determine minimum functionality and robustness for release.
15:21:46 <edwarnicke> gzhao: :)
15:22:00 <tbachman> #info phrobb1 points out that  they do determine minimum functionality and robustness for release.
15:22:09 <tbachman> #undo
15:22:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab5d10>
15:22:27 <tbachman> #info phrobb1 points out that the TSC does determine minimum functionality and robustness for release
15:22:41 <flaviof> tbachman: edwarnicke: phrobb1: sorry for the delay. My focus has been on the summit and L3 in ovsdb netvirt. I tried to help mestery_ a bit on the SG stuff, but that has not been a priority for me.
15:22:43 <edwarnicke> phrobb1: Only to the extent that it can decide to not ship.  The TSC controls no resources
15:22:58 <tbachman> flaviof: ACK :)
15:23:17 <tbachman> (and welcome flaviof ;) )
15:23:19 <edwarnicke> phrobb1: The TSC has no capacity to say 'This will be the minimal functionality in the release' only to say 'We will not release a release without this functionality'
15:23:31 <edwarnicke> flaviof: Welcome :)
15:23:42 <phrobb1> edwarnicke:  regXboi for the record, I agree and support the statement that the TSC has no control over resources :-)
15:24:17 <edwarnicke> flaviof: Can you tell us what you know of the SG and SGR stuff?  Is there a bug filed on the OS side, and if not, where should it be filed over there?
15:24:39 <flaviof> edwarnicke: ty. ;) the sad state of our openstack ci makes devel on the SG harder, in my humble and honest opinion.
15:24:55 <tbachman> #info edwarnicke asks flaviof if he knows whether there’s a bug filed on the OS side, and if not, where should it be filed over there?
15:25:01 <flaviof> edwarnicke: I think so. /me looking
15:25:25 <regXboi> honestly, openstack ci is somewhat orthogonal to this conversation
15:25:41 <edwarnicke> I concur witj regXboi
15:25:43 <flaviof> #link https://bugs.launchpad.net/networking-odl  odl ml2 bugs
15:26:12 <flaviof> https://bugs.launchpad.net/networking-odl/+bug/1444112
15:26:26 * gzhao wonders should he end this meeting
15:26:53 <flaviof> #link https://bugs.launchpad.net/networking-odl/+bug/1450603 critical odl bug: fix ci
15:26:57 <regXboi> #info regXboi want to make the point that this is a change in scope
15:27:26 <regXboi> #info regXboi points out that we are now saying we are blocking on bugs that *ARE OUTSIDE ODL'S SCOPE*
15:27:28 <tbachman> #link : https://bugs.launchpad.net/networking-odl/+bug/1444112 bug against networking_odl security groups (in openstack)
15:27:50 <regXboi> #info regXboi says "and that's a *major* change"
15:28:00 <phrobb1> gzhao, maybe ask the group if there are other blocking bugs that should be discussed here?
15:28:14 <regXboi> colindixon: are you reading my last infos? (as TSC chair)
15:29:49 <gzhao> phrobb1: I think this SG issue should be discussed in TSC meeting, it probably cannot reach agreement here, but it is a good discussion
15:30:11 <regXboi> all: I have a problem with that -
15:30:18 <regXboi> I'm not around on thursday to input
15:30:18 <phrobb1> gzhao:  agree
15:30:24 <gzhao> we doubled the meeting time already, so I am going to end this meeting, don't mean to end the discussion
15:30:26 <edwarnicke> phrobb1: agree
15:30:59 <gzhao> or shall I just add a topic Openstack SG
15:32:30 <phrobb1> gzhao: Not sure what you are asking… Maybe it would be best to send a note to the TSC list right after this meeting to kick off the further discussion with the TSC on the ML.  That way regXboi can contribute to the discussion
15:32:51 <edwarnicke> phrobb1: gzhao I've added the bug to the blocking bugs list
15:33:00 <gzhao> phrobb1: ok
15:33:11 <edwarnicke> #link https://wiki.opendaylight.org/view/Weather#Blocking_Bugs
15:33:25 * tbachman has to go
15:33:26 <gzhao> edwarnicke: thanks, let's put that but in info, then I will end the meeting
15:33:46 <edwarnicke> #info edwarnicke has added the SG and SGR issue to blocking bugs list
15:34:34 <gzhao> #action gzhao sends email to TSC for further SG/SGR discussions
15:34:37 <gzhao> #topic cookies
15:34:37 <regXboi> phrobb1: that would be a good idea
15:34:43 * regXboi giggles
15:34:49 <gzhao> #endmeeting