15:31:55 <colindixon> #startmeeting weekly_lithium_irc_sync
15:31:55 <odl_meetbot> Meeting started Wed Mar  4 15:31:55 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:31:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:31:55 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
15:32:00 <colindixon> #topic agenda bashing
15:32:04 <alagalah> #info alagalah for GBP
15:32:12 <tbachman> alagalah: I kind of liked the heyllo
15:32:14 <colindixon> #chair tbachman phrobb- alagalah
15:32:14 <odl_meetbot> Current chairs: alagalah colindixon phrobb- tbachman
15:32:15 <tbachman> it’s “mod” ;)
15:32:19 <tbachman> btb
15:32:21 <tbachman> brb
15:32:23 <dkutenic> #info dkutenic for bgpcep, tcpmd5
15:32:28 <colindixon> #info colindixon for docs,  ttp and the TSC
15:32:30 <LuisGomez> #info LuisGomez from integration
15:32:34 <fabiel> #info fabiel for Persistence Store Service
15:32:37 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow plugin
15:32:40 <hideyuki> #info Hideyuki for VTN
15:33:15 <alagalah> colindixon: Where on the agenda can we address some the build failures we saw overnight, with errors on what looked like git cloning ?
15:33:32 <alagalah> colindixon: releng jenkins
15:33:46 <tbachman> back
15:33:52 <tykeal> wee... talk about perfect timing to drive by on this channel
15:34:06 <alagalah> tykeal: hey man
15:34:08 <tykeal> alagalah: rackspace rebooted all of their servers in the DC last night because of a xen issue
15:34:13 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings the agenda for today and where to add things for future meetings
15:34:14 * tbachman wonders if tykeal gets channel beeps on “releng"
15:34:15 <alagalah> tykeal: I'll wait for colindixon to put it on agenda
15:34:27 <tykeal> tbachman: no... but I could set that up in my znc reflector ;)
15:34:27 <tbachman> tykeal: ouch
15:34:29 <alagalah> tykeal: ...and there's no need for it to go on the agenda... thanks
15:34:30 <tbachman> lol
15:34:44 <abhijitkumbhare> Do we have an invite for this meeting? I believe folks may not have this on their calendar
15:34:45 <ttkacik> #info ttkacik for yangtools and controller
15:34:57 <tbachman> abhijitkumbhare: fwiw, it’s on the google calendar
15:34:57 <gzhao> #info gzhao release
15:34:59 <alagalah> abhijitkumbhare: its part of the odl gcal
15:35:03 <abhijitkumbhare> ok
15:35:09 <gzhao> #info gzhao release
15:35:11 <tbachman> alagalah: jinx
15:35:21 <tykeal> tbachman: I litterally was just sweeping all the channels that were showing me new updates since last I checked when I said that ;)
15:35:29 <tbachman> :)
15:35:45 <alagalah> abhijitkumbhare: https://wiki.opendaylight.org/view/Meetings
15:35:57 <alagalah> abhijitkumbhare: Not to be confused with the IRC logs which are meetings.opendaylight.org
15:36:02 <colindixon> ok
15:36:07 <colindixon> let’s let people roll in, but we’ll start here
15:36:12 <tbachman> is there a phrobb- around?
15:36:14 <colindixon> please bring up other topics
15:36:22 <colindixon> as we go
15:36:24 * alagalah done
15:36:37 <tbachman> colindixon: do we want to say anything about Steve Dean’s question on the mailing list re: M3?
15:36:42 <tbachman> I think someone answered him
15:36:43 <colindixon> #topic topics of general concern
15:36:48 <colindixon> tbachman: sure
15:36:49 <tbachman> just wasn’t sure if it was worth repeating here
15:36:51 <colindixon> that’s next
15:36:54 * tbachman goes off to find email
15:37:11 <colindixon> #info alagalah asks what was going on with builds failing last night because of what looked like git clone issues
15:37:15 <tykeal> phrobb-: is in europe for MWC (mobile world conference) dunno if he's going to show for your meeting ;)
15:37:16 <colindixon> tykeal: quick thoughts?
15:37:30 <tbachman> #link https://lists.opendaylight.org/pipermail/release/2015-March/001523.html Email fom sdean778 on M3 requirements
15:37:46 <gzhao> colindixon: single feature test <==https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722
15:38:00 <tykeal> colindixon: as I said, rackspace rebooted all of the Xen hosts last night. They did it over ~8 hours so the entire environment would have been very unstable
15:38:01 <colindixon> thanks
15:38:10 <tbachman> #link https://lists.opendaylight.org/pipermail/release/2015-March/001524.html Response from gzhao to sdean778’s M3 requirements email
15:38:11 <colindixon> tykeal: is it back to normal?
15:38:25 <tykeal> I did have notice but I was so busy with things that I failed to message it out
15:38:25 <alagalah> #info tykeal: rackspace rebooted all of the Xen hosts last night. They did it over ~8 hours so the entire environment would have been very unstable
15:38:29 <colindixon> thanks alagalah
15:38:39 <tbachman> alagalah: beat me to i t;)
15:38:43 <tbachman> it
15:38:45 <tykeal> colindixon: yes, it's back to normally. We've got no more host system updates that I know of coming up right now
15:38:51 <alagalah> no sweat, had to copy pasta the "as I said" bit out :)
15:38:53 <colindixon> #info the gist of gzhao’s response to sdean778 is that you should report where you are and for things that aren’t on track what the new ETA is
15:39:01 <colindixon> #info tykeal says that things appear to be back to normal
15:39:10 <sdean778> #info Steve Dean for DIDM and SNMP PLugin
15:39:15 <tykeal> mea culpa on my part for the bad messaging
15:39:47 <alagalah> tykeal: ????
15:39:48 <tbachman> tykeal: no mea culpa needed — your cred is good here ;)
15:40:01 <alagalah> tykeal: Yeah man I mean... what could you have done ?
15:40:06 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-February/001489.html we still need lots of people to update their single feature test and note that it’s been fixed in the spreadsheet
15:40:22 <tykeal> alagalah: not get a lot of sleep because my pager was do the two-step all night?
15:40:48 <tbachman> ouch
15:40:49 * colindixon notes that he has a huge amount of respect for tykeal after seeing how hard it is to run this stuff internally
15:40:50 <alagalah> tykeal: Sorry dude
15:41:02 * tbachman nods to colindixon’s comment
15:41:06 * alagalah me too
15:41:11 <colindixon> ok, other topics of general interest?
15:41:12 <alagalah> colindixon: the spreadsheet
15:41:17 <tbachman> tykeal and zxiiro deserve tons o’ community luv :)
15:41:35 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 the sheet to report when you’ve updated your single feature test (also linked from the above mail)
15:41:41 <colindixon> going once
15:41:47 <alagalah> colindixon: Is this just a list of folks not with SingleFeature and if you are not on it you are ok? I know we've fixed our stuff up a while back.. .just want to ensure that that is known
15:42:07 <alagalah> colindixon: compliance by ommision ?
15:42:20 <colindixon> alagalah: that is correct to the best of my knowledge
15:42:46 <tbachman> gzhao: is that correct ^^^ ?
15:42:51 <colindixon> this mail shows how I produced the list and has newer list
15:42:53 <colindixon> https://lists.opendaylight.org/pipermail/release/2015-February/001506.html
15:42:56 * tbachman believes that’s the case — just wanted to make ure
15:43:01 <tbachman> sure
15:43:20 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-February/001506.html this shows how colindixon produced the list of offending projects and a more recent (but not curent) list
15:43:27 * tbachman is missing keys right and left this a.m. — could make for some embarrassing emails ;)
15:43:35 <gzhao> tbachman: that list was based on findings compiled by colindixon
15:43:37 <alagalah> colindixon: Ack, that makes sense...
15:43:43 <tbachman> gzhao: thx!
15:43:51 <alagalah> Therefore omission == compliance :)
15:43:51 * tbachman takes another sip of coffee
15:44:03 * alagalah has complete faith in colindixon's regex grep-fu
15:44:07 <colindixon> alagalah: yes, I *think* it’s hard to be doing it wrong and not make my list
15:44:21 <colindixon> it is possible to do things right and still make my list though :p
15:44:33 <alagalah> colindixon: False positive better than false negative
15:44:34 <colindixon> ok, going twice to move to next topic
15:45:04 <colindixon> #topic questions about M3 deliverables
15:45:22 <colindixon> since this is tomorrow for a lot of folks, I want to hit it to make sure we can help
15:46:19 <colindixon> anyone?
15:46:31 <tbachman> <crickets>
15:46:31 <colindixon> questions about docs? system test? integration? features?
15:47:10 <LuisGomez> does anybody has a sense how projects are doing with feature definition?
15:47:38 <colindixon> LuisGomez: I don’t, but I have a script that might give some answers
15:47:51 <tbachman> colindixon: has a script for everything :)
15:47:57 <colindixon> LuisGomez: my guess is that there will be a lot more scrambling and looking for help starting about 36 hours from now :p
15:48:05 <LuisGomez> cool, because i have not seen patches in integration for now…
15:48:06 <tbachman> lol
15:48:30 <colindixon> LuisGomez: how many offset 1 projects are new to Lithium?
15:49:03 <colindixon> tbachman: I really only have a good understanding of grep and this script: https://github.com/nilok/odlutils
15:49:08 <LuisGomez> i think around 3
15:49:13 <tykeal> tbachman: I want to know if colindixon has a script to be colindixon ;)
15:49:17 <LuisGomez> let me check
15:49:34 * tbachman clicks on link that lets colindixon p0wn tbachman’s laptop
15:49:44 <colindixon> #topic questions from one project to another
15:50:01 <colindixon> any projects have questions they need answered from another project?
15:50:31 <LuisGomez> colindixon, 5 projects counting the new Neutron project
15:50:57 <colindixon> #undo
15:50:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a8c650>
15:51:04 <colindixon> LuisGomez: what are the projects?
15:52:01 <LuisGomez> persistence, SXP, SNMP and topology processing
15:52:01 <sdean778> snmp plugin is an offset 1 project that is new for lithium
15:52:02 <colindixon> ANYONE WITH ANY QUESTIONS ABOUT THE LITHIUM RELEASE, M3 DELIVERABLES, OR ANYTHING SHOUDL FEEL FREE TO VOICE IT NOW
15:52:09 <gzhao> persistence, topology, snmpplugin, sxp
15:52:13 <LuisGomez> the last has their features in already
15:52:40 <colindixon> #info LuisGomez notes that he has gotten nearly no features patches to integration despite the M3 offiset 1 deadline for that being tomorrow
15:52:56 <colindixon> #info LuisGomez says that there are only 5 projects that are offset 1 and new to Lithium: persistence, SXP, SNMP and topology processing
15:53:19 <fabiel> The persistence project subtmitted a patch for the features. We are still looking into integration.
15:53:35 <colindixon> #info only topoprocessing has gotten their features in, but this is less worrying since it’s just three projects that haven’t done it yet
15:53:56 <colindixon> #info fabiel notes that persistence is working on it as we speak
15:54:45 <colindixon> #topic questions from one project to another
15:54:49 <colindixon> any questions here?
15:55:02 <colindixon> going once
15:55:06 * colindixon counts to 15
15:55:30 <colindixon> going twice
15:55:31 * tbachman notes that colindixon’s 15 is multi-core, so it’s probably more like 5
15:55:33 * colindixon counts to 15
15:55:58 <colindixon> gone
15:56:11 <tbachman> endmeeting?
15:56:12 <colindixon> #topic announcements of changes that might affect other projects
15:56:15 <tbachman> ah
15:56:18 <LuisGomez> #info announce: TWS call in 2 weeks (Mon March 16th) we will explain Robot Framework
15:56:54 <colindixon> #action all projects to check and/or fix their single feature test using the link above in the minutes
15:57:12 <LuisGomez> #info with robot examples, best practices, etc…
15:57:42 <colindixon> #action at least SXP, persistence, Neutron, and SNMP to get their features into integration. Other offset 1 projects may need to update their features definitions.
15:57:49 <colindixon> Thanks LuisGomez!
15:59:45 <colindixon> #info ttkacik says that yangtools and controller will be pushing patches to move completely to normalized node from composite node starting on monday
15:59:51 <colindixon> ok
15:59:55 <colindixon> last call for anything
16:00:05 <colindixon> that’s information from here: https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-03-03-16.59.html
16:00:22 <ttkacik> also mentioned it on previous cross-project :)
16:00:26 <hideyuki> colindixon: Thanks for the information.
16:00:38 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-03-03-16.59.html more info on the move from composite to normalized nodes is here (only affects controller and ttp as far as ttkacik knows)
16:00:41 <colindixon> ttkacik: thanks!
16:00:44 <colindixon> ok
16:00:48 <colindixon> I think we’re done then
16:00:57 <ttkacik> patches for netconf / restconf are already on code-review (by Vaclav Demcak and Maros Marsalek)
16:00:59 <tbachman> colindixon: thx for running it!
16:01:09 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings post any topics for next week here
16:01:13 <colindixon> #endmeeting