#opendaylight-meeting: weekly lithium IRC sync

Meeting started by colindixon at 14:30:39 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 14:30:45)
    1. tbachman for groupbasedpolicy (tbachman, 14:31:09)
    2. Project Leads and TSC members please #info in (phrobb, 14:31:09)
    3. colindixon for docs, ttp, and the tsc (colindixon, 14:31:17)
    4. gzhao release (gzhao, 14:31:19)
    5. LuisGomez for Integration (LuisGomez, 14:31:23)
    6. Steve Dean for DIDM and SNMP Plugin (sdean778, 14:31:37)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings the loose agenda (colindixon, 14:32:24)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-02-25-15.31.html there were no action items from the previous meeting (colindixon, 14:32:46)
    9. Everyone please note that next Thursday (3/19) is M3 for Offset-2 project AND M4 == API Freeze for Offest-0 projects (phrobb, 14:33:42)

  2. single feature test (colindixon, 14:36:15)
    1. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 < Single Feature spreadsheet (colindixon, 14:36:23)
    2. as per the spreadsheet, it appears that aaa, capwap, controller, dlux, discovery, integration, l2switch, lacp, packetcable, plugin2oc, reservation, sdninterfaceapp, snbi, snmp4sdn, sxp, and tsdr have yet to fix their single feature test (colindixon, 14:38:18)
    3. I remind al projects the single feature test is a condition to push your features to integration repo (LuisGomez, 14:39:33)
    4. ACTION: aaa, capwap, controller, dlux, discovery, integration, l2switch, lacp, packetcable, plugin2oc, reservation, sdninterfaceapp, snbi, snmp4sdn, sxp, and tsdr projects to move to the new single feature test (colindixon, 14:39:57)
    5. https://lists.opendaylight.org/pipermail/release/2015-February/001488.html this mail gives guidelines as to how exactly to fix it, but for most projects there is already a patch waiting to be merged (colindixon, 14:40:40)

  3. topics of general concern (colindixon, 14:40:53)
    1. we have seen more and more projects in yellow status, so far, I didn't notice significant impact on depended projects (gzhao, 14:42:08)
    2. Reminder of Robot FW tutorial next TWS call (LuisGomez, 14:42:55)
    3. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the current project status (colindixon, 14:44:16)
    4. FYI on Maple, I have a meeting with the Lawyers (OpenDaylight's and Yale's) this afternoon (phrobb, 14:46:01)
    5. phrobb asks about the status of OVSDB hitting the “deprecate AD-SAL” and “add MD-SAL interface” and how that interacts with the M3 functionality freeze (colindixon, 14:46:02)
    6. ACTION: flaviof and/or dfarrell07 to figure that out since if we miss those targets it will have siginificant impact on other projects (colindixon, 14:47:00)

  4. cookies (colindixon, 14:49:07)


Meeting ended at 14:49:09 UTC (full logs).

Action items

  1. aaa, capwap, controller, dlux, discovery, integration, l2switch, lacp, packetcable, plugin2oc, reservation, sdninterfaceapp, snbi, snmp4sdn, sxp, and tsdr projects to move to the new single feature test
  2. flaviof and/or dfarrell07 to figure that out since if we miss those targets it will have siginificant impact on other projects


Action items, by person

  1. dfarrell07
    1. flaviof and/or dfarrell07 to figure that out since if we miss those targets it will have siginificant impact on other projects


People present (lines said)

  1. colindixon (37)
  2. phrobb (12)
  3. gzhao (8)
  4. dfarrell07 (7)
  5. LuisGomez (6)
  6. odl_meetbot (6)
  7. tbachman (4)
  8. sdean778 (3)


Generated by MeetBot 0.1.4.