14:30:58 <colindixon> #startmeeting weekly lithium irc sync
14:30:58 <odl_meetbot> Meeting started Wed May  6 14:30:58 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:58 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:31:05 <colindixon> #topic agenda bashing and roll call
14:31:11 <colindixon> #info colindixon for TTP, docs and TSC
14:31:19 <lori> #info lori for lispflowmapping
14:31:20 <Prem_> #info Prem for VPNService
14:31:23 <hideyuki> #info Hideyuki for VTN
14:31:24 <Shreyas_> #info shreyas for Persistence Store Service
14:31:41 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current weather with some actual points of note
14:32:15 <gzhao> #info gzhao
14:32:22 <regXboi> #info regXboi for NN
14:32:24 <colindixon> #chair gzhao phrobb tbachman
14:32:24 <odl_meetbot> Current chairs: colindixon gzhao phrobb tbachman
14:32:29 <gzhao> #info gzhao
14:32:36 <colindixon> any topics people would like to cover?
14:32:36 <tbachman> #info tbachman for GBP
14:34:03 <LuisGomez> #info LuisGomez
14:34:07 * regXboi listens to crickets
14:34:21 <colindixon> ok
14:34:28 <colindixon> #chair phrobb1
14:34:28 <odl_meetbot> Current chairs: colindixon gzhao phrobb phrobb1 tbachman
14:34:58 <zxiiro> #info Thanh
14:35:14 <colindixon> #topic weather
14:35:57 <abhijitkumbhare> #info abhijitkumbhare OF Plugin
14:36:06 <phrobb1> colindixon:  and gzhao: I won't be able to stay on this morning but wanted to make sure the meeting got started.  I'll drop off in about 10 minutes
14:36:08 <colindixon> #info there’s a link above, but right now we’ve seen a decrease in the OpenFlow plugin’s “drop test” performance because of chanign the way the notification broker works
14:36:38 <gzhao> phrobb1: ok
14:36:46 <zxiiro> I'd like to talk about bug 3124. We're stuck and I think the SFC team needs some help getting it unstuck.
14:36:47 <abhijitkumbhare> I believe Jamo has pointed that the drop may be due to a patch related to flow hash
14:36:52 <gzhao> do we have representative from SFC, there is a blocking issue from zxiiro
14:37:33 <hideyuki> zxiiro: I hope it helps https://git.opendaylight.org/gerrit/#/c/19667/
14:37:37 <colindixon> #info I’m told it shouldn’t affect actual performance of apps other than the drop test, and it should be resolved by adding threading to the drop test instead of relying on the MD-SAL to provide the threads
14:37:55 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Switch_to_Lithium_Notification_Broker this is the link to the real root cause
14:38:46 <colindixon> #topic SFC issues causing breakage in auto-release
14:38:52 <ttkacik1> #info ttkacik for yangtools / controller
14:38:54 <abhijitkumbhare> We have an OF Plugin bug scrub meeting in an hour and half - we will discuss this in more detail - but for now whatever colindixon info'ed is fine
14:39:22 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3124 the bug in question
14:39:33 <zxiiro> hideyuki: thanks' i hadn't seen it but ifi t works it'll unblock us
14:39:48 <colindixon> zxiiro: I don’t think we have people on the call from sfc but we still spend a few minutes on it and #action something
14:40:09 <colindixon> has sfc been interactive around fixing it?
14:40:41 <abhijitkumbhare> pinging brady
14:40:52 <hideyuki> zxiiro: It seems to me that munge-maven-plugin is not used by sfcof12, but sfcof12 has the dependency munge-maven-plugin.
14:40:52 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/19667/ gerrit from hideyuki that may fix the issue
14:40:59 <zxiiro> colindixon: they have before the hackathon until they got stuck. at this point i think they don't know how to fix it. but hideyuki's patch seems to fix it so we might have a fix
14:41:21 <tbachman> #info colindixon asks if SFC has been interactive in fixing the bug
14:41:26 <zxiiro> colindixon: we should action SFC to test hideyuki's patch https://git.opendaylight.org/gerrit/#/c/19667/
14:41:29 <colindixon> #info zxiiro says the above patch from hideyuki may fix the issue
14:41:38 <abhijitkumbhare> Brady is joining
14:41:56 <colindixon> abhijitkumbhare: ok
14:42:07 <ebrjohn> Hello, Brady from SFC here
14:42:08 <abhijitkumbhare> welcome ebrjohn
14:42:32 <colindixon> #action ebrjohn to look at patch https://git.opendaylight.org/gerrit/#/c/19667/ to see if it resolves the auto-release issues
14:42:44 <tbachman> ebrjohn: just in time to be actioned ;)
14:42:49 <ebrjohn> Looking now
14:42:58 <colindixon> ebrjohn: you can look at the logs here: https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-05-06-14.30.log.txt
14:43:04 <gzhao> zxiiro: hideyuki  I updated the spreadsheet <==https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675
14:43:14 <colindixon> zxiiro: do you want to cover anything else here?
14:43:21 <zxiiro> colindixon: no that's all from me
14:43:22 <ebrjohn> Yes, I saw the patch come in, but it has the following in the comments: "DO NOT MERGER"
14:43:31 <hideyuki> colindixon: No from me.
14:43:40 <colindixon> ebrjohn: my suggestion it to work with hideyuki and zxiiro to see if we can make it work
14:43:48 <ebrjohn> ok, sounds good
14:44:04 <ebrjohn> hideyuki: any reason it still has that in the comments?
14:44:05 <colindixon> #topic upcoming deadlines
14:44:23 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Schedule the lithium schedule
14:44:49 <hideyuki> ebrjohn: I would like to check if sfcof12 uses munge-maven-plugin or not.
14:45:21 <colindixon> #info code freeze (and supposedly final draft docs) have passed for offset-0 and offset-1
14:45:27 <hideyuki> ebrjohn: After I check it and get the answer from the SFC project, I would like to remove "DO NOT MERGE" from the comment.
14:45:31 <colindixon> #inod code freeze for offset-2 is a week from tomorrow
14:45:45 <colindixon> #Info code freeze for offset-2 is a week from tomorrow
14:45:48 <ebrjohn> Ok, Im not sure if we use the munge-maven-plugin
14:46:15 <ttkacik> I would question why java preprocessor is needed...
14:46:23 <gzhao> #info reminder email sent to 4 offset1 projects yesterday, still waiting for 3  offset 1projects to respond for M5
14:46:23 <anipbu> #info anipbu for usc
14:47:07 <colindixon> gzhao: anything else you wanted to add before I link in the blocking bugs spreadsheet?
14:47:16 <hideyuki> ebrjohn: I checked some files of the SFC project. It seems to me that the sfcof12 does not use the munge-maven-plugin.
14:47:21 <colindixon> #topic tracking blocking bugs
14:47:53 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 gzhao has created a tab in the main lithium project status sheet for tracking blocking bugs
14:48:16 <ebrjohn> hideyuki: ok, it should be ok to remove it then
14:48:21 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Project_Status the sheet (not that tab) is also linked to from the Lithium release page here
14:48:37 <hideyuki> ebrjohn: Ok, so I'll remove the "DO NOT MERGE"
14:48:49 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Blocking_Bugs that tab is also directly embedded in the weather page here
14:48:51 <ebrjohn> ok, and I'll merge the patch
14:49:33 <gzhao> Daniel put colindixon's steps into wiki,  do we have a link for that
14:50:05 <colindixon> #info the spreadsheet is gonig to be considered ground truth for tracking and working on blocking bugs for Lithium, but make sure bugs, but use mailing lists, IRC, bug comments, etc. to document and work on things
14:50:42 <colindixon> gzhao: they’re listed on that last link
14:51:02 <gzhao> colindixon: cool, thanks
14:51:18 <colindixon> other topics?
14:51:26 <colindixon> anyone?
14:51:27 <gzhao> #link https://lists.opendaylight.org/pipermail/release/2015-May/002177.html <== steps
14:51:31 <gzhao> just in case
14:51:37 <colindixon> going once
14:51:41 * colindixon counts to 10 slowly
14:52:15 <colindixon> going twice
14:52:20 * colindixon counts to 10 slowly
14:52:22 * regXboi waits for the closing topic
14:52:37 <colindixon> gone
14:52:40 <colindixon> #topic cookies
14:52:43 <colindixon> #endmeeting