14:30:36 <colindixon> #startmeeting weekly lithium irc sync
14:30:36 <odl_meetbot> Meeting started Wed May 13 14:30:36 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:36 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:30:41 <colindixon> #topic agenda bashing
14:30:45 <Prem> #info Prem for VPNService
14:30:58 <regXboi> #info regXboi for NN
14:31:05 <colindixon> #info colindixon for TTP, TSC and docs
14:31:19 <gzhao> #info gzhao for release, USC
14:31:28 <lori> #info lori for lispflowmapping
14:31:30 <Prem> colindixon:  Could you approve the VPN Service docs.  Thanks!
14:31:36 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings the (out-of-date) agenda in it’s usual place
14:31:52 <colindixon> Prem: yeah, I’m in a huge backlog of docs, but I’m trying
14:31:56 <zxiiro> #info Thanh
14:32:38 <Prem> colindixon:  Fine. No issues. Will wait for the turn :)
14:32:43 <odl-casey> #info odl-casey
14:32:47 <hideyuki> #inof Hideyuki for VTN
14:32:54 <LuisGomez1> #info LuisGomez1 for integration
14:32:57 <hideyuki> #info Hideyuki for VTN
14:33:41 <jburns> #info jburns for iotdm
14:34:07 <colindixon> ok, so the basic strategy here is that it’s open mic session
14:34:16 <colindixon> anyone with burning cross-project topics bring them up
14:34:30 <colindixon> the obvious one I have is that it’s M5 for offset 2 projects
14:34:39 <colindixon> and I wanted to talk a bit about branch cutting
14:34:44 <colindixon> who else has topics?
14:35:09 <colindixon> Prem: I know I’m behind and I apologize :-)
14:35:13 <zxiiro> just an FYI, that openflowplugin version bumping is currently blocking all projects they depend on from proceeding
14:35:41 <abhijitkumbhare> #info abhijitkumbhare OpenFlow plugin
14:36:40 <colindixon> zxiiro: meet abhijitkumbhare, abhijitkumbhare meet zxiiro
14:36:45 <gzhao> zxiiro: abhijitkumbhare: said Michal will have it done yesterday.
14:36:48 <abhijitkumbhare> michal_rehak mentioned that this was waiting for:
14:36:50 <abhijitkumbhare> Current status is that on master we need to fix ipv6prefix validation issues which got visible after bumping of yangtools. In order to prevent squashing bump with fix we first need to catch all ipv6 related issues and then we can bump. Also it looks like dlux has already bumped so we do not need to do bumping fix.
14:36:52 * colindixon points to the first statement
14:37:10 <colindixon> any ohter topics people want to bring up?
14:37:12 <colindixon> anything at all
14:37:21 <colindixon> #topic M5 milestone
14:37:42 <colindixon> #info the M5 status is due *tomorrow* for offset 2 projects and that will mean the whole project is code frozen with only bug fixes
14:38:11 <colindixon> #info as part of that you should cut a stable/lithium branch for your bug fixes, zxiiro has instructions on how to do that
14:38:22 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Cutting_Stability_Branches the instructions are here
14:38:41 <tonytkacik> colindixon -  does thay means no new tutorials could be added to coretutorials?
14:38:53 <colindixon> #info after you’ve cut your branch, you’ll bump versions on the master branch to keep the two from interfering with each other
14:39:07 <gzhao> #info snmp4sdn and snbi M5 status are two weeks overdue
14:39:11 <colindixon> tonytkacik: I’m not actually sure what the status fo coretutorials is
14:40:05 <colindixon> tonytkacik: there hasn’t been a milestone readout from that project since M2
14:40:08 <colindixon> :-(
14:40:22 <colindixon> if they chose to drop out of the release that might make things easier
14:40:22 <tonytkacik> I see
14:40:47 <colindixon> and would allow you to make changes, but they wouldn’t be shipped with the release download, but my guess is that would be fine
14:41:10 <tonytkacik> Thay arent bundling anything in integration
14:41:25 <colindixon> yeah
14:41:32 <tonytkacik> Since mostly they are hosting tutorials and samples for lithium code
14:41:44 <colindixon> so, then there’s no reason for them to officially be part of the release really, and code freeze wouldn’t apply
14:41:47 <colindixon> but that’s up to them
14:42:02 <LuisGomez1> we plan to use 1 coretutorials feature or DS benchmark
14:42:11 <tonytkacik> Note to self: beryllium should have section about docs-like projects
14:42:12 <colindixon> #info after you’ve bumped versions on the master branch you can do whatever development you want on master
14:42:27 <LuisGomez1> but we can hide the feature
14:42:46 <colindixon> #info bug fixes should go to stable/lithium (and in 99% of the cases also be cherry-picked to master)
14:43:01 <colindixon> #topic coretutorials
14:43:15 <colindixon> #info tonytkacik asks if coretutorials will be able to add new tutorials after code freeze
14:43:48 <colindixon> #info there’s some discussion on whether they should be in the release, and leaving might make that easier since the rules wouldn’t apply, but LuisGomez1 says they ahve one feature used in integration for a DS benchmark
14:43:56 <lori> route -n
14:44:02 <colindixon> lori: wrong window :p
14:44:11 <lori> colindixon: yeap, sorry
14:44:33 <colindixon> #action colindixon to try to add some stuff to beryllium for docs-like projects
14:45:03 <colindixon> #action colindixon, gzhao, and phrobb to work with core tuorials to figure out what needs to happen
14:45:08 <colindixon> ok, other topics?
14:45:18 <tonytkacik> colindixon : also we should consider allowing project-specific guided outside docs
14:45:39 <colindixon> tonytkacik: I’m not sure I follwed that
14:45:54 <colindixon> tonytkacik: do we have the list of “easy” bugs for controller and yangtools
14:45:57 <phrobb1> tonytkacik:  me neither, could you elaborate?
14:46:03 <tonytkacik> That is for longer discussion
14:46:18 <tonytkacik> Should be in meeting minutes from md-sal weekly
14:46:34 <colindixon> #action tonytkacik to send mail to the list (or phrobb and colindixon) about different docs in Beryllium
14:46:53 <colindixon> #topic bugs in key projects
14:47:12 <colindixon> #info at the MD-SAL weekly interest call we tried to find simple bugs during the bug scrub
14:47:30 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-05-12-16.07.html easy bugs for controller and yangtools are listed here undr “4. bug scrub”
14:47:53 <colindixon> #info if anyone wants to help fix bugs deep in ODL infrastructure for everyone in Lithium, this is the time and place
14:48:00 <abhijitkumbhare> Hi zxiiro, colindixon - michal_rehak has just joined for a minute or two - to discuss the branch creation/version bumping
14:48:18 <colindixon> #info tonytkacik has volunteered to mentor help, so it’s a great opportunity to get involved
14:48:21 <colindixon> sure
14:48:32 <colindixon> #topic branch cutting/version bumping
14:48:39 <colindixon> abhijitkumbhare, michal_rehak, the floor is yours
14:48:44 <abhijitkumbhare> He has a thought regarding branch creation
14:49:22 <abhijitkumbhare> Since the OpenFlow plugin version bump depends on the IPv6 fix
14:49:30 <abhijitkumbhare> it will take end of the week
14:50:02 <abhijitkumbhare> he is suggesting:
14:50:13 <abhijitkumbhare> may be faster to drop the branch and recreate it as soon as we have master ready"
14:51:06 <zxiiro> can we not version bump and then port the fix to both master and stable/lithium at the same time?
14:51:21 <zxiiro> as far as I understand that's what most projects are doing
14:51:41 <ttkacik> zxiiro: yangtools merged fix for bug 3051 on master
14:52:06 <abhijitkumbhare> michal_rehak - do you have thoughts on zxiiro 's question?
14:52:07 <ttkacik> which will prevent bumping without fixing Ipv6 fix
14:52:23 <colindixon> #info there is discussion about cutting the openflowplugin branch and a dependency on an IPv6 fix to bump versions
14:52:32 <ttkacik> which efectivelly means after bump OFplugin will not pass unit tests
14:52:38 <zxiiro> ttkacik: oh ok, that would mean yangtools has to also cherry-pick to lithium though does it not?
14:52:49 <ttkacik> cherry-pick is there
14:52:55 <ttkacik> but we did not merged it yet
14:52:57 <colindixon> #action ttkacik, abhijitkumbhare, michal_rehak, and zxiiro to work on getting openflowplugin unstuck
14:53:02 <zxiiro> ttkacik: gotcha
14:53:05 <ttkacik> in order to wait for downstream to fix that
14:53:54 <ttkacik> zxiiro: practically same issue as bumping controller after checkstyle was upgraded
14:54:35 <zxiiro> understood. i guess all we can do is wait for now...
14:54:35 <gzhao> I have a question regarding code that is not part of the controller,  e.g. agent code, can it just be RPM format, or should have src code with make file ?
14:54:55 <colindixon> so, it sounds like we understand what needs to happen and either (a) we will be without master for a bit or (b) we’ll have to figure out some better way to unblock things
14:55:06 <ttkacik> other suspsects which will require Ipv6 fix: ovsdb,gbp
14:55:19 <colindixon> gzhao: good question, hideyuki how does VTN do it?
14:55:42 <hideyuki> gzhao: What do you mean?
14:56:18 <gzhao> hideyuki: for VTN, it will be coordinator part, it is not part of the controller but shipped with ODL release
14:56:32 <hideyuki> gzhao: Yes.
14:56:50 <gzhao> hideyuki: do you check in VTN coordinator C or C++ code?
14:57:10 <gzhao> hideyuki: or just RPM
14:57:23 <hideyuki> gzhao: Yes. the vtn.git has its C/C++ source code.
14:57:43 <LuisGomez1> i guess michal question is also why you need to branch if you know bump is going to be delayed? it seems it only adds the burden of cherry-picking all patches
14:57:44 <abhijitkumbhare> colindixon, I guess from what ttkacik, zxiiro & michal_rehak are saying - it may be better to wait for the IPv6 fix before the version bump - but that will delay the version bump for dependent projects past M5
14:57:53 <gzhao> hideyuki: thanks, I think so does opflex agent code.
14:58:52 <colindixon> abhijitkumbhare: ugh, noted
14:59:12 <gzhao> abhijitkumbhare: will that delay all offset 2?
14:59:15 <abhijitkumbhare> and that it may affect OVSDB & GBP as well
14:59:28 <colindixon> #info it seems like master for projects dependent on openflowplugin is going to be blocked for a while while the IPv6 fix is worked out (the IPv6 issues may affect OVSDB and GBP)
14:59:39 <abhijitkumbhare> I guess all dependent projects
14:59:49 <colindixon> this is because of a change in yangtools?
14:59:58 <regXboi> colindixon: for the minutes - is there a #link for "the IPv6 issues"?
15:00:12 <ttkacik> colindixon: yes
15:01:18 <colindixon> #info colindixon notes that in beryllium we should try to avoid this issue (changes happening in upstream projects before you cut your branch making your version bump impossible), possibly by cutting branches all the same time
15:01:18 <regXboi> ah I see the statement from abhijitkumbhare, but it's only text, not #info'd
15:01:28 <ttkacik> https://lists.opendaylight.org/pipermail/controller-dev/2015-April/009149.html
15:01:44 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-April/009149.html the IPv6 issue at hand :-/
15:01:45 <colindixon> ok
15:01:49 <colindixon> we’re past the top of the hour
15:01:53 <colindixon> any last minute things?
15:01:58 <colindixon> I don’t think we’re going to resolve this issue today
15:02:10 <abhijitkumbhare> colindixon - that info statement may be "it seems like master for projects dependent on openflowplugin, ovsdb  (probably) & gbp (probably) is going to be blocked for a while while the IPv6 fix is worked out"
15:02:14 <colindixon> it may just block branch cutting for a while
15:02:19 <zxiiro> FYI I recently started scanning projects for dependencies https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-daily-master/lastFailedBuild/artifact/dependencies.log
15:02:21 <ttkacik> last-option is revert on yangtools but would rather avoid that
15:02:30 <gzhao> should add this to blocking issue spreadsheet
15:02:48 <colindixon> gzhao: it’s technically not blocking lithium
15:02:49 <zxiiro> not sure how useful this script is yet and i probably have to make some tweaks but it produces a dependency list between odl projects based on what all their pom.xml files say
15:02:50 <ttkacik> zxiiro: yangtools should list odlparent there
15:03:11 <LuisGomez1> colindixon: +1 to have faster branch+bump in berylium
15:03:17 <zxiiro> ttkacik: yes that's a issue with the script, it currently doesn't scan <parent> sections, it only scans <dependencies>
15:03:36 <colindixon> people can still cut lithium branches, it’s just they won’t be able to version bump on master and thus shouldn’t really push any patches there
15:03:41 <ttkacik> ok...so next thing is...why odlparent has dependency on controller :)
15:04:26 <colindixon> ok, any last minute topics, it sounds like this yangtools/ofplugin issue is going to need some more offline attention and some thinking in beryllium
15:04:28 <ttkacik> zxiiro: where is that script available?
15:04:50 <colindixon> #action colindixon to add a discussion of how to avoid branch cutting delay in Beryllium
15:05:07 <colindixon> #topic deependency tracking
15:05:08 <zxiiro> ttkacik: https://git.opendaylight.org/gerrit/gitweb?p=releng/autorelease.git;a=blob;f=scripts/list-project-dependencies.sh;h=4faaa9860bf5459a06ce00a34571d3fe3914f0cc;hb=HEAD
15:05:20 <colindixon> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-daily-master/lastFailedBuild/artifact/dependencies.log zxiiro wrote a script to track dependencies
15:05:33 <colindixon> #link https://git.opendaylight.org/gerrit/gitweb?p=releng/autorelease.git;a=blob;f=scripts/list-project-dependencies.sh;h=4faaa9860bf5459a06ce00a34571d3fe3914f0cc;hb=HEAD the script is here
15:05:37 <colindixon> any last minute topics
15:05:38 <colindixon> ?
15:05:59 <colindixon> going once
15:06:45 <zxiiro> ttkacik: seems like a bug somewhere, i dont' see controller in anyi pom files in odlparent when i grep it's repo
15:07:09 <ttkacik> also: coretutorials:controller,dlux,odlparent,toaster,yangtools
15:07:15 <ttkacik> there is no such toaster project
15:07:53 <colindixon> gone
15:07:57 <colindixon> thanks folks
15:08:01 <colindixon> #topic cookies
15:08:05 <LuisGomez1> thanks
15:08:07 <colindixon> #endmeeting