14:30:50 <colindixon> #startmeeting weekly lithium irc sync
14:30:50 <odl_meetbot> Meeting started Wed May 20 14:30:50 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:50 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:50 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:30:51 <colindixon> #topic agenda items and roll call
14:31:00 <colindixon> #info colindixon for TSC, docs and TTP
14:31:08 <Prem> #info Prem for VPNService
14:31:10 <zxiiro> #info Thanh releng
14:31:21 <colindixon> #chair edwarnicke dfarrell07 tbachman alagalah gzhao zxiiro phrobb
14:31:21 <odl_meetbot> Current chairs: alagalah colindixon dfarrell07 edwarnicke gzhao phrobb tbachman zxiiro
14:31:25 <LuisGomez> #info LuisGomez integration
14:31:29 <colindixon> so, topics?
14:31:43 <tbachman> neutron NB breakage?
14:31:45 <alagalah> #info here
14:31:53 * alagalah What he said
14:31:56 <tbachman> lol
14:32:09 <hideyuki> #info Hideyuki for VTN
14:32:17 <tbachman> colindixon: still in Vancouver?
14:32:18 <anipbu> #info anipbu for usc
14:32:24 <alagalah> #info alagalah for GBP
14:32:44 <colindixon> tbachman: yup
14:32:52 * tbachman waves to phrobb1, who is also probably still up North
14:32:53 <colindixon> ok
14:32:56 <colindixon> let’s get started
14:33:03 <colindixon> #topic neutron northbound breakage
14:33:06 <phrobb1> howdy tbachman
14:33:13 <tbachman> phrobb1:  hi! :)
14:33:14 <alagalah> Where would you like me to start ?
14:33:33 <alagalah> Shall I #info my views ???
14:33:35 <colindixon> #chair phrobb1
14:33:35 <odl_meetbot> Current chairs: alagalah colindixon dfarrell07 edwarnicke gzhao phrobb phrobb1 tbachman zxiiro
14:33:41 <colindixon> alagalah: sure
14:33:47 <colindixon> I can always #undo if they get bad :p
14:34:00 <colindixon> do we have regXboi or edwarnicke or vishnoianil_ ?
14:34:00 <alagalah> #info late yesterday afternoon saw issues with CDS borks when writing to OVSDB....
14:34:04 <tbachman> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-May/009400.html Email to lists, reporting breakage
14:34:20 <alagalah> #info Backed out yangtools to May15 (pre 5 patches on the same bug) and was able to continue
14:34:50 <alagalah> #info later that night, was testing a patch for "fixedIPs" in neutron stable/ lithium, and was able to test, prove patch, but then found next fault (approx 9pm) and emailed Ed
14:35:15 <alagalah> #info at midnight, Ed had another patch for me to fix next fixedIPs issue and it was at that time I saw "Activator" problems (ie couldn't load feature)
14:35:40 <alagalah> #info I discovered that -DskipTests can sometimes be evil, and that NEutron was borking on various UTs
14:36:04 <colindixon> alagalah: OK and where are we now?
14:36:13 <colindixon> alagalah: and thank you for pushing through all of that
14:36:19 <alagalah> #info at same time yangtools/controller were also fixing issues, so it was a matter of "do I wait?" "try this?" but results in 5-6 hours of playing fetch me a rock with yangtools, controller, neutron and my m2
14:36:35 <vishnoianil_> yes
14:36:36 <tbachman> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-May/009401.html email from rovarga, asking edwarnicke if the problem was a commit he made
14:36:39 <alagalah> #info Last status is I sent my SureFire reports to controller-dev, yangtool-dev, neutron-dev and...
14:37:00 <alagalah> #info rovarga has replied with "something got taken out of neutron around Activator"
14:37:02 <vishnoianil_> #info vishnoianil_
14:37:09 <alagalah> (it was more elequent than that but you get the idea)
14:37:15 <alagalah> ...and thats been my morning :D
14:37:22 <alagalah> Who's next for show n tell ?
14:37:36 <colindixon> alagalah: noted, so is there anything that needs to be done to help?
14:37:57 <alagalah> colindixon: I have texted Ed, I believe Ryan is on PTO and maybe driving... Flavio is up in Vancouver as is Ed
14:38:00 <colindixon> or are we sort of just blundering into the next issue repeated and making frustringly slow progress, but still progress
14:38:07 <colindixon> alagalah: and me, sadly
14:38:11 <alagalah> colindixon: I do not know of any other active Neutron committers (they may exist, I do not know them)
14:38:18 <colindixon> hence I pinged vishnoianil_ since I think knows the Neutron code a bit
14:38:46 <colindixon> but he’s not a committer as far as I can tell
14:38:50 <alagalah> colindixon: blundering isn't quite right, but "moving ground" sums it up
14:39:04 <vishnoianil_> colindixon, i didn't poke int to neutron code yet, as we still struggling with the yangtoolks issue
14:39:11 <alagalah> colindixon: if vishnoianil_ can solve it, and you are committer... there's a path and I can test
14:39:17 <colindixon> #action colindixon to find flaviof or edwarnicke in Vancover and see if he can get them to look at NN for a bit
14:39:44 <colindixon> I’ll do my best
14:39:50 <alagalah> colindixon: As do we all
14:39:56 <colindixon> ok, more topics?
14:40:32 <colindixon> #topic cutting RC0
14:40:48 <colindixon> zxiiro: do you know where we are in figuring out to get this?
14:40:48 <LuisGomez> are all these issues reported as blocking already?
14:41:00 <vishnoianil_> i believe ovsdb is using master branch of neutron, so we are not broken from neutron side
14:41:06 <zxiiro> colindixon: I do not other than we are still wiating on openflowplugin
14:41:40 <zxiiro> it's holding everything up at the moment :(
14:41:48 <colindixon> #info zxiiro says we are still waiting on openflowplugin to cut branches to start the lithium auto-release
14:42:11 <colindixon> so, openflowplugin ought to be able to cut stable/lithium, it will just block master until they fix the issue, right?
14:42:33 <colindixon> LuisGomez: good question, alagalah and tbachman did you file a blocking bug on the spreadsheet?
14:42:48 <tbachman> colindixon: I haven’t
14:42:53 <alagalah> colindixon: For which one ?
14:42:55 <zxiiro> no because even lithium depends on a patch for yangtools into lithium which i'm not sure is merged yet?
14:42:58 <alagalah> colindixon: Or all of them ?
14:43:04 <colindixon> do you have a bug?
14:43:22 <colindixon> well, I would say if you’re blocking on something for longer and a few hours, it makes sense to enter a line here: https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675
14:43:31 <colindixon> longer than
14:43:31 <alagalah> colindixon: hold 1
14:43:38 <zxiiro> my understanding is that there were multiple patches that needed to be merged at the same time as it breaks code
14:43:58 <colindixon> ugh
14:44:20 <ttkacik> zxiiro patch to yangtools does not to be merged
14:44:32 <alagalah> zxiiro: colindixon Ack... it would be disingenous of me to point at https://bugs.opendaylight.org/show_bug.cgi?id=3283 since I could have tested this at midnight last night... but ... chaos ensued
14:44:34 <ttkacik> In order for openflowplugin to fix their side
14:44:56 <zxiiro> ttkacik: oh ok
14:44:58 <colindixon> vishnoianil_: I’m assuming you’re heads down on trying to unblock openflowplugin
14:45:03 <colindixon> do we havea bug to track this?
14:45:33 <colindixon> ALSO, OTHERS PLEASE BRING UP TOPICS IF YOU HAVE THEM
14:45:39 <ttkacik1> merging yangtools patch will "only" result in IllegalARgumentExceptions when incorrect value is passed arround
14:46:01 <alagalah> colindixon: updated spreadsheet
14:46:05 <colindixon> ttkacik, zxiiro: do we have a bug for “openflowplugin can’t version bump"
14:46:08 <colindixon> alagalah: I see it
14:46:09 <ttkacik1> and on master where this patch is present we can see places where the incorrect values are passed arounds
14:47:06 <zxiiro> colindixon: i'm not aware of one but i can create one this morning if one isn't already there
14:47:36 <colindixon> #action zxiiro to create a bug to track the inability of openflowplugin to cut stable/lithium and put it on the blocking bugs list
14:48:13 <colindixon> #info it sounds like it make be the case that openflow plugin could cut stable/lithium it’s just that it would block master after that because you would *have* to immediately version bump, but that might be better than being unable to cut RC0
14:49:02 <colindixon> zxiiro: it might make sense to have two bugs: one that is can’t cut stable/lithium and another that is can’t bump master versions
14:49:17 <zxiiro> colindixon: ok
14:50:31 <colindixon> ttkacik: so, I *think* we could cut openflowplugin over to stable/lithium and still have things “work” except that we wouldn’t be able to version bump master, which effectively means master would be stopped until we could create one single mega-patch to fix the issue and version bump
14:50:32 <colindixon> is that right?
14:51:03 <ttkacik1> right
14:51:10 <ttkacik1> I do not believe single megapatch
14:51:26 <ttkacik1> but probably this https://git.opendaylight.org/gerrit/#/c/20704/
14:51:34 <ttkacik1> but not sure if it is sufficient
14:51:39 <phrobb1> colindixon:  is that the question for the Release list and the TSC?… Do we block on cutting Stable Lithium and RC0 or do we block on master/Beryllium new dev while the IPv6 bug hunt is on?
14:52:39 <colindixon> phrobb1, zxiiro: the other qusetion is could we buld RC0 using master from OpenFlow Plugin
14:52:56 <colindixon> #action colindixon to try to lay out the current problem and paths forward on the release/TSC mailing list
14:52:59 <colindixon> #undo
14:52:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1c19090>
14:53:06 <zxiiro> colindixon: we could as long as the versions line up properly
14:53:08 <colindixon> #action colindixon to try to lay out the current problem with openflowplugin and paths forward on the release/TSC mailing list
14:53:17 <colindixon> zxiiro: noted
14:53:19 <colindixon> ok
14:53:36 <colindixon> I think this needs to move to the mailing lists where openflowplugin people are
14:53:42 <colindixon> other topics?
14:55:05 <colindixon> going once
14:55:10 <colindixon> going twice
14:55:16 <colindixon> gone
14:55:19 <colindixon> #topic cookies
14:55:24 <colindixon> #endmeeting