14:29:25 <colindixon> #startmeeting weekly lithium IRC sync
14:29:25 <odl_meetbot> Meeting started Wed May 27 14:29:25 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:29:25 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:25 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:29:35 <colindixon> #topic roll call and agenda bashing
14:29:52 <colindixon> #info colindixon for TSC, TTPs and docs
14:30:58 <Prem> #info Prem for VPNService
14:31:08 <ttkacik> #info ttkacik for controller and yangtoools
14:31:15 <hideyuki> #info Hideyuki for VTN
14:31:17 <odl-casey> #info Casey Cain for ODL
14:31:44 <tbachman> #info tbachman for Group Based Policy
14:31:52 <abhijitkumbhare> #info abhijitkumbhare  for OpenFlow Plugin
14:31:55 <colindixon> please as for any topics
14:32:02 <tbachman> odl-casey: for all of ODL :)
14:32:07 <tbachman> FTW!
14:32:11 <colindixon> please ask for any topics people want to bring up
14:32:20 <colindixon> #chair gzhao tbachman phrobb
14:32:20 <odl_meetbot> Current chairs: colindixon gzhao phrobb tbachman
14:32:41 <tbachman> RC0 logistics/
14:32:43 <LuisGomez1> #info LuisGomez1 integration
14:32:54 <colindixon> tbachman: noted
14:33:38 <abhijitkumbhare> We have cut the OpenFlow plugin branch yesterday
14:34:28 <abhijitkumbhare> This points to the Yangtools without the IPv6 prefix change
14:34:39 <colindixon> #topic RC0 and branch cutting
14:34:43 * tbachman hopes abhijitkumbhare doesn’t say “old"
14:34:49 <abhijitkumbhare> no :)
14:34:50 <tbachman> ;)
14:34:55 <abhijitkumbhare> avoided it tbachman
14:34:58 <tbachman> lol
14:35:02 <colindixon> #info abhijitkumbhare says that openflow plugin cut their stable/lithium branch yesterday
14:35:13 <colindixon> #info that means we can start to try to cut RC0 today
14:35:27 <Prem> colindixon: Any change to the RCx dates or we will continue to have the original planned dates
14:35:48 <LuisGomez1> ofplugin bumped master version too?
14:35:53 <tbachman> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2015-May/003170.html email from michal_rehak on branch cut
14:35:55 <abhijitkumbhare> #info abhijitkumbhare says openflow plugin points to the version of yangtools without the IPv6 prefix change
14:36:06 <colindixon> #info zxiiro said he was going to work on cuttong RC0 today
14:36:17 <colindixon> Prem: I think the plan is to try to keep the dates the same
14:36:29 <tbachman> RC0 is 28th, riht?
14:36:37 <tbachman> (i.e. zxiiro is just prepping/testing for cut)
14:36:48 <Prem> colindixon: ok. Thanks!
14:36:48 <colindixon> #link https://www.timeanddate.com/countdown/generic?iso=20150528T235959&p0=1440&msg=Lithium+RC0+Build+Start
14:37:05 <colindixon> so, cutting RC0 in ~33.5 hours
14:37:05 <tbachman> nice :)
14:37:06 <colindixon> I think
14:37:23 <colindixon> anything else on this topic?
14:38:15 <colindixon> #topic blocking bugs
14:38:58 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 the blocking bugs spreadsheet
14:39:14 <colindixon> #info please add any blocking bugs here and we’ll try to track it
14:41:27 <colindixon> ok
14:41:28 <abhijitkumbhare> For https://bugs.opendaylight.org/show_bug.cgi?id=3341 - looks like there is a patch by ttkacik out for review: https://git.opendaylight.org/gerrit/#/c/19607/
14:41:50 <colindixon> can we add that to the sheet?
14:42:33 <abhijitkumbhare> Sure
14:42:38 <abhijitkumbhare> I will add it
14:42:41 <colindixon> #action abhijitkumbhare to update the entries fro openflowplugin in the blocking bug sheet, I think we have patches for 3305 and 3341, it’s unclear about 3306 since they’re still using the Lithium versions of yangtools
14:43:07 <hideyuki> #info I plan to add bug 3344 as a blocking bug to the spreadsheet. https://bugs.opendaylight.org/show_bug.cgi?id=3344
14:43:27 <colindixon> #info the remainting bugs are against iotdm for blocking autorelease, and neutron/ovsdb for issues blockg GBP
14:43:32 <colindixon> hideyuki: thanks
14:44:08 <colindixon> anything else here?
14:44:17 <hideyuki> #info Due to the Bug 3344, VTN Manager does not work correctly. ttkacik (Tony) is working on that.
14:45:00 <colindixon> #topic 3rd party sources
14:45:16 <colindixon> #info odl-casey has been trying round up the source code for our 3rd party dependenceis
14:45:24 <colindixon> odl-casey: do you have the link to the spreadsheet?
14:45:27 <colindixon> is there a new one?
14:45:28 <odl-casey> https://docs.google.com/spreadsheets/d/1q_vxUjo4gIxpyAGq43Yiu77o1GHdLaSlxVMysd6G5bQ/edit?usp=sharing
14:45:50 <ttkacik> Bug 3341 will probably require some changes also in Openflowplugin
14:46:00 <ttkacik> separate from controller
14:46:12 <ttkacik> will try to have OF plugin patch ready tommorow
14:46:21 <odl-casey> Thanh and I are working on this, but if anyone has a second to verify that the work is complete... Please check any 3rd party plugins that you use have source.
14:46:33 <hideyuki> ttkacik: Thanks a lot!!!!
14:46:54 <hideyuki> ttkacik: Oh, that is about 3341.
14:47:09 <colindixon> #link https://docs.google.com/spreadsheets/d/1q_vxUjo4gIxpyAGq43Yiu77o1GHdLaSlxVMysd6G5bQ/edit?usp=sharing this is the list of 3rd-party dependenceis which we’re still looking for source jars for
14:47:11 <ttkacik> hideyuki: still trying to figure out yours
14:47:20 <hideyuki> ttkacik: Thanks again.
14:47:27 <colindixon> any other topics today?
14:47:56 <hideyuki> colindixon:  I would like to know the status of version bumps for Beryllium.
14:48:10 <colindixon> I know that there are a lot of bugs in yangtools and controller which those teams would like help with, if you’re interested in helping, please either come to the MD-SAL weekly interest call or read the minutes
14:48:28 <hideyuki> colindixon: Do we have a spareadsheet which shows the status of version bumps for all projects?
14:48:28 <colindixon> #topic version bumps on master for Beryllium development
14:48:46 <colindixon> gzhao, zxiiro: do we have any updates on this?
14:48:50 <colindixon> I think they’re not around
14:49:11 <hideyuki> ok.
14:49:12 <colindixon> #info hideyuki asks if we have a way we’re tracking who has bumped their versions on master
14:49:53 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1592977660 it is supposedly tracked in column F of this sreadhseet tab based on the M5 readout
14:50:56 <colindixon> #info based on what abhijitkumbhare said, it might still be dangerous for projects using openflowplugin to do a version bump becuase I think openflowplugin is still using the lithium versions of yangtools, so a normal version bump will result in a skew between the versions of yangtools that are used
14:51:22 <hideyuki> colindixon: I see.
14:51:46 <hideyuki> colindixon: So should a project which depends on of plugin project stop to version bumps for Beryllium?
14:52:04 <colindixon> #action zxiiro and abhijitkumbhare to touch base to figure out if it’s safe for projects downstream of openflowplugin to bump their versions, for now, I’d recommend not
14:52:13 <abhijitkumbhare> Yes
14:52:34 <abhijitkumbhare> It is what colindixon says as per my understanding
14:52:40 <hideyuki> I see.
14:52:56 <hideyuki> Do we have ETA for version bumps of of plugin project?
14:53:06 <colindixon> hideyuki: I mean, we can fix things later, so if you want to try, go ahead, but it might be better to wait if you don’t *need* to do the version bump
14:53:10 <colindixon> abhijitkumbhare?
14:53:18 <abhijitkumbhare> Not yet
14:53:30 <hideyuki> abhijitkumbhare: Ok. Thanks.
14:53:31 <colindixon> #info hideyuki asks if there’s an ETA for a version bump in openflowplugin, abhijitkumbhare says not yet
14:53:52 <colindixon> #topic bug fixing in yangtools and controller
14:54:28 <colindixon> #info if there are broader community members interested in getting involved in fixing bugs in the key parts of ODL, please come to the MD-SAL weekly interest calls where we’ve been doing bug scrubbing and finding bugs which are “easy” with mentoring to fix them
14:54:44 <colindixon> #link https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call more information on when the meetings are and old minutes here
14:54:54 <colindixon> any other topics?
14:56:06 <colindixon> going once
14:56:12 * colindixon counts to 10
14:56:18 <colindixon> going twice
14:56:21 * colindixon counts to 10
14:56:34 <colindixon> gone
14:56:37 <colindixon> #topic cookies
14:56:40 <colindixon> #endmeeting