14:30:24 <gzhao> #startmeeting weekly lithium irc sync
14:30:24 <odl_meetbot> Meeting started Wed Jun 10 14:30:24 2015 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:24 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:31:07 <gzhao> #topic roll call and agenda
14:31:57 <gzhao> #chair phrobb1 colindixon
14:31:57 <odl_meetbot> Warning: Nick not in channel: colindixon
14:31:57 <odl_meetbot> Current chairs: colindixon gzhao phrobb1
14:32:35 <gzhao> #info gzhao release USC
14:32:40 <hideyuki> #info Hideyuki for VTN
14:32:57 <Prem> #info Prem for VPNService
14:33:08 <gzhao> #chair colindixon
14:33:08 <odl_meetbot> Current chairs: colindixon gzhao phrobb1
14:33:19 <colindixon> #info colindixon
14:33:22 <colindixon> thanks for getting things going gzhao
14:33:26 <colindixon> #undo
14:33:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3f410>
14:33:36 <colindixon> #info colindixon for TTP, docs, and TSC
14:33:47 <LuisGomez1> #info LuisGomez1
14:35:25 <odl-casey> #info Casey Cain
14:35:33 <gzhao> #topic blocking issues
14:35:58 <abhijitkumbhare> #info abhijitkumbhare OpenFlow plugin
14:36:08 <tbachman> #info tbachman for GBP
14:36:22 <colindixon> ok
14:36:27 <colindixon> it’s 6 after, we should probably get started
14:36:29 <gzhao> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 <--- blocking issues
14:36:33 <colindixon> #undo
14:36:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b98d50>
14:36:38 <colindixon> #topic blocking bugs
14:36:44 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 <--- blocking issues
14:36:51 <tbachman> :)
14:37:34 * colindixon puts puts the the openstack bug in the to review
14:37:54 <gzhao> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1360517736 <-- RC0 issues
14:38:59 <gzhao> #info We have currently two outstanding issues: 1) dLux 2) integration needs internet to start
14:39:01 <colindixon> #info we seem to have 3 blocking bugs right now: 3368, 3602, 3656 and each of them have handlers
14:39:10 <gzhao> #undo
14:39:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3f910>
14:39:12 <gzhao> #undo
14:39:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3f8d0>
14:39:24 <gzhao> #info we seem to have 3 blocking bugs right now: 3368, 3602, 3656 and each of them have handlers
14:40:07 <colindixon> ok
14:40:21 <colindixon> gzhao: are we tracking the RC0 issues?
14:40:36 <gzhao> #info according to Ryan, 3368 need to be fixed externally
14:41:15 <colindixon> IF ANYONE HAS TOPICS THEY NEED TO COVER, SAY SO. THAT WAY WE CAN COVER THEM BEFORE THE END OF THIS MEETING.
14:41:19 <gzhao> colindixon: Luis create spreadsheet, there are two blocking issues, I copied the dlux one to blocking issue link
14:41:40 <colindixon> DON’T LET GEORGE AND I JUST TALK THE WHOLE TIME IF YOU HAVE THINGS TO SAY.
14:41:44 <colindixon> ok
14:41:57 <colindixon> #info colindixon notes that very few projects have responeded to the RC0 call for reports
14:42:07 <hideyuki> #info VTN project is testing RC0, and have not detected any new critical issues in it so far.
14:42:20 <alagalah> #info alagalah GBP
14:42:37 <alagalah> colindixon: Yes
14:42:38 <hideyuki> Do we need to report RC0 status in release ML?
14:42:48 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-June/002575.html if you haven’t sent in a report, it would help a lot if you could reply to Luis’s mail here
14:42:53 <gzhao> zxiiro: do we have daily build push artifacts?
14:42:57 <tbachman> #info GBP has done some testing on RC0, but was waiting to finish testing before updating the spreadsheet
14:43:10 <alagalah> colindixon: Has there been any official word that we are indeed pushing everything back a week for RC? Or are we going to skip an RC ?
14:43:22 <colindixon> hideyuki: we will not kick you out if you dont, but it would be hugely helpful to get the report
14:43:43 <colindixon> alagalah: the current plan is to that we will try to do RC0, RC1, RC2, release and skip RC3 to release on tme
14:44:06 <gzhao> hideyuki: you may do so through https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1072617634
14:44:27 <colindixon> #info alagalah asks if we will delay release because we missed RC0 for a week, colindixon says not right now, the current plan is to do RC0, RC1, RC2 and then release (skipping an RC3) to try to release on time
14:44:27 <LuisGomez1> everybody please feed the RC0 test report after evaluating the candidate
14:45:05 <LuisGomez1> as colin said few people did
14:45:05 <colindixon> gzhao, hideyuki: filling out the spreadsheet is fast and easy, but if you have *any* time please also send back the report that LuisGomez1 asked for since it has more information and will help a lot
14:45:16 <gzhao> #info LuisGomez1 said all projects should feed https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1072617634
14:45:33 <hideyuki> colindixon: Ok, thanks.
14:45:40 <colindixon> hideyuki, gzhao: ah
14:45:44 <colindixon> don’t listen to me :-)
14:45:48 <LuisGomez1> i will send another reminder today
14:45:49 <colindixon> listing to LuisGomez1 and gzhao
14:45:52 <colindixon> thanks
14:46:48 <gzhao> colindixon: ok, then that should be done before RC1 cut off
14:47:14 <tbachman> btw — folks sonar reports may look a little worse than usual for today (patch submitted to yangtools master to fix this)
14:47:30 <colindixon> #topic sonar reports
14:47:41 <colindixon> #info tbachman says “btw — folks sonar reports may look a little worse than usual for today (patch submitted to yangtools master to fix this)”
14:47:45 <tbachman> colindixon: thx!
14:47:50 * tbachman was just queuing that up
14:47:52 <colindixon> #topic RCs and reports
14:48:27 <colindixon> #info as stated above the plan is to have only 3 RCs (called RC0, RC1, and RC2, but on the original dates slated for RC1, RC2, and RC3) and release on time
14:48:28 <gzhao> #info Projects please respond email https://lists.opendaylight.org/pipermail/release/2015-June/002575.html for RC0 reports.
14:48:48 <colindixon> #info there is an e-mail asking for RC0 reports based on testing, please fill that out
14:49:01 <colindixon> any other topics?
14:49:20 <gzhao> colindixon: I update Lithium release plan to change the RC dates.
14:49:58 <colindixon> #action gzhao to update the release plan to make the dates correc
14:50:02 <colindixon> #topic documentation
14:50:07 <phrobb1> gzhao:  did you want to mention anything about release reviews and the proposed schedule?
14:50:09 * tbachman runs and hides
14:50:11 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-June/002618.html this shows the state of documentation as of Monday
14:50:16 <abhijitkumbhare> gzhao: are you planning to update https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan or some other place?
14:50:22 <zxiiro> gzhao: sorry not yet. It's on my todo list
14:50:38 <zxiiro> gzhao: I'll try to get the daily jobs producing staging repos today
14:50:38 <gzhao> abhijitkumbhare: yes, that has been updated.
14:50:39 <colindixon> #info I’m updating the tracking spreadsheet pretty regularly and recording the last update at the top
14:50:45 <abhijitkumbhare> OK
14:50:52 <gzhao> phrobb1: yes, release plan review.
14:51:13 <colindixon> #action zxiiro will try to get autorelease-daily jobs to produce staging repos as well so people can check if their bugs are fixed more than once a week
14:51:27 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit?pli=1#gid=613128231 here’s the docs tracking spreadsheet
14:51:31 <colindixon> #topic release reviews
14:51:34 <colindixon> gzhao: go
14:52:15 <gzhao> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=743945554
14:52:36 <gzhao> however, not sure if any projects are ready for release plan review this week
14:52:40 * tbachman would undo that, adding context, but he’s not a chair
14:52:52 <colindixon> #chair tbachman
14:52:52 <odl_meetbot> Current chairs: colindixon gzhao phrobb1 tbachman
14:52:53 <colindixon> #undo
14:52:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x18d7490>
14:53:01 <tbachman> colindixon: thx!
14:53:04 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=743945554 the signup sheet for release reviews
14:53:18 <colindixon> #info gzhao asks projects to please sign up for slots to have a release review
14:53:32 <gzhao> I leave next week blank for ONS
14:53:49 <tbachman> June 11th and 12th?
14:53:49 <colindixon> #info to have a release review, you need to bring release notes and the release review templates filled in
14:54:02 <colindixon> #link https://wiki.opendaylight.org/view/Sample_Release_Notes sample release notes template that you can use
14:54:10 <colindixon> #link https://wiki.opendaylight.org/view/Sample_Release_Review sample release review template tha tyou can use
14:54:13 <gzhao> tbachman: hope offset 0 projects are done.
14:54:20 <tbachman> gzhao: good point
14:54:39 <colindixon> #info gzhao notes that hes left next week blank because of ONS, but we might need to change that to get everything done
14:55:01 <colindixon> #action gzhao to send mail to the rlease list for people to sign up
14:55:36 <colindixon> #info colindixon notest that the docs group would like to get the release notes *also* into AsciiDoc, but we’ll sort that out later
14:55:51 <colindixon> gzhao: did you want to cover anything else?
14:56:12 <gzhao> colindixon: shall I add some slot next Wed and Fri to give some buffers?
14:56:30 <abhijitkumbhare> gzhao: tbachman - wouldn’t there be issues left to be fixed for offset 0 projects - in case offset 1 and 2 file bugs against them? Or is it still OK to get the release review done June 11 & 12 for offset 0?
14:56:53 <tbachman> abhijitkumbhare: I think the release review is just a readiness
14:57:05 <tbachman> they don’t have to be “done” — just need everything in order
14:57:09 <colindixon> abhijitkumbhare: the release review shouldn’t take much time and isn’t tied to stopping working on bugs
14:57:29 <abhijitkumbhare> Yes - but there would be the release notes that could change significantly
14:57:37 <abhijitkumbhare> in case of blocking bugs
14:57:45 <abhijitkumbhare> found late
14:57:51 <colindixon> abhijitkumbhare: fair, although usually you only talk about bugs fixed since the last release
14:58:01 <abhijitkumbhare> OK
14:58:26 <gzhao> colindixon: I don't have anything new.
14:58:31 <colindixon> #info abhijitkumbhare asks how we can do release reviews while we’re still fixing bugs since the releast notes might change to reflect blocking bugs
14:58:44 <LuisGomez1> i do not think we should sleep the release reviews with so many projects we have
14:58:59 <LuisGomez1> the sooner the better
14:59:11 <abhijitkumbhare> yes - that’s true LuisGomez1
14:59:15 <colindixon> #inco colindixon notes that the bugs listed should really only be bugs fixed since the last release, but if there are blocking bugs we’ll add them to the release notes as needed even after a release review
14:59:20 <colindixon> #info colindixon notes that the bugs listed should really only be bugs fixed since the last release, but if there are blocking bugs we’ll add them to the release notes as needed even after a release review
14:59:20 <gzhao> LuisGomez1: ok, I will add time for next week as well.
14:59:40 <colindixon> #action gzhao to open slots for release reviews for next week as well to try to get through things
15:00:03 <colindixon> #info colindixon notes that the TSC doesn’t *need* to attend them, but is merely encouraged to do so, so sscheduling should be easier
15:00:33 <colindixon> #action at some point gzhao to start scheduling projects into slots and telling them when the slot is and asking them to object if we get to the point that we might not finish
15:00:52 <colindixon> gzhao: I’m hoping that won’t be necessary, but I’m guessing it might be
15:00:54 <colindixon> ok
15:00:57 <colindixon> anything else?
15:01:03 <colindixon> we’re at the top of the hour
15:01:06 <colindixon> going once....
15:01:10 <colindixon> going twice…
15:01:17 * colindixon counts to 10
15:01:27 <colindixon> #topic cookies
15:01:29 <colindixon> #endmeeting