15:28:23 <anipbu> #startmeeting beryllium release review
15:28:23 <odl_meetbot> Meeting started Thu Feb 11 15:28:23 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:28:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:28:23 <odl_meetbot> The meeting name has been set to 'beryllium_release_review'
15:28:30 <anipbu> #topic roll call
15:28:42 <anipbu> #info PTL and TSC members please #info in
15:28:48 <anipbu> #info anipbu
15:30:45 <yamahata> #info yamahata for neutron northbound
15:31:04 <colindixon> #info colindixon for TTP, docs, and TSC
15:31:28 <anipbu> So today we have nine projects presenting: neutron, sdni, snap, sep, tcpmd5, yang push, alto, didm, vtn, flux, faas, lispflowmapping
15:31:34 <anipbu> PTL, please info in
15:32:05 <anipbu> #chair colindixon
15:32:05 <odl_meetbot> Current chairs: anipbu colindixon
15:32:10 <anipbu> Let's get started
15:32:14 <anipbu> #topic NEUTRON (Neutron Northbound)
15:32:19 <anipbu> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium:Release_Notes <-- Release Notes
15:32:20 <qwebirc791144> yang push: AmbikaPrasadTripathy
15:32:24 <anipbu> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium:Release_Review <-- Release Review
15:32:28 <anipbu> #info Isaku Yamahata is representing NEUTON
15:32:34 <anipbu> yamahata, anything you would like to add?
15:32:41 <yamahata> Yes.
15:32:58 <yamahata> Right now two patches are under review. Those may break downstream build.
15:33:07 <yamahata> So we need coordination how to handle them.
15:33:17 <yamahata> i.e. merge them for release or delay them for SR.
15:33:25 <yamahata> Now I sent a mail on it for communication.
15:33:39 <anipbu> are those issues BLOCKING and we cannot release Beryllium without it?
15:33:53 <colindixon> https://lists.opendaylight.org/pipermail/release/2016-February/005456.html
15:33:55 <yamahata> It's critical.
15:34:08 <colindixon> https://bugs.opendaylight.org/show_bug.cgi?id=4527
15:34:08 <anipbu> this is https://bugs.opendaylight.org/show_bug.cgi?id=4527
15:34:40 <yamahata> Yes. that bug
15:34:51 * colindixon reads the other docs, anipbu and yamahata it seems like the issue is that there is a whole slug of patches we need from multiple projects before tonight
15:35:13 <colindixon> yamahata: do we have a complete list of the patches needed and buy in from all the projects?
15:35:25 <yamahata> Yes, let me check...
15:35:46 <yamahata> https://git.opendaylight.org/gerrit/#/c/33957/
15:35:51 <yamahata> https://git.opendaylight.org/gerrit/#/c/33932/
15:35:58 <yamahata> These are the two patches.
15:36:19 <colindixon> yamahata: are they the only ones requried?
15:36:27 <yamahata> Yes.
15:37:55 <yuling> Is tonight's build the last build for Beryllium?
15:38:03 <yamahata> 33932 may need respin.
15:38:04 <colindixon> yuling: that's the idea
15:38:11 <colindixon> yuling: assuming no blockers are found
15:38:11 <yuling> ok, thanks
15:38:32 <yamahata> 33957 is ready to merge
15:38:37 <colindixon> yamahata: OK, so I think if you have buy in from everyone and are convinced it won't break autorelease, we should push to ge those patches merged
15:38:45 <colindixon> yamahata: make really sure it's not going to break things though
15:38:59 <yamahata> colindixon: got it.
15:39:11 <colindixon> yamahata: on the release notes can you note which things are deprectated vs. removed?
15:39:26 <anipbu> yamahata, any experimental features in neutron?
15:39:38 <yamahata> colindixon:  sure will do
15:39:42 <yamahata> anipbu: no experimental feature
15:40:03 <anipbu> neutron has waiver for system test
15:40:10 <colindixon> yamahata: are any of the features you have experimental?
15:40:18 <colindixon> thanks
15:40:23 <LuisGomez> right anipbu
15:40:23 <colindixon> I see it above
15:40:37 <anipbu> Neutron waiver was approved by integration: https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Waiver/System_Test#Neutron_Northbound
15:40:45 <colindixon> and you have no user-facing features, is that correct?
15:40:55 <LuisGomez> they test the neutron interface via PAX-EXAM
15:41:01 <yamahata> colindixon: Right.
15:41:21 <anipbu> yamahata, have you done any external testing on the RC2 artifacts to validate neutron functinality?
15:41:40 <colindixon> yamahata: and migration is pretty much not supported from Li to Be, right?
15:41:43 <yamahata> It's being done right now
15:41:56 <yamahata> https://review.openstack.org/#/c/271012/
15:42:07 <yamahata> It's taking a while to complete
15:42:18 <yamahata> Oh wrong link
15:42:28 <yamahata> https://review.openstack.org/#/c/278839/
15:42:34 <yamahata> 278839 is correct
15:42:39 <colindixon> assuming others are OK and we confirm that migration isn't supported, then I'm happy
15:42:41 <anipbu> neutron looks good to me, assuming the critical issue is fixed and the external testing completes.
15:42:53 <anipbu> LuisGomez, any comments you;d liek to make?
15:43:13 <colindixon> #action yamahata to update the EoL/Deprecated/Removed list in the release notes to specify which ones are deprecated vs. removed
15:43:13 <yamahata> migration isn't supported.
15:43:31 <colindixon> #info yamahata notes that migration to Be from any previous release ins't supported
15:43:34 <colindixon> I'm good
15:43:36 <colindixon> anyone else?
15:43:43 <anipbu> Let's move on
15:44:02 <LuisGomez> i am good
15:44:15 <anipbu> #info update external testing once it is done
15:44:23 <anipbu> #topic SDNINTERFACEAPP
15:44:34 <anipbu> #link https://wiki.opendaylight.org/view/ODL-SDNi:Beryllium_Release_Notes <-- Release Notes
15:44:46 <anipbu> #link https://wiki.opendaylight.org/view/ODL-SDNi:Beryllium_Release_Review <-- Release Review
15:45:03 <anipbu> #info Shahid Shaik is representing SDNINTERFACEAPP
15:45:15 <anipbu> Shahid_Shaik, anything you would like to add?
15:45:27 <Shahid_Shaik> that's good
15:45:46 <anipbu> #chair LuisGomez phrobb
15:45:46 <odl_meetbot> Current chairs: LuisGomez anipbu colindixon phrobb
15:46:20 <anipbu> Shahid_Shaik, are any of your features considered experimental?
15:46:23 <colindixon> Shahid_Shaik, zxiiro: I remember sdni being responsible for more than  few autorelease breakges, is that wrong?
15:46:28 * colindixon starts reading
15:46:42 <Shahid_Shaik> it was addressed, currently there are no breakages
15:47:06 <anipbu> Shahid_Shaik, have you tested against RC2 artifacts, are there any blocking issues?
15:47:11 <LuisGomez> features were late in distribution but now they ar there
15:47:34 <LuisGomez> there is no sytem test, not even a test plan.
15:47:46 <LuisGomez> is this experimental feature?
15:47:53 <Shahid_Shaik> LuisGomez: no
15:48:05 <LuisGomez> so how do you test this?
15:48:22 <Shahid_Shaik> LuisGomez: we don't have any user facing features, it was unit and integration testing
15:48:28 <colindixon> Shahid_Shaik: many sections are missing from release notes
15:48:49 <Shahid_Shaik> colindixon: Please let me know what are all sections to be updated
15:48:53 <colindixon> Shahid_Shaik: really, just the changes since prior releases
15:49:06 <colindixon> #actoin Shahid_Shaik to add the changes since previous releases sections to the release notes fro SDNi
15:49:13 <colindixon> #action Shahid_Shaik to add the changes since previous releases sections to the release notes fro SDNi
15:49:13 <LuisGomez> Shahid_Shaik, in this situation the normal is to ask for a system test waiver
15:49:29 <Shahid_Shaik> colindixon: it was AD-SAL to MD_SAL migration
15:49:29 <colindixon> https://wiki.opendaylight.org/view/Sample_Release_Notes
15:49:57 <Shahid_Shaik> colindixon: And we covered it
15:50:10 <anipbu> #info sdni has not system test, no test plan.  Shahid_Shaik says sdni don't have any user facing features, it was unit and integration testing
15:50:14 <colindixon> Shahid_Shaik: so, I need you to fill out any bugs that were fixed, if migration works, if it's compatible with previous releases, and anything that was deprectaed or removed
15:50:38 <anipbu> Shahid_Shaik, have you tested against RC2 artifacts, are there any blocking issues?
15:51:21 <Shahid_Shaik> colindixon: No migration won't work, as such currently there is no mechanism how it has to be migrated from Lithium to Beryllium
15:51:24 <anipbu> Do folks feel we need a follow up with SDNI?
15:51:33 <Shahid_Shaik> anipbu: Yes, it was tested
15:51:57 <anipbu> #info Shahid_Shaik says they have against RC2 artifacts and no blockers
15:52:08 <colindixon> #action Shahid_Shaik to focus on migration/compatibility from/with previous releases and anyting that was deprecated or removed (it sounds like no compatibility or migration)
15:52:37 <Shahid_Shaik> colindixon: will updated the release notes related to migration/compatibility
15:52:45 <anipbu> So we're over time, do folks feel we need a follow up with SDNI, or can we move on?
15:53:19 <colindixon> anipbu, Shahid_Shaik: do we have the right list of user-facing features from SDNi?
15:53:22 <colindixon> if so, I'm good
15:53:41 <Shahid_Shaik> colindixon: we don't have any user facing features
15:54:37 <colindixon> Shahid_Shaik: who is the target audience for the functionality then?
15:54:50 <jamoluhrsen> colindixon, anipbu LuisGomez: i'm here.
15:55:06 <LuisGomez> hi jamoluhrsen
15:55:09 * colindixon waves to jamoluhrsen
15:55:13 <Shahid_Shaik> colindixon: we have the exposed RPC services
15:55:26 <anipbu> Given the questions surrounding sdni, I believe we may benefit from a follow up
15:55:32 <colindixon> anipbu: OK
15:55:42 <LuisGomez> agree
15:55:45 <anipbu> Let's move on
15:55:46 <phrobb> In Li there is a feature listed as "odl-sdninterfaceapp-all.  Is that no longer present?
15:55:56 <colindixon> #action anipbu to start an email follow up thread with relevant people about SDNi
15:56:11 <anipbu> #topic SNMP
15:56:15 <Shahid_Shaik> phrobb : it is there in Beryllium as well
15:56:29 <anipbu> #info Vaishali Mithbaokar is representing SNMP
15:56:44 <anipbu> Vaishali, anything you would like to add?
15:56:44 <Vaishali> I am here to represent SNMP project, since Adam is not available
15:56:44 <phrobb> Thanks Shahid_Shaik, will follow up with you later
15:56:57 <anipbu> Please link your release review and release notes
15:57:05 <Vaishali> So on SNMP side, there are no changes in Beryllium release
15:57:19 <Vaishali> except couple of bug fixes
15:57:26 <anipbu> Vaishali, do you have release notes and release review template available?
15:57:47 <Vaishali> There is one integration test failure, which isknown to us. We still need to add snmp simulator , get it working in integration set up
15:58:10 <colindixon> anipbu, Vaishali: I can't find release notes or release review on the wiki
15:58:14 <Vaishali> I see the templates now, will go ahead and state in that saying no changes in Beryllium
15:58:19 <Vaishali> I will send email after that
15:58:20 <jamoluhrsen> Vaishali, are you referring to the one CSIT failure here: snmp-csit-1node-basic-only-beryllium
15:58:28 <Vaishali> yeah, thats the one
15:58:37 <Vaishali> the IP addr in there is test one
15:59:03 <anipbu> #action SNMP to create release notes and release plan template
15:59:07 <Vaishali> thats why it fails, we still have action to get snmp simulator working, and put the IP address of simulated device in test case, rather than hard coded one
15:59:07 <colindixon> #action Vaishali to create pages for SNMP's release review and release notes for Beryllium based on the templates here: https://wiki.opendaylight.org/view/Sample_Release_Notes https://wiki.opendaylight.org/view/Sample_Release_Review
15:59:15 <colindixon> we should move on
15:59:25 <Vaishali> sure I will do that and send email to release mailer.
15:59:34 <phrobb> Yes, I suggest we reschedule
15:59:37 <LuisGomez> yes, we need to review this later with the templats filled
15:59:45 <colindixon> Vaishali: I think we need to schedule another 10 minute slot for later
15:59:52 <Vaishali> sure
15:59:52 <anipbu> #action anipbu to follow up with SNMP
15:59:57 <colindixon> thanks anipbu
16:00:02 <anipbu> Let's move on
16:00:29 <anipbu> #topic SXP
16:00:33 <anipbu> #link https://wiki.opendaylight.org/view/SXP:Beryllium:Release_Review <-- Release Review
16:00:46 <anipbu> #link https://wiki.opendaylight.org/view/ODL-SDNi:Beryllium_Release_Notes <-- Release Notes
16:01:11 <anipbu> #info Matthew Robertson is representing SXP
16:01:30 <anipbu> mamihale, anything you would like to add?
16:01:46 <mamihale> no nothing
16:01:52 <anipbu> #info mamihale is representing SXP on behalf of Matthew Robertson
16:01:57 <colindixon> #action mamihale  needs to add the section on Changes Since Previous Releases from the sample release notes template for SXP
16:02:16 <anipbu> mamihale, have you tested against RC2, are there any blockers?
16:02:29 <anipbu> mamihale, are any of your features considered experiemental?
16:02:31 <colindixon> mamihale: the key points are migration/compatibility from/with previous release and if anything was deprecated or removed
16:02:47 <mamihale> there are no blockers
16:03:01 <mamihale> also there are no experimental features
16:03:08 <anipbu> Are these all user facing features: odl-sxp-all odl-sxp-api odl-sxp-core odl-sxp-controller
16:03:21 <anipbu> #info SXP has tested against RC2 with no blockers
16:03:30 <mamihale> and nothing was depricated or removed so compatibility should be ok
16:03:37 <colindixon> #action colindixon to add a list of experimental features, a list of user-facing features, and a link to system test results or waiver to the sample release review template
16:03:38 <anipbu> #info mamihale says no experiemental features
16:04:10 <colindixon> mamihale: a network operator should know about and understand all those features?
16:04:15 <colindixon> mamihale: that seems wrong
16:04:24 <mamihale> yes those are the only user facing features
16:04:44 <colindixon> mamihale: presumably controller installs all the others right and most people won't want to install them individually, or am I wrong?
16:05:25 <phrobb> mamihale we ask about the user facing features so we are sure we understand what needs to be documented for the user.
16:05:27 <colindixon> mamihale: please complete the sections in the release notes to note that things should be compatible and that nothing was removed or deprecated, have you tested migrating
16:05:34 <colindixon> ?
16:06:02 <mamihale> yes in controller all are used as you mentioned
16:06:03 <colindixon> if you think it *should* work, but haven't tested I would note that so users understand what's been tested and aren't surprised
16:06:39 <mamihale> let me correct my self it have been tested
16:06:52 <anipbu> #chair jamoluhrsen
16:06:52 <odl_meetbot> Current chairs: LuisGomez anipbu colindixon jamoluhrsen phrobb
16:07:31 <LuisGomez> btw, sxp features are commented in distribution test because some yang parser issues, so they still exist?
16:07:34 <LuisGomez> https://git.opendaylight.org/gerrit/gitweb?p=integration/distribution.git;a=blob;f=features-test/src/main/resources/features.xml;h=d735ec0d24d868defc6d57d1f2c733768b9f8ea3;hb=refs/heads/stable/beryllium
16:07:37 <colindixon> mamihale: so, you need to add the "Changes Since Previous Releases" section filled out to your release notes from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
16:07:42 <colindixon> and add that information
16:08:36 <mamihale> issue with yang parser have been fixed
16:08:59 <colindixon> mamihale: we still have the questions about which features should be called user-facing, which is defined here: https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features
16:09:29 <colindixon> LuisGomez: so is SXP even building into integration?
16:09:36 <LuisGomez> mamihale, can you please patch distribution to renable your feature?
16:09:37 <anipbu> #info mamihale to update the list of user-facing features
16:09:42 <LuisGomez> yes colindixon
16:09:45 <colindixon> #undo
16:09:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x223bdd0>
16:09:59 <colindixon> #action mamihale to update the list of user-facing features based on the definition here: https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features
16:10:03 <LuisGomez> only the feature test is missing but features are thre
16:10:07 <colindixon> LuisGomez: ah
16:10:28 <colindixon> #action mamihale to re-enable feature testing in integration for SXP
16:10:29 <jamoluhrsen> we need to get sxp back in to feature test is all.
16:10:40 <anipbu> #info mamihale to add the "Changes Since Previous Releases" section filled out to release notes from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
16:10:42 <colindixon> at this point I'm good if the action items happen
16:11:00 <jamoluhrsen> I'm good.  sys test looks clean -and- it exists
16:11:10 <phrobb> No more questions from me
16:11:13 <anipbu> sxp looks good to me as well
16:11:14 <LuisGomez> i am good as well with the list of actions
16:11:20 <anipbu> Let's move on
16:11:30 <anipbu> congrats sxp
16:11:33 <anipbu> #topic TCPMD5
16:11:37 <anipbu> #link https://wiki.opendaylight.org/view/TCPMD5:Beryllium_Release_Notes <-- Release Notes
16:11:41 <anipbu> #link https://wiki.opendaylight.org/view/TCPMD5:Beryllium_Release_Review <-- Release Review
16:11:54 <jamoluhrsen> tcpmd5 has system test waiver.
16:11:55 <anipbu> #info Milos Fabian is representing TCPMD5
16:12:05 <anipbu> #tcpmd5 has system test waiver
16:12:35 <anipbu> Milos_ anything you would like to add?
16:12:52 <Milos_> No changes in Beryllium
16:12:57 <colindixon> this looks awesome
16:13:03 <colindixon> next project :p
16:13:22 <vina_ermagan> #info Vina Ermagan for lispflowmapping
16:13:26 <jamoluhrsen> :)
16:13:32 <anipbu> Milos_ have you tested against RC2 artifacts and any blockers?
16:14:10 <Milos_> TCP MD5 is tested with BGPCEP - all those system tests are passing
16:14:44 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/project:tcpmd5+status:merged there were no commits of substance (other than version bumps and tracking upstream changes etc.) in Beryllium for TCPMD5
16:14:45 <anipbu> #info Milos_ says TCP MD5 is tested with BGPCEP - all those system tests are passing.  No blockers in RC2
16:14:55 <LuisGomez> i am good with tcpmd5
16:15:11 <jamoluhrsen> yeah.  what LuisGomez said.
16:15:13 <anipbu> tcpmd5 looks good to me.
16:16:29 <anipbu> phrobb colindixon any other comments?
16:16:38 <colindixon> I'm good
16:16:53 <phrobb> Nope, nothing from me
16:16:54 <anipbu> Okay Let's move on
16:16:59 <anipbu> congrats tcpmd5
16:17:04 <anipbu> #topic YANGPUSH
16:17:09 <anipbu> #link https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_Release_Notes <-- Release Notes
16:17:14 <anipbu> #link https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_Release_Review <-- Release Review
16:17:25 <anipbu> #info Ambika Prasad Tripathy is representing YANGPUSH
16:18:04 <anipbu> qwebirc791144 anything you would like to add?
16:18:27 <qwebirc791144> Bug in YANG TOOL "https://bugs.opendaylight.org/show_bug.cgi?id=5099"
16:18:34 <qwebirc791144> affects YANGPUSH
16:18:58 <anipbu> qwebirc791144, have you tested against RC2 artifacts and were there any blockers?
16:18:58 <colindixon> #action qwebirc791144 it would be great if you could add the expansion of the bug and what it means to users instead of just the link to the URL in the known issues for yang push
16:18:59 <jamoluhrsen> #info no CSIT for yangpush
16:19:29 <anipbu> qwebirc791144, are your features experimental?
16:19:37 <qwebirc791144> yes
16:19:39 <colindixon> qwebirc791144: something like "[[https://bugs.opendaylight.org/show_bug.cgi?id=5099 bug-5099] <description of issue>" instead of "[https://bugs.opendaylight.org/show_bug.cgi?id=5099]"
16:19:55 <qwebirc791144> Issue in casting a anyxml leaf to anyXMLNode type
16:20:29 <colindixon> qwebirc791144: I mean in the actual wiki pages
16:20:46 <anipbu> #info qwebirc791144 says yangpush features are experimental
16:21:02 <qwebirc791144> update the wiki accordingly
16:21:16 <anipbu> There is no system test plan either for yangpush.  So I'm curious how it was tested.
16:21:36 <colindixon> anipbu: https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_Release_Review#Quality_Assurance_.28test_coverage.2C_etc.29
16:21:43 <colindixon> JUNIT testing and Integration testing. TO BE DONE
16:21:44 <colindixon> System tests performed manually with success.
16:21:45 <colindixon> Manual Testing provides around 80% code coverage.
16:21:46 <colindixon> No blocking issues identified as yet.
16:22:01 <LuisGomez> no csit and no testplan, i am ok if features are expeimental
16:22:03 <qwebirc791144> aded system test plan to wiki: https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_System_Test
16:22:33 <colindixon> #info LuisGomez notes that he doesn't have issues with the testing or lack thereof it it's an experimental feature
16:23:04 <anipbu> qwebirc791144 thanks for the system test plan
16:23:21 <anipbu> #info link https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_System_Test <-- System Test Plan Manual
16:24:20 <phrobb> qwebirc791144 Documentation looks to be a little bit lite at this point.  Are you planning on submitting some more before the release?
16:24:21 <LuisGomez> thanks, at least basic test plan is there
16:24:46 <qwebirc791144> yes. we are planning to update user doc and release doc before next RC
16:25:30 <colindixon> qwebirc791144: the next RC is tonight
16:25:48 <jamoluhrsen> qwebirc791144, can you add your sys test plan here: https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
16:25:59 <qwebirc791144> Oh.. Then by 18th Feb
16:26:43 <qwebirc791144> Yes. we can update.
16:27:05 <colindixon> qwebirc791144: OK, I know docs has a big backlog, which is mostly my fault, but the sooner you get those in the better
16:28:18 <qwebirc791144> Colindixon: Yes we will update to wiki and asciidoc
16:28:29 <colindixon> #action qwebirc791144 to update the documentation as soon as is possible
16:28:31 <anipbu> qwebirc791144, are there any blockers in yangpush bugs?
16:28:38 <qwebirc791144> no
16:28:55 <anipbu> #info no blockers in yangpush after RC2 manual testing
16:29:07 <anipbu> yangpush looks good to me
16:29:11 <phrobb> no more questions from me
16:29:44 <anipbu> colindixon LuisGomez jamoluhrsen any other comments?
16:29:58 <LuisGomez> no, i am good
16:30:01 <jamoluhrsen> I am good
16:30:32 <colindixon> other than the actions above, I"m good
16:30:40 <anipbu> Okay let's move on
16:30:45 <anipbu> congrats yangpush
16:30:50 <anipbu> #topic ALTO
16:30:55 <anipbu> #link https://wiki.opendaylight.org/view/ALTO:Beryllium:Release_Notes <-- Release Notes
16:31:00 <anipbu> #link https://wiki.opendaylight.org/view/ALTO:Beryllium:Release_Review <-- Release Review
16:31:14 <anipbu> #info Kai Gao or Jensen Zhang is representing ALTO
16:31:32 <anipbu> jensen_zhang anything you would like to add?
16:31:51 <jensen_zhang> Yes
16:32:25 <jensen_zhang> Some patches (about docs and system test) weren't merged now.
16:32:26 <colindixon> #action jensen_zhang to note that migration isn't possible in the release notes
16:32:44 <colindixon> jensen_zhang: does it require Java 7 or work with Java 8 too?
16:33:03 <jensen_zhang> work with Java 8
16:33:05 <jamoluhrsen> #info no CSIT for ALTO
16:33:19 <anipbu> jensen_zhang, what are the patches missing?
16:33:39 <LuisGomez> jamoluhrsen, there is a csit patch, how des it look?
16:33:43 <colindixon> #action jensen_zhang to add to the release notes that it requires java 8 or java 7 not just java 7
16:33:57 <jensen_zhang> anipbu: system test
16:33:59 <anipbu> jensen_zhang, have you tested against RC2 artifacts and where were there any blockers?
16:34:15 <colindixon> https://git.opendaylight.org/gerrit/#/c/32581/
16:34:26 <colindixon> ^^^^ that's the system test patch
16:34:34 <jamoluhrsen> LuisGomez, CSIT patch is under review
16:35:30 <LuisGomez> it seems that basic functionality is covered there right?
16:35:48 <jensen_zhang> anipbu: no blockers
16:35:51 <colindixon> jensen_zhang: are any of the features experimental and is your list of user-facing features up to date?
16:36:08 <jamoluhrsen> yes, LuisGomez the CSIT patch will get some basic coverage.
16:37:29 <jensen_zhang> colindixon: no user-facing features, they are experimental now.
16:37:37 <colindixon> jensen_zhang: OK
16:37:44 <LuisGomez> ok jensen_zhang
16:37:47 <colindixon> #Info jensen_zhang notes ALTO's features are experimental in Beryllium
16:37:51 <colindixon> I'm happy then
16:37:56 <LuisGomez> i am good too
16:38:08 <jamoluhrsen> good
16:38:18 <phrobb> I'm good
16:38:54 <phrobb> Did we lose anipbu?
16:39:16 <LuisGomez> oh oh…
16:39:36 <phrobb> Let's move on...
16:39:48 <phrobb> #topic DIDM
16:40:04 <colindixon> thanks phrobb
16:40:06 <colindixon> I'm grapping docs
16:40:12 <phrobb> Do we have Anandhi from the DIDM project here?
16:40:20 <anandhi_> Good Morning!
16:40:29 <colindixon> #link https://wiki.opendaylight.org/view/DIDM:_Beryllium_Release_Review <--- release review
16:40:38 <colindixon> #link https://wiki.opendaylight.org/view/DIDM:_Beryllium_Release_Notes <--- release notes
16:40:42 <colindixon> anandhi_: any blocking issues?
16:40:50 <colindixon> anandhi_: or anything to  add as we start?
16:40:53 <anandhi_> No
16:40:54 <phrobb> anandhi_ Do you have anything to add beyond what's in the release review?
16:41:03 <phrobb> colindixon :-)
16:41:11 <anandhi_> We are good to start
16:41:37 <colindixon> anandhi_: are any of your karaf features user-facing?
16:42:05 <jamoluhrsen> #info basic system test is there, but broken.  needs fixing.
16:42:17 <anandhi_> odl-didm-all takes care of all feature installation of DIDM
16:42:20 <colindixon> anandhi_: this is the 2nd release of DIDM, right? are there any compatibility/migration issues from previous releases? anything deprecated or removed?
16:42:34 <anandhi_> yes
16:42:50 <anandhi_> no, no compatibility issues, nothing was removed.
16:42:53 <colindixon> #action anandhi_ to add a filled out "Changes Since Previous Releases" section for the release notes borrowing it from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
16:43:01 <colindixon> anandhi_: and migration should work
16:43:02 <anandhi_> We have added support for floemod driver
16:43:11 <anandhi_> flowmod
16:43:26 <phrobb> anandhi_ Do you consider any of your features "experimental"?
16:43:32 <colindixon> #Info it sounds like there are no compatibility issues, migration should work, and nothing was deprecated or removed, but that should be noted in the release notes
16:43:38 <anandhi_> no
16:43:59 <anandhi_> ok, will update release notes to reflect this.
16:44:27 <jamoluhrsen> anandhi_, need your system test plan linked from here: https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
16:44:37 <anipbu2> Hi, sorry guys, irc account is getting flakey
16:44:56 <anandhi_> ok, sure, wil updatete release notes to include system test plan link
16:45:04 <LuisGomez> anandhi_, what is current code coverage for didm project?
16:45:08 <phrobb> welcome back anipbu2 , we've been muddling along without you ;-)
16:45:26 <colindixon> #action anandhi_ to update create asciidoc documentation as well as the wiki docs. Instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements
16:46:00 <anandhi_> HAven't checked the code coverage part, can I get back y to you?
16:46:54 <anandhi_> Have updated user guide - https://wiki.opendaylight.org/view/DIDM:User_Guide
16:47:05 <colindixon> anandhi_: it should be easy to find in sonar
16:47:12 <anandhi_> dev guide - https://wiki.opendaylight.org/view/DIDM:User_Guide
16:47:21 <colindixon> anandhi_: https://sonar.opendaylight.org/dashboard/index/44169
16:47:29 <LuisGomez> anandhi_ it sems like 0% in jenkins https://jenkins.opendaylight.org/releng/view/didm/ but it can be an error
16:47:32 <colindixon> anandhi_: they need to also be in asciidoc per the isntructions
16:48:07 <colindixon> #action anandhi_ to follow up with tracking sonar reporting, zxiiro can probably help (doesn't need to be before the release I don't think though)
16:48:28 <colindixon> anandhi_: are the features in DIDM experimental?
16:48:35 <anandhi_> Sure, will check sonar and update
16:49:41 <phrobb> colindixon no experimental features, asked and answered above
16:50:05 <colindixon> phrobb: sorry
16:50:08 <anipbu2> anandhi_ any blocking issues after testing with RC2 artifacts?
16:50:10 <anandhi_> yes, no experimental features
16:50:12 <colindixon> I'm happy then
16:50:25 <anandhi_> no blocking issues
16:50:26 <phrobb> No more questions from me either
16:50:34 <anipbu2> didm looks good to me
16:50:42 <anipbu2> #chair anipbu2
16:50:42 <jamoluhrsen> fine from me.
16:50:44 <colindixon> VTN is up next
16:50:56 <anipbu2> can somebody chair me?
16:50:57 <anandhi_> Thank you
16:50:57 <anipbu2> #topic VTN
16:51:04 <hideyuki> #info Hideyuki for VTN
16:51:04 <jamoluhrsen> #chair anipbu2
16:51:04 <odl_meetbot> Current chairs: LuisGomez anipbu anipbu2 colindixon jamoluhrsen phrobb
16:51:13 <anipbu2> #topic VTN
16:51:18 <anipbu2> #link https://wiki.opendaylight.org/view/VTN:Beryllium:Release_Review <-- Release Review
16:51:22 <anipbu2> #link https://wiki.opendaylight.org/view/VTN:Beryllium:Release_Notes <-- Release Notes
16:51:27 <anipbu2> #info Hideyuki Tai is representing VTN
16:51:38 <anipbu2> hideyuki anything you would like to add?
16:51:59 <hideyuki> There is one ciritical bug; Bug 4678
16:52:02 <anipbu2> So the CSIT failures yesterday was found to be a a timing issue
16:52:15 <jamoluhrsen> anipbu2, I don't totally agree
16:52:26 <hideyuki> But bug-fix patch was pushed today: https://git.opendaylight.org/gerrit/#/c/34465/
16:52:36 <hideyuki> For bug 4678: https://git.opendaylight.org/gerrit/#/c/34465/
16:52:39 <anipbu2> jamoluhrsen: okay
16:52:55 <hideyuki> So I think we can fix the bug 4678 today.
16:53:33 <colindixon> hideyuki: OK
16:53:55 <anipbu2> concerning 5305 that is the CSIT jobs failing https://bugs.opendaylight.org/show_bug.cgi?id=5305
16:54:09 <hideyuki> I'm still not sure yet why the CSIT failed on RC2. (bug 5305)
16:54:24 <hideyuki> But, reading the log file, I think this is not a bug of VTN.
16:54:48 <jamoluhrsen> agreed that this is probably not VTN issue, but something more core that is causing massive slowness of feature loading.
16:55:03 <jamoluhrsen> I want to see what RC2.2 does.
16:55:05 <hideyuki> jamoluhrsen: Agree with you.
16:55:19 <colindixon> jamoluhrsen: I agree, Tom Pantelis is the person who (with Tony) fixed the last time this happened
16:55:21 <anipbu2> hideyuki: any experimental features in VTN?
16:55:27 <colindixon> so maybe reaching out there
16:55:50 <hideyuki> anipbu2: No, we don't have any experimental features in VTN project.
16:56:11 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/33787/ asciidoc commit for Be docs
16:56:39 <colindixon> #action hideyuki to provide a link to asciidoc commit https://git.opendaylight.org/gerrit/#/c/33787/ that from the release review
16:57:04 <colindixon> hideyuki: and do we have a list of user-facing features?
16:57:19 <hideyuki> colindixon: No, I don't think so.
16:58:12 <jamoluhrsen> colindixon, the system testplan lists the user facing features, if that's what you mean.
16:58:12 <hideyuki> Is my action item to add a link to asciidoc commit to the release review wiki page? https://wiki.opendaylight.org/view/VTN:Beryllium:Release_Review
16:58:27 <anipbu2> #info hideyuki says no experimental features
16:58:35 <colindixon> #action hideyuki to provide anipbu2 a list of user-facing features
16:58:43 <colindixon> anipbu2: where are we tracking user-facing features?
17:00:31 <colindixon> if we get the actions taken care of I'm happy and we could move on to dlux
17:00:52 <LuisGomez> i am good with vtn
17:00:54 <anipbu> I've been tracking it here, but it was base don M3 status.  I'll start a track.
17:00:58 <anipbu> vtn looks good to me
17:01:04 <hideyuki> Ok. Thanks!
17:01:13 <anipbu> #action anipbu to track user-facing on spreadsheet
17:01:23 <jamoluhrsen> I'm good.
17:01:33 <anipbu> Okay Let's move on
17:01:36 <anipbu> congrats vtn
17:01:56 <anipbu> #topic DLUX
17:02:05 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Beryllium:Release_Notes <-- Release Notes
17:02:15 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Beryllium_Release_Review <-- Release Review
17:02:32 <anipbu> #info Maxime Millette Coulombe is representing DLUX
17:02:43 <anipbu> mmcoulombe anything you would like to add?
17:02:56 <mmcoulombe> i don't think so
17:03:06 <colindixon> does it actually require java 7 or does it work with Java 8 as well? my guess is it also requires a web browser?
17:04:03 <mmcoulombe> its works with both. yes you need a web browser (chrome/firefox/safari) i don't know if it's works with ie/edge/opera
17:04:16 <colindixon> mmcoulombe: and does migration work? it sounds like yes
17:04:26 <jamoluhrsen> #info no CSIT as of yet.
17:04:41 <colindixon> #action mmcoulombe to add the latest version of chrome/firefox/safari to the target execution environment
17:05:01 <colindixon> #action mmcoulombe to not that it works with Java 8 as well as Java 7
17:05:13 <anipbu> Does DLUX have a pending patch for CSIT?
17:05:31 <mmcoulombe> yes https://git.opendaylight.org/gerrit/#/c/29612/
17:05:35 <anipbu> mmcoulombe, have you tested against RC2 artifacts and were there any blockers?
17:05:53 <colindixon> mmcoulombe: does DLUX have pending patches for docs? I'm not seeing them?
17:05:54 <anipbu> #info DLUX CSIT pending patch https://git.opendaylight.org/gerrit/#/c/29612/
17:06:14 <mmcoulombe> ascii doc ?
17:06:27 <LuisGomez> it seems the csit patch did not update since December
17:06:46 <LuisGomez> are you waiting for review?
17:07:04 <mmcoulombe> LuisGomez yes
17:07:23 <jamoluhrsen> ouch!  sorry mmcoulombe
17:08:28 <colindixon> #action mmcoulombe to work on updating the AsciiDoc versions of developer/user guides for beryllium, instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements
17:08:44 <mmcoulombe> anipbu: we didnt have done any test with RC2 artifact.
17:09:16 <LuisGomez> and how do we know dlux works?
17:09:25 <anipbu> #action mmcoulombe to download RC artifacts and test if DLUX works
17:09:51 <anipbu> Since DLUX doe snot have CSIT jobs available, I think mmcoulombe will need to do some sort of manual testing against the RC
17:10:02 <colindixon> #action jamoluhrsen and LuisGomez to work to get the system test patch reviewed and merged
17:10:23 <mmcoulombe> as info, nothing change from Lithium at all
17:10:49 <anipbu> are there any features in dlux considered to be experimental?
17:11:04 <colindixon> mmcoulombe: there are some things which are deprecated though and presumably users/developers want to know that
17:11:18 <mmcoulombe> anipbu none
17:12:24 <colindixon> anipbu: assuming that we get the above action items taken care of, I'm good
17:12:37 <mmcoulombe> colindixon depricated functionality have been reflected in the getting started of the wiki https://wiki.opendaylight.org/view/OpenDaylight_dlux:Beryllium_Create_A_Module
17:12:38 <LuisGomez> i am good too
17:12:42 <phrobb> same here
17:12:49 <anipbu> dlux looks good to me
17:12:49 <jamoluhrsen> colindixon, unlikely review+merge of csit happens before release.  just fyi.
17:12:52 <jamoluhrsen> I'm good
17:12:58 <anipbu> Okay let's move on
17:13:00 <anipbu> congrats dlux
17:13:08 <anipbu> #topic FAAS
17:13:12 <anipbu> #link https://wiki.opendaylight.org/view/FaaS:Beryllium_Release_Notes <-- Release Notes
17:13:16 <colindixon> mmcoulombe: yes, but this presumably hasn't been updated: https://github.com/opendaylight/docs/blob/master/manuals/developer-guide/src/main/asciidoc/dlux/dlux-core-dev.adoc
17:13:27 <anipbu> #link https://wiki.opendaylight.org/view/FaaS:Beryllium_Release_Review <-- Release Review
17:13:44 <anipbu> #info Xingjun Chu is representing FAAS
17:14:02 <anipbu> xingjun xingjun_ anything you would like to add?
17:14:06 <anipbu> What the state of CSIT jobs?
17:14:09 <xingjun_> I dont think so
17:14:19 <xingjun_> no CSIT yet, in process to add
17:14:19 <colindixon> xingjun_: does it require Java 8? or java 7 or Java 8?
17:14:27 <xingjun_> both work
17:14:58 <anipbu> Has faas been added to the distribution test features xml?
17:15:01 <jamoluhrsen> xingjun, any patches for CSIT yet or still working to push
17:15:16 <colindixon> #action xingjun_ to note that Java 7 and Java 8 work rather than saying Java 8 is required in the FaaS release notes
17:15:31 <jamoluhrsen> anipbu, faas is not in test features xml
17:15:37 <anipbu> Looks like some of the features were cmmented out in the test features sml
17:15:52 <colindixon> #action xingjun_ it would be great if we could add links to the bugs in the known issues of the release notes for FaaS
17:15:55 <xingjun_> anipbu, not sure about the distribution test features
17:16:01 <LuisGomez> this project has features commented out in distribution test due to some timeout, is this still an issue?
17:16:03 <LuisGomez> https://git.opendaylight.org/gerrit/gitweb?p=integration/distribution.git;a=blob;f=features-test/src/main/resources/features.xml;h=d735ec0d24d868defc6d57d1f2c733768b9f8ea3;hb=refs/heads/stable/beryllium
17:16:07 <xingjun_> still working to push jamoluhrsen
17:16:35 <LuisGomez> if not please readd the faas features
17:16:52 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/31228/ link to asciidocs for FaaS in beryllium
17:16:55 <xingjun_> luisGomez we have fixed the bug, and will submit today
17:16:57 <colindixon> #action xingjun_ to add a link to https://git.opendaylight.org/gerrit/#/c/31228/ in the non-code section of the FaaS release review
17:17:18 <jamoluhrsen> xingjun, is there a system test plan?  if so, please link it from here: https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
17:17:28 <xingjun_> yes, there is a system test plan
17:17:31 <anipbu> #action faas to work on CSIT
17:17:35 <LuisGomez> #action xingjun_ to add faas features to distribution test
17:17:41 <xingjun_> Ok will link it
17:17:47 <anipbu> https://wiki.opendaylight.org/view/FaaS:SystemTestPlan
17:18:00 <anipbu> #link https://wiki.opendaylight.org/view/FaaS:SystemTestPlan <-- FaaS System Test Plan
17:18:06 <colindixon> #action xingjun_ should link to bugs listed in the bugzilla section of the FaaS release review rather than just listing them as text
17:18:22 <xingjun_> OK colin
17:18:27 <anipbu> #action faas to link system test plan to https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
17:18:38 <anipbu> are any of fass features experimental?
17:18:42 <xingjun_> no
17:18:44 <anipbu> what are the user facing features?
17:19:10 <xingjun_> defined in the user guide
17:19:20 <anipbu> xingjun_ have you tested against RC2 artifacts and were there any blockers?
17:19:31 <jamoluhrsen> did anyone ask about manual/external system tests?  xingjun do you have coverage somewhere?
17:19:46 <xingjun_> #link https://wiki.opendaylight.org/view/FaaS:User_Guide
17:20:17 <xingjun_> Yes, we did test RC2 this morning. no blockers, but a small issue. and investigation going on
17:20:34 <colindixon> xingjun_: so odl-faas-all is the only user-facing feature
17:20:46 <xingjun_> Yes, we have external tests scripts
17:20:52 <colindixon> as an aside, if it requires GBP, it should probably install that as well as part of it
17:21:10 <anipbu> #info user-facing features of fass: odl-faas-all
17:21:28 <xingjun_> Colin Ok
17:22:01 <xingjun_> odl-faas-all yes, that is the top feature we will enable it today
17:22:14 <colindixon> xingjun_: OK
17:23:15 <anipbu> #info fass has no experimental features
17:23:16 <xingjun_> jamoluhrsen, the external test scripts are submitted in the code base.
17:23:35 <jamoluhrsen> xingjun, you mean in the faas project itself?
17:23:40 <xingjun_> yes
17:23:48 <anipbu> #info faas test RC2 this morning. no blockers
17:23:48 <xingjun_> jamoluhrsen yes
17:24:26 <anipbu> We're behind by 4 minutes.  Do we need a follow up with FaaS?
17:24:35 <jamoluhrsen> xingjun, ok.  hopefully we can help you get robot system test working upstream in Integration/Test.
17:24:44 <jamoluhrsen> sorry anipbu.  no follow up needed.  I'm good
17:24:47 <xingjun_> jamo, thanks
17:25:03 <LuisGomez> i am good too
17:25:04 <anipbu> faas looks good to me as well.
17:25:05 <colindixon> ok
17:25:07 <colindixon> I'm good
17:25:16 <LuisGomez> just the action list
17:25:23 <anipbu> phrobb any comments
17:25:31 <anipbu> phrobb- any comments?
17:25:53 <colindixon> I think we should move on and we can get phrobb- later
17:25:56 <anipbu> Okay Let's move on
17:26:00 <anipbu> congrats faas
17:26:04 <xingjun_> thanks all
17:26:04 <anipbu> #topic LISPFLOWMAPPING
17:26:25 <anipbu> #info Vina Ermagan is representing LISPFLOWMAPPING
17:26:26 <vina_ermagan> https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Review
17:26:33 <LuisGomez> sorry i have to leave now, jamoluhrsen can cover integration for lisp
17:26:38 <vina_ermagan> https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Notes
17:27:18 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Review <-- Release Review
17:27:28 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Notes <-- Release Notes
17:28:16 <colindixon> #action vina_ermagan it would be good to call out the major feature in Beryllium for LFM in the release notes
17:28:27 <anipbu> vina_ermagan are any of your features experimental?
17:28:39 <anipbu> vina_ermagan have you tested against RC2 artifacts and were there any blockers?
17:28:40 <vina_ermagan> Neutron is marked experimental
17:29:06 <vina_ermagan> colindixon Ack, I will add the major features to Release Notes
17:29:28 <vina_ermagan> anipbu RC2.1 has been tested
17:29:34 <anipbu> #info neutron is marked as experimental
17:29:40 <vina_ermagan> RC2.1 passed all tests
17:29:41 <colindixon> vina_ermagan: removing the boilerplate "Only list requirements beyond the usual JRE requirements of OpenDaylight." in both places under target environment would be good and just say none beyond what ODL requires
17:29:51 <anipbu> #info lspflowmapping is tested in RC2.1 and no blockers
17:30:01 <colindixon> vina_ermagan: the migration section in release notes seems to have nothing to do with migration, am I missing something?
17:30:11 <jamoluhrsen> nothing to ask from system test side.
17:30:12 <vina_ermagan> colindixon Ack on removing boilerplates
17:31:20 <colindixon> #action vina_ermagan to make sure the EOLing sections on the release notes and release review match
17:31:30 <vina_ermagan> colindixon: Our NB API has changed to adopt IETF recently published YANG models
17:31:57 <colindixon> vina_ermagan: so, if you migrate from Li to Be, will you keep your mappings?
17:32:14 <colindixon> vina_ermagan: I understand the NB API changed, that's a compatibility issue
17:33:23 <anipbu> are all these features user facing: odl-lispflowmapping-msmr odl-lispflowmapping-southbound, odl-lispflowmapping-neutron, odl-lispflowmapping-ui
17:34:08 <vina_ermagan> colindixon: we will update the migration section of release notes.
17:34:13 <anipbu> vina_ermagan what are the list of user facing features in lispflowmapping
17:34:28 <anipbu> #action vina_ermagan to update the migration section of release notes
17:34:32 <colindixon> thanks anipbu
17:35:48 <anipbu> did I drop again?  can folks still read me?
17:35:53 <vina_ermagan> anipbu : yes
17:35:53 <colindixon> anipbu: I see you
17:36:03 <anipbu> vina_ermagan what are the list of user facing features in lispflowmapping?
17:36:04 <vina_ermagan> all user facing
17:36:10 <anipbu> okay, thanks
17:36:16 <anipbu> vina_ermagan  thanks
17:36:24 <anipbu> lispflowmapping looks good to me
17:36:43 <anipbu> colindixon phrobb any comments?
17:37:31 <jamoluhrsen> good by me.
17:37:39 <colindixon> I'm good assuming the above happens
17:37:57 <anipbu> Okay. Let's move on
17:38:02 <anipbu> congrats lispflowmapping
17:38:07 <anipbu> that's all the projects for today
17:38:10 <anipbu> thanks everyone
17:38:13 <vina_ermagan> colindixon anipbu thanks.
17:38:17 <anipbu> #topic cookies
17:38:32 <colindixon> thanks
17:38:35 <jamoluhrsen> that's it?  thanks guys.  have a good thursday.
17:38:42 <colindixon> see everyone in 20 minutes :p
17:38:47 <vina_ermagan> :)
17:38:48 <jamoluhrsen> oh yeah...
17:38:57 <anipbu> thanks colindixon jamoluhrsen LuisGomez phrobb
17:39:02 <anipbu> #endmeeting