15:30:14 <anipbu> #startmeeting beryllium release review
15:30:14 <odl_meetbot> Meeting started Fri Feb 12 15:30:14 2016 UTC. The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:30:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:14 <odl_meetbot> The meeting name has been set to 'beryllium_release_review'
15:30:18 <anipbu> #topic roll call
15:30:25 <anipbu> #info PTL and TSC members please #info in
15:30:25 <colindixon> #info colindixon for TTP, docs, and TSC
15:30:32 <anipbu> #info anipbu
15:31:07 <vjanandr> #info vjanandr for SNBI
15:31:32 <anipbu> Okay Let's get started
15:31:36 <anipbu> #topic SNBI
15:31:43 <anipbu> #link https://wiki.opendaylight.org/view/SNBI_Berrylium_Release_Notes <-- Release Notes
15:31:48 <anipbu> #link https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:BerylliumReleaseReview <-- Release Review
15:32:05 <anipbu> #info Vijay Anand R is representing SNBI
15:32:06 <vjanandr> https://git.opendaylight.org/gerrit/#/c/34063/ asciidoc
15:32:17 <anipbu> vjanandr: anything you would like to add?
15:32:27 <colindixon> does it require Java 7 or does it also work with Java 8
15:32:28 <colindixon> ?
15:32:34 <anipbu> vjanandr: are there any features you would like to mark as experimental?
15:32:37 <colindixon> oh, it says or above
15:32:42 <vjanandr> works with java7 and java8
15:32:55 <anipbu> vjanandr: have you tested against RC2 artifacts and were there any blocking issues?
15:33:05 <vjanandr> SNBI would be an experimental release for Beryllium
15:33:17 <vjanandr> I am yet to verify with RC2
15:33:23 <colindixon> "It is expected to finish the forwarding element coding and then interoperate with the controller in Beryllium release." did you finish it?
15:33:35 <vjanandr> yes this is done
15:33:43 <anipbu> #info SNBI would be an experimental release for Beryllium
15:33:50 <colindixon> #action vjanandr to not that "It is expected to finish the forwarding element coding and then interoperate with the controller in Beryllium release." was actually done in the release notes
15:33:56 <aleckey> #info aleckey for NetIDE
15:34:08 <colindixon> vjanandr: is migration supported, is it compatible with older versions? it looks like no
15:34:20 <vjanandr> no its not compatible with older version
15:34:27 <vjanandr> I have captured the change in the release note
15:34:28 <anipbu> #action vjanandr to verify against RC
15:34:51 <anipbu> vjanandr: what are the user facing features?
15:35:01 <vjanandr> SNBI registrar
15:35:05 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/34063/ patch for docs for Beryllium
15:35:25 <anipbu> #info user facing features: SNBI registrar
15:35:47 <phrobb> vjanandr The release review says this is the first release of SNBI. That is not the case right? Could you fix that?
15:35:59 <colindixon> vjanandr: it looks like you need to copy the EoL stuff from release notes to release review instead of saying it's the first release
15:36:02 <kalai> #info kalai for LACP
15:36:03 <vjanandr> yes this is not.. let me fix that
15:36:04 <vjanandr> thanks
15:36:08 <anipbu> vjanandr: what are the migration and capatibility issues?
15:36:34 <colindixon> #action vjanandr to note that the Be release of SNBI is not compatible with and does not support migration from the Li release on the release notes
15:36:52 <colindixon> #action vjanandr to copy EoL and deprecated things from the release notes to the release review for SNBI
15:37:02 <vjanandr> previous release used to support neighbor discovery on the registrar/controller..
15:37:02 <LuisGomez1> #LuisGomez1
15:37:10 <LuisGomez1> #info LuisGomez1
15:37:10 <vjanandr> this has been moved to the ForwardingElement
15:37:24 <anipbu> vjanandr: is your features in the distribution test features xml?
15:37:32 <colindixon> vjanandr: "No blocking issues identified as yet." probably makes sense just to drop that
15:37:42 <vjanandr> yes..
15:37:43 <vjanandr> ok
15:37:44 <vjanandr> will do
15:37:48 <anipbu> #chair colindixon LuisGomez1
15:37:48 <odl_meetbot> Current chairs: LuisGomez1 anipbu colindixon
15:37:57 <anipbu> #chair phrobb
15:37:57 <odl_meetbot> Current chairs: LuisGomez1 anipbu colindixon phrobb
15:38:50 <anipbu> vjanandr: any CSIT?
15:38:56 <vjanandr> I am working on the CSIT...
15:39:01 <vjanandr> I am not yet done with it
15:39:22 <anipbu> #action vjanandr to complete CSIT for SNBI
15:39:47 <anipbu> vjanandr: what are the migration and capatibility issues?
15:40:01 <vjanandr> I have captured that in the release not..
15:40:27 <vjanandr> The controller no longer supports neighbour discovery, only the registrar functionality is supported on the controller.
15:40:41 <vjanandr> previous release dint support the Forwarding Element Agent
15:40:57 <vjanandr> this is the first release that brings both together
15:41:27 <vjanandr> so I guess there shouldn't be a migration issue ?
15:41:52 <colindixon> vjanandr: I'll take your word for whatever you say, but make sure it's there and if you haven't tested it yet, say that
15:42:01 <anipbu> The release notes has migration and captaibility sections empty
15:42:15 <vjanandr> I have not tested with previous release..
15:42:28 <vjanandr> let me do that and I will capture that in the release note...
15:42:50 <vjanandr> I will update that section
15:43:41 <anipbu> Does SNBI have a test plan?
15:43:50 <vjanandr> https://wiki.opendaylight.org/view/SNBI_Berrylium_Test_plan
15:44:11 <anipbu> #link https://wiki.opendaylight.org/view/SNBI_Berrylium_Test_plan <-- SNBI System test plan
15:44:20 <anipbu> SNBI looks good to me
15:44:41 <LuisGomez1> vjanandr, would you consider your feature experimental at this moment?
15:44:47 <vjanandr> yes..
15:45:00 <vjanandr> SNBI would be an experimental feature for this release
15:45:01 <LuisGomez1> ok, i am good too
15:45:38 <anipbu> colindixon: phrobb: any additional comments?
15:45:55 <phrobb> No nothing else from me
15:46:40 <anipbu> Okay's Let's move on
15:46:51 <anipbu> congrats snbi
15:47:02 <vjanandr> thanks
15:47:26 <colindixon> I'm good if the actions above happen
15:47:33 <anipbu> Unfortunately Keith Burns will not be joining us today for GROUPBASEDPOLICY, so we will reschedule
15:47:38 <anipbu> #topic IOTDM (IoT Data Management)
15:47:43 <anipbu> #link https://wiki.opendaylight.org/view/Iotdm:Beryllium_Release_Notes <-- Release Notes
15:47:48 <anipbu> #link https://wiki.opendaylight.org/view/Iotdm:_Beryllium_Release_Review <-- Release Review
15:47:53 <anipbu> #info Lionel Florit will be representing IOTDM
15:48:05 <lflorit> Hello
15:48:08 <anipbu> lflorit: anything you would like to add?
15:48:17 <lflorit> no
15:48:21 <anipbu> Are IOTDM's features experimental?
15:48:37 <anipbu> lflorit: Are IOTDM's features experimental?
15:49:02 <colindixon> lflorit: you're missing the compatibility, migration, etc. sections for releases after the first
15:49:16 <anipbu> lflorit: have you tested against RC artifacts and were there any blocking issues?
15:49:28 <lflorit> no blocking issues
15:49:33 <anipbu> lflorit: what are the user facing features of IOTDM?
15:49:39 <colindixon> #action lflorit to complete the subsections under "Changes Since Previous Releases" from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
15:49:46 <anipbu> #info IOTDM has test against RC and no blocking issues
15:49:55 <lflorit> all features have been tested
15:50:03 <lflorit> some manually
15:50:09 <lflorit> most with robot
15:50:13 <colindixon> lflorit: are there updated asciidocs for Beryllium
15:50:24 <lflorit> no
15:50:46 <colindixon> lflorit: should there be, has anything changed?
15:50:51 <anipbu> I believe this is IOTDM's second release (first introduced in Lithium). So should there be a section on migration/captability with previous release?
15:51:03 <colindixon> anipbu: I got that above
15:51:04 <anipbu> nevermind, colindixon already asked
15:51:07 <lflorit> No we have fixed the format of the specification that has been changing under us
15:51:15 <LuisGomez1> it looks like most csit tests are failing for Beryllium: https://jenkins.opendaylight.org/releng/view/iotdm/job/iotdm-csit-1node-basic-only-beryllium/
15:51:20 <lflorit> but nothing has change in terms of how you use IoTDM
15:51:25 <lflorit> from the previous release
15:51:33 <anipbu> lflorit: Are IOTDM's features experimental?
15:51:38 <colindixon> anipbu, florinc: do you know if it's compatible with Li and/or if you can migrate from Li to Be with it?
15:51:48 <lflorit> I'm sorry I'm not sure what that means "experimental"
15:52:08 <anipbu> I mean, would like to voluntarily mark iotdm features as experimental.
15:52:43 <colindixon> lflorit: basically, if you don't think that somebody should try to use it in production
15:52:53 <colindixon> I think that's pretty much been the bar
15:52:57 <lflorit> no they can use it
15:53:30 <anipbu> #info iotdm features can be used in production
15:53:36 <anipbu> do you have a system test plan for iotdm?
15:54:13 <lflorit> we have Python scripts
15:54:14 <colindixon> anipbu: I'm happy at this point assuming we got an answer about user-facing feaures
15:54:19 <LuisGomez1> lflorit, is it normal most csit are failing?
15:54:50 <anipbu> I mean, does iotdm have this template filled out https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template
15:54:55 <LuisGomez1> https://jenkins.opendaylight.org/releng/view/iotdm/job/iotdm-csit-1node-basic-only-beryllium/
15:55:28 <lflorit> I don't think we do
15:55:36 <anipbu> lflorit: what are the user facing features of IOTDM?
15:55:57 <anipbu> #action lflorit to provide system test plan template for iotdm https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template
15:55:58 <lflorit> the oneM2M API
15:56:10 <anipbu> #info user facing features of iotdm: the oneM2M API
15:56:18 <anipbu> iotdm looks good to me
15:56:34 * colindixon is going to be distracted starting at 11:15, but I'll try to chime in when I can
15:56:39 <anipbu> LuisGomez1: phrobb: any additional comments?
15:56:50 <LuisGomez1> i have not got an answer for the failing csit tests
15:56:57 <phrobb> None from me anipbu
15:57:05 <colindixon> I want to see LuisGomez1 get his answer
15:57:20 <lflorit> I need to get back to you on this one
15:57:41 <colindixon> #info lflorit says that the docs haven't changed from Li, but that was intentional
15:58:07 <anipbu> #action lflorit to get back to why most csit are failing
15:58:14 <lflorit> ok
15:58:22 <anipbu> #info https://jenkins.opendaylight.org/releng/view/iotdm/job/iotdm-csit-1node-basic-only-beryllium/ <-- lflorit to get back to why most csit are failing
15:58:56 <colindixon> #action lflorit to follow up with anipbu and LuisGomez1 about why csit tests are faiing for IoTDM
15:58:57 <LuisGomez1> lflorit, have you tested iotdm manually?
15:59:12 <lflorit> yes for MQTT
15:59:24 <lflorit> python robot for others
16:00:05 <LuisGomez1> python robot you mean csit or your own pybot robot?
16:00:05 <lflorit> we have completed our robots test suite, we have more than 200 tests
16:00:37 <LuisGomez1> there are 195 tests failing
16:00:39 <lflorit> our own plus on Jenkins
16:00:46 <lflorit> got it
16:00:46 <LuisGomez1> ah ok
16:00:58 <LuisGomez1> ok, i am good
16:01:07 <anipbu> Okay's let's move on
16:01:11 <anipbu> congrats iotdm
16:01:15 <LuisGomez1> just the action to fix the csit
16:01:16 <anipbu> #topic LACP
16:01:35 <anipbu> #link https://wiki.opendaylight.org/view/LACP:Beryllium:Release_Notes <-- Release Notes
16:01:40 <anipbu> #link https://wiki.opendaylight.org/view/LACP:Beryllium:Release_Review <-- Release Review
16:01:44 <anipbu> #info Badrinath Viswanatha will be representing LACP
16:01:48 <anipbu> Badri: anything you would like to add?
16:02:05 <Badri> Kalai would also be providing details
16:02:33 <anipbu> #action lflorit: to fix the csit and to get back to LuisGomez1 regarding fix
16:02:50 <kalai> No changes in Lacp from Lithium
16:02:51 <anipbu> Kalai: anything you would like to add?
16:03:47 <kalai> clustering support alone added for LACP
16:04:09 <anipbu> kalai: are there any features you would like to mark as experimental?
16:04:35 <kalai> no
16:04:44 <anipbu> #info no experimental features in lacp
16:04:49 <kalai> we already have documentation and csit job for lacp
16:04:52 <anipbu> kalai: what the user facing features?
16:05:02 <kalai> odl-lacp-ui
16:05:10 <kalai> odl-lacp-rest, odl-lacp-plugin
16:05:23 <anipbu> #info odl-lacp-ui odl-lacp-rest, odl-lacp-plugin are user facing features in LACP
16:05:44 <anipbu> kalai: have you tested against RC and were there any blockers?
16:05:54 <kalai> we have tested with RC2.2
16:06:00 <kalai> no blockers for LACP
16:06:12 <anipbu> #info LACP has tested against RC with no blockers
16:06:23 <LuisGomez1> kalai, csit jobs are failing: https://jenkins.opendaylight.org/releng/view/lacp/job/lacp-csit-1node-lacp-only-beryllium/
16:06:31 <LuisGomez1> any idea why?
16:06:44 <kalai> no
16:06:52 <kalai> but we have csit jobs passing on sandbox
16:07:03 <kalai> https://jenkins.opendaylight.org/sandbox/job/lacp-csit-1node-lacp-all-stable-lithium/
16:07:14 <LuisGomez1> so it is test issue not controller issue?
16:07:34 <anipbu> #chair anipbu2
16:07:34 <odl_meetbot> Current chairs: LuisGomez1 anipbu anipbu2 colindixon phrobb
16:08:00 <LuisGomez1> same test passes in sandbox and not in relent?
16:08:07 <kalai> we had some issues regarding mininet hosts not sending pdus
16:08:10 <LuisGomez1> releng
16:08:16 <kalai> so we went for sandbox environment
16:08:32 <kalai> yes
16:08:45 <kalai> #luis yes
16:08:52 <LuisGomez1> ok, please follow up with int/test team to fix your test in releng
16:09:04 <kalai> ok
16:09:11 <LuisGomez1> i am good with lacp
16:09:20 <anipbu> #action kalai to follow up with int/test team to fix test in releng
16:09:34 <anipbu> kalai: do you have any pending docs patch?
16:09:53 <kalai> no documents are already updated
16:10:09 <phrobb> kalai given nothing has changed for Li to Be I assume there are no migration issues. Would you mind confirming that?
16:10:15 <kalai> yes
16:10:20 <kalai> no migration issues
16:10:24 <phrobb> thanks
16:10:30 <anipbu> #info no migration issues in LACP
16:10:37 <anipbu> lacp looks good to me
16:10:45 <anipbu> phrobb: any additional comments?
16:10:47 <phrobb> no more questions from me
16:10:52 <anipbu> Okay Let's move on
16:10:59 <anipbu> congrats lacp
16:11:14 <anipbu> #topic NETIDE
16:11:19 <anipbu> #link https://wiki.opendaylight.org/view/NetIDE:Release_Notes <-- Release Notes
16:11:28 <anipbu> #link https://wiki.opendaylight.org/view/NetIDE:Release_Review <-- Release Review
16:11:40 <anipbu> #info Alec Leckey will be representing NETIDE
16:11:47 <aleckey> Good morning all
16:11:52 <anipbu> aleckey: anything you would like to add?
16:12:03 <anipbu> aleckey: would you like to mark any of your features as experimental?
16:12:06 <aleckey> We tested with RC2 (vanilla) at start of this week. Only 1 x minor bug found, logged and fixed
16:12:30 <anipbu> #info NETIDE has tested against RC and found one minot bug (logged and fixed)
16:12:34 <anipbu> any blockers?
16:12:42 <aleckey> I don't think we're experimental, as we do have a system test in place (not automated)
16:12:55 <anipbu> #info NETIDE has no blocking issues from testing
16:13:14 <anipbu> #info netide has no experimental features
16:13:35 <anipbu> aleckey: are there any user facing features in netide?
16:13:48 <aleckey> odl-netide-rest
16:14:07 <anipbu> #info odl-netide-rest is user facing features of netide
16:14:40 <LuisGomez1> aleckey, you call system test 1 test case doing 1 rest call to a generic controller url?
16:14:42 <LuisGomez1> https://jenkins.opendaylight.org/releng/view/netide/job/netide-csit-1node-basic-only-beryllium/
16:14:45 <phrobb> aleckey: Do you have plans to put your docs in adoc so that we can add them to the PDF versions of the user guide, dev guide etc?
16:14:51 <LuisGomez1> or you have other system tests?
16:15:04 <aleckey> Manual external system testing was performed using the following test plan: https://wiki.opendaylight.org/view/NetIDE:Beryllium:System_Test
16:15:12 <aleckey> I do have a pending patch in Docs from M4 (our Developer/Userguides). Could I get someone to merge? https://git.opendaylight.org/gerrit/#/c/30562/
16:15:14 <LuisGomez1> ah ok
16:15:21 <anipbu> #info this is netide first release, so no migration issues
16:15:43 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/30562/ <-- pending docs patch
16:15:43 <phrobb> Yes colindixon is a bit backlogged on docs merges.
16:16:03 <aleckey> We have versions of userguide/dev guide on our project wiki page
16:16:09 <aleckey> also
16:16:09 <phrobb> #action colindixon to review/merge docs patch(es) for NetIDE
16:16:47 <LuisGomez1> aleckey, any plan to automate the manual system test soon?
16:17:18 <aleckey> ideally, the manual system test will be converted to ROBOT. As soon as we can...
16:17:30 <LuisGomez1> thanks
16:18:04 <phrobb> I don't have any other questions for aleckey
16:18:05 <LuisGomez1> i am good with netide
16:19:17 <anipbu> netide looks good to me as well
16:19:47 <anipbu> #info the manual system test will be converted to ROBOT as soon as possibel
16:19:53 <anipbu> Let's move on
16:19:57 <anipbu> congrats netide
16:20:03 <aleckey> Thanks guys
16:20:10 <anipbu> #topic NIC
16:20:16 <anipbu> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Release_Notes <-- Release Notes
16:20:25 <anipbu> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Beryllium_Release_Review <-- Release Review
16:20:38 <anipbu> #info Raphael Amorim is representing NIC
16:20:45 <raphaelamorim> here
16:20:51 <anipbu> raphaelamorim: anything you would like to add?
16:21:04 <raphaelamorim> just about documentation
16:21:24 <anipbu> raphaelamorim: have you tested against RC and were there any blockers?
16:21:25 <raphaelamorim> there's a lot of information on the wiki that is not on ascii
16:21:45 <raphaelamorim> no test blockers, but there's this patch https://git.opendaylight.org/gerrit/#/c/33932/
16:21:53 <anipbu> when can those information be moved from wiki to ascidocs?
16:21:57 <raphaelamorim> from openstack nbi that might cause issues
16:22:08 <raphaelamorim> I think today
16:22:16 <raphaelamorim> I can provide a patch
16:22:26 <phrobb> raphaelamorim That was going to be my first question on Docs. Can you get that information into adoc so that we can put it in the proper PDF guides?... that's where we are going to point all the users for Be docs
16:22:37 <raphaelamorim> around 3-4 pm
16:22:49 <anipbu> #info NIC tested on RC and no blockers
16:23:10 <raphaelamorim> hi phrobb that's the idea
16:23:29 <phrobb> Great, thanks raphaelamorim.
16:23:57 <anipbu> #action raphaelamorim: get information on wiki into adoc so that we can put it in the proper PDF guides
16:23:58 <phrobb> #action raphaelamorim and NIC team to get all docs on wiki into adoc prior to Be Release
16:24:09 <phrobb> anipbu :-)
16:24:21 <LuisGomez1> csit looks very short today, any plan to extend the system test?
16:24:30 <raphaelamorim> thanks I'll focus on that
16:25:12 <raphaelamorim> carmen kelling is working on adding more tests. He was working on adding other use cases.
16:25:17 <anipbu> raphaelamorim: this is NIC's second release, as it was in Lithium. Do you have a section on "Changes Since Previous Releases"
16:25:21 <phrobb> raphaelamorim Can you list NIC's user-facing features please?
16:25:54 <raphaelamorim> odl-nic-console
16:26:18 <anipbu> #info user facing features for nic: odl-nic-console
16:26:55 <raphaelamorim> odl-nic-core-service-mdsal
16:26:58 <raphaelamorim> odl-nic-core-service-hazelcast
16:27:29 <raphaelamorim> sorry, those got refactory recently
16:27:41 <phrobb> raphaelamorim, rephrasing anipbu's question: Are there any migration concerns/issues we need to make users aware of in the release notes as they go from Li to Be?
16:27:46 <raphaelamorim> so, those last 2 install nbi's
16:28:19 <anipbu> #undo
16:28:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x20d3250>
16:28:20 <raphaelamorim> Li release is a very experimental one, so I would say no problems.
16:28:37 <anipbu> #info user facing features for nic: odl-nic-console odl-nic-core-service-mdsal odl-nic-core-service-hazelcast
16:28:52 <LuisGomez1> are any of these features experimental?
16:29:18 <raphaelamorim> we're still an experimental project :D
16:29:36 <LuisGomez1> ok, that answers :)
16:30:11 <anipbu> #info all NIC features are considered experimental (NIC is still an experimental project)
16:30:29 <phrobb> raphaelamorim so you suggest that users continue to use NIC for PoC/lab types of activities in the Be release?
16:30:46 <raphaelamorim> phrobb: yes
16:30:54 <anipbu> #action raphaelamorim to update the sections on migration concerns/issues
16:30:58 <LuisGomez1> i am good with nic
16:31:13 <anipbu> raphaelamorim: even so, you should still state that there are no migration issues on the release notes
16:31:15 <phrobb> No more questions from me
16:31:22 <phrobb> thanks raphaelamorim!
16:31:27 <raphaelamorim> thanks
16:31:32 <anipbu> nic looks fine to me
16:31:37 <anipbu> Let's move on
16:31:41 <anipbu> congrats nic
16:31:47 <anipbu> #topic PACKETCABLE (PacketCable PCMM/COPS)
16:31:51 <anipbu> #link https://wiki.opendaylight.org/view/PacketCablePCMM:BerylliumReleaseReview <-- Release Review
16:31:56 <anipbu> #link https://wiki.opendaylight.org/view/PacketCablePCMM:BerylliumReleaseNotes <-- Release Notes
16:32:00 <anipbu> #info Kevin Kershaw is representing PACKETCABLE
16:32:13 <kkershaw> present - also Ryan Vail is joining me
16:32:17 <anipbu> kkershaw: anything you would like to add?
16:32:33 <kkershaw> No. Any questions from the review team?
16:33:06 <anipbu> kkershaw: 1) Have you tested against RC and were there any blockers? 2) Do you have any features that should be considered experimental? 3) What are the user-facing features in your project?
16:33:46 <kkershaw> We tested against RC2.1 - Ryan can confirm. We have not tested RC beyond that
16:34:06 <anipbu> any blockers found?
16:34:22 <rvail> None
16:34:22 <kkershaw> We have one user-facing feature: odl-packetcable-policy-server
16:34:45 <anipbu> #info packetcable tested against RC and no blockers found
16:34:45 <kkershaw> It is not considered experimental I think
16:35:01 <anipbu> can it be used in production?
16:35:11 <anipbu> #info have one user-facing feature: odl-packetcable-policy-server
16:35:48 <kkershaw> The provisioning model that it supports is not a full replacement for existing production systems so while it could be used in production
16:36:04 <kkershaw> it is probably not sufficient for all use cases
16:36:15 <anipbu> #info packetcable has no experimental features. ready for production.
16:36:31 <phrobb> kkershaw Do you have the documentation for PCMM in adoc so that it will be put into the proper PDF user/dev guides?
16:37:05 <kkershaw> I think this is perhaps a weakness on our part. We have more doc in the wiki that is not found in the adocs
16:38:30 <phrobb> kkershaw Would it be possible to get it into Adoc for the Be release? That's where we're pointing all the end users for docs... as we know from history that users aren't finding the docs when they are scattered
16:39:16 <anipbu> #action kkershaw to get wiki docs into Adoc for the Be release
16:39:27 <kkershaw> It would be possible. I need to find a resource here at Cablelabs for that work although I think it's not too great. What is the deadline we would need to meet?
16:39:31 <anipbu> kkershaw: do you have any migration issues?
16:39:48 <anipbu> kkershaw: try to get docs in as soon as possible
16:40:12 <phrobb> kkershaw we're trying to have solid docs for release next Thursday (2/18)
16:40:15 <kkershaw> anipbu - yes, there is a backward's compatibility issue in the REST APIs. This is documented in the release notes, I believe.
16:40:55 <kkershaw> phrobb - OK - I think we can get our docs in shape before then. Thanks.
16:41:04 <phrobb> Thanks kkershaw !
16:41:36 <anipbu> kkershaw: in addition to compatibility issues, we should mention that migration will be a problem for users on Li moving to Be if that is the case
16:41:50 <phrobb> did we get system test questions answered?
16:41:58 <LuisGomez1> i see this project has no csit, did it get a waiver?
16:42:16 <kkershaw> We have CSIT - I believe.
16:42:43 <LuisGomez1> ih yes
16:42:43 <anipbu> https://jenkins.opendaylight.org/releng/view/packetcable/job/packetcable-csit-1node-pcmm-all-beryllium/
16:42:48 <kkershaw> #link https://jenkins.opendaylight.org/releng/view/packetcable/job/packetcable-csit-1node-pcmm-all-beryllium/
16:43:05 <LuisGomez1> right, i neglected it
16:43:25 <phrobb> I have no more questions
16:43:31 <kkershaw> ...and we will add migration info to our adocs
16:43:32 <anipbu> LuisGomez1: the integration matrix may also https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1401406837
16:43:38 <anipbu> packetcable looks good to me
16:43:43 <LuisGomez1> thanks anipbu
16:43:52 <LuisGomez1> i am good with packetcable
16:44:07 <kkershaw> OK thanks very much to all of you. Enjoy your weekend.
16:44:15 <anipbu> Okay Let's move on
16:44:19 <anipbu> congrats packetcable
16:44:26 <anipbu> #topic VPNSERVICE
16:44:30 <anipbu> #link https://wiki.opendaylight.org/view/Vpnservice:Beryllium_Release_Notes <-- Release Notes
16:44:35 <anipbu> #link https://wiki.opendaylight.org/view/Vpnservice:Beryllium_Release_Review <-- Release Review
16:44:40 <anipbu> #info Prem Sankar will be representing VPNSERVICE
16:44:45 <anipbu> Prem_: anything you would like to add
16:45:07 <Prem_> This was an important release for VPNService
16:45:24 <Prem_> This is also getting upstreamed to OPNFV as part of SDNVPN
16:45:24 <LuisGomez1> why so?
16:45:34 <LuisGomez1> cool
16:45:46 <anipbu> Prem_: 1) Have you tested against RC and were there any blockers? 2) Do you have any features that should be considered experimental? 3) What are the user-facing features in your project?
16:46:16 <Prem_> Yes, we have tested with all RCs and no blockers
16:46:43 <Prem_> ELAN can be called as experimental. This was not in original scope
16:46:55 <Prem_> odl-vpnservice-core is the main user-facing feature
16:47:22 <Prem_> we also have odl-vpnservice-openstack - for Openstack BGPVPN integration
16:47:42 <phrobb> Prem_ Your "Known Issues" section of the release notes seems ot still have the boiler plate info
16:48:04 <anipbu> #info spnservice has tested against RC and no blockers found
16:48:14 <Prem_> sorry, we have 2 more defects that are open
16:48:25 <Prem_> analysis is going on and hence have not updated it
16:48:32 <anipbu> #info ELAN is experimental features
16:48:42 <anipbu> #info odl-vpnservice-core is the main user-facing feature
16:48:55 <anipbu> #undo
16:48:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1fd3990>
16:48:56 <Prem_> will update if these 2 bugs are not addressed
16:49:15 <anipbu> info user facing features: odl-vpnservice-core odl-vpnservice-openstack
16:49:25 <LuisGomez1> Prem_ some csit tests are failing, do you know why?
16:49:27 <LuisGomez1> https://jenkins.opendaylight.org/vpnservice/job/vpnservice-csit-1node-vpnservice-only-beryllium/
16:49:29 <Prem_> Yes
16:49:48 <phrobb> Prem_ Also, the "Migration from Previous Releases" and "Compatibility with Previous Releases" section fo the Release Notes would benefit with a bit more explanation that just "Yes". :-)
16:49:52 <Prem_> Sorry, that is a weak area
16:49:59 <anipbu> Prem_: the two open defects are NOT blockers. Is that correct?
16:50:12 <Prem_> We have just raised another patch with new set of test cases
16:50:24 <Prem_> once this is in - we will have these addressed
16:50:44 <LuisGomez1> thanks
16:50:51 <Prem_> we were doing good in System test with respect to Li, but had a bit of setback in Be :(
16:51:00 <phrobb> #action Prem_ to review/update the Release Notes "Known Isusues", "Migration", and "Capatibilitiy"
16:51:09 <Prem_> phrobb: I will update more about that. Sure
16:51:22 <Prem_> anipbu: The are not blockers
16:51:27 <phrobb> Prem_ Thanks!
16:51:31 <anipbu> #info no blockers in VPNSERVICE
16:52:12 <Prem_> phrobb: We will also refresh the wiki pages and design doc section with more info
16:52:28 <phrobb> Prem_ are there any docs on the wiki not in the adoc? We are trying to have the adoc be the be-all, end-all for end user documentation.
16:52:29 <Prem_> phrobb: The userdoc is updated and review pending
16:52:40 <anipbu> what is teh patch id?
16:52:47 <Prem_> phrobb: They are in adoc
16:53:01 <phrobb> Excellenet Prem_ , thanks
16:53:03 <Prem_> anipbu: I had mentioned it in release review and let me pull it
16:53:25 <Prem_> 30978
16:53:27 <anipbu> #info vpnservice has pending docs https://git.opendaylight.org/gerrit/#/c/30978/
16:53:40 <anipbu> Prem_: thanks
16:54:04 <Prem_> phrobb: We will also try to make a video or tutorial for this
16:54:05 <phrobb> I have no more questions
16:54:20 <LuisGomez1> vpnservice is good for me
16:54:22 <Prem_> phrobb: mostly like demo and
16:54:50 <phrobb> That would be outstanding Prem_ ! We'll take this offline, but I'd love to know if you could have something ready for the Booth at ONS :-)
16:55:14 <Prem_> phrobb: We will aim for it :)
16:55:30 <anipbu> #action Prem_ to address CSIT failures
16:55:30 <phrobb> Great!
16:56:07 <anipbu> #info VPNSERVICE have just raised another patch with new set of test cases
16:56:13 <anipbu> vpnservice looks good to me
16:56:21 <anipbu> Okay Let's move on
16:56:30 <anipbu> congrats vpnservice
16:56:58 <anipbu> OFCONFIG never responded to the meeting invite or the release review schedule
16:57:00 <Prem_> Thanks An Ho, Phil and Luiz and have a great weekend!
16:57:01 <pradeeban1> #info Pradeeban for Messaging4Transport.
16:57:08 <phrobb> Thanks Prem_
16:57:17 <anipbu> So we will have to skip OFCONFIG and reschedule
16:57:44 <anipbu> #anipbu and Wei Meng will reschedule for OFCONFIG
16:57:51 <anipbu> #action anipbu and Wei Meng will reschedule for OFCONFIG
16:57:57 <anipbu> #topic MESSAGING4TRANSPORT
16:58:02 <anipbu> #link https://wiki.opendaylight.org/view/Messaging4Transport:Beryllium:Release_Notes <-- Release Notes
16:58:06 <anipbu> #link https://wiki.opendaylight.org/view/Messaging4Transport:Beryllium:Release_Review <-- Release Review
16:58:10 <anipbu> #info Pradeeban Kathiravelu is representing MESSAGING4TRANSPORT
16:58:18 <anipbu> Pradeeban: anything you would like to add?
16:58:46 <pradeeban1> anipbu, Messaging4Transport was developed as a part of OpenDaylight Summer Internship 2015.
16:58:55 <anipbu> pradeeban1: 1) Have you tested against RC and were there any blockers? 2) Do you have any features that should be considered experimental? 3) What are the user-facing features in your project?
16:59:59 <pradeeban1> 1. There were no blockers in RC found. 2. As pointed out by Luiz in an email, probably Messaging4Transport should be considered experimental, since it lacks complete external system tests. 3. User facing features is, odl-messaging4transport
17:00:33 <anipbu> #info Messaging4Transport tested against RC and found no blockers
17:00:51 <anipbu> #info all Messaging4Transport features are considered experimental
17:00:58 <phrobb> pradeeban1 Do you have your documentation in adoc format as well as on the wiki? If not, can you put it there?
17:01:14 <anipbu> #info user facing features in Messaging4Transport: odl-messaging4transport
17:01:30 <pradeeban1> yes, of course. However, the patch was never merged. I have already sent an email to the documentation team. Let me get the patch ID.
17:02:14 <anipbu> what is the patch ID?
17:02:18 <pradeeban1> https://git.opendaylight.org/gerrit/#/c/30724/
17:02:29 <LuisGomez1> i am good with this feature as experimental
17:02:32 <phrobb> pradeeban1 Great, thanks. Our docs committer list is a bit short at the moment (aka Colin Dixon). I know he's looking to get many reviews/merges done asap
17:02:56 <pradeeban1> There are a few other wiki pages listed from https://wiki.opendaylight.org/view/Messaging4Transport:Main as well
17:03:25 <phrobb> Do you feel you have all end-user-relevant docs in adoc?
17:03:27 <pradeeban1> For example, some prototypes built extending the model of M4T - https://wiki.opendaylight.org/view/Messaging4Transport:Use_Cases
17:03:29 <anipbu> #info pending docs patches https://git.opendaylight.org/gerrit/#/c/30724/
17:04:11 <pradeeban1> phrobb, yes, in 2 docs - user guide and installation guide
17:04:17 <pradeeban1> developer guide
17:04:47 <anipbu> #info M4T has all end-user relevant docs in adoc: in 2 docs - user guide and installation guide
17:04:51 <phrobb> Great, thanks pradeeban1 !
17:05:15 <pradeeban1> anipbu, I meant, user guide (including installation guide) and developer guide. sorry for the confusion in wording.
17:05:24 <anipbu> #undo
17:05:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1eb66d0>
17:05:34 <pradeeban1> developer.adoc and user.adoc
17:05:35 <anipbu> #info M4T has all end-user relevant docs in adoc: in 2 docs - user guide and developer guide
17:05:40 <phrobb> I have no more questions.
17:05:57 <anipbu> Messaging4Transport looks good to me
17:06:04 <anipbu> Okay Let's move on
17:06:08 <anipbu> congrats messaging4Transport
17:06:09 <phrobb> Actually, one more....
17:06:25 <pradeeban1> Thanks anipbu, phrobb, and LuisGomez1. Have a great weekend.
17:06:28 <phrobb> M4T requires Java 7, and will not work with Java 8?
17:06:34 <anipbu> pradeeban1: ^^^^
17:06:44 <pradeeban1> phrobb, it works with java8, and tested with java8.
17:06:48 <anipbu> pradeeban1: one more question ^^^^
17:07:02 <pradeeban1> phrobb, (it requires java7 or higher.)
17:07:09 <phrobb> Can you update the release notes to reflect that?
17:07:23 <LuisGomez1> thanks pradeeban1
17:07:31 <pradeeban1> phrobb, sure. will do.
17:07:52 <phrobb> #action pradeeban1 to update release notes to include support for Java 8 as well as 7
17:08:15 <anipbu> phrobb: any additional comments?
17:08:22 <phrobb> Now I have no more questions. thanks pradeeban1
17:08:31 <anipbu> Okay Let's move on
17:08:33 <pradeeban1> Thank you
17:08:42 <anipbu> #topic OPENFLOWPLUGIN
17:08:47 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Beryllium_Release_Notes <-- Release Notes
17:08:51 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Beryllium_Release_Review <-- Release Review
17:08:55 <abhijitkumbhare> Yes
17:08:55 <anipbu> #info Abhijit Kumbhare is representing OPENFLOWPLUGIN
17:09:06 <anipbu> abhijitkumbhare: anything you would like to add?
17:09:28 <abhijitkumbhare> The release review template has been filled in
17:09:33 <anipbu> abhijitkumbhare: 1) Have you tested against RC and were there any blockers? 2) Do you have any features that should be considered experimental? 3) What are the user-facing features in your project?
17:09:45 <abhijitkumbhare> And at three places I have mentioned the following
17:09:59 <abhijitkumbhare> Helium design will be deprecated in Boron and projects will be asked to move to the Lithium design (target: Beryllium service release). Any new Boron development will be done on the Lithium design only.
17:10:11 <abhijitkumbhare> In the release notes and release review
17:10:24 <abhijitkumbhare> (that was what you would like to add)
17:10:47 <abhijitkumbhare> About 1 - there are no blockers currently
17:11:23 <abhijitkumbhare> About 2 - no experimental features
17:11:44 <abhijitkumbhare> About 3 - only user facing are the REST API
17:12:00 <abhijitkumbhare> for things like flow addition/deletion
17:12:16 <abhijitkumbhare> otherwise mostly an infrastructure component
17:12:27 <anipbu> #info OPENFLOWPLUGIN tested against RC and no blockers found
17:12:39 <anipbu> #info OPENFLOWPLUGIN has no experimental features
17:13:47 <anipbu> abhijitkumbhare: what the name of the user facing feature?
17:13:55 <phrobb> abhijitkumbhare For the Release Notes, Is there value in mentioning to the end user that there are two designs when all components in Be initial release only use the He design?
17:14:21 <abhijitkumbhare> I can remove that phrobb
17:14:34 <abhijitkumbhare> From the release notes
17:15:02 <abhijitkumbhare> but I think it makes sense for the release review - right?
17:15:11 <phrobb> Thanks, similarly in the Deprecated EoL section. No need to confuse the user with deprecation that will be occuring in the next release
17:15:32 <abhijitkumbhare> OK - will remove that as well
17:15:40 <phrobb> Yes, makes sense in release review (our dev internal doc) but not the release-notes - end-user-facing doc
17:16:02 <abhijitkumbhare> In that case - I can keep the list of bugs to be only the ones applicable to Helium design
17:16:23 <phrobb> Correct. It's all about not confusing the user :-)
17:16:29 <LuisGomez1> right, i agree with phrobb, we keep the plugins internal
17:16:32 <abhijitkumbhare> OK :)
17:16:40 <abhijitkumbhare> Makes sense
17:16:44 <anipbu> +1 don't confuse end users :)
17:17:20 <abhijitkumbhare> Will update the release notes to remove the info about the 2 designs
17:17:35 <anipbu> #action abhijitkumbhare to update release notes and remove the info about the 2 designs
17:17:46 <abhijitkumbhare> and keep the bugs only about the Helium design
17:18:03 <LuisGomez1> openflowpugin has functional, perf/scal, longevity and cluster csit tests in place so no questions on that area :)
17:18:11 <anipbu> #action abhijitkumbhare to update bug list to helium design
17:18:34 <phrobb> abhijitkumbhare: No migration issues at all for the user re clustering or anything else?... what they may need to do going from Li to Be?
17:18:36 <anipbu> #info openflowpugin has functional, perf/scal, longevity and cluster csit tests in place
17:19:17 <abhijitkumbhare> No migration issues - the clustering support is new
17:19:53 <phrobb> Fair enough. I have no more questions for OFPlugin, Thanks for all your work on this abhijitkumbhare
17:20:03 <anipbu> openflowplugin looks good to me
17:20:13 <anipbu> Okay Let's move on
17:20:21 <anipbu> congrats openflowplugin
17:20:43 <anipbu> #topic OPFLEX
17:20:45 <anipbu> #link https://wiki.opendaylight.org/view/OpFlex:Beryllium_Release_Notes <-- Release Notes
17:20:49 <abhijitkumbhare> thanks phrobb and anipbu
17:20:51 <anipbu> #link https://wiki.opendaylight.org/view/OpFlex:Beryllium_Release_Review <-- Release Review
17:20:56 <anipbu> #info Rob Adams is representing OPFLEX
17:21:00 <readams> #info Tested externally against OpenStack and ACI plus unit tests in ODL build
17:21:04 <readams> #info no experimental features
17:21:09 <readams> #info no Karaf features at all
17:21:27 <anipbu> readams: thanks
17:23:00 <anipbu> #info opflex has been tested against external RC artifacts of OpFlex. No blockers found. There are no experimental features in opflex. There are no user-facing features in opflex.
17:23:29 <anipbu> Do you have link to external RC artifacts you have been testing?
17:23:48 <readams> They're the ones in the latest Be merge task
17:24:11 <readams> Currently all we can build using ODL infra are the source tarballs
17:24:37 <anipbu> #info Tested externally against OpenStack and ACI plus unit tests in ODL build. opflex system test plan https://wiki.opendaylight.org/view/OpFlex:Beryllium_Feature_Integration_System_Test
17:25:08 <anipbu> #info opflex RC artifacts are located in latest Be merge task
17:26:00 <anipbu> readams: do you have any pending docs patches?
17:26:08 <readams> none pending no
17:26:17 <readams> actually I don't think there were any docs changes this cycle
17:26:50 <LuisGomez1> so i guess we will have link the tar balls in the release page. was this the case last release?
17:27:11 <readams> Last release we put them in as gz artifacts in maven
17:27:28 <readams> Not that this adds a ton of value for anyone, but at least they're archived permanently
17:28:03 <anipbu> readams: we should do the same thing for this release as well
17:28:52 <readams> It's possible to build RPM and DEB packages for Ubuntu 14.04 and RHEL 7 directly from those source tarballs.
17:28:57 <anipbu> LuisGomez1: I *hope* that we can get opflex and nextuitoolkit to upload their final release artifacts to nexus before the release next week.
17:29:27 <LuisGomez1> ok
17:29:55 <phrobb> readams is there anyplace in the docs that tell the user where to get the OpFlex .gz file?.. I'm not finding it in the "getting started" guide
17:30:36 <readams> Um, I don't think so. Honestly the hidden previous step to "getting started" is probably "talk to Rob and he'll give you binary packages" :-)
17:31:22 <phrobb> Can we get something in there pointing to the artifact?... or a link to your email address ;-)
17:31:29 <readams> Though the build guide can be used with the tarballs
17:32:17 <readams> We can try. Not sure if I know where the released artifacts final location will be
17:32:49 <readams> Probably it would go in the dev guide rather than the getting started guide?
17:33:44 <anipbu> #action readams to work with anipbu and zxiiro to upload the final release artifacts for opflex into some public location, such as nexus, etc.
17:34:27 <phrobb> readams If you are an end user just wanting to "use" OpFlex in your environemnt (ie you already have apps that take advantage of it), how would you contstuct an ODL/OpFlex config to do that?... that would be the question I think
17:34:54 <readams> I think that much is covered in the docs
17:35:16 <readams> The default config file itself is also heavily commented
17:36:06 <phrobb> Sounds good readams . Just want to make sure the user can get what they need.
17:36:25 <phrobb> I've got no more questions. Thanks readams !
17:36:30 <anipbu> opflex looks good to me
17:36:43 <anipbu> LuisGomez1: any additional comments?
17:37:02 <LuisGomez1> since this project does not run in ODL controller, i do not have integration questions :)
17:37:14 <anipbu> Okay Let's move on.
17:37:18 <readams> Thanks, folks!
17:37:18 <anipbu> congrats opflex
17:37:25 <anipbu> that's all the projects we have today
17:37:28 <anipbu> so we're done
17:37:49 <anipbu> thanks phrobb LuisGomez1 colindixon
17:37:50 <phrobb> Yep, thanks anipbu and LuisGomez1 for all the great questions
17:38:01 <anipbu> #topic cookies
17:38:16 <LuisGomez1> thanks
17:38:18 <anipbu> #endmeeting