15:30:42 <anipbu> #startmeeting beryllium weekly sync
15:30:42 <odl_meetbot> Meeting started Wed Jan 13 15:30:42 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:30:42 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:42 <odl_meetbot> The meeting name has been set to 'beryllium_weekly_sync'
15:30:52 <anipbu> #topic roll call
15:31:16 <anipbu> Good Morning!
15:31:19 <anipbu> Folks, please info your projects
15:31:30 <Prem> #info Prem for VPNService
15:31:42 <LuisGomez> #info LuisGomez for integration
15:31:53 <lori> #info lori for lispflowmapping
15:31:59 <yamahata> #info yamahata for neutron northbound
15:32:07 <davidmichaelkarr> #info yangide
15:32:20 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Weekly_Sync_Meeting#Agenda <- Agenda for Beryllium Weekly Sync
15:32:31 <gvrangan> #info Venkat for VTN
15:33:10 <rgoulding> #info rgoulding for AAA
15:33:28 <zxiiro> #info Thanh releng
15:33:40 <vrpolak> #info vrpolak for integration/distribution
15:33:56 <anipbu> #info anipbu for usc nemo
15:34:06 <zxiiro> Just an FYI to everyone here we had to kick Jenkins this morning due to some issues we're seeing. We're getting it back online now
15:34:34 <davidmichaelkarr> (Is there a point to adding your name to info when the name is implicit?)
15:35:12 <zxiiro> davidmichaelkarr: not everyone recognizes your username
15:35:20 <aleckey> #info Alec Leckey (NetIDE)
15:35:23 <zxiiro> davidmichaelkarr: for example I don't use my real name as my username
15:35:40 <anipbu> Any other folks please info your projects?
15:35:48 <anipbu> Let's move on to blocking issues.
15:35:56 <anipbu> #topic blocking issues
15:36:36 <anipbu> #info Just an FYI to everyone here we had to kick Jenkins this morning due to some issues we're seeing. We're getting it back online now
15:37:34 <anipbu> zxiiro: thanks for the update on Jenkins
15:37:51 <LuisGomez> thanks, it was quite slow yesterday night
15:38:18 <zxiiro> yeah Jenkins was 700% CPU when i saw it, it was not happy this morning :(
15:38:37 <anipbu> zxiiro: do we know the root cause?
15:38:54 <adetalhouet> #info adetalhouet
15:39:18 <zxiiro> anipbu: likely got overloaded and never recovered
15:39:39 <anipbu> zxiiro: okay. thanks.
15:39:59 <yuling> #info yuling
15:41:36 <anipbu> If any projects have any blocking issues they would like to bring up, please feel free to chime in.
15:42:21 <davidmichaelkarr> Well, if Robert Varga is around, I could use an email reply from him.
15:42:24 <vrpolak> We should probably talk about two OpenFlowPlugin implementations we have in place.
15:42:43 <Prem> General Qn -- How do we update  the copyright string to reflect 2016?
15:43:08 <vrpolak> Some projects pull features for one, other project for other and in runtime one of them fails to bind port.
15:43:11 <adetalhouet> vrpolak: +1
15:43:24 <anipbu> #info davidmichaelkarr asks robert varga to respond to email inquiries about yangtools
15:43:46 <anipbu> #info OpenFlowPlugin implementations
15:44:01 <anipbu> vrpolak could you elaborate
15:44:03 <adetalhouet> I'm really interested in knowing what are the "obvious" different between the two, and why one of them is not compatible with the other features ODL provide
15:45:04 <vrpolak> There are several possible solution, differing on ugliness and which project will end up doing most of work. My favourite is to open Bug against Openflowplugin project to rework that to have only one set of features and leave it to a config .xml file to choose which one gets started (similarly to what PCEP does for the two drafts it supports).
15:45:30 <lori> Prem: I think you shouldn't do a blanket update of copyright strings, in general if you modify a file with an existing copyright header, you have two options: if the year span is continuous, you use xxxx-yyyy notation, if docontinuous you use a comman
15:46:20 <Prem> lori: Thanks!
15:46:20 <anipbu> #info adetalhouet says we currently have two OpenFlowPlugin implementations in place and wants to know why one of them is not compatible with the other features ODL provide
15:46:36 <vrpolak> From what I have heard, both OFP implementations have the same API but somewhat different behaviors. Conflict is when two instances try to bind to the same port.
15:47:06 <Prem> vrpolak: I had the same qn - how will the conflict be resolved
15:47:57 <LuisGomez> vrpolak, i think the issue is to figure out how we are going to ship Beryllium if 2 applications require different version of the plugin
15:48:33 <vrpolak> Some other solutions: Require every project to use only one implementation (possibly offering optional features for the other one, but those features will not be tested much).
15:48:37 <LuisGomez> as from that point we have to tell users these applications are not compatible
15:49:16 <yuling> Question regarding the copyright: do we need to change the copyright of each class to include "2016"?
15:49:16 <vrpolak> Another solution: Create two different karaf distributions, each with only one implementation so that conflict cannot happen.
15:50:39 <LuisGomez> i think we need to bring this issue to next TSC call…
15:50:49 <zxiiro> yuling: you only need to change it if you made changes to it in 2016
15:51:07 <yuling> ah.. I see. Thanks.
15:51:07 <vrpolak> Either way, integration/distribution has verify job which checks for port conflict, so everytime a project chooses to switch its dependency, integration/distribution stops being able to move forward; so current situation is quite time-consuming and unpleasant.
15:51:43 <zxiiro> yuling: there's an eclipse plugin that you can use and it will handle license headers automatically for you https://wiki.eclipse.org/Development_Resources/How_to_Use_Eclipse_Copyright_Tool
15:52:03 <zxiiro> if you use eclipse that is
15:52:26 <anipbu> #info Both OFP implementations have the same API but somewhat different behaviors. Conflict occurs when two instances try to bind to the same port.  We need to find solution for how to ship Beryllium if two applications require different version of the plugin.
15:53:23 <anipbu> #info possible solutions: 1) Require every project to use only one implementation.  2) Create two different karaf distributions
15:53:46 <zxiiro> yuling: the first year is most important, then if you modify the file in another year you add ", 2016" to it. You only change the copyright owner if your company makes significant modifications to the code (ie, changed more than 50% of the code in that file) otherwise copyright should stay with the original author.
15:54:25 <anipbu> #info LuisGomez says we should bring OFP up for TSC call tomorrow
15:54:49 <yuling> I see... thanks zxiiro for the info.
15:55:08 <zxiiro> yuling: to be clear about changing copyright owner. You don't "change" the line rather you add a new line to lise an additional copyright owner starting with a new year if they make more than 50% of the code changes in that file. There should be a list of all copyright owners since the beginning of the file's existance
15:55:20 <vrpolak> There was also 0) Unify OFP features and choose active implementation via config subsystem.
15:55:20 <LuisGomez> anipbu, there is 3) which is document very well which applications work with which plugin and are compatible among them but i think that is kind of burden to the users.
15:56:00 <anipbu> #info possible solutions: 3) document which applications work with which plugin
15:56:17 <LuisGomez> vrpolak, 0) requires 3) very good documentation on how to use the features
15:56:20 <anipbu> LuisGomez: thanks.
15:56:39 <yuling> Got it...thanks zxiiro.
15:56:50 <yuling> B.T.W., a question for Luis... can we still make changes to integration/test? For example, changing the feature test name from odl-tsdr-h2-all to odl-tsdr-hsql-all?
15:57:06 <anipbu> #action anipbu send email to add OFP discussion to tomorrow's TSC call.
15:58:01 <LuisGomez> sure yuling
15:58:16 <yuling> Great...thanks.
15:59:46 <anipbu> #info yuling asked about making changes to integration/test such as renaming feature test name.  LuisGomez says that's okay.
16:00:20 <LuisGomez> changing the name of a feature nobody depends on is not a big deal, and can be done at any time imo
16:00:45 <LuisGomez> just remember to updte distribution repo
16:01:00 <LuisGomez> as otherwise it will break
16:02:14 <LuisGomez> btw these changes (feature name) are not in integration/test but in project repo
16:02:26 <yuling> We didn't really want to change the name at such late stage. However, there's a bug and we probably have to change. Still working on the fix to avoid such change.
16:02:51 <anipbu> #info reminder to update distribution repo if there are name changes, otherwise it will break distribution
16:03:39 <LuisGomez> +1 anipbu, this is very common neglect
16:03:43 <adetalhouet> if there are _feature_ name changes
16:04:15 <anipbu> #undo
16:04:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1fd81d0>
16:04:26 <anipbu> #info reminder to update distribution repo if there are feature name changes, otherwise it will break distribution
16:04:36 <adetalhouet> ;) I think it's clearer like that
16:07:24 <anipbu> #info Copyright notice: if you modify a file (make code changes) with an existing copyright header, you have some options:  copyright year can use xxxx-yyyy notation if continuous or comma if discontinuous.  copyright owner can be updated if your company makes significant modifications to the code (>50%).  Add a new line to list additional copyright owner
16:07:24 <anipbu> starting with a new year.  There should be a list of all copyright owners since the beginning of the file's existence.
16:08:29 <anipbu> #action robertvarga should respond to email inquiries about yangtools from davidmichaelkarr
16:08:49 <anipbu> Okay, any other topics folks want to raise?
16:08:55 <anipbu> #topic red flags
16:09:08 <anipbu> we're past the hour
16:09:44 <anipbu> #action abhijitkumbhare to respond to inquiries about conflicting OFP version issues
16:10:06 <anipbu> #info reminder that M5 Code Freeze is tomorrow for offset 2 projects
16:10:29 <anipbu> #info we will also be doing Branch Cutting
16:11:06 <anipbu> zxiiro: i believe this is something that releng will do automatically for projects, so no actions required from projects.
16:11:43 <anipbu> any last minute topics to raise?
16:11:52 <anipbu> going once
16:12:03 <anipbu> goince twice
16:13:06 <anipbu> Okay, thanks folks for joining.
16:13:08 <anipbu> #topic cookies
16:13:19 <anipbu> #endmeeting