15:30:22 <anipbu> #startmeeting beryllium weekly sync
15:30:22 <odl_meetbot> Meeting started Wed Jan 20 15:30:22 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:30:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:22 <odl_meetbot> The meeting name has been set to 'beryllium_weekly_sync'
15:30:32 <anipbu> #topic roll call
15:30:50 <colindixon> #info colindixon for docs, ttp, and TSC
15:30:53 <anipbu> Folks, please info your projects
15:31:13 <anipbu> Morning Colin
15:31:50 <LuisGomez> #info LuisGomez integration
15:32:36 <colindixon> ah, that feels better
15:33:32 <yamahata> #info yamahata for neutron northbound
15:34:32 <anipbu> #chair zxiiro anipbu colindixon
15:34:32 <odl_meetbot> Current chairs: anipbu colindixon zxiiro
15:34:40 <anipbu> #info anipbu for usc nemo
15:34:48 <zxiiro> #info Thanh releng
15:35:02 <anipbu> Any other folks please info your projects?
15:35:08 <anipbu> Let's move on to blocking issues.
15:35:14 <anipbu> #topic blocking issues
15:35:16 <ChristineH> #info ChristineH for snmp4sdn
15:35:47 <anipbu> If any projects have any blocking issues they would like to bring up, please feel free to chime in.
15:36:11 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&list_id=45711&query_format=advanced&resolution=--- for what it's worth this is the lists of blocking bugs in bugzilla
15:38:31 <anipbu> zxiiro: are the validate-autorelease jobs fixed?
15:39:00 <colindixon> there's a weather event coming in here: https://bugs.opendaylight.org/show_bug.cgi?id=4295
15:39:21 <zxiiro> anipbu: yes, we need to somehow get all lprojects to realize they need to rebase their work though
15:39:39 <zxiiro> otherwise this breakage will keep happening
15:39:59 <colindixon> zxiiro: can we change that?
15:40:02 <colindixon> to auto-rebase?
15:40:16 <colindixon> I guess not
15:40:29 <colindixon> I know robert talked about this a while ago
15:40:44 <anipbu> #info All projects need to rebase their work to prevent breaking validate-autorelease jobs.
15:40:48 <zxiiro> rebase if necessary is an option but I'm not sure what "if necessary" means
15:40:53 <anipbu> #info https://lists.opendaylight.org/pipermail/release/2016-January/005259.html <-- email thread
15:41:27 <zxiiro> colindixon: we could try setting prjoects to rebase if necessary instead of merge if necessary
15:41:43 <zxiiro> colindixon: no wait, that wouldn't cause a revalidate though
15:41:46 <zxiiro> so that wouldn't help
15:41:58 <colindixon> https://git.opendaylight.org/gerrit/#/q/topic:be/migration/mdsal+status:open is it true that these two projects haven't moved to using the mdsal project yet? If so, does that mean they aren't buidling in autorelease?
15:42:26 <zxiiro> colindixon: what we really need is a pre-merge gate that runs validate-autorelease just before a merge happens and blocks the merge if it fails
15:42:43 <zxiiro> unfortunately that's something we don't have the ability to do at the moment
15:43:31 <anipbu> ChristineH: has snmp4adn moved to mdsal?
15:43:36 <colindixon> #info zxiiro says that we really need pre-mege gating avoid critical failures that might slip through the lack of rebasing on validate
15:44:01 <colindixon> anipbu: I think that's about moving to the MD-SAL project instead of pulling in the mdsal artifacts from the controller
15:44:43 <LuisGomez> zxiiro, why do not add a rebase in your autoreleas verify job?
15:45:37 <LuisGomez> at least with that you can spot the issue with recheck
15:46:38 <LuisGomez> another option is to do autorelease verification at merge time, similar to distribution check proposal
15:47:16 <zxiiro> LuisGomez: not sure what you mean by rebase in the verify job?
15:47:34 <zxiiro> LuisGomez: do you mean we should run "git rebase origin/master" inside the verify job as a step?
15:47:40 <LuisGomez> yes
15:48:11 <LuisGomez> rebase the given patch before building autorelease
15:49:01 <zxiiro> LuisGomez: the problem though is that hte patch was old and already passed verify
15:49:08 <colindixon> yeah
15:49:27 <zxiiro> LuisGomez: so we need something to cause it to recheck again before merge happens if it is an old patch
15:49:53 <colindixon> zxiiro: is the fact that the build queue is at 225 normal or signs of stress?
15:50:01 <zxiiro> we can achieve this with gates but current infrastructure does not support gates.
15:50:39 <zxiiro> colindixon: no Rackspace is broken. I've been working with them since monday to fix it. They have a solution but waiting for them to deploy it
15:51:23 <LuisGomez> zxiiro, you have hit the same issue then as we discussed for the distribution check
15:51:29 <zxiiro> colindixon: all csit jobs are failing
15:51:44 <LuisGomez> it has to happen at merge time and block the merge in case of failure
15:52:08 <zxiiro> LuisGomez: yes but for the validate-autorelease job the merge job doesn't matter for us. we don't depend on Nexus
15:52:32 <zxiiro> LuisGomez: if a project merges a patch that breaks the validate-autorelease job, it immediately affects every project regardless of if Nexus is updated or not
15:52:32 <anipbu> #info Jenkins queue is at 225.  zxiiro says there are some issues with Rackspace and currently working with them to resolve.
15:53:07 <zxiiro> LuisGomez: which is why I've just fixed it for them on their behalf with my super committer powers.
15:53:48 <LuisGomez> well yes, but if the merge fails, projects normally repair that otherwise they do not see the changes reflected.
15:54:16 <colindixon> zxiiro: do we have an ETA on fixing that?
15:54:18 <LuisGomez> anyway lets table this for now :)
15:54:33 <colindixon> any other blocking issues?
15:54:40 <zxiiro> colindixon: no official ETA from them but should be sometime today.
15:54:57 <colindixon> anipbu: it'd probably be good to follow up with projects that have blocking bugs listed in bugzilla to make sure we track them
15:55:26 <anipbu> #action anipbu to follow up with projects with blocking bugs on bugzilla
15:55:49 <colindixon> #link https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=2030147923 we should probably also keep this up to date
15:56:10 <colindixon> #action colindixon to bring up this meeting, the blocking bugs spreadsheet, and blocking bugs in bugzilla at the TSC and TWS meetings
15:57:04 <anipbu> #info Weather Item: BUG-4295: Lazy Data Tree MERGE operations: https://lists.opendaylight.org/pipermail/release/2016-January/005251.html
15:57:07 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=4295
15:58:24 <anipbu> #info OpenFlow Plugin 2 Design Discussion Thread Here: https://lists.opendaylight.org/pipermail/release/2016-January/005241.html
15:59:03 <anipbu> Okay, any other topics folks want to raise?
15:59:11 <colindixon> anipbu: is the plan of record to have projects only move to the -li design starting in Boron?
15:59:26 <pradeeban> #info pradeeban for messaging4transport. Sorry for the delay in appearing here.
16:00:14 <anipbu> colindixon: in Boron, all projects should move to -li design, as it will be the only one supported.
16:00:14 <hideyuki> #colindixon VTN project plans to move to the li design in Boron so far.
16:00:37 <anipbu> colindixon: however, the question for TSC is what to do in Beryllium
16:00:46 <colindixon> anipbu: OK, noted
16:00:46 <vrpolak> Speaking about OpenFlowPlugin designs. LACP has switched to He, but NIC and DIDM still require table features (not sure how impossible to add support into He within Beryllium).
16:01:12 <colindixon> anipbu: do we have a good understanding of the consequences of not moving?
16:01:16 <ChristineH> anipbu: sorry for late response. snmp4sdn not completely move to md-sal, it still use ad-sal such as the plugin Activator
16:01:54 <colindixon> ChristineH, zxiiro, anipbu: is it building and working in autorelease?
16:01:57 <anipbu> #info vrpolak says LACP has switched to He, but NIC and DIDM still require table features (not sure how impossible to add support into He within Beryllium).
16:02:49 <zxiiro> colindixon: we got a workaround at the moment but I can't remember what the workaround was.... I think we pointed it to Lithium released artifacts
16:03:00 <colindixon> zxiiro: and is that OK?
16:03:07 <colindixon> are we willing to release with them?
16:03:10 <anipbu> colindixon: here is snmp4sdn features being built by autorelease https://jenkins.opendaylight.org/autorelease/job/autorelease-release-beryllium/21/org.opendaylight.snmp4sdn$features-snmp4sdn/
16:03:17 <ChristineH> colindixon: snmp4sdn looks works in autorelease. I download the autorelease daily build and run it.
16:03:39 <zxiiro> colindixon: I don't know, someone needs to validate that it actually works at runtime. From a build time perspective it's passing....
16:03:58 <zxiiro> ChristineH: ok that's good to know
16:04:22 <colindixon> #action colindixon to follow up with people about whether SNMP4SDN pulling in Lithium released artifacts in Beryllium is OK, just to make sure there's no gotchas
16:05:06 <colindixon> zxiiro, anipbu: have there been any other non-standard modifications to projects to work in autorelease?
16:05:21 <zxiiro> colindixon: not that I'm aware
16:05:28 <colindixon> zxiiro: OK, good to know
16:06:00 <colindixon> #info for what it's worth, colindixon knows that docs is way behind on reviewing patches, but hopes to get through them this week
16:06:57 <anipbu> colindixon: no.
16:07:02 <anipbu> We're past the hour.  Any last minute topics to raise from folks?
16:07:10 <colindixon> ok
16:07:11 <colindixon> thanks
16:07:25 <anipbu> going once
16:07:34 <anipbu> goince twice
16:08:34 <anipbu> Okay, thanks folks for joining.
16:08:38 <anipbu> #topic cookies
16:08:49 <anipbu> #endmeeting