15:30:51 <anipbu> #startmeeting beryllium weekly sync
15:30:51 <odl_meetbot> Meeting started Wed Jan 27 15:30:51 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:30:51 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:51 <odl_meetbot> The meeting name has been set to 'beryllium_weekly_sync'
15:30:57 <anipbu> #topic roll call
15:31:18 <anipbu> Folks, please info your projects
15:31:52 <anipbu> #chair zxiiro anipbu colindixon
15:31:52 <odl_meetbot> Current chairs: anipbu colindixon zxiiro
15:31:58 <LuisGomez> #info LuisGomez for integration
15:32:09 <hideyuki> #info Hideyuki for VTN
15:32:15 <yamahata> #info yamahata for neutorn northbound
15:32:17 <adetalhouet> #adetalhouet NIC UniMgr
15:32:28 <colindixon> #info colindixon for TTP, docs, and TSC
15:32:34 <adetalhouet> #info adetalhouet NIC UniMgr
15:33:03 <zxiiro> #info Thanh releng
15:33:05 <anipbu> #info anipbu for usc, nemo
15:35:08 <anipbu> Any other folks please info your projects?
15:35:10 <anipbu> Let's move on to blocking issues.
15:35:17 <anipbu> #topic blocking issues
15:35:34 <anipbu> #info RC0
15:35:36 <zxiiro> rackspace port issues this morning, I'm on phone with rackspace about it right now. Should be cleared up soon
15:35:43 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#RC0
15:35:54 <anipbu> #undo
15:35:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x203c8d0>
15:35:56 <anipbu> #undo
15:35:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x203c0d0>
15:36:12 <lori> #info lori for lispflowmapping
15:36:25 <anipbu> #info rackspace port issues should be cleared up soon
15:36:45 <anipbu> zxiiro: is it affecting jenkins builds?
15:36:53 <zxiiro> anipbu: only CSIT jobs as usual
15:37:08 <LuisGomez> zxiiro, i think we need some sort of evaluation on rackspace reliability, it seems that for a cloud service rackspace is not very reliable…
15:37:46 <LuisGomez> are ther other providers we can consider for next releases?
15:37:59 <anipbu> #info Luis says we should evaluate rackspace reliability, given the recent issues.
15:38:17 <zxiiro> LuisGomez: we'd need to talk to Andy about that. but this should stop being a problem once we move into the private cloud
15:38:21 <LuisGomez> it is not recent, they are happening all the time.
15:38:34 <LuisGomez> ok zxiiro
15:38:58 <anipbu> zxiiro: when will the move to private cloud complete?
15:39:29 <zxiiro> anipbu: I have no ETA, Andy's tied up in a bunch of other things so it's been delaying his ability to deploy the private cloud
15:39:56 <anipbu> zxiiro: okay thanks.
15:40:31 <LuisGomez> zxiiro, i think we need that for boron but it is ok, lets bring that in the tsc call.
15:40:41 <colindixon> zxiiro: can we logically chron the script to reclaim ports and basically ask them to run it every 24-hours
15:40:44 <colindixon> would that help
15:40:47 <colindixon> ?
15:41:01 <zxiiro> colindixon: that's what I asked them to do yesterday but they haven'tg came back with an answer for me yet
15:41:12 <zxiiro> colindixon: I think the cron should actually run every 12 hrs or even more often
15:41:28 <anipbu> #info zxiiro says the recent problems should go away once we move to the private cloud
15:41:29 <zxiiro> colindixon: based on what i saw last night. at midnight 0 bad ports, woke up at 9 am this morning 60 bad ports
15:41:52 <zxiiro> so I'm gonna see if they can run the cron a few times a day
15:42:22 <phrobb> The private cloud will definitely be set up for Boron LuisGomez.  We had wanted it before the release of Beryllium, but as zxiiro mentions we've had some delays from other needs
15:42:46 <LuisGomez> ok phrobb
15:43:21 <anipbu> #info RC0
15:43:30 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#RC0
15:43:31 <colindixon> zxiiro: can they run the script every 4 hours then?
15:43:55 <zxiiro> colindixon: That's what I'm asking them
15:44:13 <zxiiro> colindixon: don't have an answer yet but working on it
15:44:48 <colindixon> zxiiro: thanks
15:44:57 <anipbu> #link https://jenkins.opendaylight.org/releng/job/integration-distribution-test-beryllium/290/  <-- here are the results of our test job for RC0
15:45:33 <anipbu> #info we need projects to go in and report their ST status
15:45:35 <anipbu> #link https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=762439142
15:45:39 <colindixon> #Info it looks like the only failures are with the hbase datastore
15:45:52 <colindixon> anipbu: are we pinging projects that haven't responded?
15:46:58 <anipbu> colindixon: no, I haven't had a chance to ping them yet.  There was an issue with some of the tests failing when they shouldn't.
15:47:17 <colindixon> anipbu: ah, w.r.t. to rackspace issues
15:47:28 <colindixon> I guess when we get bad ports reaped, we can kick off CSIT again
15:48:06 <colindixon> thanks anipbu
15:48:25 <anipbu> #action anipbu to ping projects that have not responded
15:48:32 <colindixon> thanks
15:48:38 <anipbu> colindixon: i've added an action item to me to follow up with projects
15:49:10 <colindixon> we should let projects know that if they don't attend these syncs and don't report test results, their code will wind up being shipped as-is without their input
15:50:12 <colindixon> anipbu: where do we stand on OpenFlow plugin issues?
15:50:15 <colindixon> is that the next topic?
15:50:23 <anipbu> colindixon: would it help if I composed a roll call spreadsheet to track projects who participate in the syncs?
15:50:38 <LuisGomez> as well as we will not attend to last minute issues if a project starts to test in RC2
15:50:39 <colindixon> anipbu: maybe
15:50:46 <phrobb> yes, that would be helpful anipbu
15:51:54 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&query_format=advanced&resolution=--- this is a list of all critical and blocker bugs in OpenDaylight, there are 50 of them
15:52:29 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&query_format=advanced&resolution=--- that's only the blockers, that's 13 of them
15:53:21 <colindixon> somebody needs to ping projects at least about the blocker bugs and get them to say they're not blockers and/or fix them
15:54:06 <colindixon> so, I have two more topics I think we need to cover: (1) does anyone have any blocking issues they need help with here, and (2) where are we with the OpenFlow plugin design issues?
15:54:16 <anipbu> #action anipbu follow up with projects with blocker bugs on bugzilla and either reassign severity or fix them
15:54:25 <colindixon> thanks anipbu
15:54:38 <anipbu> #topic OpenFlowPlugin
15:54:48 <anipbu> We've been discussing OpenFlow Plugin, in TSC and OpenFlow Monday Meetings, but here's the summary so far.
15:54:56 <anipbu> #link https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=556767095
15:55:22 <anipbu> #info all projects that have immediaite POM dependenacy on OpenFlowPlugin have responded to survey
15:55:27 <anipbu> https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-project-report-beryllium/lastSuccessfulBuild/artifact/dependencies.log
15:55:39 <colindixon> OK
15:55:44 <anipbu> 8	In Boron
15:55:48 <anipbu> 4	In Beryllium (But Prefer Boron)
15:55:52 <anipbu> 5	In Beryllium (Immediately)
15:56:24 <colindixon> so, as I understand it we had two solutions proposed (a) roll back to the older design by adding the features projects needed from the new one to it and (b) ship with both and make sure compatibility doesn't suffer
15:56:24 <anipbu> 2 projects are working to move to OFP-He: DIDM and NIC
15:56:53 <colindixon> as I understand it vishnoianil did the work to allow DIDM and NIC to move back
15:57:03 <colindixon> has anyone done the work about compatibility checking
15:57:03 <colindixon> ?
15:57:58 <colindixon> it looks like controller shield also needs to move back to the old design
15:58:15 <LuisGomez> you mean to check all apps work together?
15:58:34 <colindixon> #action anipbu to work with others to figure out if controller shield can move back to the old design
15:59:02 <colindixon> LuisGomez: I mean to document what features can be installed together both normally and based on their dependencies on the openflowplugin
15:59:06 <colindixon> to make sure we document the right things
15:59:13 <anipbu> I need to double check with controller shield, because I believe they are on OFP-He
15:59:25 <colindixon> anipbu: thanks
15:59:28 <colindixon> they said -li
15:59:35 <colindixon> but if that's wrong we should know
15:59:46 <colindixon> it would be good to double check poms to figure out who's depending on the -li features
16:00:03 <colindixon> #action colindixon to check pom files to see who actually depends on -li openflowpluin features
16:00:40 <anipbu> usecplugin doesn't seem to be using openflowplugin
16:00:41 <anipbu> https://git.opendaylight.org/gerrit/gitweb?p=usecplugin.git;a=blob;f=features/src/main/features/features.xml;
16:00:57 <adetalhouet> FYI: NIC doesn't use -li anymore, thanks to Anil, NIC move back to -he https://git.opendaylight.org/gerrit/#/c/33399/
16:01:10 <hideyuki> adetalhouet: Great job!
16:01:24 <LuisGomez> i think if we are going to default in He-plugin, the only project that needs extra documentation is OFP to enable Li-plugin.
16:01:25 <adetalhouet> hideyuki: say that to vishnoianil :)
16:01:29 <anipbu> usecplugin response ought to be "does not apply"
16:01:50 <anipbu> adetalhouet: thanks for the update.  that's great to hear.
16:01:51 <colindixon> LuisGomez: we track if projects can be run together or not with the compatible-with-all and things, so that helps, we don't track the various openflow plugin dependencies
16:01:55 <colindixon> ok
16:02:04 <hideyuki> FYI: In Just in case, VTN project starts the preparation for the migration to OFP-Li.
16:02:09 <colindixon> I have to jump on the docs meeting, but I'll stay here in IRC for what I can
16:02:37 <LuisGomez> colindixon: we can test feature compatibility in inetgration yes
16:02:40 <hideyuki> And, of course, we are testing OFP-He for Beryllium, as well.
16:03:25 <colindixon> hideyuki: I agree that you should start the work, but I wouldn't merge it into stable/beryllium, and I'd make sure to give yourself room to use either one for the foreseeable future (that's my personal view as an engineer)
16:03:32 <anipbu> adetalhouet: have the ST passed for NIC after the migration to OFP-He?
16:03:53 <adetalhouet> anipbu: it's been working on as we speak
16:04:05 <anipbu> adetalhouet: in other words, are there any bugs we know of so far?
16:04:11 <anipbu> adetalhouet: okay, thanks
16:04:11 <adetalhouet> anipbu: jamoluhrsen has made some changes that should make things work again
16:04:43 <anipbu> Okay other comments from folks about OFP?
16:05:10 <anipbu> #topic red flags
16:05:34 <anipbu> Okay, any issues folks want to bring up or raise?
16:06:05 <colindixon> anipbu: we need somebody to do the compatibility analysis otherwise I think shipping projects that use the -li version isn't really possible
16:06:40 <colindixon> anipbu: if everyone can move back to the older design, it's a moot point, but I think it will frustrate robert and others
16:07:35 <LuisGomez> to my knowledge it is only ovsdb project that have features in both He and Li and they are holding for decision on which plugin will be default.
16:08:57 <anipbu> colindixon: so for compatibility analysis, we want to generate a list of features that cannot work with OFP-He.  Assuming that NIC and DIDM migrate back to OFP-He, and assuming that USECPLUGIN incorrectly reported their use of OpenFlowPlugin, and assumming circuitsw is out of Beryllium....then that leaves only OVSDB with features in Beryllium that depend on
16:08:57 <anipbu> OFP-Li.  But they have other features for backwards compatibility with OFP-He.
16:12:35 <anipbu> #action anipbu to send out email with features incompatible with OFP-He
16:13:16 <anipbu> LuisGomez:  may I action you to send the results of the feature compatibility in inetgration tests?
16:13:30 <LuisGomez> sure
16:13:47 <colindixon> anipbu: OK
16:13:49 <anipbu> #action LuisGomez to send the results of the feature compatibility in integration tests?
16:14:20 <anipbu> We're past the hour.  Any last minute topics to raise from folks?
16:14:21 <colindixon> so then the plan of record it to move everyone back to the old design at least for the first Beryllium release?
16:15:20 <anipbu> That's the plan so far.  Still waiting on DIDM of the progress of migration.
16:17:12 <anipbu> Any last minute topics to raise from folks?
16:17:31 <anipbu> going once
16:17:57 <anipbu> goince twice
16:19:02 <anipbu> Okay, thanks folks for joining.
16:19:08 <anipbu> #topic cookies
16:19:14 <anipbu> #endmeeting