#opendaylight-meeting: beryllium weekly sync

Meeting started by anipbu at 15:30:02 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 15:30:07)
    1. AmbikaTripathy representing YANG-PUSH (AmbikaTripathy, 15:30:37)
    2. Hideyuki for VTN project (hideyuki, 15:30:38)
    3. ttkacik for mdsal, controller (ttkacik, 15:31:25)
    4. rovarga yangtools, odlparent (rovarga, 15:31:37)
    5. yamahata for neutron northbound (yamahata, 15:31:41)
    6. lori for lispflowmapping (lori, 15:31:44)
    7. Thanh releng (zxiiro, 15:31:51)
    8. aleckey for NetIDE (aleckey, 15:31:55)
    9. LuisGomez integration (LuisGomez, 15:32:40)
    10. Prem VPNService (Prem_, 15:33:07)
    11. anipbu for USC, NEMO (anipbu, 15:34:33)

  2. agenda (anipbu, 15:35:08)
    1. RC3 (anipbu, 15:35:12)
    2. release review (anipbu, 15:35:15)
    3. blocking bugs (anipbu, 15:35:19)

  3. RC3 (anipbu, 15:36:25)
    1. Projects PTL please cast your vote on Beryllium Go/NOGO (anipbu, 15:36:30)
    2. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1599673811 <-- Vote here (anipbu, 15:36:36)
    3. ACTION: need votes from DIDM, GroupBasedPolicy, Integration/Distribution, PacketcablePCMM (anipbu, 15:36:45)
    4. ACTION: anipbu and AmbikaTripathy follow up with docs team for any tools to generate ascii doc from project wiki (anipbu, 15:38:50)
    5. pProjects PTL, please identify if the RC3 issues are "OKAY" to release or "BLOCKING" and need to delay Beryllium. (anipbu, 15:39:05)
    6. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=2095652051 <-- Comment on test (anipbu, 15:39:17)
    7. ACTION: need comments from ovsdb, sxp, topoprocessing (anipbu, 15:39:30)
    8. abhijitkumbhare for OpenFlow Plugin (abhijitkumbhare, 15:39:50)
    9. ACTION: shague_ still waiting on ovsdb comments on test failures (anipbu, 15:40:26)

  4. release review (anipbu, 15:43:08)
    1. Project PTL, please address the action items during your release review. (anipbu, 15:43:16)
    2. action items are summarized in the spreadsheet for your convenience (anipbu, 15:43:21)
    3. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=45904332 (anipbu, 15:43:25)
    4. ACTION: ALL PTL to make sure their action items during release review are completed. (anipbu, 15:43:50)

  5. blocking bugs, red flags, open mic (anipbu, 15:45:13)
    1. it seems we have mismatch between how slaves are configured and what the jobs expect (rovarga, 15:46:20)
    2. ACTION: anipbu and yuling to follow up on release review action items (anipbu, 15:46:37)
    3. rovarga raised some concerns regarding stability of -autorelease and -distribution jobs (anipbu, 15:47:00)
    4. zxiiro says that dynamic_merge vms are still spinning up with the old image (anipbu, 15:48:01)
    5. zxiiro says that on monday we built a new vm image that includes both xmlstarlet adn sshpass so we no longer depend on spinup scripts to start them (anipbu, 15:48:28)
    6. in the future, we can send email to dev/release list so that the community knows we are aware of problems and addressing as soon as possible. (anipbu, 15:52:28)
    7. LuisGomez notes yangtools does not have distribution check job. asks rovarga to add this once these issues are fixed. (anipbu, 15:54:11)
    8. ACTION: rovarga to add yangtools distribution check job (anipbu, 15:55:41)
    9. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=2030147923 <-- List of blocking issues (anipbu, 16:00:35)
    10. ACTION: PTL, please verify the blocking issues are no longer appearing and move the bug to the FIXED list in the spreadsheet (anipbu, 16:01:39)
    11. AmbikaTripathy notes there is a bug in yangtools. However, is NOT BLOCKING and okay to release Beryllium with the known bug. ttkacik notes there is currently no fix available for this bug. https://bugs.opendaylight.org/show_bug.cgi?id=5099 (anipbu, 16:08:29)
    12. ACTION: projects should verify blocking bug fixes and update sheet before tomorrow’s TSC call. (LuisGomez, 16:09:50)

  6. cookies (anipbu, 16:12:13)


Meeting ended at 16:12:23 UTC (full logs).

Action items

  1. need votes from DIDM, GroupBasedPolicy, Integration/Distribution, PacketcablePCMM
  2. anipbu and AmbikaTripathy follow up with docs team for any tools to generate ascii doc from project wiki
  3. need comments from ovsdb, sxp, topoprocessing
  4. shague_ still waiting on ovsdb comments on test failures
  5. ALL PTL to make sure their action items during release review are completed.
  6. anipbu and yuling to follow up on release review action items
  7. rovarga to add yangtools distribution check job
  8. PTL, please verify the blocking issues are no longer appearing and move the bug to the FIXED list in the spreadsheet
  9. projects should verify blocking bug fixes and update sheet before tomorrow’s TSC call.


Action items, by person

  1. AmbikaTripathy
    1. anipbu and AmbikaTripathy follow up with docs team for any tools to generate ascii doc from project wiki
  2. anipbu
    1. anipbu and AmbikaTripathy follow up with docs team for any tools to generate ascii doc from project wiki
    2. anipbu and yuling to follow up on release review action items
  3. rovarga
    1. rovarga to add yangtools distribution check job
  4. shague_
    1. shague_ still waiting on ovsdb comments on test failures
  5. yuling
    1. anipbu and yuling to follow up on release review action items
  6. UNASSIGNED
    1. need votes from DIDM, GroupBasedPolicy, Integration/Distribution, PacketcablePCMM
    2. need comments from ovsdb, sxp, topoprocessing
    3. ALL PTL to make sure their action items during release review are completed.
    4. PTL, please verify the blocking issues are no longer appearing and move the bug to the FIXED list in the spreadsheet
    5. projects should verify blocking bug fixes and update sheet before tomorrow’s TSC call.


People present (lines said)

  1. anipbu (67)
  2. zxiiro (21)
  3. rovarga (15)
  4. LuisGomez (8)
  5. odl_meetbot (5)
  6. AmbikaTripathy (4)
  7. yuling (2)
  8. hideyuki (2)
  9. ttkacik (2)
  10. yamahata (1)
  11. abhijitkumbhare (1)
  12. Prem_ (1)
  13. lori (1)
  14. shague_ (1)
  15. aleckey (1)
  16. anipbu2 (0)


Generated by MeetBot 0.1.4.