14:30:16 <anipbu> #startmeeting boron release review
14:30:16 <odl_meetbot> Meeting started Fri Aug 26 14:30:16 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:16 <odl_meetbot> The meeting name has been set to 'boron_release_review'
14:30:23 <anipbu> #topic roll call
14:30:28 <anipbu> #info PTL and TSC members please #info in
14:38:02 <anipbu> #info anipbu
14:38:44 <anipbu> Anyone from integration here?
14:40:06 <vrpolak> anipbu: Me.
14:40:22 <anipbu> vrpolak: good morning
14:40:43 <anipbu> vrpolak: would you be comfortable running the release review for usc and nemo?
14:41:02 <anipbu> vrpolak: i am PTL in usc so I cannot review my own projects =)
14:41:31 <vrpolak> anipbu: Oh, is there a checklist for running the release review?
14:42:21 <anipbu> Just make sure the release notes and release templetes are filled out.  All the "checklist" items are spelled out in the release notes and release templates
14:42:35 <anipbu> Release Note: https://wiki.opendaylight.org/view/Sample_Release_Notes
14:42:35 <anipbu> Release Review Template: https://wiki.opendaylight.org/view/Sample_Release_Review
14:45:04 <anipbu> vrpolak: or we can wait until JamO arrives to do usc/nemo.
14:45:13 <vrpolak> Alright. Ucs contact person, please paste here URLs to your filled-out Release Review page and to your Release Notes.
14:45:24 <anipbu> #topic USC (Unified Secure Channel)
14:45:28 <anipbu> #link https://wiki.opendaylight.org/view/USC:Boron:Release_Review <-- Release Review
14:45:32 <anipbu> #link https://wiki.opendaylight.org/view/USC:Boron:Release_Notes <-- Release Notes
14:45:36 <anipbu> #info anipbu is representing USC
14:45:58 <anipbu> anipbu: 1) Have you tested against RC1 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:46:17 <anipbu> Yes, we have tested against RC1 and found no blockers.
14:46:22 <anipbu> spreadsheet has been updated
14:46:53 <anipbu> We have no experimental features.  Some system tests were failing, that they have been fixed.
14:47:10 <anipbu> https://jenkins.opendaylight.org/releng/view/usc/job/usc-csit-1node-tcp-all-boron/   <--- USC System tests now passes
14:47:28 <anipbu> https://jenkins.opendaylight.org/releng/view/usc/job/usc-csit-1node-tcp-only-boron/   <--- USC system tests now passes
14:48:13 <anipbu> User facing feature is odl-usc-channel-ui
14:48:29 <anipbu> vrpolak: any questions, concerns?
14:49:02 <vrpolak> Do you have any top-level features that are not user-facing?
14:49:44 <anipbu> vrpolak: No.  odl-usc-channel-ui is both user facing and top level.
14:50:43 <vrpolak> As contact for integration/test I confirm CSIT tests are passing and are included in list of "stable" tests.
14:51:18 <anipbu> vrpolak: thanks.
14:51:22 <vrpolak> No more questions from me.
14:52:12 <anipbu> #info USC is approved for Boron.  Congratulations.
14:52:18 <anipbu> Okay, let's move on.
14:52:26 <anipbu> #topic NEUTRON (Neutron Northbound)
14:52:31 <anipbu> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Boron:Release_Review <-- Release Review
14:52:36 <anipbu> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Boron:Release_Notes <-- Release Notes
14:52:40 <anipbu> #info Isaku Yamahata is representing NEUTRON
14:52:49 <anipbu> iyamahat: good morning!
14:52:58 <yamahata> anipbu: good morning
14:53:12 <anipbu> yamahata: 1) Have you tested against RC1 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:53:51 <yamahata> 1) yes, 2)yes 3) odl-neutron-service, odl-neutron-logger
14:54:21 <anipbu> yamahata: did you list all the migration, API changes that happened in neutron for this release in the release notes?  I recall Neutron made some big changes.
14:55:05 <yamahata> yes. It's yang model changes.
14:55:25 <anipbu> Is this listed in the release notes? "For "Other Protocol" rule, NeutronSecurityRule.getSecurityRuleProtocol() is set to NULL"
14:56:32 <yamahata> Yes, It's a part of I*Aware interface protocol.
14:56:43 <yamahata> Should I write it in detail?
14:57:03 <yamahata> In Deprected... section
14:57:18 <anipbu> I think a pointer to someplace with more details would be nice
14:57:29 <anipbu> maybe point to the bugzilla link?
14:57:50 <anipbu> #action yamahata to add links to more details about the deprecated APIs, etc. in the release notes
14:57:50 <yamahata> The link is in "Known..." section.
14:58:17 <yamahata> Anyway I'll revise it to add more links
14:58:38 <anipbu> yamahata: our goal is to give the end users as much details as they need to understand the changes.
14:59:06 <anipbu> I link the I*Aware interface changes should have link to bugzilla, or link to documentation.
14:59:35 <yamahata> Okay.
15:00:11 <anipbu> Neutron received a test waiver, but did you run any manual tests?
15:00:32 <yamahata> I tested it as a part of openstack ci
15:00:39 <yamahata> https://review.openstack.org/#/c/359954/
15:00:46 <anipbu> Do you have a link to the openstack ci test results?
15:00:55 <yamahata> It didn't show regression.
15:01:05 <yamahata> http://logs.openstack.org/54/359954/1/check/gate-tempest-dsvm-networking-odl-boron-snapshot/47fbe34/
15:01:29 <anipbu> okay perfect.  Could you also link into the release review template the external openstack tests cases?
15:01:52 <yamahata> Will do.
15:01:54 <anipbu> yamahata: again, our goal is to give the end users a sense of how much external testing was done with  neutron northbound.
15:02:08 <anipbu> #action yamahata to add links to external openstack tests in release review template.
15:02:23 <anipbu> besides those two items, neutron looks good!
15:02:50 <anipbu> #info NEUTRON approved for Boron pending action items.  Congratulations!
15:02:54 <yamahata> thanks!
15:03:15 <anipbu> #topic TOPOPROCESSING
15:03:19 <anipbu> #link https://wiki.opendaylight.org/view/Topology_Processing_Framework:BORON_Release_Review <-- Release Review
15:03:25 <anipbu> #link https://wiki.opendaylight.org/view/Topology_Processing_Framework:BORON_Release_Notes <-- Release Notes
15:03:30 <anipbu> #info Andrej Záň is representing TOPOPROCESSING
15:03:39 <anipbu> AnZa: good morning!
15:03:45 <AnZa> Hi everybody
15:04:15 <anipbu> AnZa: anything you would like to add?
15:04:22 <AnZa> no thanks
15:04:36 <anipbu> AnZa: 1) Have you tested against RC1 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:05:23 <AnZa> 1) yes 2) all of them 3) no user-facing features
15:05:51 <vrpolak> As a contact for integration/test I confirm CSIT tests (topology-operations functionality) are passing and are included in list of "stable" tests.
15:07:00 <anipbu> AnZa: could you update the list of features: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
15:07:32 <anipbu> Even if topoprocessing has added no new features, we still want to list all the top level/userfacing features on the release review
15:07:42 <AnZa> Of course, I didn't noticed that they are missing...
15:07:54 <anipbu> #action AnZa to update the list of features on release review
15:08:31 <anipbu> Your release notes states that "API was slightly changed".  What does that mean?  Which API was changed? What are the impact to end user?
15:09:15 <anipbu> https://wiki.opendaylight.org/view/Topology_Processing_Framework:BORON_Release_Notes#Changes_Since_Previous_Releases
15:09:38 <AnZa> My fault again. it wasn't changed in any way. Sorry for that
15:10:20 <AnZa> I'll edit release notes
15:10:36 <anipbu> #action AnZa to update the release notes regarding the statement "API was slightly changed"
15:11:20 <anipbu> AnZa: Such beautiful system tests!  Glad to see such good code coverage =)
15:11:34 <AnZa> Thanks :|
15:11:39 <AnZa> :)
15:12:14 <anipbu> Do you ahve pending documentation?  Seems like there are git patches.
15:12:38 <anipbu> Any security considerations?  If not, maybe we can remove that section.
15:13:28 <anipbu> #action AnZa to update the links to the documentation to point to the asciidocs/rst files (currently it is pointing to gerrit patches).
15:14:01 <anipbu> Any other folks have questions for topoprocessing?
15:15:00 <AnZa> We don't have any security considerations. I'll add links to any pending documentation which I'll find
15:15:21 <anipbu> AnZa: thanks
15:15:33 <AnZa> Thanks
15:16:07 <anipbu> topoprocessing looks good to me
15:16:20 <anipbu> #info TOPOPROCESSING approved for Boron pending action items.  Congratulations!
15:16:23 <anipbu> Okay let's move on.
15:16:30 <anipbu> #topic OPENFLOWJAVA
15:16:36 <anipbu> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Boron_Release_Review <-- Release Review
15:16:40 <anipbu> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Boron_Release_Notes <-- Release Notes
15:16:45 <anipbu> #info Michal Polkorab is representing OPENFLOWJAVA
15:16:50 <oflibMichal> hello
15:17:02 <anipbu> oflibMichal: hello =)
15:17:07 <anipbu> oflibMichal: anything you would like to add?
15:17:12 <oflibMichal> no
15:17:28 <anipbu> oflibMichal: 1) Have you tested against RC1 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:17:59 <oflibMichal> 1) yes - no blockers, 2) no, 3) none
15:18:36 <anipbu> oflibMichal: can you please update this now: column B/C for RC1 testing status: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:18:54 <vrpolak> Waiver, so no comment from integration/test side.
15:18:58 <oflibMichal> done
15:20:27 <anipbu> Migration from Previous Releases is left blank.  DOes this mean it does not support migration form rpevious release?
15:21:21 <oflibMichal> actually it is stated just below
15:21:30 <oflibMichal> that migration should be a no-op
15:21:46 <anipbu> Ah okay.  Good catch.  You are correct.
15:22:01 <anipbu> I *think* the target environment for execution and development both requires java 8?  If so, culd you update the section on "Target Environment"
15:22:25 <oflibMichal> ok, I thought this is considered default
15:22:32 <oflibMichal> but sure, I will do that
15:22:53 <anipbu> #action oflibMichal to update the target environment
15:23:11 <anipbu> Just to confirm, there are no API changes in this release, correct?
15:23:31 <oflibMichal> right
15:23:45 <oflibMichal> the target environment is updated
15:24:12 <anipbu> oflibMichal: what sort of manual/external testing was done to validate the openflowjava code?  Did you reply solely on openflowplugin for code coverage testing?
15:24:37 <oflibMichal> unit tests cover about 89% of the code
15:24:49 <oflibMichal> openflowplugin covers the integration / system tests
15:25:13 <anipbu> Could you provide the link to the unit tests sonar report on the release review template?
15:25:21 <oflibMichal> ok
15:25:34 <anipbu> #action oflibMichal to add link to the sonar unit test report to release review template
15:26:08 <anipbu> wow - 89%.  Very impressive =)
15:26:51 <oflibMichal> thank you :-)
15:27:15 <anipbu> our goal is to provide end users with a sense of how much testing was done on functionality of openflowjava, so please update the documents on the testing with the appropriate links.
15:27:22 <anipbu> besides that, openflowjava looks good to me.
15:27:44 <anipbu> Do folks have any other comments or questions for openflowjava?
15:28:37 <anipbu> #info OPENFLOWJAVA approved for Boron pending action items.  Congratulations!
15:28:44 <anipbu> vrpolak: can you do release review for NEMO?
15:28:59 <anipbu> I am committer on NEMO so I cannot review my own project.
15:29:05 <vrpolak> anipbu: Ok.
15:29:09 <anipbu> #topic NEMO (Network Modeling)
15:29:13 <anipbu> #link https://wiki.opendaylight.org/view/NEMO:Boron:Release_Review <-- Release Review
15:29:17 <anipbu> #link https://wiki.opendaylight.org/view/NEMO:Boron:Release_Notes <-- Release Notes
15:29:21 <anipbu> #info anipbu is representing NEMO
15:29:37 <anipbu> anipbu: 1) Have you tested against RC1 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:29:51 <anipbu> Yes we tested RC1 and found no blockers.
15:30:12 <anipbu> We have no experimental features.  But our tests are failing.  We think it is becasue of restconf response issues.
15:30:36 <vrpolak> anipbu: any top-level features except odl-nemo-engine-ui?
15:30:44 <anipbu> Patch is pending to fix test: https://git.opendaylight.org/gerrit/#/c/44702/
15:31:05 <anipbu> nope, odl-nemo-engine-ui is our top level and user facing
15:32:59 <vrpolak> anipbu: Yes, it is the restconf status code issue. But it is always the last check in test case and the following test case pass, so test would be stable after status code fix.
15:33:47 <anipbu> vrpolak: yup
15:34:31 <vrpolak> The pending fix is merged now.
15:35:09 <anipbu> vrpolak: thanks!
15:35:39 <anipbu> vrpolak: any other questions, concerns?
15:37:41 <vrpolak> anipbu: The tests only seem to invoke RPCs (after initial configuration) but it is not tested whether subsequent southbound operations do what they have to. Do the RPCs themselves perform such checking?
15:38:24 <anipbu> Yes, the RPC internally perform the necessary rendering to DSL (doman specific lanaguage).
15:39:33 <anipbu> in fact, nemo is designed such that the language style interface and the rpc style interface is rendered similarly, such that testing one, will verify the other.
15:39:58 <anipbu> that is one of the highlights of NEMO intent engine.
15:41:17 <vrpolak> Ok, anyone have comments?
15:42:01 <vrpolak> Ok, I approve NEMO for Boron.
15:43:00 <anipbu> vrpolak: Thanks!
15:43:15 <anipbu> #info NEMO approved for Boron.  Congratulations!
15:43:25 <anipbu> Okay that's it.  We're done for today.
15:44:11 <anipbu> Thanks vrpolak iyamahat AnZa oflibMichal and other folks for joining today
15:44:45 <anipbu> #topic cookies
15:44:54 <anipbu> #endmeeting