14:30:32 <anipbu> #startmeeting boron release review
14:30:32 <odl_meetbot> Meeting started Mon Aug 29 14:30:32 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:32 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:32 <odl_meetbot> The meeting name has been set to 'boron_release_review'
14:30:38 <anipbu> #topic roll call
14:30:46 <anipbu> #info PTL and TSC members please #info in
14:30:51 <anipbu> #info anipbu
14:31:23 <rgoulding> #info Ryan Goulding (rgoulding) for AAA
14:31:24 <skitt> #info skitt
14:31:42 <aleckey> #info Alec Leckey for NetIDE
14:31:49 <colindixon> #info colindixon for docs, and TSC
14:32:09 <jensen_zhang> #info Jensen Zhang for ALTO
14:33:16 <emiapwil> #info Kai for ALTO
14:33:38 <anipbu> Do we have anyone from integration here?
14:34:09 <vrpolak> #info Vratko polak for integration/distribution and integration/test
14:34:10 <colindixon> anipbu: jamo said he wouldn't be here until 8:05
14:34:16 <colindixon> but he sent out summaries
14:34:30 <VivekSri> #info VivekSri for Genius
14:34:37 <anipbu> colindixon: vrpolak says he can represent integration
14:34:46 <colindixon> cool!
14:34:49 <anipbu> Good Morning vrpolak colindixon
14:34:50 <colindixon> want to get started?
14:34:51 <anipbu> Let's get started
14:34:56 <anipbu> #topic AAA
14:35:01 <anipbu> #link https://wiki.opendaylight.org/view/AAA:Boron:Release_Review   <--- Release Review
14:35:06 <anipbu> #link https://wiki.opendaylight.org/view/AAA:Boron:Release_Notes   <--- Release Notes
14:35:11 <anipbu> #info rgoulding is representing AAA
14:35:16 <anipbu> rgoulding: anything you would like to add?
14:35:25 <rgoulding> anipbu: no nothing I can think of
14:35:40 <rgoulding> open to questions/concerns from others
14:36:13 <anipbu> rgoulding: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:36:38 <colindixon> rgoulding: is all the information on the wiki pages migrated to docs in the open patch, or just some of it?
14:36:58 <rgoulding> anipbu: 1) yes, looks good 2) they are listed in the release review and notes 3) in the release review as well
14:37:17 <anipbu> rgoulding: please update with AAA RC2 testing https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
14:37:19 <colindixon> I read through everything and it looks good to me
14:37:26 <rgoulding> colindixon: no just the stuff that is useful for users;  there is development oriented stuff that is still just wiki
14:38:00 <rgoulding> anipbu: done
14:38:57 <colindixon> i'm happy
14:39:22 <vrpolak> AAA has two CSIT suites, one is passing, the other one is failing. Perhaps wrong features are being installed. That means some features should be considered experimental, but I am not sure which ones.
14:39:40 <rgoulding> vrpolak: that suite (idmlite) has never passed
14:39:52 <rgoulding> vrpolak: some features are considered experimental, they are listed in the release review...
14:40:02 <rgoulding> #link https://wiki.opendaylight.org/view/AAA:Boron:Release_Review
14:40:33 <rgoulding> idmlite is not a feature at all... i don't know who pushed the original code for that test
14:41:18 <anipbu> #info idmlite is not a feature in aaa for boron.  tests are failing, but they are invalid anyways.
14:41:59 <anipbu> vrpolak: based on rgoulding response to your questions, do you have any other concerns?
14:42:24 <anipbu> #info all of AAA features are experimental
14:42:34 <anipbu> #info AAA has tested RC2 and found no problems
14:42:56 <anipbu> If there vrpolak has no other concerns, I am ready to move on.
14:43:18 <colindixon> anipbu: wait, all of AAA features are experimental?
14:43:18 <vrpolak> odl-aaa-cli and odl-aaa-cert features do not seem to be tested in the one passing job.
14:43:51 <vrpolak> I believe odl-aaa-shiro is the only feature tested successfully.
14:43:58 <anipbu> colindixon: it looks that way form the release review template https://wiki.opendaylight.org/view/AAA:Boron:Release_Review
14:43:59 <colindixon> odl-aaa-authn (which is odl-aaa-shiro) I think is tested and is no experiemntal
14:44:03 <rgoulding> odl-aaa-shiro wraps odl-aaa-authn
14:44:10 <colindixon> OK
14:44:12 <rgoulding> but yes, the old-aaa-cli and old-aaa-cert are experimental
14:44:27 <rgoulding> they are tested only through unit tests at this point
14:44:31 <colindixon> rgoulding: is shiro supposed to be experimental? I thought no.
14:44:33 <rgoulding> i did not contribute those
14:44:52 <rgoulding> colindixon: i don't know the definition of experimental... it is not in my opinion
14:45:09 <colindixon> it has tests, it's considered prodution ready?
14:45:13 <colindixon> if so, it's not experimental
14:45:25 <rgoulding> yes... it is installed one every running instance of ODL in the world to my knowledge
14:45:35 <rgoulding> i think the test suite is called authn
14:45:37 <anipbu> #action rgoulding to follow up with shiro experimental state
14:45:38 <rgoulding> but its really testing shiro
14:45:55 <rgoulding> shiro just wraps authn and adds IDP on top
14:46:09 <anipbu> colindixon rgoulding I have added an action item for AAA to follow up on the state of shiro.
14:46:20 <rgoulding> i just did... its not experimental.
14:46:23 <rgoulding> ill change it
14:46:28 <colindixon> ok
14:46:29 <colindixon> thanks
14:47:05 <anipbu> Okay, do folks have any additional concerns or comments for AAA?
14:47:12 <colindixon> no, I think we're good
14:48:12 <anipbu> #action rgoulding to follow up on code coverage for the system test: "odl-aaa-cli and odl-aaa-cert features do not seem to be tested in the one passing job."
14:48:16 <vrpolak> anipbu: No more comments on AAA.
14:48:26 <anipbu> Okay, Let's move on
14:48:31 <anipbu> #info AAA approved for Boron pending action items.  Congratulations!
14:48:36 <anipbu> #topic ODLPARENT
14:48:40 <anipbu> #link https://wiki.opendaylight.org/view/ODL_Parent:Boron:Release_Review   <--- Release Review
14:48:44 <anipbu> #link https://wiki.opendaylight.org/view/ODL_Parent:Boron:Release_Notes   <--- Release Notes
14:48:52 <anipbu> #info skitt is representing ODLPARENT
14:48:57 <anipbu> skitt: anything you would like to add?
14:49:03 <skitt> anipbu, not that I can think of
14:49:38 <anipbu> skitt: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:49:54 <skitt> no blockers on RC2
14:50:04 <skitt> no experimental features
14:50:10 <skitt> no user-facing features
14:50:19 <vrpolak> Oldparent has a system test waiver, so no comments from integration.
14:50:27 <colindixon> the Karaf 3.0.7 upgrade is done?
14:50:37 <skitt> colindixon, yes, it's done in Boron
14:50:58 <skitt> colindixon, RC2 and I think RC1 use 3.0.7
14:51:10 <colindixon> cool!
14:51:27 <skitt> :-)
14:51:28 <anipbu> #info odlparent has no blockers in RC2 (tested).  no experimental features.  no user facing features
14:51:47 <anipbu> #info karaf 3.0.7 upgrade is complete
14:52:34 <anipbu> skitt did you state in release notes the 3.0.7 upgrade?
14:52:38 <colindixon> yes
14:52:47 <skitt> yes
14:52:49 <colindixon> Many upstream upgrades, including Karaf (3.0.7 for Boron)
14:52:51 <colindixon> " Many upstream upgrades, including Karaf (3.0.7 for Boron) "
14:53:11 <anipbu> #info ODLPARENT has system test waiver approved by the integration team https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Waiver/System_Test
14:53:28 <anipbu> I'm fine with odlparent
14:53:37 <colindixon> so am I
14:53:54 <anipbu> Do folks have any futhur concerns or questions?
14:54:34 <anipbu> I think we're ready to move on.
14:55:00 <anipbu> #info ODLPARENT approved for Boron.  Congratulations!
14:55:05 <skitt> thanks!
14:55:05 <anipbu> #topic NETIDE
14:55:11 <anipbu> #link https://wiki.opendaylight.org/view/NetIDE:Boron_Release_Review   <--- Release Review
14:55:14 <anipbu> #link https://wiki.opendaylight.org/view/NetIDE:Boron_Release_Notes   <--- Release Notes
14:55:24 <anipbu> #info aleckey is representing NETIDE
14:55:29 <anipbu> aleckey: anything you would like to add?
14:55:39 <aleckey> No, think that is everything
14:55:42 <anipbu> aleckey: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:56:31 <aleckey> we have the one user facing feature: odl-netide-rest. It is experimental and has been tested for RC2. All good, forgot to update spreadsheet
14:57:13 <vrpolak> NetIDE feature repository is included in integration, but its features are commented out, so the do not participate in compatibility testing (-all- jobs).
14:57:41 <anipbu> #info netide has tested RC2 and found no issues
14:58:20 <colindixon> it looks good to me
14:58:21 <anipbu> aleckey: please take a moment to update column B/C of the spreadsheet https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
14:58:21 <vrpolak> One CSIT suite is run, but it does not test NetIDE at all. Yep, experimental.
14:58:34 <colindixon> in the long-run it would be good to push the docuemntation into reStructuredText so it's all in one place
14:58:44 <aleckey> Yes, I'll update spreadsheet
14:58:55 <anipbu> netide looks good to me
14:59:17 <anipbu> #info netide features are experimental
14:59:38 <anipbu> #info NetIDE feature repository is included in integration, but its features are commented out, so the do not participate in compatibility testing (-all- jobs)
14:59:54 <anipbu> Do folks have any futhur concerns or questions?
15:00:25 <colindixon> it looks good to me
15:00:27 <colindixon> cool stuff
15:00:41 <anipbu> #action aleckey to follow up on pushing the docuemntation into reStructuredText so it's all in one place
15:00:46 <anipbu> Okay let's move on
15:01:11 <anipbu> #info NETIDE approved for Boron.  Congratulations!
15:01:16 <anipbu> #topic ALTO
15:01:21 <anipbu> #link https://wiki.opendaylight.org/view/ALTO:Boron:Release_Review   <--- Release Review
15:01:26 <anipbu> #link https://wiki.opendaylight.org/view/ALTO:Boron:Release_Notes   <--- Release Notes
15:01:30 <anipbu> #info jensen_zhang is representing ALTO
15:01:33 <anipbu> jensen_zhang: anything you would like to add?
15:01:51 <jensen_zhang> No. I think that is all.
15:02:20 <jamoluhrsen> anipbu, vrpolak, colindixon: I'm here now.
15:02:29 * colindixon reads
15:02:36 <anipbu> jensen_zhang: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:02:55 <anipbu> #chair jamoluhrsen colindixon vrpolak
15:02:55 <odl_meetbot> Current chairs: anipbu colindixon jamoluhrsen vrpolak
15:03:16 <colindixon> afk 1 min
15:04:03 <anipbu> jensen_zhang: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:04:05 <jensen_zhang> no blockers on rc2. odl-alto-release is our top feature. it is experimental and user-facing.
15:04:19 <anipbu> #info alto has tested RC2 and found no blockers
15:04:37 <anipbu> #info all of alto features are experimental
15:05:46 <colindixon> looks good to me
15:07:11 <emiapwil> Great, thanks.
15:07:19 <anipbu> jensen_zhang: no new code this release, is that correct?
15:07:30 <anipbu> I'm also fine with ALTO
15:07:53 <vrpolak> There is a CSIT job. One test case (in Resourcepool suite) passes, the other three tests fail (possibly because only feature named odl-alto-resourcepool is installed).
15:07:55 <jensen_zhang> anipbu: I think we introduce two new funtions in this release.
15:08:41 <anipbu> okay, so those two new functions are wrapped in the existing feature, correct?
15:08:56 <jensen_zhang> anipbu: yes
15:10:34 <anipbu> Do folks have any futhur concerns or questions?
15:10:44 <colindixon> I'm good
15:11:00 <anipbu> Okay, I think we're ready to move on.
15:11:21 <anipbu> jamoluhrsen:  good morning, glad to see you join us!
15:11:33 <anipbu> #info ALTO approved for Boron.  Congratulations!
15:11:40 <emiapwil> Thanks.
15:11:41 <anipbu> #topic BGPCEP
15:11:47 <anipbu> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Boron_Release_Review   <--- Release Review
15:11:51 <anipbu> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Boron_Release_Notes   <--- Release Notes
15:11:56 <anipbu> #info milfabia is representing BGPCEP
15:12:00 <anipbu> milfabia: anything you would like to add?
15:13:12 <jamoluhrsen> anipbu: are you linking project csit analysis here in irc?
15:13:48 <milfabia> CSIT BGP tests results shows some failures - https://bugs.opendaylight.org/show_bug.cgi?id=6497 - affecting functionality, issue was addressed to yangtools and mdsal
15:14:08 <anipbu> jamoluhrsen: I think vrpolak has been giving the CSIT analysis on IRC
15:14:18 <jamoluhrsen> ok
15:14:30 <milfabia> problem it is all working locally but not on ODL machines
15:14:46 <jamoluhrsen> milfabia, is this a blocker?
15:14:56 <colindixon> I thought taht timing issues had been plaguing bgpcep
15:15:03 <anipbu> jamoluhrsen: but we haven't had any links available.  Please feel free to #info #link as appropriate
15:15:14 <anipbu> milfabia: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:16:02 <anipbu> milfabia: is there an ETA for when bug 6497 will be resolved?
15:16:13 <milfabia> yes, I would say this one is a blocker - I will prepare a wrokaround in BGP code, if there is not response from yantools
15:16:41 <milfabia> ETA tomorrow
15:16:52 <anipbu> milfabia: seems we are cutting very close the last and final build (RC3 this Thursday).  Has yangtools been notified?
15:17:08 <milfabia> email was sent
15:17:14 <milfabia> on friday
15:17:15 <jamoluhrsen> milfabia: is 6497 expected to clean up all the csit failures?
15:17:52 <colindixon> #info CRITICAL: bug 6497 appears to be a blocking bug somewhere between bgpcep and yangtools, it's being debugged and a fix is hoped for by tomorrow
15:18:21 <anipbu> milfabia: please update the spreadsheet on BGPCEP testing for RC2: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:18:24 <anipbu> #action milfabia to follow up with bug 6497
15:18:33 <milfabia> ok, will do
15:19:46 <anipbu> milfabia: could you state in the release notes that the target environment https://wiki.opendaylight.org/view/BGP_LS_PCEP:Boron_Release_Notes
15:20:00 <anipbu> I think it's java 8 requirement, correct?
15:20:15 <milfabia> yes, you are right
15:20:56 <vrpolak> I would say BMP and PCEP features have stable tests, but BGP tests failures do not point to corresponding Bugs. So BGP would be experimental from testing point of view.
15:21:04 <anipbu> milfabia: could you list out the features and whether they are user-facing or experimental or have CSIT code with it https://wiki.opendaylight.org/view/BGP_LS_PCEP:Boron_Release_Review#Major_Features
15:21:34 <anipbu> You can see an example of the listing here: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
15:21:47 <colindixon> at some point we should go through and make an official set of requiments so others can ignore the rest, I've been meaning to better tempaltize the release review and release notes
15:21:49 <colindixon> but didn't have time
15:22:09 <anipbu> #action milfabia to update the target environment
15:22:11 <milfabia> ok, I will update
15:22:34 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/bgpcep-dev/2016-August/000729.html  email with CSIT analysis.
15:22:44 <anipbu> #action milfabia to update the list of features and if they are user-facing or experimental, etc.
15:23:10 <anipbu> milfabia: it seems most features are experimental, is that correct?
15:23:28 <jamoluhrsen> #info 10 CSIT jobs (which is great), but 8 of them have unexpected failures.  as vrpolak points out, they might be consistently failing but they should point to an open non-blocking bug if so.
15:24:19 <milfabia> there are 3 user facing feature in bgpcep, none of them are considered stable
15:24:55 <anipbu> milfabia: did you mention in the release notes that BGPCEP has refactored to remove TCPMD5 dependencies?
15:25:51 <milfabia> oh, good point...I forget to mention that
15:26:20 <anipbu> #action milfabia to update the release notes with reference on TCPMD5 migration
15:27:13 <anipbu> #action milfabia to follow up on the CSIT failures.  (if they are all experimental features, then okay.  but for any non-experimental features, the CSIT must pass, etc)
15:27:28 <anipbu> I don't have any additional questions.
15:27:41 <vrpolak> milfabia: Are there top-level features which are only experimental (as opposed to just not stable)?
15:28:44 <milfabia> no, they are not experimental
15:28:51 <anipbu> mlemay_: Do you know if Maxime Millette-Coulombe is online?
15:30:06 <milfabia> no new top-level feature were add in Boron, just updated existing with new functionality
15:30:14 <anipbu> milfabia: for the ones that are not experimental, please review the CSIT comments from the integration team.  You have been #action to follow up on those.
15:30:19 <jamoluhrsen> vrpolak, by definition most if not all bgpcep features are experimental, right?
15:31:09 <anipbu> jamoluhrsen: It seems from milfabia's commentst that there are some non-experimental features.
15:31:37 <jamoluhrsen> milfabia: which features are non experimental that are doing CSIT?
15:32:18 <milfabia> odl-bgpcep-bgp, odl-bgpcep-pcep, odl-bgpcep-bmp
15:32:36 <vrpolak> jamoluhrsen: Based on CSIT? odl-bgpcep-bgp is experiemental, but odl-bgpcep-bgp and odl-bgpcep-bgp are not as their suites pass 100%.
15:32:37 <milfabia> the bgp has failures in CSIT
15:32:58 <colindixon> anipbu: should we take this offline?
15:33:12 <anipbu> colindixon: I think BGPCEP is worth following up over email
15:33:23 <jamoluhrsen> colindixon, there is already the email they can reply to about this.
15:33:27 <anipbu> #action anipbu to follow up with BGPCEP over email
15:34:08 <anipbu> Do folks have any further concerns or questions?  Otherwise Let's follow up with BGPCEP over email and move on.
15:34:08 <vrpolak> Sorry, wrong paste. odl-bgpcep-pcep and odl-bgpcep-bmp
15:34:39 <anipbu> #info CAPWAP cannot made their release review.  Will reschedule.
15:35:07 <anipbu> Is anybody from controller here?
15:35:27 <anipbu> I never received any confirmation from controller team.
15:36:00 <anipbu> If there are no representatives from controller, we will have to reschedule controller as well.
15:36:50 <anipbu> #info CONTROLLER was unresponsive.  Will reschedule.
15:37:04 <colindixon> I can do docs
15:37:51 <anipbu> Next up is DLUX actually
15:38:01 <anipbu> #topic DLUX
15:38:16 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Boron_Release_Review   <--- Release Review
15:38:28 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Boron:Release_Notes <--- Release Notes
15:38:39 <anipbu> #info mmcoulombe is representing DLUX
15:38:45 <anipbu> mmcoulombe: anything you would like to add?
15:38:59 <mmcoulombe> one thing, links won't difer a lot from Berrilyum
15:39:06 <mmcoulombe> nothing really change
15:39:10 * colindixon reads
15:39:24 <mmcoulombe> nobody got time to work on DLUX
15:40:05 <anipbu> mmcoulombe: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:40:13 <colindixon> is this still up-to-date? http://docs.opendaylight.org/en/stable-boron/user-guide/using-the-opendaylight-user-interface-(dlux).html
15:40:25 <jamoluhrsen> #info all dlux features should be considered experimental
15:40:40 <colindixon> I'm assuming this is: http://docs.opendaylight.org/en/stable-boron/developer-guide/dlux.html
15:40:53 <mmcoulombe> :colindixon this should be
15:41:06 <colindixon> the first link I think was written a long time ago
15:42:30 <mmcoulombe> :colinduxon true but it's still accurate. Nothing really change since helium release for DLUX
15:42:57 <anipbu> mmcoulombe: Have you tested against RC2 and were there any blockers?
15:43:19 <mmcoulombe> :anipbu not yet
15:44:07 <anipbu> mmcoulombe: please take a moment to download and test RC2.  The last and final build is this Thursday.
15:44:20 <mmcoulombe> sure i will
15:44:21 <anipbu> mmcoulombe: is there an ETA for when you can test RC2?
15:44:38 <mmcoulombe> today, worst case tomorrow
15:45:21 <anipbu> #action mmcoulombe to test RC2 today or (worst case) tomorrow and confirm if there are any blocking issues and update the spreadsheet appropriately: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:45:56 <anipbu> #info dlux docs are still accurate since nothing really change since helium release for DLUX
15:47:00 <anipbu> mmcoulombe: it think for the target environment, it requires java 8.  seems like you listed java 7 or 8.
15:47:44 <mmcoulombe> my mistake, i'll update it
15:47:58 <anipbu> #action mmcoulombe to update the release notes target environment
15:48:41 <anipbu> dlux looks good to me
15:48:47 <colindixon> same here
15:49:00 <anipbu> jamoluhrsen: any other comments?
15:49:12 <anipbu> Do folks have any further concerns or questions?  Other let's move on.
15:49:16 <jamoluhrsen> anipbu, nothing from me.  easy one from csit point of view
15:49:26 <anipbu> #info DLUX approved for Boron pending action items.  Congratulations!
15:49:35 <anipbu> #topic DOCS
15:49:36 <anipbu> #link https://wiki.opendaylight.org/view/Documentation/Boron/Release_Review   <--- Release Review
15:49:42 <anipbu> #link https://wiki.opendaylight.org/view/Documentation/Boron/Release_Notes <--- Release Notes
15:49:48 <anipbu> #info colindixon is representing DOCS
15:49:59 <anipbu> colindixon: anything you would like to add?
15:50:29 <colindixon> not really, migration to reST is ongoing, but moves, we plan to merge these patches w/o project involvment on thursday: https://git.opendaylight.org/gerrit/#/q/(topic:adoc2rst+OR+topic:adoc2rst-user)+status:open
15:50:58 <colindixon> that's something like 12 projects of stuff
15:51:43 <anipbu> #info migration to reST is ongoing pending 12 projects https://git.opendaylight.org/gerrit/#/q/(topic:adoc2rst+OR+topic:adoc2rst-user)+status:open
15:52:20 <anipbu> #info docs does not need to test RC2: N/A
15:52:34 <colindixon> yeah... CSIT is n/a
15:54:40 <colindixon> anything else?
15:55:00 <colindixon> #link http://docs.opendaylight.org/ this is the big thing we delivered
15:55:13 <colindixon> #info we also no support inclusion of docs directly from project repos
15:55:16 <anipbu> For the Non-Code Aspects section, please update with link to the docs docs.opendaylight.org.
15:55:28 * colindixon does that
15:55:47 <anipbu> #action colindixon to update Non Code Aspects with appropriate links.
15:56:22 <anipbu> docs looks good to me
15:56:29 <anipbu> Do folks have any further concerns or questions?
15:57:38 <anipbu> If folks do not have any futhur questions, then let's move on.
15:58:17 <anipbu> #info DOCS approved for Boron.  Congratulations!
15:58:33 <anipbu> The eman team has requested to reschedule.
15:58:43 <colindixon> thanks
15:58:59 <anipbu> #info EMAN cannot made their release review.  Will reschedule.
15:59:25 <anipbu> #topic GENIUS
15:59:33 <anipbu> #link https://wiki.opendaylight.org/view/Genius:Boron:Release_Review   <--- Release Review
15:59:40 <anipbu> #link https://wiki.opendaylight.org/view/Genius:Boron:Release_Note <--- Release Notes
15:59:45 <anipbu> #info VivekSri is representing GENIUS
15:59:51 <anipbu> VivekSri: anything you would like to add?
16:00:00 <VivekSri> one thing, our CSIT reviews are not merged yet.
16:00:07 <VivekSri> I just got a mail from jamo indicating that since the CSIT is not merged, all genius features should be considered experimental
16:00:26 <VivekSri> however, we have all the tests passing in our environment with the tests up for review.
16:00:35 <VivekSri> Also NetVirt project is extensivey using genius features, and thus genius features are also tested with NetVirt CSIT.
16:00:48 <VivekSri> Do we still consider these features experimental?
16:01:10 <colindixon> so, do you want them to be experiemental? I think if you have the tests and jamoluhrsen or vrpolak can confirm that, ythey don't have to be
16:01:31 <anipbu> VivekSri: Have you tested against RC2 and were there any blockers?
16:01:38 <VivekSri> i consider them as non experimental
16:02:19 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/genius-dev/2016-August/000282.html  email about CSIT analysis for Genius project
16:02:24 <anipbu> #info CSIT patches are pending merge.
16:02:26 <anipbu> #info NetVirt project is extensivey using genius features, and thus genius features are also tested with NetVirt CSIT
16:02:38 <jamoluhrsen> #info there is currently no csit so by definition all features would be experimental.
16:02:51 <jamoluhrsen> #info integration team needs to review those patches
16:03:22 <jamoluhrsen> #info netvirt is going to be labeled experimental all over the place too, so we can't use that project's CSIT for genius
16:03:24 <colindixon> does genius have reST and/or AsciiDoc docs or plan to?
16:03:44 <anipbu> VivekSri: seems like your project is not meeting test expectations for nonexperimental.
16:04:00 <jamoluhrsen> #action jamoluhrsen to review genius csit patches.
16:04:00 <VivekSri> AsciiDoc is also up for review
16:04:13 <VivekSri> https://git.opendaylight.org/gerrit/#/c/39665/
16:04:18 <colindixon> VivekSri: that being said, you I think you can request that to be reviewed
16:04:26 <colindixon> if you get the tests in soon
16:04:33 <VivekSri> ok, will do
16:04:40 <anipbu> #info genius has pending docs patches for review: https://git.opendaylight.org/gerrit/#/c/39665/
16:04:52 <colindixon> VivekSri: it looks like we're waiting for more input here: https://git.opendaylight.org/gerrit/#/c/39665/
16:04:54 <anipbu> #action VivekSri to follow up on docs patches
16:05:10 <VivekSri> sure, will follow up
16:05:24 <anipbu> #action VivekSri to follow up on CSIT tests and "experimental" tag for relevant features.
16:06:10 <anipbu> VivekSri: I've added an action for you to follow up with integration team on the CSIT tests and experimental tag.  Currently you project features do not meet test expectations to be labeled nonexperimental.
16:06:20 <anipbu> VivekSri: Have you tested against RC2 and were there any blockers?
16:06:32 <VivekSri> yes, no blockers
16:07:43 <anipbu> #info genius has tested RC2 and found no blockers
16:08:22 <anipbu> VivekSri: could you please update this spreadsheet with the status of RC2 testing for Genius: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
16:08:38 <colindixon> things look good to me
16:08:40 <VivekSri> ok, will do
16:09:35 <anipbu> VivekSri: genius provides fcaps?
16:10:07 <anipbu> VivekSri: if genius provides fcaps, are there any security considerations that needs to be spelled out in the release review template?
16:10:16 <VivekSri> yes, there are features to include fcaps framework and application
16:10:56 <VivekSri> no specific security considerations i can see
16:11:15 <anipbu> #info genius has no security considerations
16:12:45 <anipbu> genius looks good to me, pending action item of follow up on the CSIT tests and experimentatl tag
16:12:59 <anipbu> Do folks have any further concerns or questions?
16:13:55 <anipbu> jamoluhrsen: any additional concerns you would like to raise?
16:15:07 <anipbu> Okay, if there are no other concerns, Let's move on.
16:15:19 <anipbu> #info GENIUS approved for Boron pending action items.  Congratulations!
16:15:29 <VivekSri> thanks!
16:15:44 <anipbu> Any folks from HONEYCOMB VBD?
16:15:45 <jamoluhrsen> anipbu: all good with me.
16:15:52 <anipbu> Any folks from HONEYCOMB VBD?
16:16:38 <anipbu> VBD has been unresponsive, so let's reschedule them.
16:17:01 <anipbu> #topic L2SWITCH
16:17:06 <anipbu> #link https://wiki.opendaylight.org/view/L2_Switch:Boron:Release_Review   <--- Release Review
16:17:10 <anipbu> #link https://wiki.opendaylight.org/view/L2_Switch:Boron:Release_Notes <--- Release Notes
16:17:19 <anipbu> #info evanz is representing L2SWITCH
16:17:28 <anipbu> evanz: anything you would like to add?
16:17:45 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/l2switch-dev/2016-August/001260.html  csit analysis email.
16:17:50 <evanz> anipbu: nothing to add
16:18:16 <jamoluhrsen> #info looks like all l2switch features should have the experimental label.
16:18:30 <colindixon> "There is a backlog of bugs here waiting for some love. "
16:18:32 <colindixon> love that
16:18:49 <anipbu> evanz: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:20:51 <vrpolak> Only sub-suite for loop remover has failures, but there is only one user-facing feature, so odl-l2switch-switch is experimental from testing point of view.
16:21:19 <evanz> 1. I haven't looked at RC2 myself, but I can take a look and follow up 2. all of them, as per @jamoluhrsen?
16:21:54 <jamoluhrsen> vrpolak: also the scale job is reporting zero.
16:22:09 <anipbu> evanz: in your release review template, could you list out the features and whether they are user-facing or experimental or have CSIT code with it https://wiki.opendaylight.org/view/L2_Switch:Boron:Release_Review#Features
16:22:09 <colindixon> is that a regression?
16:22:13 <anipbu> evanz: You can see an example of the listing here: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:22:18 <colindixon> anipbu: we should probably ask if there are any known regressions?
16:22:22 <jamoluhrsen> the test is "PASS", but the value is 0 which is not good.
16:22:39 <anipbu> #info l2switch to test RC2 and report the status of any blocking bugs
16:23:06 <colindixon> jamoluhrsen: I was curious if it returned more than 0 in the past
16:23:58 <anipbu> evanz: please update the spreadsheet on L2SWITCH testing for RC2: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
16:24:18 <evanz> will do
16:24:19 <anipbu> #action evanz to update the list of features and if they are user-facing or experimental, etc.
16:24:43 <colindixon> evanz, jamoluhrsen, vrpolak anyone know the answer to my question: did the scale test return >0 before?
16:24:45 <jamoluhrsen> colindixon: let me try to find out
16:24:47 <anipbu> #action evanz to follow up on RC2 testing and update the spreadsheet
16:24:50 <colindixon> OK
16:24:54 <evanz> colindixon, I think it did
16:25:06 <colindixon> it doesn't affect this right now, but it would be good to know and understand if it's real or fake
16:25:10 <vrpolak> jamoluhrsen: Oh. Yes, and the reason is the same: failed ping check. Not sure which functionality is failing for that one.
16:25:17 <jamoluhrsen> colindixon, it was 100 at one point
16:25:30 <colindixon> OK
16:25:47 <colindixon> #action evanz to figure out if the scale test is a real regression or just a test failure
16:25:53 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/l2switch/job/l2switch-csit-1node-periodic-host-scalability-daily-only-boron/plot/Inventory%20Host%20Scalability/  scalability test showing zero, but was 100 in the past
16:26:01 <colindixon> tjamls
16:26:02 <vrpolak> 100 is the first step. Maybe suite with smaller step would measure non-zero.
16:26:16 <Sai_> I can take a look at it.
16:27:24 <colindixon> Sai_: it looks like it happened between 6/22 and 6/24, which is odd because there's nothing of substance here: https://git.opendaylight.org/gerrit/#/q/project:l2switch+status:merged
16:27:36 <colindixon> maybe it's a timing issue
16:27:44 <colindixon> that's about when we migrated
16:29:37 <anipbu> So maybe we can follow up over email on the test failures to determine if there are any regression?
16:30:41 <Sai_> colindixon: yes, the graphs says so, I will go through tests and provide an update.
16:30:57 <colindixon> cool
16:31:12 <colindixon> given that it's experimental and works in manual testing, this isn't a blocker, but would be good to understand
16:31:17 <colindixon> OK
16:31:36 <anipbu> I think it would be worth following up with l2switch over email to cover: rc2 testing, updating features list on release review template, and csit/scale test issues
16:31:44 <colindixon> +1
16:31:54 <LuisGomez> i will take a look at the l2switch failures later today, at least to a point to know whether this is test or controller issue.
16:32:42 <colindixon> mostly for completeness b/c everything is experimental, I'm not as worried
16:32:48 <anipbu> #info anipbu evanz: l2switch to follow up over email to cover: rc2 testing, updating features list on release review template, and csit/scale test issues
16:33:13 <anipbu> #undo
16:33:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x246dcd0>
16:33:18 <anipbu> #action anipbu evanz: l2switch to follow up over email to cover: rc2 testing, updating features list on release review template, and csit/scale test issues
16:33:31 <anipbu> Do folks have any further concerns or questions for l2switch?
16:33:50 <Sai_> no, thanks anipbu , colindixon
16:33:58 <colindixon> I'm good
16:34:07 <anipbu> Okay let's move on
16:34:20 <anipbu> MDSAL has been unresponsive.
16:34:30 <anipbu> Are there any representatives from mdsal?
16:35:09 <colindixon> my guess is it's the same as controller
16:35:22 <anipbu> #info MDSAL was unresponsive.  Will reschedule.
16:35:32 <anipbu> NIC has been unresponsive.
16:35:40 <anipbu> Are there any representatives from NIC?
16:36:26 <anipbu> #info NIC was unresponsive.  Will reschedule.
16:36:46 <anipbu> Okay that's it folks.  I think we covered all the projects for today.
16:37:00 <anipbu> We're done for today.
16:37:49 <anipbu> Thanks vrpolak colindixon jamoluhrsen
16:38:29 <colindixon> thanks!
16:38:54 <anipbu> #topic cookies
16:39:02 <anipbu> #endmeeting