14:30:30 <anipbu> #startmeeting boron release review
14:30:30 <odl_meetbot> Meeting started Tue Aug 30 14:30:30 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:30 <odl_meetbot> The meeting name has been set to 'boron_release_review'
14:30:34 <anipbu> #topic roll call
14:30:38 <anipbu> #info PTL and TSC members please #info in
14:30:43 <anipbu> #info anipbu
14:30:45 <colindixon> #Info colindixon for TSC, docs, and ttp
14:30:49 <gdavid_comp> #info gdavid_comp for unimgr
14:30:53 <anipbu> gdavid_comp: good morning!
14:31:04 <ravit_> #info ravit_ for infrautils
14:31:05 <gdavid_comp> anipbu: good afternoon :)
14:31:22 <ravit_> good morning/afternoon to you all
14:31:43 <wei____> night now:)
14:31:59 <anipbu> vrpolak: Do we have anyone from integration here?
14:32:31 <vrpolak> #info Vratko Polak for Integration/Test
14:32:57 <anipbu> awesome!  Good morning vrpolak colindixon!
14:33:07 <anipbu> #chair vrpolak colindixon
14:33:07 <odl_meetbot> Current chairs: anipbu colindixon vrpolak
14:33:13 <anipbu> Okay.  Let's get started
14:33:18 <anipbu> #topic UNIMGR
14:33:22 <anipbu> #link https://wiki.opendaylight.org/view/Unimgr:BoronReleaseReview   <--- Release Review
14:33:27 <anipbu> #link https://wiki.opendaylight.org/view/Unimgr:BoronReleaseNotes <--- Release Notes
14:33:35 <anipbu> #info gdavid_comp is representing UNIMGR
14:33:39 <anipbu> gdavid_comp: anything you would like to add?
14:33:55 <gdavid_comp> anipbu: no, that's about it
14:34:16 * colindixon reads
14:34:16 <anipbu> gdavid_comp: Have you tested against RC2 and were there any blockers?
14:34:48 <gdavid_comp> yes, and no blockers found. we have one major bug open, which should be fixed this week
14:35:27 <anipbu> gdavid_comp: could you please update this spreadsheet column B/C with your RC2 status: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
14:35:31 <colindixon> gdavid_comp: and by that you mean before Thursday?
14:35:48 <gdavid_comp> colindixon:yes
14:36:14 <anipbu> Do you have the bug id for the last major bug?
14:36:54 <gdavid_comp> 6558
14:37:05 <anipbu> gdavid_comp: thanks
14:37:15 <colindixon> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020 <---- the release review schedule
14:37:41 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=6558 major bug discovered in RC2 for unimgr, should be fixed by RC3 spin
14:38:09 <vrpolak> Csit coverage: looks good. https://lists.opendaylight.org/pipermail/unimgr-dev/2016-August/000226.html
14:39:41 <colindixon> cool!
14:39:49 <colindixon> there's a documentation patch in flight
14:40:12 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/44844/ documentation in flight
14:40:26 <anipbu> #info CSIT in good condition https://lists.opendaylight.org/pipermail/unimgr-dev/2016-August/000226.html
14:41:00 <gdavid_comp> colindixon:that patch is part of the infra utils project, not unimgr
14:41:28 <colindixon> sorry
14:41:33 <anipbu> #undo
14:41:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24b6cd0>
14:41:34 <colindixon> #Undo
14:41:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x24b6610>
14:41:35 <anipbu> #undo
14:41:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x24b6110>
14:41:43 <anipbu> #info CSIT in good condition https://lists.opendaylight.org/pipermail/unimgr-dev/2016-August/000226.html
14:41:45 <colindixon> that was one too many, anipbu you take over
14:42:03 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=6558 major bug discovered in RC2 for unimgr, should be fixed by RC3 spin
14:42:24 <anipbu> colindixon: okay, fixed =)
14:42:41 <anipbu> unimgr looks good to me
14:42:48 <anipbu> Do folks have any further concerns or questions?
14:43:01 <colindixon> I'm good
14:43:40 <anipbu> vrpolak: any other concerns or questions?
14:44:03 <vrpolak> anipbu: No other comments.
14:44:28 <anipbu> Okay Let's move on.
14:44:30 <anipbu> #info UNIMGR approved for Boron pending.  Congratulations!
14:44:38 <anipbu> #topic INFRAUTILS
14:44:39 <gdavid_comp> anipbu: Thanks!
14:44:42 <anipbu> #link https://wiki.opendaylight.org/view/Infrautils:BoronReleaseReview   <--- Release Review
14:44:47 <anipbu> #link https://wiki.opendaylight.org/view/Infrastructure_Utilities:BoronReleaseNotes <--- Release Notes
14:45:04 <anipbu> #info ravit_ is representing INFRAUTILS
14:45:11 <anipbu> ravit_: anything you would like to add?
14:45:25 <ravit_> I have this documentation patch pending...
14:45:33 <ravit_> for the developers guide
14:45:37 <colindixon> ravit_: I know, it's only my list :-)
14:45:52 <ravit_> other than that I have nothing to add
14:46:32 <ravit_> colindixon: thanks :-) !
14:46:36 <anipbu> ravit_: Have you tested against RC2 and were there any blockers?
14:46:37 * colindixon reads
14:46:53 <ravit_> our code is tested via netvirt
14:47:03 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/44844/ documentation in flight
14:47:29 <ravit_> I don't know of any open issue with infrautils usage within netvirt
14:47:38 <vrpolak> Infrautils have no csit jobs, but I think they have the waiver (and all top-level features in Release Review are marked as experimental anyway).
14:47:47 <colindixon> this looks good to me
14:47:58 <ravit_> yes we do
14:47:59 <anipbu> ravit_: if you found no problems could you please update the spreadsheet: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
14:48:10 <ravit_> sure
14:48:26 <anipbu> #info infrautils has system test waiver
14:48:36 <ravit_> updated.
14:49:53 <anipbu> ravit_: your project is missing a system test plan template.  please create one and update it with the the test case coverage and results of manuel/external testing through netvirt.
14:50:12 <anipbu> #action ravit_ to complete system test plan for infrautils
14:50:17 <ravit_> ok. I will do it right away
14:51:02 <anipbu> #info all infrautils features are experimental
14:51:25 <anipbu> infrautils looks good me
14:51:30 <anipbu> Do folks have any further concerns or questions?
14:52:10 <colindixon> I'm good here
14:52:32 <anipbu> vrpolak: any other concerns or questions?
14:52:34 <colindixon> next time, my guess is that you want to call out the individual features vs. the -all version, but that's a really minor nit
14:53:05 <anipbu> #info suggestion for infrautils to break features up: call out the individual features vs. the -all version
14:53:06 <vrpolak> anipbu: No.
14:53:17 <anipbu> #info INFRAUTILS approved for Boron pending action items.  Congratulations!
14:53:29 <anipbu> #topic OF-CONFIG
14:53:47 <anipbu> wei___ wei____ Do you have the links to release review and release notes?
14:53:51 <wei____> yes
14:54:04 <wei____> https://wiki.opendaylight.org/view/OF-CONFIG:Boron:Release_Review
14:54:13 <ravit_> colindixon: ok i will, thanks.
14:54:17 <wei____> https://wiki.opendaylight.org/view/OF-CONFIG:Boron:Release_Notes
14:54:46 <anipbu> #link https://wiki.opendaylight.org/view/OF-CONFIG:Boron:Release_Review   <--- Release Review
14:54:51 <anipbu> #link https://wiki.opendaylight.org/view/OF-CONFIG:Boron:Release_Notes <--- Release Notes
14:55:19 <anipbu> #info wei____ is representing OF-CONFIG
14:55:25 <anipbu> wei____: anything you would like to add?
14:55:35 <wei____> no
14:56:07 <colindixon> wei___: anything to add for these sections not in your release notes?
14:56:08 <colindixon> Changes Since Previous Releases
14:56:09 <colindixon> Bugs Fixed in this Release
14:56:10 <colindixon> Migration from Previous Releases
14:56:11 <colindixon> Compatibility with Previous Releases
14:56:12 <colindixon> Deprecated, End of Lifed, and/or Retired Features/APIs
14:56:23 <colindixon> e.g., see: https://wiki.opendaylight.org/view/Infrastructure_Utilities:BoronReleaseNotes
14:56:33 <colindixon> my guess is you didn't have them last time b/c it was the first release
14:56:52 <anipbu> wei____: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:57:00 <vrpolak> Release Review page links to CSIT jobs, but they do not test OF-config at all. Every feature should be considered experimental. https://lists.opendaylight.org/pipermail/integration-dev/2016-August/008007.html
14:57:24 <wei____> 1) yes, no blockers
14:57:49 <anipbu> #info ofconfig has tested RC2 and found no blockers
14:57:54 <wei____> 2) the features mentioned in the release_notes
14:58:44 <wei____> 3) I deleted the description of user-facing features that written in Beryllium release_note
14:58:58 <anipbu> wei____: the feature names were not mentioned in the release notes.  at least i can't find them
14:59:32 <wei____> of-config-1.2-options
14:59:44 <wei____> feature-name  of-config-1.2-options
15:00:06 <colindixon> so, it says things about of-config 1.1.1 and 1.2, does it support both? one?
15:00:16 <wei____> yes, both
15:00:24 <anipbu> wei____: please take a look at this link and update the release review with the karaf feature names and their state (experimental, user facing, tested, etc): https://wiki.opendaylight.org/view/Sample_Release_Review#Features
15:00:51 <anipbu> #action wei____ to update the release review with list of features and their related attributes
15:01:08 <anipbu> #info Release Review page links to CSIT jobs, but they do not test OF-config at all. Every feature should be considered experimental. https://lists.opendaylight.org/pipermail/integration-dev/2016-August/008007.html
15:01:14 <wei____> ok, I will update it right now
15:01:32 <wei____> I aggree, An
15:01:58 <colindixon> also, it would be good if the wiki documentation could be moved to reStructuredText so it appears here: http://docs.opendaylight.org/
15:02:13 <anipbu> #info supports both of-config 1.1.1 and 1.2
15:02:26 <wei____> ok
15:03:09 <anipbu> wei____: any comments regarding the sections not in your release notes (see colindixon's comments)
15:03:44 <anipbu> #action wei____ to move wiki documentation to restructuredtext
15:03:56 <wei____> I will update it ASAP
15:04:13 <colindixon> really, it's just so people can learn how to use it as easily as possible
15:04:39 <wei____> ok
15:04:39 <colindixon> it would probably be on top of this patch: https://git.opendaylight.org/gerrit/#/c/44184/
15:04:50 <anipbu> #action wei____ to update the release notes with the missing sections: changes, bug fixed, migration, compatibility, deprecation: https://wiki.opendaylight.org/view/Sample_Release_Notes
15:05:06 <colindixon> and this one: https://git.opendaylight.org/gerrit/#/c/44347/
15:05:18 <wei____> got it
15:06:18 <anipbu> I think of-config will need a follow up after the release notes and release reviews are updated with necessary content
15:06:23 <davidmichaelkarr> Hey, if someone has a moment, could they PM me for a simple question about wiki work?
15:06:35 <colindixon> done
15:07:19 <colindixon> anipbu: I'd tend to agree, but I also don't think the issues are a blocker
15:08:13 <anipbu> #info of-config follow up to complete the content in the release notes and release review
15:08:15 <anipbu> #action anipbu to follow up with of-config
15:08:38 <anipbu> Do folks have any further concerns or questions?  Otherwise Let's move on.
15:09:48 <anipbu> #info OF-CONFIG approved for Boron pending action items, follow up to complete release review and release notes.  Congratulations!
15:09:55 <anipbu> #topic NETCONF
15:10:00 <anipbu> #link https://wiki.opendaylight.org/view/NETCONF:Boron:Release_Review   <--- Release Review
15:10:03 <anipbu> #link https://wiki.opendaylight.org/view/NETCONF:Boron:Release_Notes <--- Release Notes
15:10:11 <anipbu> #info tcere is representing NETCONF
15:10:15 <anipbu> tcere: anything you would like to add?
15:10:21 <tcere> nope
15:10:27 * colindixon reads
15:11:24 <anipbu> tcere: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:11:52 <jamoluhrsen> colindixon, anipbu, vrpolak: jamo here.
15:12:19 <anipbu> #chair jamoluhrsen
15:12:19 <odl_meetbot> Current chairs: anipbu colindixon jamoluhrsen vrpolak
15:12:31 <anipbu> jamoluhrsen we're reviewing netconf right now
15:12:45 <jamoluhrsen> anipbu: ack
15:13:03 <colindixon> tcere: is it draft 11 still or draft 14/15?
15:13:23 <tcere> 1) no manual testing apart from the csit that are ran on releng 2) odl-netconf-clustered-topology 3) odl-netconf-mdsal, odl-netconf-topology, odl-netconf-connector-all, odl-netconf-clustered-topology, odl-netconf-console
15:13:47 <tcere> i'll have to check the cherry-picked patches
15:13:58 <tcere> it should be 15 but im not 100% sure
15:14:02 <vrpolak> On one hand, there are failures not pointing to known bugs https://lists.opendaylight.org/pipermail/integration-dev/2016-August/008008.html
15:14:07 <jamoluhrsen> per my analysis yesterday, all netconf features are experimental
15:14:31 <colindixon> presumably restconf is covered by downstream tests, e.g., all of them, right?
15:14:54 <jamoluhrsen> colindixon, yes
15:14:54 <vrpolak> On the other hand, "userfeatures" job has only one failure, bug was in suite, fix is waiting for review and everything else passes. https://git.opendaylight.org/gerrit/44832
15:15:05 <tcere> jamoluhrsen: netconf-csit-1node-userfeatures-all-boron, netconf-csit-1node-userfeatures-only-boron - wrong status code and it should already be fixed by vratko
15:15:20 <anipbu> tcere: can you confirm if there are any problems with RC2 (with respect to netconf)
15:15:33 <tcere> nope
15:15:36 <tcere> no problems
15:15:50 <anipbu> #tcere has tested RC2 and found no problems
15:16:05 <jamoluhrsen> colindixon: btw, this is now the fourth project we are finding that is still affected by rest response changes.
15:16:12 <anipbu> #info tcere has tested RC2 and found no problems
15:16:34 <colindixon> so, jamoluhrsen, my guesss is that at least odl-restconf is not experimental
15:16:46 <colindixon> do we not have good test coverage for odl-netconf-connector?
15:16:50 <anipbu> jamoluhrsen: 8th actually.  we added nemo and netconf to the list of the previous 6
15:17:15 <vrpolak> Here is the passing Sandbox job: https://jenkins.opendaylight.org/sandbox/job/netconf-csit-1node-userfeatures-only-boron/1
15:17:17 <colindixon> jamoluhrsen: yeah... my guess is that response code changes will continue to cause problems for a bit
15:17:20 <anipbu> tcere: could you please update this spreadsheet with the statu of netconf RC2 testing https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:17:34 <jamoluhrsen> anipbu: add packetcable to that list.  i put a fix for them yesterday
15:18:06 <tcere> will do
15:18:37 <anipbu> tcere: could you please update your release review template with the list of features and their attributes such as experimental, user-facing, tested, etc.  See this sample here: https://wiki.opendaylight.org/index.php?title=Sample_Release_Review#Features
15:19:07 <tcere> yeah
15:19:37 <colindixon> I think we need some follow up to figure out what features are experimental
15:19:52 <vrpolak> colindixon: There are failures in scale tests. Most projects with no scale (or cluster) tests passed this review without their feature being tagged experimental.
15:20:00 <anipbu> #action tcere to update the release review with the list of features and their attributes
15:20:29 <anipbu> colindixon: scale tests are not a requirement.  only required for stable features adn we have none in boron.
15:20:45 <vrpolak> (I mean most projects which passed do not have such tests. There were plenty all-experimental projects so far.)
15:21:34 <colindixon> ok
15:21:37 <jamoluhrsen> vrpolak: agreed about scale tests not causing experimental.
15:21:37 <colindixon> cool
15:21:48 <anipbu> Okay, should we do a follow up for netconf?
15:21:48 <vrpolak> I would vote netconf features are not experimental from CSIT point of view, but I was the one providing the fix, so I am biased.
15:21:59 <colindixon> so we're good and think that this project has no experiemntal features?
15:22:24 <anipbu> that's jamoluhrsen vrpolak call for experimental
15:22:26 <jamoluhrsen> +1 pending vrpolak's fix, but patch seems good to me
15:22:51 <anipbu> #action anipbu to follow up with netconf on experimental tag for features
15:23:11 <anipbu> Do folks have any further concerns or questions?
15:23:23 <colindixon> cool
15:23:24 <colindixon> I'm good then
15:23:25 <jamoluhrsen> i'm good
15:23:43 <anipbu> #info netconf to follow up on relevant action items, including assigning of experimental tag to features, etc
15:24:27 <anipbu> Okay.  Let's move on.
15:25:15 <anipbu> #info NETCONF approved for Boron pending action items and follow up.  Congratulations!
15:25:21 <anipbu> #topic NATAPP
15:25:24 <TLee> Thomas Lee, TCS representing NATApp and Controller Shield
15:25:26 <anipbu> #link https://wiki.opendaylight.org/view/NATApp_Plugin:Boron_Release_Review   <--- Release Review
15:25:30 <anipbu> #link https://wiki.opendaylight.org/view/NATApp_Plugin:Boron_Release_Notes <--- Release Notes
15:25:43 <anipbu> #info TLee is representing NATAPP
15:25:52 <anipbu> TLee: anything you would like to add?
15:25:58 <TLee> Nope Thanks
15:26:09 <TLee> I have not tested against RC2
15:26:29 <TLee> Will test and update spreadsheet tomorrow
15:26:30 <jamoluhrsen> #info all NATAPP features are experimental for Boron.
15:26:40 <anipbu> TLee: Have you tested against RC2 and were there any blockers?
15:26:40 <colindixon> I need a +1 from TLee to merge and then migrate the docs https://git.opendaylight.org/gerrit/#/c/39099/
15:26:57 <TLee> Will do that Colin.
15:27:14 <anipbu> #action natapp will test RC2 and update the spreadsheet.
15:27:33 <anipbu> TLee: please test RC2 as soon as possible, since the last build is this Thursday.
15:27:40 <colindixon> jamoluhrsen, anipbu, TLee: so the features are not listed as experimental in the release review
15:27:44 <TLee> Sure An.
15:28:16 <anipbu> TLee: are your features experimental?
15:28:19 <TLee> We had CSIT tests done.
15:28:33 <TLee> 1 node
15:28:33 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/natapp-dev/2016-August/000047.html  csit analysis email for NATAPP
15:28:55 <jamoluhrsen> TLee, I'll go double check what I found, but as of yesterday I saw no csit at all
15:29:26 <colindixon> other than that, I'm happy
15:29:29 <jamoluhrsen> TLee: here is your *only* job and it's not running anything:   https://jenkins.opendaylight.org/releng/view/natapp/job/natapp-csit-1node-basic-only-boron/
15:30:17 <TLee> Will make our features experimental
15:30:46 <TLee> In case we cant fix the csit by Thursday
15:31:06 <anipbu> #info TLee has agree to marked the natapp features as experimental
15:31:07 <vrpolak> There is a typo in testplan file name. But even then, there is only the basic restconf suite, which does not test anything project specific.
15:31:51 <anipbu> #action TLee to update the release review wiki to state the feature is experimental
15:32:03 <TLee> I am not sure how we missed this as we had around 16 robot tests for natapp
15:32:16 <TLee> sorry will check and update
15:32:37 <jamoluhrsen> TLee: send an email if you need some help.  I will help right away.
15:32:49 <TLee> thanks jamo
15:32:57 <anipbu> TLee:  please update the wiki and mark as experimental for now.  Then after fixing the test suites, we can change the wiki again.
15:33:08 <TLee> Sure An.
15:33:30 <anipbu> #action natapp will update the target environment: https://wiki.opendaylight.org/view/NATApp_Plugin:Boron_Release_Notes
15:33:50 <vrpolak> Still under review: https://git.opendaylight.org/gerrit/41701 and https://git.opendaylight.org/gerrit/42205
15:34:08 <anipbu> TLee: for a nat, I think there should be some security considerations, but that is only my opinion.
15:34:30 <anipbu> okay, I have no other concerns for natapp.
15:34:34 <anipbu> Do folks have any further concerns or questions?
15:34:41 <jamoluhrsen> vrpolak: those two patches might be duplicates.
15:34:44 <jamoluhrsen> anipbu, nothing from me.
15:35:13 <TLee> Will remove 41071
15:35:31 <anipbu> #action TLee to remove duplicate patch 410171
15:35:45 <anipbu> Okay Let's move on
15:36:09 <colindixon> thanks
15:36:12 <anipbu> #info NATAPP approved for Boron pending action items and follow up.  Congratulations!
15:36:18 <anipbu> #topic USECPLUGIN
15:36:20 <TLee> Thanks
15:36:22 <anipbu> #link https://wiki.opendaylight.org/view/Controller_Shield:_Boron_Release_Review   <--- Release Review
15:36:27 <anipbu> #link https://wiki.opendaylight.org/view/Controller_Shield:Boron_Release_Notes   <--- Release Notes
15:36:30 <anipbu> #info TLee is representing USECPLUGIN
15:36:34 <anipbu> TLee: anything you would like to add?
15:36:47 <TLee> again RC2 test is not done.
15:36:55 <TLee> Will do it by tomorrow.
15:37:11 <TLee> Nothing else.
15:37:22 <anipbu> #action usecplugin will test RC2 and update the spreadsheet.
15:37:35 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/usecplugin-dev/2016-August/000140.html  email for usecplugin csit analysis
15:37:41 <colindixon> #link I'm still waiting for feedback on docs here here: https://git.opendaylight.org/gerrit/#/c/39165/
15:37:47 <jamoluhrsen> #info all usecplugin features are experimental
15:37:48 <anipbu> #action TLee will update the release review wiki with target environment
15:38:03 <anipbu> TLee:  I think your target environment is java 8.  and that it.
15:38:20 <TLee> Yes An its java 8
15:38:48 <anipbu> TLee:  okay, please update the wiki to reflect that
15:39:03 <vrpolak> Once again, multiple integration/test contributions still not merged: https://git.opendaylight.org/gerrit/#/q/project:integration/test+usecplugin+status:open
15:39:05 <TLee> I think our csit jobs are pending with reviewer
15:39:31 <anipbu> #action TLee to follow up on CSIT tests
15:39:44 <TLee> Sure An.
15:40:03 <anipbu> TLee: would you agree to make the features experimental for now, then change it after the CSIT suites are completed?
15:40:22 <TLee> Sure An. Will make features experiemental till CSIT is completed
15:40:43 <anipbu> TLee:  please update the release review template and change the features as experimental.  Fix the CSIT suites.  Then change the feature nonexperimental once all the issues ahve been resolved.
15:41:01 <TLee> Agreed An. Thanks
15:41:13 <anipbu> #info usecplugin has agreed to mark the features as experimental for now, but will fix CSIT and follow up.
15:42:03 <anipbu> #action TLee to update the release review template and change the features as experimental.  TLee will follow up on CSIT suites.
15:42:18 <TLee> Sure. Will do.
15:42:27 <anipbu> usecplugin looks good to me, besides the action item of following up on the CSIT tests and experimental tag
15:42:33 <anipbu> Do folks have any further concerns or questions?
15:43:47 <anipbu> jamoluhrsen: colindixon: vrpolak: any other concerns or questions?
15:43:58 <colindixon> I'm good
15:44:18 <anipbu> #action TLee to follow up on feedback on docs here here: https://git.opendaylight.org/gerrit/#/c/39165/
15:44:19 <jamoluhrsen> i'm good
15:44:21 <vrpolak> anipbu: No other concerns.
15:44:24 <anipbu> Okay, let's move on
15:44:28 <anipbu> #topic LACP
15:44:34 <TLee> Thanks An, Colin, Jamo, Vratko and Luis
15:44:46 <anipbu> #info USECPLUGIN approved for Boron pending action items and follow up.  Congratulations!
15:44:51 <anipbu> #link https://wiki.opendaylight.org/view/LACP:Release_Review   <--- Release Review
15:44:55 <anipbu> #link https://wiki.opendaylight.org/view/LACP:Release_Notes   <--- Release Notes
15:45:04 <kalai> hi, kalai representing for LACP
15:45:12 <anipbu> #info kalai is representing LACP
15:45:17 * colindixon reads
15:45:17 <anipbu> kalai: anything you would like to add?
15:45:35 <kalai> LACP verified with RC1, RC2 verification pending
15:45:53 <anipbu> #info LACP verified with RC1, RC2 verification pending
15:46:03 <anipbu> kalai: what is the ETA for testing RC2?
15:46:07 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/lacp-dev/2016-August/000156.html  email with CSIT analysis for LACP
15:46:17 <kalai> ETA - 31-8-16
15:46:20 <jamoluhrsen> #info all LACP features are experimental by definition.
15:46:34 <kalai> we have a CSIT test case
15:46:43 <jamoluhrsen> something broken with LACP csit jobs.  looks like infra issues to me, but its not intermittent
15:46:44 <anipbu> kalai: please note that the last and final build for boron is this thursday.  please test as soon as possible.
15:46:48 <jamoluhrsen> kalai: your csit is not running.
15:46:50 <jamoluhrsen> or passing.
15:47:04 <kalai> but currently it is running due to ssh infrastructure issue
15:47:17 <kalai> https://lists.opendaylight.org/pipermail/integration-dev/2016-August/007910.html
15:47:24 <anipbu> kalai: would you consider your features to be experimental?
15:47:29 <kalai> sorry it is not running
15:47:30 <colindixon> is there a plan to migrate the user guide to the docs project? I see that there's a user and developer guide on the wiki (but from Ltihium) and there's only this in the docs project: http://docs.opendaylight.org/en/stable-boron/developer-guide/lacp-developer-guide.html
15:48:00 <kalai> colin: there are already available in docs project
15:48:09 <jamoluhrsen> kalai: something very strange about your CSIT.  it's hitting the infra SSH issue every time, but other jobs are not hitting it any more.  Let me take an action to investigate that more.
15:48:46 <anipbu> https://git.opendaylight.org/gerrit/#/c/44403/   <--- LACP user guide
15:48:47 <vrpolak> Last run when robot started had failed tests, not pointing to a known Bug. But it was a month ago. https://jenkins.opendaylight.org/releng/view/lacp/job/lacp-csit-1node-lacp-only-boron/488/
15:48:48 <kalai> anipbu: we have a test case so should we be experimental
15:49:09 <kalai> we were not experimental in beryllium release and no new major updates to LACP
15:49:33 <vrpolak> Possible culprit is VM used: ubuntu-trusty-mininet-ovs-23-2c-2g
15:49:34 <colindixon> kalai: the standards for being experimental have gotten more rigorous in Boron
15:49:53 <anipbu> #action kalai: jamoluhrsen: to follow up on the CSIT failures and the experimental tag
15:50:07 <kalai> colin:ok
15:50:09 <colindixon> kalai: there's no user guide in the docs project
15:50:13 <jamoluhrsen> anipbu: ack.  talking with zxiiro about it on releng channel
15:50:25 <colindixon> there is here: https://wiki.opendaylight.org/view/LACP:Lithium:User_Guide
15:50:36 <kalai> one sec
15:50:49 <colindixon> nm
15:50:51 <colindixon> I'm wrong
15:50:53 <colindixon> I take that back
15:50:55 <colindixon> http://docs.opendaylight.org/en/stable-boron/user-guide/link-aggregation-control-protocol-user-guide.html?highlight=lacp
15:51:08 <anipbu> kalai: please update the release review wiki with links to the restructuredtext documentation
15:51:14 <colindixon> it's probably be good to link to those tow docs.opendalylight.org links
15:51:15 <colindixon> thanks!
15:51:32 <kalai> colin:ok will update with new links for both docs
15:51:34 <anipbu> #action kalai to update the release review with documentation links to rst/asciidocs, etc.
15:52:01 <anipbu> lacp looks good to me except for the csit, experimental tags, and docs.  I think follow is needed.
15:52:09 <anipbu> Do folks have any further concerns or questions?
15:53:03 <colindixon> I'm good
15:53:10 <anipbu> Okay Let's move on.
15:53:33 <anipbu> #info LACP approved for Boron pending action items and follow up.  Congratulations!
15:53:48 <kalai> Thanks @all
15:54:05 <anipbu> Mahesh Govind are you online?
15:54:42 <anipbu> Anyone from CAPWAP?
15:55:14 <anipbu> #info CAPWAP to reschedule again.
15:55:28 <anipbu> #topic DIDM
15:55:34 <anipbu> #link https://wiki.opendaylight.org/view/DIDM:_Boron_Release_Review  <--- Release Review
15:55:38 <anipbu> #link https://wiki.opendaylight.org/view/DIDM:_Boron_Release_Notes   <--- Release Notes
15:55:44 <anipbu> #info subh is representing DIDM
15:55:45 <subh> Hello everyone
15:55:48 <anipbu> subh: anything you would like to add?
15:56:02 <subh> today i received mail for the the CSIT job
15:56:05 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/didm-dev/2016-August/000548.html  email for DIDM csit analysis
15:56:13 <subh> it is failing sorry I was not aware about it
15:56:23 <anipbu> subh: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:56:25 <jamoluhrsen> subh: have you seen the email about csit?  I think someone needs to take a look asap that we don't have a blocking bug
15:56:53 <subh> sure I will work with you and Anandhi
15:56:58 <subh> to resolve it asap
15:57:16 <subh> 1) is pending
15:58:02 <colindixon> preusmably the release notes should mention the addition of Flow Objectives, right?
15:58:07 <subh> 2) we havn't added any new feature after the last release, so I think after fixing the CSIT job we can go ahed
15:58:24 <anipbu> subh: please please test RC2 as soon as possible and update this spreadsheet.  Thursday is the last and final build of boron: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:58:28 <subh> I have added the point in the introduction
15:58:44 <subh> sure anipbu
16:00:18 <anipbu> #action didm to update release review wiki with links to documentation rst/asciidocs
16:00:31 <vrpolak> The odl-didm-all feature apparently does not bring in odl-restconf anymore. CSIT job needs restconf to confirm controller is (at least partially) up.
16:00:35 <anipbu> subh: please add the restructuredtext links to your release review
16:00:56 <subh> sure
16:01:07 <jamoluhrsen> vrpolak, that's an easy fix.  let me try it now.
16:01:26 <subh> thanks vrpolak for the suggestion
16:01:49 <colindixon> I'm good if we work through that
16:01:56 <anipbu> subh: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:02:23 <subh> sure anipbu.. thanks for the clarification
16:02:23 <anipbu> colindixon: are you okay with the mentions of Flow Objectives
16:02:42 <anipbu> #action subh to update the release review with the list of features and their attributes
16:02:56 <colindixon> anipbu: yes, I don't think peeople will find things via release notes mostly anyway
16:02:58 <jamoluhrsen> vrpolak, subh: here:  https://git.opendaylight.org/gerrit/44870
16:03:08 <jamoluhrsen> vrpolak, you can merge if it's right.
16:03:18 <anipbu> colindixon: okay
16:03:51 <anipbu> subh: jamoluhrsen: vrpolak: have we come to a conclusion on the experimental tags for didm?
16:04:02 <anipbu> or do we need a follow up?
16:04:06 <vrpolak> jamoluhrsen: +2, waiting for verify job.
16:04:09 <jamoluhrsen> anipbu: yes followup.
16:04:19 <jamoluhrsen> didm is experimental by definition right now.
16:05:32 <anipbu> subh: are you okay with marking your features as experimental for now?
16:05:41 <subh> okay.
16:05:59 <anipbu> #info all of didm features are experimental for now
16:06:01 <subh> may be I will ask for the clarification over the mailing list
16:06:51 <anipbu> #action subh to mark features as experimental.  Will fixed the CSIT and follow up on the features experimental tags.
16:07:14 <subh> sure we will try to fix it asap
16:07:14 <anipbu> Okay DIDM looks good to me
16:07:19 <anipbu> Do folks have any further concerns or questions?
16:07:52 <colindixon> not here
16:08:03 <jamoluhrsen> i'm good.
16:08:12 <anipbu> Okay let's move on
16:08:18 <subh> thank you everyone !!
16:08:35 <anipbu> #info DIDM approved for Boron pending action items and follow up.  Congratulations!
16:08:39 <anipbu> #topic CARDINAL
16:08:42 <anipbu> #link https://wiki.opendaylight.org/view/Cardinal:Boron:Release_Review  <--- Release Review
16:08:46 <anipbu> #link https://wiki.opendaylight.org/view/Cardinal:Boron:Release_Notes   <--- Release Notes
16:08:50 <anipbu> #info Rajani is representing CARDINAL
16:08:54 <anipbu> Rajani: anything you would like to add?
16:08:59 <Rajani> Hello all
16:09:16 <Rajani> yes
16:09:28 <Rajani> earlier the code was stable and merged
16:09:46 <Rajani> we got a mail it is throwing some error
16:09:54 <Rajani> we will resolve it asap
16:10:34 <anipbu> Rajani: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:10:49 <Rajani> same issue is the blocker
16:11:01 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/cardinal-dev/2016-August/000043.html  csit analysis email
16:11:01 <Rajani> user facing feature is odl-cardinal
16:11:11 <jamoluhrsen> #info all cardinal features are experimental
16:11:26 <anipbu> Rajani: do you have a bug ID for the blocker?
16:11:37 <Rajani> yes
16:11:37 <jamoluhrsen> LuisGomez, pointed out some NPE Cardinal is showing.  probably someone needs to investigate and put a bug
16:11:48 <Rajani> 6586
16:11:51 <parthaDatta> https://bugs.opendaylight.org/show_bug.cgi?id=6586  <--- Cardinal open bug
16:12:19 <Rajani> Yes, can consider as experimental since it is first release of Cardinal and CSIT is done for few cases( feature installation and uninstallation)
16:12:54 <anipbu> #info Rajani has agreed to mark features as experimental
16:12:59 <anipbu> Rajani: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:13:00 <jamoluhrsen> Rajani: I did not see any CSIT yesterday.
16:13:22 <Rajani> link for csit https://git.opendaylight.org/gerrit/#/c/41204/
16:13:22 <anipbu> #action Rajani to update the release review with the list of features and their attributes
16:13:29 <Rajani> sure
16:13:54 <vina_ermagan> #info Vina Ermagan for LISP Flow Mapping
16:14:42 <jamoluhrsen> Rajani: maybe you need a JJB patch too?
16:14:58 <jamoluhrsen> Rajani: there is no CSIT job here:  https://jenkins.opendaylight.org/releng/view/cardinal/
16:15:03 <anipbu> Rajani: you will need to link the rst/asciidocs links to your release view template as well
16:15:31 <Rajani> sure, actually it is in progress
16:15:32 <anipbu> #action Rajani to add the documentation links to restructuredtext in the release review
16:15:53 <Rajani> for user doc https://git.opendaylight.org/gerrit/44322
16:16:35 <vrpolak> Feature installation alone does not qualify as system test for the feature.
16:16:51 <colindixon> http://docs.opendaylight.org/en/stable-boron/developer-guide/cardinal_-opendaylight-monitoring-as-a-service.html
16:16:57 <anipbu> Rajani: patch has been merged, but you just need to add the link to the rst file to the release view wiki page
16:17:08 <Rajani> sure
16:17:40 <Rajani> ok, points noted.will work on the same
16:18:22 <anipbu> cardinal looks good to me since it is all experimental features in boron
16:18:29 <anipbu> Do folks have any further concerns or questions?
16:18:42 <Rajani> no thanks everyone
16:19:01 <colindixon> looks good to me
16:19:12 <anipbu> jamoluhrsen: any other concerns?
16:19:17 <jamoluhrsen> i'm good
16:19:59 <anipbu> Okay Let's move on
16:20:08 <anipbu> #info CARDINAL approved for Boron pending action items.  Congratulations!
16:20:11 <anipbu> #topic CENTINEL
16:20:15 <anipbu> #link https://wiki.opendaylight.org/view/Centinel:Boron:Release_Review  <--- Release Review
16:20:18 <anipbu> #link https://wiki.opendaylight.org/view/Centinel:Boron:Release_Notes   <--- Release Notes
16:20:26 <anipbu> #info sumit_ is representing CENTINEL
16:20:34 <anipbu> sumit_: anything you would like to add?
16:20:48 <Guest18385> Hello Everyone , Abhishek this side
16:21:10 <Guest18385> I am presenting for Centinel
16:21:24 <anipbu> #info Abhishek Guest18385 is representing CENTINEL
16:21:36 <anipbu> Guest18385: anything you would like to add?
16:21:41 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/centinel-dev/2016-August/000137.html  email with Centinel CSIT analysis
16:21:51 <jamoluhrsen> #info all centinel features are experimental
16:22:14 <anipbu> sumit_ Guest18385: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:22:17 <jamoluhrsen> btw, Guest18385: looks like trouble just installing centinel features
16:22:28 <Guest18385> We are working on it and issue is with feature install timing issue
16:22:36 <Guest18385> there is no blocker as such
16:22:50 <Guest18385> user facing feature is odl-centinel-all
16:23:07 <anipbu> #info Guest18385 centinel has tested RC2 and found no blockers
16:23:33 <anipbu> Guest18385:  could you please update this spreadsheet with the status of your RC2 testing: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
16:23:53 <colindixon> Guest18385: it looks like the centinel docs havne't been updated since November of 2015
16:23:59 <colindixon> are they still up-to-date
16:24:27 <jamoluhrsen> Guest18385: I'm worried that odl-centinel-all doesn't work.  please check your csit.
16:24:40 <Guest18385> All the documentation are up to date. Because we have not added any new user facing features
16:24:54 <Guest18385> sure I will check
16:24:58 <colindixon> Guest18385: also, it would be helpful if you could +1 this so we could migrate the docs https://git.opendaylight.org/gerrit/44323
16:25:11 <Guest18385> sure
16:25:14 <anipbu> #info all documentation are up to date (even though though they were last updated on 11/2015)
16:25:15 <colindixon> we'll migrate it without your +1 at 23:59 UTC on Thursday
16:25:43 <anipbu> #action Guest18385  to approve patch for docs https://git.opendaylight.org/gerrit/44323
16:25:44 <Guest18385> I will update
16:25:49 <anipbu> Guest18385: would you agree that your features are all experimental?
16:26:03 <Guest18385> yes
16:26:25 <anipbu> #info Guest18385 has agreed that all in centinel are experimental
16:26:32 <anipbu> Guest18385: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:26:32 <colindixon> it would be good to confirm that things load at all
16:27:05 <anipbu> #action Guest18385 to update the release review with the list of features and their attributes
16:27:25 <Guest18385> ok. I will update the experimental features
16:27:27 <sumit_> sure .. Centinel team will update features as experomental for now
16:27:56 <sumit_> since some of CSIT test cases are failinh ..and as per pur debugging those are test cases issues..
16:27:57 <anipbu> #action centinel team to follow up on the critical issue of whether the features can load at all
16:28:18 <anipbu> jamoluhrsen: do we have a bug ID for the features not loading at all
16:28:52 <jamoluhrsen> anipbu: I don't know of a bug.  no.   If it's truly the case, then I think it's a blocker bug.  I'll take the action to look in to it.
16:28:52 <sumit_> We dont have bug ID for that,, but team is working on it ..mostly it is test cases issue..CSIT
16:29:43 <Guest18385> We are able to load it in local setup
16:29:51 <anipbu> #action jamoluhrsen sumit_ to follow up on whether centinel features can even load up at all and provide bug id as appropriate
16:30:03 <sumit_> sure ..
16:30:08 <Guest18385> there is issue related to timeout for feature install
16:30:23 <anipbu> centinel looks good to me
16:31:26 <colindixon> I'm good given what's already been said and the fact that it's experimental
16:31:28 <anipbu> actually, there are things missing in centinel's release notes:
16:31:51 <anipbu> Guest18385 sumit_: you are missing many sections in your release notes
16:32:39 <anipbu> Guest18385 sumit_: compatibility, migration, deprecation, changes, bugs, etc.  Please review the sample release notes and add the relevant sections https://wiki.opendaylight.org/view/Sample_Release_Notes
16:32:51 <sumit_> will update release notes..by tommotrow
16:33:34 <anipbu> #action Guest18385 sumit_ to update compatibility, migration, deprecation, changes, bugs, in the release notes
16:34:01 <vrpolak> Centinel feature repository is in integration, but the actual features are commented out. The comment states "Commented out because two of the features lead to Yang pares errors."
16:34:47 <sumit_> this was verly bug in berrlium .we have fixed it ..in start of boron
16:35:38 <vrpolak> sumit_: Feel free to contribute change to Integration/Distribution then.
16:35:48 <anipbu> #action sumit_ centinel to follow up on adding centinel to the features-test https://github.com/opendaylight/integration-distribution/blob/stable/boron/features-test/src/main/resources/features.xml
16:36:01 <sumit_> sure .. it is action item on me ..
16:36:12 <anipbu> Do folks have any further concerns or questions?
16:36:33 <anipbu> jamoluhrsen: vrpolak: any other concerns?
16:36:38 <vrpolak> No other concerns.
16:36:49 <jamoluhrsen> i'm ok.
16:37:24 <anipbu> okay let's move on
16:37:37 <anipbu> #info CENTINEL approved for Boron pending action items.  Congratulations!
16:37:43 <Guest18385> thanks all
16:37:43 <anipbu> #topic LISPFLOWMAPPING
16:37:48 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Boron_Release_Review  <--- Release Review
16:37:48 <vina_ermagan> #link https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Boron_Release_Review
16:38:02 <anipbu> #undo
16:38:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x23299d0>
16:38:05 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Boron_Release_Notes   <--- Release Notes
16:38:32 <anipbu> #info vina_ermagan is representing LISPFLOWMAPPING
16:38:36 <anipbu> vina_ermagan: anything you would like to add?
16:38:55 <anipbu> vina_ermagan: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:38:59 * colindixon reads
16:39:15 <vina_ermagan> We have tested RC2, no blocking bugs.
16:39:18 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/lispflowmapping-dev/2016-August/000802.html  email for CSIT analysis for lispflowmapping
16:39:37 <jamoluhrsen> #info all features covered in CSIT can be released without experimental labal.
16:39:37 <vina_ermagan> list of features are available in the release review
16:39:47 <jamoluhrsen> s/labal/label
16:39:48 <vina_ermagan> and two are marked experimental
16:40:02 <jamoluhrsen> thanks for the clean CSIT vina_ermagan
16:40:17 <colindixon> is there no developer guide?
16:40:24 <vina_ermagan> Thanks #jamoluhrsen
16:40:34 <anipbu> #info vina_ermagan lispflowmapping has tested RC2 and found no blockers
16:40:38 <colindixon> as always, lisp looks great
16:40:59 <anipbu> vina_ermagan: could you please update this spreadsheet with the status of RC2 testing?  https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
16:40:59 <vina_ermagan> Thanks  colindixon
16:41:30 <anipbu> vina_ermagan: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:41:35 <vina_ermagan> will do anipbu
16:42:36 <anipbu> #action vina_ermagan to update the release review with the list of features and their attributes
16:42:39 <colindixon> vina_ermagan: for what it's worth, it seems like there's been no lisp developer guide since helium
16:43:20 <colindixon> that's probably fine as the user docs are more important, but I just wanted to let you know
16:44:07 <vina_ermagan> anipbu: list of features is already listed with experimental marks on release review , the top level features listed are all user facing. I'll make this clear in the release review page
16:44:45 <anipbu> vina_ermagan: yes, please make this clear on the release review page.  Thanks.
16:44:56 <anipbu> lispflowmapping looks good to me
16:45:00 <anipbu> Do folks have any further concerns or questions?
16:45:01 <vina_ermagan> colindixon: right. Our user guide essentially covers what would go to the developer guide...
16:45:05 <jamoluhrsen> i'm good
16:45:30 <anipbu> colindixon: any additional questions or concerns?
16:46:02 <colindixon> I'm good
16:46:26 <colindixon> vina_ermagan: if that's the case, then putting a link to it, or even just directly including it in the developer guide would be a good idea
16:46:27 <anipbu> Okay.  Let's move on.
16:46:28 <colindixon> I can do that if you want
16:46:37 <colindixon> ping me oob
16:46:39 <colindixon> thnks anipbu
16:47:10 <anipbu> #action vina_ermagan to add link to user guide for the "developer guide" section, since they cover both.
16:47:16 <anipbu> #info LISPFLOWMAPPING approved for Boron pending action items.  Congratulations!
16:47:19 <anipbu> #topic OVSDB
16:47:22 <vina_ermagan> colindixon: thats a great point. will do
16:47:24 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Boron_Release_Review  <--- Release Review
16:47:28 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Boron_Release_Notes   <--- Release Notes
16:47:32 <anipbu> #info vishnoianil is representing OVSDB
16:47:35 <anipbu> vishnoianil: anything you would like to add?
16:47:38 <vina_ermagan> Thanks all!
16:47:54 <vishnoianil> anipbu, colindixon jamoluhrsen i am here
16:48:08 * colindixon reads
16:48:21 <anipbu> vishnoianil: anything you would like to add?
16:48:39 <vishnoianil> anipbu, Documentation is the only thing that requires some work.
16:48:51 <jamoluhrsen> good morning vishnoianil
16:48:56 <vishnoianil> After netvirt project split, we need to clean- up some of the existing wiki page
16:49:00 <vishnoianil> jamoluhrsen, good morning ;)
16:49:03 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/ovsdb-dev/2016-August/003762.html email with CSIT analysis for OVSDB
16:49:23 <anipbu> vishnoianil: 1) Have you tested against RC2 and were there any blockers?
16:49:29 <jamoluhrsen> #info ovsdb southbound features are good with CSIT, so no experimental label there.
16:49:48 <jamoluhrsen> #info hw vtep has no CSIT, so needs experimental label for Boron
16:49:57 <vishnoianil> anipbu, 1) Yes our CSIT test runs look good
16:50:04 <colindixon> so, are the docs up to date at all?
16:50:30 <anipbu> #info vishnoianil ovsdb has tested RCO and CSIT test runs looks good.  No blockers founds.
16:50:36 <anipbu> #undo
16:50:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24963d0>
16:50:43 <anipbu> #info vishnoianil ovsdb has tested RC2 and CSIT test runs looks good.  No blockers founds.
16:50:54 <vishnoianil> jamoluhrsen, basically we need to remove lot of content, because mostly ovsdb docs are about netvirt only
16:51:19 <vishnoianil> so developers guide is something that pretty much same, but user guide is something that we need to update.
16:51:46 <anipbu> #action vishnoianil to follow up on updating the user guide
16:52:11 <vishnoianil> jamoluhrsen, i marked the hardware vtep feature experimental and ovsdb southbound feature non-experimental
16:52:20 <vishnoianil> in the release notes
16:52:55 <colindixon> so, aside from the comment about docs, I'm good here
16:52:59 <anipbu> #info developers guide is something that pretty much same, but user guide is something that ovsdb needs to update.
16:53:07 <anipbu> ovsdb looks good to me
16:53:11 <jamoluhrsen> vishnoianil: sounds good about all of it.
16:53:12 <vishnoianil> colindixon, For documentation, i am pointing to the wiki page, because am planning to have a explicit reference to modify the user/developer guide
16:53:15 <jamoluhrsen> anipbu: I'm good.
16:53:41 <anipbu> okay, let's move on
16:53:55 <anipbu> #info OVSDB approved for Boron pending action items.  Congratulations!
16:53:59 <vishnoianil> jamoluhrsen, colindixon anipbu thanks
16:54:40 <anipbu> #topic ATRIUM
16:54:44 <anipbu> #link https://wiki.opendaylight.org/view/Atrium:Boron_Release_Review  <--- Release Review
16:54:48 <anipbu> #link https://wiki.opendaylight.org/view/Atrium:Boron_Release_Notes   <--- Release Notes
16:54:52 <anipbu> #info Manoj-atrium is representing ATRIUM
16:54:56 <Manoj-atrium> Hi this is manoj representing atrium
16:54:57 <anipbu> Manoj-atrium: anything you would like to add?
16:55:18 <Manoj-atrium> We need to update RC2 status . We will add that
16:56:04 <anipbu> Manoj-atrium: have you tested any of the RC0, Rc1, RC2?
16:56:05 <Manoj-atrium> And we will be updating user guide in 2 days
16:56:17 <Manoj-atrium> with additional info
16:56:56 * colindixon reads
16:57:00 <anipbu> #action Manoj-atrium atrium will test RC2 and provide update on the test status
16:57:01 <colindixon> thanks vishnoianil
16:57:26 <Manoj-atrium> Also need to update status for rc0, rc1
16:57:36 <vrpolak> Atrium has its feature in integration, but no suites in integration/test.
16:57:49 <Manoj-atrium> we have a waiver for integration test
16:58:01 <anipbu> #info atrium has a system test waiver
16:59:01 <vrpolak> Oh, yes, I forgot.
16:59:07 <anipbu> Manoj-atrium: what are the results of your external testing?Please update the Atrium System Test Plan with the results of external testing.  Even though atrium was granted a system test waiver, it must routinely report the results of external testing: https://wiki.opendaylight.org/view/Atrium:Boron_Test_Plan#Test_Result
16:59:57 <Manoj-atrium> we will update this page. Not yet updated. As such there is no blocker
17:00:00 <anipbu> #action Manoj-atrium to update the boron test plan with test results
17:00:04 <colindixon> I have no specific comments
17:01:44 <jamoluhrsen> i'm good
17:02:05 <anipbu> atrium looks good to me as well, pending result from external testing
17:02:49 <anipbu> Manoj-atrium please test RC2 as soon as possible.  The last final build is this Thursday.
17:02:56 <anipbu> Okay Let's move on.
17:02:59 <anipbu> #info ATRIUM approved for Boron pending action items.  Congratulations!
17:03:10 <Manoj-atrium> Sure. Will update by EOD tomorrow
17:03:42 <Manoj-atrium> Thanks anipbu,colindixon,jamoluhrsen
17:03:49 <colindixon> thanks!
17:04:07 <anipbu> #topic PACKETCABLE
17:04:11 <anipbu> #link https://wiki.opendaylight.org/view/PacketCablePCMM:BoronReleaseReview  <--- Release Review
17:04:19 <anipbu> #link https://wiki.opendaylight.org/index.php?title=PacketCablePCMM:BoronReleaseNotes   <--- Release Notes
17:04:23 <anipbu> #info kkershaw is representing PACKETCABLE
17:04:26 <anipbu> kkershaw: anything you would like to add?
17:04:39 <kkershaw> Hi - Kevin Kershaw here representing packetcable
17:04:55 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/packetcable-dev/2016-August/000138.html  email with CSIT analysis for packetcable boron release
17:05:01 <anipbu> kkershaw: anything you would like to add?
17:05:05 <jamoluhrsen> #info all packetcable features experimental
17:05:21 <jamoluhrsen> kkershaw, did you see my email and patch to try and help get CSIT to 100% passing?
17:05:33 <kkershaw> The current CSIT failure was introduced at the beginning of August (no change to Packetcable).  This was caused by change in ODL Netconf for Bugzilla 2594.  (201 vs 200 response to PUT)
17:06:00 <jamoluhrsen> kkershaw, understood.  we brought it up a lot though.
17:06:05 <jamoluhrsen> fix is needed in csit.
17:06:17 <anipbu> kkershaw: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
17:06:28 <kkershaw> There is a change already submitted in Gerrit - 44209 - that Vratko had a comment on - we were waiting for a developer to return to finish
17:06:46 <kkershaw> We have tested against RC2 - only the one CSIT failure noted.
17:06:56 <jamoluhrsen> kkershaw: ok.
17:07:08 <kkershaw> We would not have considered current features experimental except for this CSIT issue
17:07:10 <colindixon> kkershaw: I see the last documentation update was in februar, is that right?
17:07:17 <colindixon> https://git.opendaylight.org/gerrit/#/c/34925/
17:07:24 <colindixon> or do we need boron updates
17:07:27 <jamoluhrsen> vrpolak, can you go merge this one?  https://git.opendaylight.org/gerrit/#/c/44817/
17:07:42 <jamoluhrsen> vrpolak, then we can abandon 44209
17:08:11 <kkershaw> I am currently working on an update to the user guide.  It will take a couple of days to complete.  BTW, thanks colindixon for the RST conversion work.
17:08:25 <vrpolak> jamoluhrsen: Merged.
17:09:13 <kkershaw> I’ve noted the deficiency in the Release Review “Features” detail.  We will fix that later today as well
17:09:23 <anipbu> kkershaw: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
17:09:40 <kkershaw> understood
17:09:41 <anipbu> #action kkershaw to update the release review with the list of features and their attributes
17:10:41 <anipbu> kkershaw do we have a bug ID for the blocking issue in RC2 testing?
17:11:07 <kkershaw> Yes - 6572: https://bugs.opendaylight.org/show_bug.cgi?id=6572
17:11:14 <anipbu> #action kkershaw to update the user guide
17:11:47 <colindixon> kkershaw: thanks, no worries about the conversion, it was an automated tool that my intern wrote, it's pretty incredible stuff
17:12:10 <kkershaw> love those interns!
17:12:30 <anipbu> jamoluhrsen: kkershaw: so have be decided if packetcable features are experimental?
17:13:10 <anipbu> jamoluhrsen: kkershaw: perhaps we should have a follow up after the CSIT is fixed?
17:13:35 <kkershaw> Will the merge just done drive a rerun of the CSIT jenkins jobs?
17:13:36 <jamoluhrsen> anipbu: sure.  fix is merged.  will rerun job now.  someone send an email that we can track with.
17:14:15 <anipbu> #action packetcable to follow up on the "experimental" tag after fixing the CSIT tests.
17:14:20 <anipbu> packetcable looks good to me
17:14:24 <kkershaw> I can send an email - to [release] ?
17:14:24 <anipbu> Do folks have any further concerns or questions?
17:14:53 <anipbu> kkershaw: i think it is being tracked on the integration mailing list
17:15:54 <anipbu> kkershaw: you also need a section for migration in your release nots
17:15:56 <anipbu> *notes
17:16:10 <anipbu> #action kkershaw to update the release notes with section on migration
17:16:47 <anipbu> jamoluhrsen colindixon: any other questions or concerns?
17:16:53 <jamoluhrsen> i'm good
17:17:21 <kkershaw> OK - I will fix that - may have accidentally deleted from previous version.  thanks colindixon, jamoluhrsen, anipbu, & vrpolak for your help.
17:17:31 <anipbu> Okay let's move on.
17:17:39 <anipbu> #info PACKETCABLE approved for Boron pending action items.  Congratulations!
17:17:44 <anipbu> I think we covered all the projects for today.
17:17:51 <kkershaw> Thank you!
17:17:56 <anipbu> Okay.  That's it folks.  We're done for today.
17:17:58 <colindixon> I'm good
17:17:59 <colindixon> thanks you
17:18:08 <colindixon> thanks so much anipbu
17:18:10 <jamoluhrsen> thanks guys.  have a good afternoon.
17:18:30 <anipbu> Thanks colindixon jamoluhrsen vrpolak
17:18:36 <anipbu> #topic cookies
17:18:42 <anipbu> #endmeeting