15:01:09 <anipbu> #startmeeting boron release review
15:01:09 <odl_meetbot> Meeting started Wed Aug 31 15:01:09 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:09 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:09 <odl_meetbot> The meeting name has been set to 'boron_release_review'
15:01:14 <anipbu> #topic roll call
15:01:19 <anipbu> #info PTL and TSC members please #info in
15:01:24 <anipbu> #info anipbu
15:01:29 <anipbu> Do we have anyone from integration here?
15:01:50 <anipbu> vrpolak are you ready?  I think you're up first for integration/distribution?
15:02:32 <vrpolak> anipbu: Just finished editing wikipages. What is the spreadsheed to copy links into?
15:02:35 <zxiiro> Thanks anipbu !
15:02:39 <anipbu> https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020
15:03:03 <anipbu> #topic INTEGRATION/DISTRIBUTION
15:03:40 <vrpolak> #info from Integration/Distribution import Vratko Polak as vrpolak
15:03:48 <vrpolak> Links inserted, ready for review.
15:03:56 <anipbu> #link https://wiki.opendaylight.org/view/Integration/Distribution/Boron_Release_Review  <--- Release Review
15:04:00 <anipbu> #link https://wiki.opendaylight.org/view/Integration/Distribution/Boron_Release_Notes   <--- Release Notes
15:04:23 <anipbu> #info vrpolak is representing INTEGRATION/DISTRIBUTION
15:04:30 <anipbu> vrpolak: anything you would like to add?
15:04:57 <vrpolak> jamoluhrsen did not send e-mail about CSIT, we have two specific tests for Version functionality (1 failure due to known non-blocking Bug 6003)
15:05:33 <vrpolak> See links under odl-distribution-version in https://wiki.opendaylight.org/view/Integration/Distribution/Boron_Test_Report
15:06:03 <anipbu> #info int/dis has two specific tests for Version functionality (1 failure due to known non-blocking Bug 6003)
15:06:04 <vrpolak> SR2 tested, no blockers visible.
15:06:11 <vrpolak> I mean RC2
15:06:20 <anipbu> #info int/dis has tested RC2.  No blockers found.
15:07:13 <anipbu> I reviewed the release notes and release review templates and they look good.  Well written!
15:07:16 <vrpolak> One issue may be that we are not testing tar.gz archives in CSIT at all, but risk is negligible I think.
15:08:39 <vrpolak> No more comments come to my mind.
15:09:02 <anipbu> int/dis looks good to me
15:09:08 <anipbu> Do folks have any further concerns or questions?
15:09:44 <anipbu> #info INTEGRATION/DISTRIBUTION approved for Boron.  Congratulations!
15:09:53 <vrpolak> anipbu: Thanks!
15:09:55 <anipbu> Okay  Let's move on.
15:10:27 <anipbu> #topic SXP
15:10:31 <anipbu> #link https://wiki.opendaylight.org/view/SXP:Boron:Release_Review  <--- Release Review
15:10:36 <anipbu> #link https://wiki.opendaylight.org/view/SXP:Boron:Release_Notes   <--- Release Notes
15:10:46 <anipbu> Is Martin Mihálek online?
15:11:06 <mamihale> Yes I am present
15:11:19 <anipbu> #info mamihale is representing SXP
15:11:25 <anipbu> mamihale: anything you would like to add?
15:12:58 <mamihale> We have at the moment one open Bug 6448 that depends on on 6540
15:13:00 <anipbu> mamihale: 1) Do you have any features that should be considered experimental?  2)  What are the user-facing features in your project?
15:13:01 <anipbu> #info INTEGRATION/DISTRIBUTION approved for Boron pending action items.  Congratulations!
15:13:06 <anipbu> #undo
15:13:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2597d10>
15:13:36 <mamihale> only one user facing feature odl-sxp-controller
15:14:09 <vrpolak> CSIT review: https://lists.opendaylight.org/pipermail/integration-dev/2016-August/008042.html
15:14:25 <jamoluhrsen> anipbu, vrpolak, colindixon: checking in
15:14:28 <anipbu> mamihale: would you agree that that all your features are experimental?
15:14:45 <anipbu> #chair jamoluhrsen vrpolak colindixon
15:14:45 <odl_meetbot> Current chairs: anipbu colindixon jamoluhrsen vrpolak
15:15:06 <anipbu> #info sxp has texted RC2 and found no blocking bugs
15:15:22 <anipbu> #info CSIT review: https://lists.opendaylight.org/pipermail/integration-dev/2016-August/008042.html
15:15:27 <vrpolak> Each test job suffers from occassional failures. Most test cases do Wait Until Keyword Succeeds with 15 second timeout, so I guess the instability is in ODL itself.
15:15:35 <colindixon> I'm looking
15:15:41 <colindixon> integration disribution looks perfec
15:16:27 <anipbu> mamihale: would you agree that that all your features are experimental?
15:16:53 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/sxp-dev/2016-August/000057.html  email for sxp csit analysis
15:17:41 <anipbu> #info sxp has only one user facing feature odl-sxp-controller
15:17:42 <mamihale> yes based on distribution tests result from boron cycle
15:18:06 <anipbu> #info mamihale has agreed that all SXP features are experimental in boron
15:18:13 <anipbu> mamihale: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
15:18:20 <anipbu> #action mamihale to update the release review with the list of features and their attributes
15:19:27 <anipbu> #action mamihale to put links to the asciidocs/rst documents into the release review template
15:19:49 <anipbu> mamihale: your docs patches have been merged
15:20:39 <anipbu> mamihale: I believe TCPMD5 has been removed in Boron: See section Security Considerations: "There is no support for any form of session authentication, protocol support TCP MD5 authentication."
15:21:13 <anipbu> Do folks have any further concerns or questions?
15:21:52 <jamoluhrsen> i'm good.
15:22:33 <anipbu> #info SXP to complete action items and follow up
15:23:00 <mamihale> We have switched to netty TCPMD5 implementation so the statement was not updated as there was no impact on TCPMD5 authentification
15:23:27 <anipbu> mamihale: okay
15:23:55 <vrpolak> anipbu: Tcpmd5 is not a Boron ODL project, but the equivalent functionailty is provided by upstream (netty). Still, if SXP code does not invoke that functionality, it remains true that SXP does not support TCP MD5.
15:24:17 <vrpolak> Otherwise no more comments from me.
15:24:39 <anipbu> #action anipbu to follow up with SXP on action items
15:24:45 <anipbu> Okay.  Let's move on.
15:25:25 <anipbu> #topic OCPPLUGIN
15:25:30 <anipbu> #link https://wiki.opendaylight.org/view/OCP_Plugin:Boron_Release_Notes  <--- Release Review
15:25:34 <anipbu> #link https://wiki.opendaylight.org/view/OCP_Plugin:Boron_Release_Review   <--- Release Notes
15:25:40 <anipbu> #info richardchien is representing SXP
15:25:45 <anipbu> richardchien: anything you would like to add?
15:26:03 <richardchien> no
15:26:03 <colindixon> for what it's worth SXP has new docs in Boron, which is good
15:26:06 * colindixon reads
15:26:33 <anipbu> #info ocpplugin has texted RC2 and found no blocking issues
15:27:00 <anipbu> #info all ocpplugin features are marked as experimental
15:27:27 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/ocpplugin-dev/2016-August/000024.html  csit analysis email for ocplugin
15:27:37 <richardchien> this should be updated
15:27:39 <jamoluhrsen> #info all system tests are meeting expectations
15:28:19 <colindixon> this looks good to me
15:28:22 <colindixon> it's experimental, right
15:28:37 <jamoluhrsen> not experimental from system test point of view
15:29:09 <anipbu> richardchien: is there a link to OCP capable radio head device or simulator (for testing)
15:29:39 <anipbu> jamoluhrsen: they have voluntarily marked their features as experimental based on the release review template: https://wiki.opendaylight.org/view/OCP_Plugin:Boron_Release_Review#Features
15:30:06 <richardchien> info about the simulator can be found in user guide
15:30:09 <jamoluhrsen> anipbu: ok
15:30:26 <anipbu> #info info about the simulator can be found in user guide
15:30:33 <anipbu> ocpplugin looks good to me
15:30:53 <anipbu> richardchien: congrats on having no action items =)
15:31:12 <anipbu> Do folks have any further concerns or questions?
15:31:19 <anipbu> Otherwise, let's move on.
15:32:16 <anipbu> #info OCPPLUGIN approved for Boron.  Congratulations!
15:32:23 <anipbu> #topic GROUPBASEDPOLICY
15:32:29 <anipbu> #link https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Boron/Release_note  <--- Release Review
15:32:33 <anipbu> #link https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Boron/Release_review  <--- Release Notes
15:32:42 <anipbu> #info vlavor is representing GROUPBASEDPOLICY
15:32:47 <anipbu> vlavor: anything you would like to add?
15:33:04 <vlavor> no, nothing I can think of
15:33:23 <anipbu> What is teh status of this bug?
15:33:25 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=6421
15:33:41 <anipbu> Can we close the bug, retarget for carbon, or provide a fix?
15:33:49 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2016-August/003559.html  email for gbp csit review
15:33:51 <vlavor> already fixed
15:34:28 <jamoluhrsen> csit is not meeting expectations for the most part.  I have a hunch that it's small test issues that need to be fixed.
15:34:34 <anipbu> #info bug 6421 is already fixed accoridng to vlavor
15:34:47 <anipbu> vlavor: could you please close the bug if it has already been fixed.
15:34:51 <anipbu> vlavor: 1) Have you tested against RC2 and were there any blockers?
15:35:28 <colindixon> GBP has had very little documentation updates in Boron, was that intentional?
15:35:37 <vlavor> bug 6421 updated, resolved fixed
15:37:25 <anipbu> Thanks!
15:37:32 <anipbu> vlavor: 1) Have you tested against RC2 and were there any blockers?
15:37:39 <colindixon> this looks godo other than my comment above ^^^^^
15:38:07 <vlavor> yes, we tested against RC2, no blockers found
15:38:25 <vlavor> documentation was created for new features only
15:38:45 <colindixon> vlavor: and not all of them, right?
15:38:55 <colindixon> I only saw new docs for the vpp mapper
15:38:57 <colindixon> or am I wrong
15:39:01 <colindixon> it's fine actually
15:39:48 <vlavor> vpp-mapper is done, some documentation is still in progress
15:39:50 <colindixon> I just wanted to ask
15:39:51 <colindixon> ok
15:39:51 <colindixon> good
15:39:52 <colindixon> thanks
15:40:00 <anipbu> #info odl-groupbasedpolicy-ofoverlay is nonexperimental feature.  All other features are experimental.
15:40:21 <anipbu> jamoluhrsen: are you okay with odl-groupbasedpolicy-ofoverlay as nonexperimental?
15:40:35 <jamoluhrsen> anipbu: I don't think so.
15:40:43 <colindixon> cool
15:41:12 <anipbu> vlavor jamoluhrsen: can we come to an agreement for odl-groupbasedpolicy-ofoverlay, otherwise let's do a follow up.
15:41:19 <jamoluhrsen> when I look yesterday it seems almost all CSIT was having unexpected failures.
15:41:43 <vlavor> we have investigated it, it looks like problems with tests themselves
15:42:08 <jamoluhrsen> vlavor: we need to get the tests fixed.  if we can do that asap (I'll help) then we can say not experimental.
15:42:21 <jamoluhrsen> otherwise we have to use the same measuring stick as we are with all other projects
15:43:39 <anipbu> #action jamoluhrsen vlavor  to follow up on the CSIT failures for odl-groupbasedpolicy-ofoverlay
15:44:52 <colindixon> thanks jamoluhrsen for all the hard work
15:45:04 <vlavor> we are going to try to fix them
15:45:13 <anipbu> #info groupbasedpolicy to follow up
15:45:17 <jamoluhrsen> sure thing colindixon :)
15:45:19 <anipbu> Do folks have any further concerns or questions?
15:45:33 <jamoluhrsen> vlavor: send an email update to me if you want, and I can try to jump in to help
15:45:48 <vlavor> jamoluhrsen: sure
15:46:08 <vlavor> jamoluhrsen: thanks
15:46:45 <colindixon> OK, what's next?
15:47:04 <anipbu> OKay Let's move on.
15:47:13 <anipbu> #info GROUPBASEDPOLICY approved for Boron pending action items.  Congratulations!
15:47:44 <anipbu> #topic NETVIRT
15:47:48 <anipbu> #link https://wiki.opendaylight.org/view/NetVirt:Boron_Release_Review  <--- Release Review
15:48:10 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2016-August/001391.html  <--- email review of netvirt CSIT
15:48:11 <anipbu> #info shague_ is representing NETVIRT
15:48:18 <jamoluhrsen> morning shague_
15:48:19 <anipbu> shague_: anything you would like to add?
15:48:23 <shague_> hey
15:48:27 <anipbu> shague_: I cannot find your release notes
15:49:19 <shague_> we have the old-ovsdb-openstack marked as experimental right now, but think we can get that to stable after fixing failing csit
15:49:32 <shague_> https://wiki.opendaylight.org/view/NetVirt:Boron_Release_Notes
15:49:38 <anipbu> #link https://wiki.opendaylight.org/view/NetVirt:Boron_Release_Notes  <--- Release Notes
15:50:30 <shague_> anipbu: sorry, just fixed the spreadsheet
15:51:19 * colindixon reads
15:51:41 <anipbu> shague_: 1) Have you tested against RC2 and were there any blockers?
15:52:13 <anipbu> #info all netvirt features are marked as experimental
15:52:26 <colindixon> is that right?
15:52:26 <afredette> :s/old-ovsdb-openstack/odl-ovsdb-openstack
15:52:42 <shague_> yes, no blockers. There are CSIT test failures, but we should have the legacy netvirt fixed and the new netvirt will remain with failures
15:53:13 <shague_> yes, right now they are marked as experimental. I think we will get odl-ovsdb-openstack CSIT fixed and can remove experimental
15:53:38 <anipbu> colindixon: according to the release review template, all the featues are experimental
15:53:52 <colindixon> cool
15:53:56 <colindixon> I'm happy
15:54:02 <jamoluhrsen> i'm good
15:54:04 <anipbu> shague_: there no mention of the vpnservice/netvirt migration in your release notes.
15:54:29 <shague_> anipbu: that is this comment: Move to new, more modular architecture based on vpnservice and genius
15:54:35 <colindixon> I saw that
15:54:43 <colindixon> it is there
15:54:59 <anipbu> Ah missed it.
15:55:01 <colindixon> shague_: you know this, but the docs desperately need updaing
15:55:26 <anipbu> Is a more comprehensive description anywhere that described that migration effort in detail for end users?
15:55:33 <shague_> yes. That is the note in the release review that we will look at those next week
15:56:07 <afredette> colindixon: re:docs, we'll take a pass over within a week.
15:56:14 <colindixon> cool
15:56:15 <colindixon> thanks
15:56:25 <anipbu> #action shague_ to add more about vpnservice/netvirt migration in docs
15:56:32 <anipbu> netvirt looks good to me
15:56:36 <anipbu> Do folks have any further concerns or questions?
15:56:40 <colindixon> I'm good
15:56:48 <anipbu> Okay let's move on.
15:56:50 <colindixon> I hope the CSIT gets fixed, but I understand it's been painful
15:57:32 <shague_> colindixon: agreed. we are working on it
15:58:01 <anipbu> #action shague_ to work on addressing CSIT failures and update the experimental tag if necessary
15:58:35 <anipbu> #info netvirt has tested rc2 and found no blockers
15:58:40 <anipbu> #info NETVIRT approved for Boron pending action items.  Congratulations!
15:58:44 <anipbu> #topic OPFLEX
15:58:47 <anipbu> #link https://wiki.opendaylight.org/view/OpFlex:Boron_Release_Review  <--- Release Review
15:58:50 <anipbu> #link https://wiki.opendaylight.org/view/OpFlex:Boron_Release_Notes  <--- Release Notes
15:58:53 * colindixon reads
15:58:55 <anipbu> #info readams is representing OPFLEX
15:58:58 <anipbu> readams: anything you would like to add?
15:59:00 <jamoluhrsen> #info opflex has a system test waiver
15:59:00 <readams> Hello folks
15:59:17 <readams> I think all the info is in the docs
16:00:16 <anipbu> readams: have you published the results of your external/manual testing of opflex in the system test plan?  If so, what were the results of the testing?
16:00:57 <readams> I don't think it's published anywhere visible externally
16:01:25 <readams> We run an automated system test against ACI with OpenStack on physical hardware
16:02:08 <jamoluhrsen> readams: assuming all your tests are passing, or if failures you are tracking with open bugzillas?
16:02:10 <anipbu> So what were the results of the test?  Did they pass (green)?
16:02:12 <readams> We recently branched off boron for our external customer release
16:02:22 <colindixon> this looks good to me
16:02:25 <readams> They're passed and now shipping to customers
16:03:01 <anipbu> #info opflex ran automated system test against ACI with OpenStack on physical hardware.  All the tests passed (green).
16:03:09 <jamoluhrsen> nice readams.  happy customers hopefully
16:03:17 <jamoluhrsen> all good from my side, anipbu
16:03:18 <readams> hopefully :-)
16:03:24 <anipbu> readams: do you have link to opflex artifacts for boron
16:03:57 <readams> the latest boron merge build should be good
16:04:11 <anipbu> readams: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:05:06 <anipbu> We seem to be missing the boron release artifacts for opflex: https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/opflex/agent-ovs/
16:05:37 <readams> 1) n/a 2) n/a 3) no :-)
16:05:50 <anipbu> #action anipbu readams zxiiro: to add opflex to the boron release artifacts:  https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/opflex/agent-ovs/
16:05:52 <readams> In the past the opflex artifacts have to be pushed manually
16:06:44 <zxiiro> readams: we should probably update teh opflex jobs so that they push to a staging repo in Nexus and we have helpdesk click the release button just like we do with the ODL release
16:06:45 <readams> random question for you guys: do you feel like it's beneficial for OpFlex to be part of ODL at this point or is it just a nuisance?
16:06:56 <anipbu> #info opflex has texted RC2 on automated systems.  tests pass (green)
16:07:14 <anipbu> readams: I would love to have opflex continue to be part of ODL! =)
16:07:21 <anipbu> Do folks have any further concerns or questions?
16:07:53 <anipbu> Okay Let's move on.
16:07:59 <anipbu> #info OPFLEX approved for Boron pending action items.  Congratulations!
16:08:08 <zxiiro> readams: but yeah manually building is fine for Boron, lets open an action item to make the opflex release more automated though
16:08:28 <anipbu> #topic NEXT
16:08:28 <zxiiro> readams: maybe somethign abelur can look into for you
16:08:34 <anipbu> #link https://wiki.opendaylight.org/view/NeXt:Boron_Release_Review  <--- Release Review
16:08:35 <readams> thanks guys
16:08:39 <anipbu> #link https://wiki.opendaylight.org/view/NeXt:Boron_Release_Notes <--- Release Notes
16:08:42 <aikepaer> hi folks
16:08:56 <aikepaer> I put most of info in that doc
16:08:56 <anipbu> #info aikepaer is representing NEXT
16:09:03 <anipbu> aikepaer: anything you would like to add?
16:09:22 <jamoluhrsen> anipbu, I didn't know what to do about next csit analysis
16:09:24 <aikepaer> Almost there
16:10:40 <zxiiro> readams: fyi I added it to our releng trello board. We'll try to look into automating opflex jobs a bit better in the next release.
16:10:42 <anipbu> aikepaer: would you agree to mark your features as experimental: since it does not have waiver and does not have CSIT tests?
16:10:56 <colindixon> aikepaer: is there any plan to move the docs the docs repo?
16:11:16 <anipbu> aikepaer: 1) Have you tested against RC2 and were there any blockers?
16:11:34 <aikepaer> anipbu, yes, it's ok to mark as experimental
16:11:58 <anipbu> #info aikepaer has agreed to mark all next features as experimental in boron
16:12:11 <aikepaer> colindixon , azverev just join us and he will update all docs in docs repo
16:12:35 <aikepaer> azverev already working on that, will commit it in next two weeks
16:12:38 <anipbu> aikepaer: could you please update the release review template and change the features as experimental: https://wiki.opendaylight.org/view/NeXt:Boron_Release_Review#Features
16:12:46 <aikepaer> sure
16:13:01 <aikepaer> and no blockers
16:13:04 <anipbu> #action aikepaer to update the release review template and change the features as experimental
16:13:14 <anipbu> #info next has tested RC2 and found no blockers
16:13:27 <anipbu> aikepaer: where are the artifacts for next ui toolkit?
16:14:22 <anipbu> #action aikepaer  anipbu zxiiro: to work with next ui toolkit to upload the artifacts to release https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/next/next/
16:14:29 <aikepaer> It should be here https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/next/next/, just realized need to push manually
16:15:14 <anipbu> aikepaer: okay I have actioned us to work with thanh to upload to release
16:15:32 <anipbu> next looks good to me
16:15:34 <aikepaer> OK, thanks
16:15:36 <anipbu> Do folks have any further concerns or questions?
16:15:40 <colindixon> I'm good
16:16:08 <colindixon> assuming we have the artifacts, the tests are understood, I'm happy
16:16:09 <jamoluhrsen> i'm good
16:16:20 <anipbu> Okay Let's move on.
16:17:15 <anipbu> #info NEXT approved for Boron pending action items.  Congratulations!
16:17:20 <anipbu> #topic SXP
16:17:23 <anipbu> #info SXP approved for Boron.  Congratulations!
16:17:26 <anipbu> Forgot to mention this.
16:17:30 <anipbu> #topic IOTDM
16:17:35 <anipbu> #link https://wiki.opendaylight.org/view/Iotdm:Boron_Release_Notes  <--- Release Review
16:17:38 <anipbu> #link https://wiki.opendaylight.org/view/Iotdm:_Boron_Release_Review <--- Release Notes
16:17:41 <jburns> hey
16:17:42 <anipbu> #info jburns is representing IOTDM
16:17:46 <anipbu> jburns: anything you would like to add?
16:17:52 <anipbu> jburns: 1) Have you tested against RC2 and were there any blockers?
16:18:15 <jburns> yes, IOTDM had a blocking bug that impacted it until Monday eveneing. Not usre what this means for RC2 …
16:18:48 <anipbu> What is the bug ID for this blocker?
16:18:53 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/iotdm-dev/2016-August/000172.html  <--- email for csit analysis of IOTDM
16:18:59 <jburns> Also, Jamo mentioned CSIT tests were failing.  We gave a Borion demo yesterday and it seemed good so need to get to the bottom of this.
16:19:02 <jamoluhrsen> #info all features experimental
16:19:23 <jburns> Actaully, I did not create a bug_id … I will do that.
16:19:40 <anipbu> jburns: has this bug been fixed, or is it still open?
16:19:56 * colindixon reads
16:20:01 <jburns> No, I’ll create a bug id for it and immediately close it.
16:20:24 <jburns> Bornon seems stable again as of Monday eventing.
16:21:23 <anipbu> jburns: please correct me if i'm wrong.  There was a blocker. It has been fixed.  RC2 has been tested and there are curretnly no blockers anymore.  The state of IOTDM is green (pass)
16:21:49 <anipbu> jburns: would you agree to that statement as correct?
16:22:09 <jburns> I have not explicitly tested RC2 … the snapshot as of Monday eveneing is stable.
16:22:21 <jamoluhrsen> anipbu: iotdm is not "green" for CSIT.
16:22:59 <anipbu> Okay, is there any chance you could test RC2 and update this spreadsheet: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
16:23:02 <jburns> Yes, I suspect the bug was impacting greatly our CSIT tests.  I will investigate our CSIT tests for Borin.
16:23:13 <jburns> I will do that!
16:23:31 <anipbu> #action jburns to test RC2 and update the spreadsheet
16:24:07 <anipbu> jburns: please test RC2 as soon as possible because the last and final build is this Thursday (tomorrow) at 11:59 UTC time zone.
16:24:13 <colindixon> the release notes seem... ight
16:24:26 <colindixon> the release review looks good
16:24:27 <anipbu> jburns: 2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:24:44 <colindixon> is it compatible with Beryllium
16:25:02 <colindixon> is there a plan to deliver more docs?
16:25:10 <colindixon> anipbu: sorry we're moving slower, trying to get forward
16:25:14 <jburns> We have introduced a GUI for IoTDM this release.  It is based onNext which is experimental so maybe it should be tagged as experimental too.
16:25:24 <jburns> We are compatibnle with Be.
16:25:42 <jburns> I think in the Carbon timeframe, we will document the GUI.
16:25:49 <anipbu> #action jburns to update the release notes with sections on changes/migration/compability/deprecation
16:26:03 <jburns> OK
16:26:14 <anipbu> jburns: so would you agree that all iotdm features are experimental?
16:26:29 <colindixon> it woudl be good to submit docs to explan the GUI if you have time
16:26:36 <jburns> NO, just the GUI.
16:27:12 <anipbu> jamoluhrsen jburns: have we come to an agreement on the experimental tags for iotdm?
16:27:33 <anipbu> jamoluhrsen jburns: seems like there needs to be a follow up to discuss more
16:27:40 <jburns> The GUI is experimental, the others are not.
16:28:12 <jamoluhrsen> anipbu, jburns all features are experimental by definition I am forced to say.
16:28:23 <anipbu> jburns: according to jamoluhrsen, it seems all "others" are experimental as well.  so let's take this offline to discuss more over email
16:28:24 <colindixon> jburns: do we have the CSIT
16:28:25 <jburns> Like I said, I will look into the CSIT failures.
16:28:32 <colindixon> cool, cool
16:28:36 <jburns> OK, offline is fine.
16:28:43 <anipbu> #action jamoluhrsen jburns to follow up on CSIT and experimental tags
16:28:51 <anipbu> jburns: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:28:56 <anipbu> #action jburns to update the release review with the list of features and their attributes
16:29:12 <anipbu> #info IOTDM to follow up on action items
16:29:20 <anipbu> #action anipbu to follow up with IOTDM
16:29:22 <jburns> Thanks
16:29:24 <anipbu> Do folks have any further concerns or questions?
16:29:30 <anipbu> Otherwise Let's move on.
16:30:33 <colindixon> thanks anipbu
16:30:35 <anipbu> #topic VTN
16:30:40 <anipbu> #link https://wiki.opendaylight.org/view/VTN:Boron:Release_Review  <--- Release Review
16:30:44 <anipbu> #link https://wiki.opendaylight.org/view/VTN:Boron:Release_Notes <--- Release Notes
16:30:48 <anipbu> #info hideyuki is representing VTN
16:30:52 <anipbu> hideyuki: anything you would like to add?
16:31:10 <hideyuki> Hi.
16:31:27 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/vtn-dev/2016-August/001585.html <--- email for VTN csit analysis
16:31:29 <anipbu> hideyuki: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:31:37 <hideyuki> Now, we are facing a critical issue due to a bug of the OpenFlow Plugin.
16:31:41 <colindixon> this looks great to me
16:31:43 <hideyuki> https://bugs.opendaylight.org/show_bug.cgi?id=6595
16:31:50 <jamoluhrsen> #info all VTN features are experimental due to system test expectations
16:32:07 <hideyuki> We've tested RC2, and it worked fine.
16:32:24 <hideyuki> #info VTN project has tested RC2, and it worked fine.
16:32:28 <anipbu> hideyuki: Please update this spreadsheet for VTN RC2 testing: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
16:32:47 <hideyuki> I think all VTN features are not experimental
16:33:05 <hideyuki> Now, as Jamo explained, CSIT fails sometimes.
16:33:22 <hideyuki> But, there are not beccause of bugs of VTN features.
16:33:28 <anipbu> hideyuki: You said there is a blocker bug (6595).  But then you said RC2 is tested and everything is fine.  Could you please clarify on the status of RC2?
16:33:46 <hideyuki> RC2 is ok except the bug 6595.
16:34:17 <anipbu> Okay, I've marked VTN as red pending openflowplugin to fix bug 6595
16:34:24 <hideyuki> anipbu: Ok. Thanks.
16:34:32 <anipbu> #info for RC2, VTN is red pending openflowplugin to fix bug 6595
16:34:43 <anipbu> hideyuki: do you have the link to the vtn coordinator?
16:34:49 <hideyuki> CSIT worked fine. But, since last week, due to the bug of the openflowplugin, it has started to faile sometims.
16:35:00 <LuisGomez> hideyuki, can you post me later the vtn jobs that are not stable?
16:35:01 <hideyuki> anipbu: What kind of link?
16:35:12 <hideyuki> LuisGomez: Sure.
16:35:20 <LuisGomez> it is very possible it is openflowplugin yes
16:35:22 <jamoluhrsen> LuisGomez, here is one: https://jenkins.opendaylight.org/releng/view/vtn/job/vtn-csit-1node-manager-only-boron/
16:35:23 <anipbu> Where is vtn coordinated located so we can put link on the downloads page.
16:35:44 <jamoluhrsen> looks like host to host ping is not working sometimes.  something is broken.
16:36:05 <hideyuki> jburns: Yes. We've filed a bug report as bug 6595.
16:36:18 <gvrangan> jamoluhrsen: No flows are wrritten
16:36:28 <jburns> Thanks
16:36:33 <hideyuki> anipbu: Are you asking the location of the RC2 artifact of the VTN Coordinator in the Nexus?
16:37:01 <jamoluhrsen> gvrangan: ok.  no flows written seems like a legit issue to me.
16:37:43 <anipbu> I believe in boron, VTN coordinator is no longer packaged as a part of the common karaf distribution (to help decrease the distribution size).  If so, then we need to provide a link to the VTN coordinator on nexus for users, similar to opflex, next, yangide, etc.
16:37:58 <hideyuki> anipbu: I know it.
16:38:09 <hideyuki> anipbu: https://nexus.opendaylight.org/content/repositories/autorelease-1452/org/opendaylight/vtn/distribution.vtn-coordinator/6.3.0-Boron-RC2/distribution.vtn-coordinator-6.3.0-Boron-RC2-bin.tar.bz2
16:38:13 <colindixon> jamoluhrsen, LuisGomez, hideyuki: I think that l2switch was seeing issues like that
16:38:17 <hideyuki> anipbu: I think this link.
16:38:17 <colindixon> not sure if they're the same
16:38:23 <colindixon> I could ask Sai
16:38:26 <colindixon> maybe LuisGomez knows
16:38:29 <anipbu> #action hideyuki anipbu zxiiro: to work with releng team to upload vtn cooridnator to the release nexus repo: https://nexus.opendaylight.org/content/repositories/autorelease-1452/org/opendaylight/vtn/distribution.vtn-coordinator/6.3.0-Boron-RC2/distribution.vtn-coordinator-6.3.0-Boron-RC2-bin.tar.bz2
16:38:54 <hideyuki> anipbu: Though, this is an artifact for RC2.
16:39:16 <anipbu> hideyuki: we can take the vtn coordinator issue offline over email with thanh ha
16:39:17 <hideyuki> anipbu: We should get the link to a release artifact of VTN  Coordinator after the community generated release artifacts.
16:39:23 <hideyuki> anipbu: Yea.
16:39:25 <anipbu> hideyuki: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:39:25 <hideyuki> anipbu: Yes.
16:39:29 <anipbu> #action hideyuki to update the release review with the list of features and their attributes
16:39:34 <LuisGomez_> hideyuki, the issue with OF10 is due to ofplugin?
16:39:46 <hideyuki> anipbu: Ok.
16:39:52 <hideyuki> LuisGomez: Yes.
16:39:55 <anipbu> jamoluhrsen hideyuki: have we come to a conclusion on the experimental tags for VTN?
16:40:08 <hideyuki> LuisGomez: Our team didn't face the issue with OF13. Our team only observed the issue with OF10.
16:40:16 <hideyuki> anipbu: No.
16:40:37 <anipbu> #action hideyuki to work with openflowteam to resolve pending blocking bug (6595)
16:40:54 <colindixon> thanks
16:41:05 <jamoluhrsen> anipbu, hideyuki: csit is not meeting expectations and looks like valid issues to me.  gotta be experimental for now
16:41:06 <anipbu> #action jamoluhrsen hideyuki to work offline to resolve CSIT failures and update the experimental tags for VTN
16:41:17 <hideyuki> If the blocking bug 6595, I think we should mention a big limitation on VTN feature on Boron which is VTN doen't work with OF10 in Boron.
16:41:28 <hideyuki> If the blocking bug 6595 is not fixed by Boron, I think we should mention a big limitation on VTN feature on Boron which is VTN doen't work with OF10 in Boron.
16:41:41 <anipbu> #info VTN to follow up with action items
16:41:49 <anipbu> #action anipbu to follow up with VTN
16:42:34 <anipbu> #info if the blocking bug 6595 is not fixed by Boron, then there is a big limitation on VTN feature on Boron which is VTN doesn't work with OF10 in Boron.
16:42:40 <LuisGomez> the only thing to be not experimental is to have decent test and mark the failures with the bug
16:42:43 <anipbu> Do folks have any further concerns or questions?
16:42:53 <hideyuki> It worked fine with OF10 before. So we are thinking it's a regression since last week...
16:43:00 <anipbu> I think VTN will need follow up offline over email
16:43:01 <hideyuki> anipbu: No.
16:43:21 <anipbu> If folks have no futhur questions, then let's move on.
16:43:28 <hideyuki> anipbu: Ok.
16:43:34 <colindixon> I'm good
16:43:34 <hideyuki> Thank you everybody1
16:43:41 <colindixon> VTN's docs are awesome as always
16:43:42 <jamoluhrsen> ok
16:44:13 <anipbu> #topic SFC
16:44:18 <anipbu> #link https://wiki.opendaylight.org/view/Service_Function_Chaining:Boron_Release_Review  <--- Release Review
16:44:23 <anipbu> #link https://wiki.opendaylight.org/view/Service_Function_Chaining:Boron_Release_Notes <--- Release Notes
16:44:36 <ebrjohn> Hello everybody, Brady here
16:44:53 <anipbu> #info ebrjohn is representing SFC
16:45:00 <anipbu> ebrjohn: anything you would like to add?
16:45:07 <ebrjohn> nothing special
16:45:10 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/sfc-dev/2016-August/003389.html <--- csit email analysis for SFC
16:45:21 <hideyuki> anipbu: Is VTN approved for Boron?
16:45:28 <ebrjohn> I invited the SFC Boron Testing contact, Miguel Angel (mangel2) to participate in case there are any detailed SFC CSIT questions.
16:45:38 <jamoluhrsen> #info all sfc features experimental currently, but some work being done currently that may clean things up.
16:45:39 <ebrjohn> Regarding the analysis, 2 of the NOT-OK tests were affected by the REST response codes, 404 on delete. A patch is in place for this.
16:45:46 <anipbu> hideyuki: we will need follow up on the action items and clarification over email.
16:45:51 <vrpolak> anipbu: "VTN coordinator is no longer packaged as a part of the common karaf distribution" is true, and the fact is now mentioned in Integration/Distribution Release {Review,Notes}
16:45:53 <ebrjohn> Can you reconsider marking all of the SFC features as experimental?
16:45:57 <colindixon> is there anythnig you wanted for docs beyond this: https://git.opendaylight.org/gerrit/#/c/39686/
16:46:04 <jamoluhrsen> ebrjohn, will try to get to that patch after release reviews
16:46:15 * ebrjohn checking patch
16:46:37 <ebrjohn> colindixon: that doc patch covers everything
16:46:41 * colindixon reads release review and notes
16:46:41 <colindixon> cool
16:46:45 <ebrjohn> jamoluhrsen: ok, thanks
16:47:09 <anipbu> ebrjohn: would you agree to make all sfc features experimental?
16:47:17 <ebrjohn> jamoluhrsen: did you see Miguel Angel's response to your email?
16:47:18 <ebrjohn> https://lists.opendaylight.org/pipermail/sfc-dev/2016-August/003389.html
16:47:34 <ebrjohn> anipbu: No, I would prefer they not be marked experimental
16:47:41 <jamoluhrsen> ebrjohn: saw the email, but didn't read it yet.
16:47:51 <jamoluhrsen> i will
16:47:54 <anipbu> jamoluhrsen ebrjohn: have we come to an agreement or do we need a follow up?
16:48:05 <ebrjohn> Ok, he analyzed the failures, and they are mostly related to the REST response codes, 404 on delete
16:48:09 <ebrjohn> but a patch is in place for that
16:48:33 <jamoluhrsen> ebrjohn: that's perfect.  we've found a handful of projects dealing with rest response codes during our release reviews.
16:48:48 <ebrjohn> jamoluhrsen: ok, cool
16:49:08 <colindixon> I'm happy
16:49:10 <anipbu> So perhaps we can continue the experimental tag offline over email?
16:49:20 <ebrjohn> so can we keep the experimental status as its listed in the release review doc?
16:49:29 <yuling_> Hi All...sorry Im late for the meeting...
16:49:38 <anipbu> ebrjohn: thanks for good section "Migration"!
16:49:50 <ebrjohn> anipbu: sure :)
16:49:55 <colindixon> as long as jamoluhrsen is happy, I'm happy
16:49:59 <colindixon> with what I see from my side
16:50:17 * ebrjohn is happy if you're happy ;)
16:50:31 <jamoluhrsen> yeah, experimental for now with high hopes that csit patch is good to fix everything.
16:50:43 <anipbu> #action jamoluhrsen ebrjohn to follow up on CSIT test and experimental tags for SFC features.
16:50:52 <jamoluhrsen> lol.  true.  if colin ain't happy, ain't nobody happy
16:50:57 <ebrjohn> jamoluhrsen: anipbu: Ok, Im cool with that
16:51:10 <anipbu> #info SFC to follow up on action items
16:51:16 <anipbu> #action anipbu to follow up with SFC
16:51:17 <colindixon> cool
16:51:23 <colindixon> experimental things aside, I think we're good
16:51:27 <ebrjohn> anipbu: what's the action item?
16:51:30 <anipbu> I think besides the CSIT and expeirmental tags, SFC looks good to me
16:51:37 <jamoluhrsen> anipbu, agreed.
16:51:51 <anipbu> ebrjohn: the action item is "jamoluhrsen ebrjohn to follow up on CSIT test and experimental tags for SFC features"
16:51:58 <ebrjohn> anipbu: ACK
16:52:11 * ebrjohn oops, didnt see that one
16:53:01 <anipbu> #info SFC has tested RC2 and found no blockers
16:53:13 <ebrjohn> yes, but I did write an email about RC2
16:53:19 <anipbu> ebrjohn: thanks for updating the RC2 spreadsheet
16:53:26 <ebrjohn> https://lists.opendaylight.org/pipermail/release/2016-August/008036.html
16:53:27 <anipbu> ebrjohn: are there blockers?
16:53:35 <ebrjohn> no, just this non-blocker
16:53:40 <ebrjohn> https://bugs.opendaylight.org/show_bug.cgi?id=6526
16:53:48 <ebrjohn> anipbu: you're welcome
16:53:53 <anipbu> okay.  if non blocker, then the spreadsheet is correct.
16:53:58 <ebrjohn> yep
16:54:02 <anipbu> #info SFC approved for Boron pending action items.  Congratulations!
16:54:09 <anipbu> Okay Let's move on
16:54:13 <ebrjohn> Awesome!
16:54:18 <ebrjohn> Thanks guys, looking forward to seeing all of you in Seattle!!
16:54:20 <anipbu> #topic TSDR
16:54:44 <anipbu> yuling_: do you have the links to the release notes and release review templates?
16:55:00 <yuling_> sorry...the documents will be ready by today
16:55:12 <yuling_> we have been busy testing the features...so kind of overlooked the document
16:55:23 <anipbu> If they are not ready now, we cannot do the release review.
16:55:27 <yuling_> however, we did test all the new features and old features manually with test report
16:55:35 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/tsdr-dev/2016-August/000962.html  <--- email for TSDR csit analysis
16:55:37 <anipbu> Perhaps we can reschedule.
16:55:46 <yuling_> yes, that would be great
16:55:52 <jamoluhrsen> #undo
16:55:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2437190>
16:56:04 <yuling_> could that be tomorrow?
16:56:05 <anipbu> Let's reschedule for TSDR.  Please email me offline to reschedule.
16:56:24 <anipbu> Okay Let's move on.
16:56:53 <anipbu> #topic FAAS
16:56:54 <yuling_> ok, thanks
16:56:58 <anipbu> #link https://wiki.opendaylight.org/view/FaaS:Boron_Release_Review  <--- Release Review
16:57:01 <anipbu> #link https://wiki.opendaylight.org/view/FaaS:Boron_Release_Notes <--- Release Notes
16:57:05 <xingjun> Hello Everyone xingjun here
16:57:08 <anipbu> #info xingjun is representing FAAS
16:57:12 <anipbu> xingjun: anything you would like to add?
16:57:33 <anipbu> xingjun: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:57:36 <xingjun> we have documentation for review, hasn't been merged yet by Colin :)
16:57:42 <colindixon> thanks
16:57:44 <colindixon> I'm on it
16:57:51 <xingjun> Yes, I did this morning, no blocking issues found
16:58:08 <anipbu> #info FAAS has tested RC2 and found no blockers
16:58:09 <xingjun> All the features are experimenal for now
16:58:32 <xingjun> the user facing feature is odl-faas-uln-mapper
16:58:34 <anipbu> #info xingjun has agreed that all FAAS features are experimental.
16:58:39 <jamoluhrsen> #info FAAS has no CSIT, so all experimental
16:58:47 <anipbu> xingjun: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:58:55 <anipbu> #action xingjun to update the release review with the list of features and their attributes
16:59:02 * colindixon reads
16:59:15 <xingjun> we do have a CSIT in process for review. we'd love to covert all the manual scripts to robot
17:00:56 <xingjun> Ok will update to reflect the experimental status
17:01:24 <anipbu> Please do so now so we can approve faas
17:02:11 <colindixon> it's compatible with previous releases?
17:02:12 <xingjun> Done
17:02:22 <anipbu> xingjun: is faas compatible with previous release?
17:02:42 <anipbu> xingjun: any migration concerns?
17:02:46 <anipbu> xingjun: any deprecation?
17:03:11 <anipbu> #action xingjun to update the release notes with the sections on changes/migration/compabilities/deprecation.
17:03:20 <xingjun> Yes compatible
18:15:44 <anipbu> Yay!
18:17:02 <anipbu> #topic cookies
18:17:07 <anipbu> #endmeeting