14:30:59 <anipbu> #startmeeting boron release review
14:30:59 <odl_meetbot> Meeting started Thu Sep  1 14:30:59 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:59 <odl_meetbot> The meeting name has been set to 'boron_release_review'
14:31:04 <anipbu> #topic roll call
14:31:09 <anipbu> #info PTL and TSC members please #info in
14:31:19 <yuling_> #info TSDR
14:31:23 <anipbu> #info anipbu
14:31:33 <RafatJahan> #info sdninterfaceapp
14:31:43 <vrpolak> #info Vratko Polak for integration
14:31:52 <vjanandr> #info vijay for snbi
14:32:03 <anipbu> yuling_: some scheduling conflict, can you do 8:20?
14:32:27 <yuling_> would prefer now...since I'll have to go to work:-)
14:32:29 <yuling_> if possible
14:32:33 <yuling_> should be quick...
14:32:41 <yuling_> we have all the documents ready
14:32:44 <anipbu> Okay, let;s do TSDR first
14:32:49 <anipbu> Okay.  Let's get started
14:32:51 <yuling_> thanks very much
14:32:55 <anipbu> #topic TSDR
14:33:04 <yuling_> https://wiki.opendaylight.org/view/Boron_Release_Review
14:33:17 <anipbu> #info https://wiki.opendaylight.org/view/Boron_Release_Review   <--- Release Review
14:33:23 <anipbu> do you have the release notes?
14:33:30 <yuling_> https://wiki.opendaylight.org/view/TSDR:Beryllium:Release_Review
14:33:54 <yuling_> https://wiki.opendaylight.org/view/Boron_Release_Review
14:34:09 <anipbu> You seem to be missing the release notes
14:34:33 <yuling_> https://wiki.opendaylight.org/view/Boron_Release_Notes
14:34:45 <anipbu> #link https://wiki.opendaylight.org/view/Boron_Release_Notes   <--- Release Notes
14:34:58 <anipbu> #info yuling_ is representing TSDR
14:35:06 <anipbu> yuling_: anything you would like to add?
14:35:13 <anipbu> yuling_: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:35:21 <rovarga> should'n those release notes be under TSDR?
14:35:46 <yuling_> oh... sorry. seems used the wrong link
14:36:02 <yuling_> 1) Yes, we tested RC2 and voted green
14:36:14 <anipbu> yuling_: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
14:36:18 <anipbu> #action yuling_ to update the release review with the list of features and their attributes
14:36:27 <yuling_> 2) We don't believe we have features that should be considered experimental
14:37:08 <yuling_> We didn't add any new user facing features in Boron
14:37:29 <yuling_> but I can add the old user facing features in the release review
14:37:52 <vrpolak> CSIT test look good, except the cassandra job which looks unstable. Discussion is ongoing: https://lists.opendaylight.org/pipermail/integration-dev/2016-September/008085.html
14:37:55 <yuling_> Also our user guide already listed all the user facing features
14:38:09 <yuling_> right. for Cassandra, we don't believe it's blocking issue
14:38:13 <anipbu> #info TSDR has tested RC2 and found no problems
14:38:22 <yuling_> since when the user deploys Cassandra, it's always in a separate server
14:38:28 <yuling_> not on the same server as ODL controller
14:38:32 <anipbu> #info TSDR has no user-facing features
14:38:44 <yuling_> TSDR has user-facing features
14:38:55 <yuling_> but no new user-facing features in Boron
14:39:04 <anipbu> yuling_: do you agree to tag cassandra an experimental feature?
14:39:10 <anipbu> #undo
14:39:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24a7e90>
14:39:27 <yuling_> As I said... Cassandra never deploys on the same machine as ODL controller
14:39:44 <yuling_> I don't believe that's a blocking issue...
14:39:59 <yuling_> we tested Cassdanra with all TSDR features...never seen issues
14:40:09 <anipbu> yuling_: are you saying that you believe cassandra should be nonexperimental?
14:40:19 <yuling_> yes
14:40:40 <yuling_> unless we can prove that when Cassandra is deployed in other server, we also see the same issue
14:40:56 <yuling_> also, we should wait until we dig out what exactly the issue is before we tag it as experiemental
14:41:08 <yuling_> we only knew this issue yesterday and Sharon is working on it
14:41:12 <yuling_> let's see what we find out
14:41:16 <anipbu> #info all features are non-experimental, except for Cassandra, which is currently tagged as experimental.  However, the TSDR team believes cassandra should be nonexperimental.
14:41:29 <yuling_> Cassandra is an important data store for our customers
14:41:48 <yuling_> we need to at least spend some time to find out what's going on before tagging the experimental tag
14:41:54 <anipbu> #action yuling_ jamoluhrsen to follow up with CSIT test adn experimental tag of cassandra
14:42:07 <yuling_> OK, thanks
14:42:29 <anipbu> yuling_: please also update your release review template with the appropriate attributes in the features section
14:42:39 <yuling_> yes, will do
14:42:52 <anipbu> yuling_: for each feature, it needs attributes like experimental, user facing, tested, etc.
14:43:12 <yuling_> for new features...or all features?
14:43:35 <anipbu> for ALL features
14:43:40 <yuling_> ok, will do
14:44:03 <anipbu> WOW 76% code coverage!  Your team is awesome!!!
14:44:16 <yuling_> yes, we worked hard on UT coverage
14:44:28 <yuling_> and all CSIT jobs passed
14:44:34 <yuling_> except the Cassandra one
14:44:34 <anipbu> Do folks have any further concerns or questions?
14:45:14 <anipbu> #info TSDR to follow up on action items
14:45:21 <anipbu> #action anipbu to follow up with TSDR
14:45:22 <yuling_> ok, thanks
14:45:28 <anipbu> Okay Let's move on.
14:45:46 <anipbu> Thanks yuling_ I have no futhur questions.
14:45:51 <anipbu> #topic SDNINTERFACEAPP
14:45:57 <anipbu> #link https://wiki.opendaylight.org/view/ODL-SDNi:Boron_Release_Review  <--- Release Review
14:45:58 <RafatJahan> #info https://wiki.opendaylight.org/view/ODL-SDNi:Boron_Release_Review
14:46:01 <anipbu> #link https://wiki.opendaylight.org/view/ODL-SDNi:Boron_Release_Notes <--- Release Notes
14:46:18 <anipbu> #info RafatJahan is representing SDNINTERFACEAPP
14:46:25 <RafatJahan> Yes An
14:46:26 <anipbu> RafatJahan: anything you would like to add?
14:46:34 <ChristineH> #info ChristineH is representing SNMP4SDN
14:46:34 <anipbu> RafatJahan: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:46:34 <RafatJahan> None from my end
14:46:52 <RafatJahan> RC2 is Okayed
14:47:09 <RafatJahan> no features to be experimental
14:47:22 <RafatJahan> No user facing features.
14:47:44 <RafatJahan> Our Top level features takes casr of all the relevent features for sdninterfaceapp
14:47:54 <RafatJahan> similar to what we have done in the past
14:48:25 <vrpolak> The single test case in CSIT does not test sdninterfaceapp at all, thus odl-sdninterfaceapp-all should be considered experimental (unless there are external test results published somewhere in public).
14:48:44 <anipbu> #info SDNINTERFACEAPP  tested RC2 and found no problems
14:49:01 <anipbu> RafatJahan: would you agree to mark all your features as experimental?
14:49:12 <RafatJahan> Sure An.
14:49:23 <RafatJahan> I will also check with the team for the patch.
14:49:57 * colindixon reads
14:50:07 <anipbu> #info RafatJahan has agreed to make mark all features as experimental
14:50:32 <anipbu> RafatJahan: could you please update your release review wiki page now to reflect the experimental tag so we can approve your project.
14:51:15 <colindixon> https://git.opendaylight.org/gerrit/#/c/34875/
14:51:24 <RafatJahan> Done An
14:51:38 <RafatJahan> Release Review Page updated
14:51:39 <colindixon> if somebody +1s that patch, I should be able to merge it
14:51:46 <anipbu> #action RafatJahan to review this patch: https://git.opendaylight.org/gerrit/#/c/34875/
14:51:57 <colindixon> assuming it's up-to-date for Boron
14:52:10 <RafatJahan> Will do it right after the call @priority
14:52:19 <anipbu> SDNINTERFACEAPP looks good to me, since it is experimental
14:52:49 <anipbu> #action RafatJahan to update release view wiki page with the links to the asciidocs/rst files
14:53:08 <anipbu> RafatJahan: your wiki page should have links to the actual documentation adoc/rst file, not the git/gerrit patch ID.
14:53:15 <RafatJahan> Will do An.Noted
14:53:16 <colindixon> I'm good
14:53:17 <anipbu> Do folks have any further concerns or questions?
14:53:20 <rovarga> I have one question ...
14:53:31 <anipbu> rovarga: sure
14:53:46 <rovarga> is the removal of forked BGPCEP code somewhere on the roadmap?
14:53:53 <colindixon> +1
14:53:57 <colindixon> I was going to ask that
14:54:13 <anipbu> #info rovarga asked about removal of forked BGPCEP code somewhere on the roadmap
14:54:29 <rovarga> I mean we have been raising this issue for at least two releases now and I am not aware of a technical reason which would require the fork ...
14:54:41 <anipbu> RafatJahan: rovarga asked about removal of forked BGPCEP code somewhere on the roadmap
14:54:47 <RafatJahan> Yes @rovarga.But to confirm I will have to check with Sirisha[PTL]
14:55:02 <RafatJahan> Surely for Carbon release it will be removed.
14:55:12 <rovarga> thanks
14:55:14 <RafatJahan> We will keep you updated on the same.
14:55:25 <anipbu> #info RafatJahan responds regarding bgcep fork: there are plans, but will need to check with PTL Sirisha
14:55:52 <anipbu> #action RafatJahan to follow up with rovarga in addressing the fork of BGCEP in Carbon
14:55:56 <anipbu> Do folks have any further concerns or questions?
14:56:01 <anipbu> Otherwise I would like to move on.
14:57:01 <anipbu> #info SDNINTERFACEAPP approved for Boron pending action items.  Congratulations!
14:57:05 <anipbu> #topic SNBI
14:57:09 <anipbu> #link https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:BoronReleaseReview   <--- Release Review
14:57:09 <RafatJahan> thanks!!!
14:57:12 <vjanandr> https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:BoronReleaseReview
14:57:13 <anipbu> #link https://wiki.opendaylight.org/view/SNBI_Boron_Release_Notes <--- Release Notes
14:57:24 <anipbu> #info frankbrockners is representing SNBI
14:57:41 <vjanandr> vjanandr will proxy on his behalf..
14:57:49 <anipbu> #info vjanandr is representing SNBI
14:57:59 <anipbu> vjanandr: anything you would like to add?
14:58:05 <anipbu> vjanandr: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
14:58:20 <vjanandr> Tested with RC1 no blockers found..
14:58:27 <vjanandr> yet to test with RC2..
14:58:36 <vjanandr> will test and update the excel..
14:58:54 <vjanandr> all features will be marked experimental
14:59:06 <vjanandr> SNBI registrar is the user facing feature
14:59:35 <anipbu> vjanandr: is there an ETA for RC2 testing?
14:59:50 <colindixon> the last documentation that was submitted appears to have been targeting Beryllium even if it was merged recently, is it up to date?
14:59:52 <vjanandr> by EOD today..
15:00:04 <anipbu> please please test RC2 as soon as possible
15:00:23 <vjanandr> yes.. I have updated the document for Boron and sent a separate gerrit..
15:00:36 <anipbu> the last build is being cut today at 11:59 UTC time so please test RC2 as soon as possible
15:00:45 <vjanandr> yes will do..
15:00:46 <colindixon> I see
15:00:48 <colindixon> it's there
15:00:50 <colindixon> good, good
15:00:51 <anipbu> #action vjanandr to test RC2
15:01:15 <anipbu> #info vjanandr has agreed that all features will be marked experimental
15:01:28 <anipbu> vjanandr: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
15:01:32 <anipbu> #action vjanandr to update the release review with the list of features and their attributes
15:01:48 <vjanandr> ok sure will do..
15:01:56 <vjanandr> will update the release review..
15:02:28 <anipbu> do we havea  patch ID for the documentation?
15:02:37 <vjanandr> https://git.opendaylight.org/gerrit/#/c/44983/
15:02:50 <anipbu> #action colindixon to review https://git.opendaylight.org/gerrit/#/c/44983/
15:03:17 <anipbu> SNBI looks good to me, considering all features are experimental
15:03:23 <anipbu> Do folks have any further concerns or questions?
15:03:47 <colindixon> I'm good
15:03:59 <jamoluhrsen> colindixon, anipbu, vrpolak: checking in
15:04:10 <anipbu> Okay Let's move on
15:04:50 <anipbu> #info SNBI approved for Boron pending action items.  Congratulations!
15:05:03 <vjanandr> thanks..
15:05:03 <anipbu> Is anybody from SNMP here?
15:05:25 <anipbu> Is Sharon Aicler here?
15:05:58 <anipbu> #action SNMP to reschedule.
15:06:05 <anipbu> #topic SNMP4SDN
15:06:11 <anipbu> #link https://wiki.opendaylight.org/view/SNMP4SDN:Beryllium_Release_Review   <--- Release Review
15:06:15 <anipbu> #link https://wiki.opendaylight.org/view/SNMP4SDN:Beryllium_Release_Note <--- Release Notes
15:06:19 <anipbu> #info ChristineH is representing SNMP4SDN
15:06:23 <anipbu> ChristineH: anything you would like to add?
15:06:29 <anipbu> ChristineH: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:08:18 <vrpolak> The links are for Beryllium. Was the anything new in Boron?
15:08:48 <ChristineH_> anipdu: excuse me, disconnected
15:08:56 <anipbu> ChristineH: welcome back!  =)
15:09:05 <ChristineH_> anipdu: 1) yes, blocker bug: https://bugs.opendaylight.org/show_bug.cgi?id=6607
15:09:34 <anipbu> ChristineH_: 4) The links are for Beryllium. Was the anything new in Boron?
15:09:42 <ChristineH_> actually the fix is ready, code merged, but the jar is rejected by nexus server
15:10:00 <anipbu> Umm.  these notes are not for Boron
15:10:44 <ChristineH_> https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Review
15:10:45 <anipbu> #undo
15:10:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x23c2f10>
15:10:47 <anipbu> #undo
15:10:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x258afd0>
15:10:50 <anipbu> #undo
15:10:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x258a990>
15:10:51 <ChristineH_> https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Note
15:11:00 <anipbu> #link https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Review   <--- Release Review
15:11:05 <anipbu> #link https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Note <--- Release Notes
15:11:10 <anipbu> #info ChristineH is representing SNMP4SDN
15:11:31 <anipbu> #info SNMP4SDN has tested RC2 and found blocking bug: https://bugs.opendaylight.org/show_bug.cgi?id=6607
15:12:17 <ChristineH_> anipdu: 2) no experimental feature
15:12:39 <ChristineH_> anipdu: 3) the user-facing features: odl-snmp4sdn-all and odl-snmp4sdn-snmp4sdn
15:12:52 <jamoluhrsen> ChristineH_, is there an external system test report
15:13:26 <anipbu> ChristineH: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
15:13:29 <anipbu> #action ChristineH to update the release review with the list of features and their attributes
15:13:53 <ChristineH_> anipdu: external system test report: https://wiki.opendaylight.org/index.php?title=SNMP4SDN:Boron_System_Test&action=edit&redlink=1
15:14:09 <anipbu> ChristineH: please add the attributes to the features
15:14:33 <ChristineH_> anipdu: corrected: external system test report: https://wiki.opendaylight.org/view/SNMP4SDN:Boron_System_Test
15:15:00 <anipbu> I don't see the published results form the system test: https://wiki.opendaylight.org/view/SNMP4SDN:Boron_System_Test
15:15:20 <jamoluhrsen> ChristineH_: do you have results from external system tests?
15:16:01 <anipbu> #info the user-facing features: odl-snmp4sdn-all and odl-snmp4sdn-snmp4sdn
15:16:10 <ChristineH_> jamoluhrsen: I missed to write the results of external system test, will write it later
15:16:30 <jamoluhrsen> ChristineH_: ok.  are the results all passing?
15:16:58 <anipbu> ChristineH_: without the published results for testing, would you agree to make the features experimental for now (we can change it once the results from the external testing are completed)
15:17:16 <ChristineH_> jamoluhrsen: not all passing, some bugs
15:18:04 <jamoluhrsen> ChristineH_: bugs are fine if they are not blocking and ok to release, but would like to see those results and list of bugs.  It's actually good that you have bugs found.  means good system test :)
15:18:04 <ChristineH_> anipbu: without the published results for testing, we agree to make the features experimental for now
15:18:16 <anipbu> could you update the release review template now so we can approve it.  It should state that all features are experimental https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Review
15:19:04 <ChristineH_> jamoluhrsen: only one blocking bug, as mentioned in anipbu question 1)
15:19:07 <anipbu> #info ChristineH_ has agreed to mark all features as experimental for now (will be updated once the external test results are published)
15:19:53 <ChristineH_> anipbu: ok, I'll state the features are all experimental in the release review
15:20:21 <anipbu> #action ChristineH_ and jamoluhrsen to follow up on publishing the test results and the experimental tag.
15:21:24 <ChristineH_> agree, thank you.
15:21:47 <anipbu> ChristineH_: is it possible for you to update it now so we can approve it?  (just the experimental tag part)
15:22:03 <ChristineH_> sure, now updating
15:23:08 <ChristineH_> updated feature list: https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Review#Features
15:23:57 <anipbu> SNMP4SDN looks good to me, considering all features are marked as experimental
15:24:04 <anipbu> Do folks have any further concerns or questions?
15:24:48 <jamoluhrsen> anipbu: I'm ok
15:24:49 <anipbu> Otherwise let's move on
15:25:34 <anipbu> ChristineH_: please add adoc/rst links to your release review
15:25:47 <anipbu> #action ChristineH_ to add adoc/rst links to release review
15:25:52 <anipbu> #info SNMP4SDN approved for Boron pending action items.  Congratulations!
15:25:57 <anipbu> #topic TTP
15:26:03 <anipbu> #link https://wiki.opendaylight.org/view/Table_Type_Patterns/Boron/Release_Review <--- Release Review
15:26:07 <anipbu> #link https://wiki.opendaylight.org/view/Table_Type_Patterns/Boron/Release_Notes <--- Release Notes
15:26:10 <anipbu> #info colindixon is representing TTP
15:26:14 <anipbu> colindixon: anything you would like to add?
15:26:16 * colindixon waves
15:26:18 <colindixon> not really
15:26:19 <ChristineH_> thanks, anipbu and jamoluhrsen
15:26:25 <colindixon> this was a zero-code change release for ttp
15:26:33 <colindixon> also all features are experimental
15:26:45 <jamoluhrsen> colindixon: I noticed.  I saw the git log.
15:27:03 <jamoluhrsen> easy peasey with this one.
15:27:27 <anipbu> colindixon: 1) Have you tested against RC2 and were there any blockers?  What are the user-facing features in your project?
15:28:19 <anipbu> colindixon: please update the release review with the list of features and their attributes such as user-facing, tested, etc.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
15:28:22 <anipbu> #action colindixon to update the release review with the list of features and their attributes
15:28:23 <colindixon> we havent' tested against RC2, I will try to do it by tonnight, but it just a yang model
15:28:35 <colindixon> the user facing features are odl-ttp-model only
15:28:40 <colindixon> there's a CLI which is a separate download
15:28:54 <anipbu> please please test as soon as possible, as we are building today at 11:59 UTC time
15:29:14 <colindixon> I know, I know
15:29:19 <anipbu> #action colindixon to test TTP for RC2 and report status of testing on here: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:29:39 <anipbu> #info All TTP features are experimental
15:29:51 <anipbu> #info user facing features: odl-ttp-model
15:29:58 <vrpolak> Separate CLI sounds like a non-karaf feature.
15:30:51 <colindixon> yes
15:30:52 <anipbu> TTP looks good to me, considering all features are experimental
15:31:49 <colindixon> thanks
15:31:51 <colindixon> I'll update things
15:31:52 <anipbu> #info the CLI tools is a serpate non-karaf feature.  It is described in more details in the documentation.  This docs is linked form the release review template
15:31:57 <anipbu> Do folks have any further concerns or questions?
15:32:01 <colindixon> yes
15:32:14 <anipbu> Do folks have any further concerns or questions?
15:32:19 <anipbu> Otherwise, Let's move on.
15:32:34 <anipbu> jamoluhrsen: any further questions or concerns?
15:32:39 <jamoluhrsen> I'm good.
15:32:41 <colindixon> I'm good
15:33:18 <anipbu> #info TTP approved for Boron pending action items.  Congratulations!
15:33:53 <anipbu> #info VPNSERVICE has dropped out of boron so there will be no release review for that project.
15:34:15 <anipbu> Is anybody from YANG-PUSH/YANGPUBSUB here?
15:34:23 <anipbu> Is Ambika Prasad Tripathy here?
15:35:15 <colindixon> I'm guessing not...
15:35:44 <anipbu> #action YANG-PUSH to reschedule
15:35:59 <anipbu> #topic YANGIDE
15:36:02 <davidmichaelkarr> #info David Karr for yangide
15:36:03 <anipbu> #link https://wiki.opendaylight.org/view/YangIDE/Boron/Release_Review <--- Release Review
15:36:07 <anipbu> #link https://wiki.opendaylight.org/view/YangIDE/Boron/Release_Notes <--- Release Notes
15:36:20 <anipbu> #info davidmichaelkarr is representing YANGIDE
15:36:26 <anipbu> davidmichaelkarr: anything you would like to add?
15:36:38 <jamoluhrsen> good morning davidmichaelkarr
15:36:45 <davidmichaelkarr> Morning folks.
15:36:56 <davidmichaelkarr> I can't think of anything to add, unless people have questions.
15:37:08 <anipbu> davidmichaelkarr: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?
15:37:32 <jamoluhrsen> davidmichaelkarr: are there any external system tests that you can report on?
15:37:55 <davidmichaelkarr> I've tested against the latest yangtools, and I didn't see any issues, so I assume that would be RC2.
15:38:03 <colindixon> this looks cool to me
15:38:11 <davidmichaelkarr> Unfortunately, my system tests are only manual, and I just ran through it this morning, and it looks ok.
15:38:31 <anipbu> davidmichaelkarr: 3) The Yang IDE currently uses the Beryllium release of the YangTools parser.  Any plans to move to boron yangtools parser.  Perhaps rovarga can help your team with moving to the latest and greatest of yangtools.
15:39:04 <anipbu> davidmichaelkarr: 4) do you have the results from the manual testing published publicly anywhere?
15:39:31 <davidmichaelkarr> Moving to the Boron release is probably going to be important for this to be a long-term viable feature.
15:39:55 <jamoluhrsen> davidmichaelkarr: yeah if you could give some status of your external system tests, it would be great.  that's what we ask for all projects with a waiver.  sounds like all were passing
15:39:57 <davidmichaelkarr> I did attempt to get help with that venture months ago, but frankly I need more than just links to the docs.
15:40:32 <colindixon> other than the testing, this all looks good to me
15:40:34 <anipbu> #info davidmichaelkarr has tested RC2 in the sense that the yangide was downloaded today and tested.  Did not see any issues
15:40:36 <davidmichaelkarr> No, I haven't published results from my manual testing.  I would do that, but it feels embarrassing. :)
15:40:42 <colindixon> testing looks fine, I just defer to jamoluhrsen
15:41:09 <anipbu> davidmichaelkarr: 2) would you consider your features to be experimental?
15:41:24 <jamoluhrsen> well it doesn't matter about posting system test results if your feature(s) are considered experimental.
15:41:33 <davidmichaelkarr> No, I don't consider it to be experimental.
15:41:50 <jamoluhrsen> ok, so we need something outlined with the results.
15:41:59 <davidmichaelkarr> Ok, so how do I do that exactly?
15:42:02 <jamoluhrsen> anipbu: where is the official place for this?  the system test plan, right?
15:42:14 <anipbu> yes, the system test plan.  there is a section for it.
15:42:33 <jamoluhrsen> hang tight davidmichaelkarr, I'll see if I can get the link for you
15:43:02 <jamoluhrsen> well, at least you were one project that put your test plan link here:    https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report#Boron
15:43:08 <anipbu> davidmichaelkarr: would you be okay with marking all features as experimental for now, until the results from the manual testing can be publicly published?
15:43:48 <jamoluhrsen> davidmichaelkarr, you probably used an older template (or before we updated it), but here:
15:43:48 <jamoluhrsen> https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template
15:43:51 <davidmichaelkarr> Uh, I suppose. Not sure what the impact of that is.
15:43:56 <jamoluhrsen> section 4
15:44:32 <anipbu> Should I interpret this as an affirmative: "Uh, I suppose."
15:44:39 <davidmichaelkarr> :) Yes.
15:45:06 <anipbu> The impact is that on our getting started guide from the OpenDaylight.org downloads page will state that your features are experimental.
15:45:20 <davidmichaelkarr> Ok.
15:45:39 <anipbu> davidmichaelkarr: could you please update this right now with a statement that all features are experimental: https://wiki.opendaylight.org/view/YangIDE/Boron/Release_Review
15:45:50 <davidmichaelkarr> Considering the medium term issues with maintaining this, I suppose calling it experimental is probably appropriate.
15:46:11 <anipbu> If you update it right now, we can approve it.
15:46:18 <davidmichaelkarr> So for all the features in the list, add a "Experimental: Yes" line?
15:46:57 <anipbu> davidmichaelkarr: Correct
15:47:26 <anipbu> This is yangide's first release so the sections under "Changes Since Previous Releases" can be left "N/A"
15:48:02 <anipbu> #info davidmichaelkarr has agreed to mark all YANGIDE features as experimental
15:48:38 <anipbu> #action davidmichaelkarr jamoluhrsen to follow up on publishing the test results and updating the experimental tag as appropriate.
15:48:56 <jamoluhrsen> anipbu: ack
15:49:02 <davidmichaelkarr> I guess talking about the "previous release" of this is confusing, as anyone with more knowledge of the codebase knows that this is not the first release of this codebase.
15:49:30 <jamoluhrsen> davidmichaelkarr: if you are going experimental then you can probably not even worry about publishing your results, if you don't want.
15:49:36 <anipbu> davidmichaelkarr: you are correct about the "previous release".
15:49:47 <anipbu> davidmichaelkarr: i'm also fine with leaving it as is
15:49:53 <davidmichaelkarr> Ok.
15:50:29 <anipbu> YANGIDE looks good to me considering all features are experimental
15:50:35 <anipbu> Do folks have any further concerns or questions?
15:50:50 <jamoluhrsen> I'm ok.
15:51:03 <davidmichaelkarr> wiki changes done.
15:51:41 <anipbu> #info YANGIDE approved for Boron pending action items.  Congratulations!
15:52:28 <anipbu> #topic YANGTOOLS
15:52:33 <anipbu> #link https://wiki.opendaylight.org/view/YANG_Tools:Boron:Release_Review <--- Release Review
15:52:37 <anipbu> #link https://wiki.opendaylight.org/view/YANG_Tools:Boron:Release_Notes <--- Release Notes
15:52:41 <anipbu> #info rovarga is representing YANGTOOLS
15:52:45 <anipbu> rovarga: anything you would like to add?
15:53:01 <rovarga> not really, release review really sums it up
15:53:23 <anipbu> rovarga: 1) Have you tested against RC2 and were there any blockers?
15:54:01 <rovarga> only blockers are reported from downstream ... I think we have only 6497 outstanding
15:54:36 <rovarga> the patches were merged, but we still need confirmation that it's fixed
15:54:59 <anipbu> rovarga: could you please update this with the status of RC2 testing for yangtools: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:55:32 <anipbu> #action rovarga to update spreadsheet on RC2 testing for yangtools
15:55:45 <anipbu> #info yangtools has system test waiver
15:56:11 <anipbu> #info All yangtools features are marked as experimental
15:56:20 <rovarga> anipbu: done, we are green for release
15:56:56 <rovarga> #info the plan is to introduce stable features in Carbon by splitting current features into smaller chunks
15:57:00 <anipbu> #info yangtools has tested RC2.  Status is green with no problems found.
15:58:41 <anipbu> There were no API deprecation in Boron?
15:59:22 <rovarga> no, we only removed previously-deprecated things
16:00:18 <anipbu> #info no deprecation of api in yangtools for Boron release. only remove previously deprecated things
16:00:27 <rovarga> there are still a few items left, but those require some unexpected surgery, so we are leaving them for some future release
16:00:58 <anipbu> would it be possible for you state what was removed in the release notes.  just so end users are made aware.
16:01:44 <anipbu> #action rovarga to mentioned in the release notes the previously-deprecated things that have been removed in Boron
16:01:52 <anipbu> YANGTOOLS looks good to me
16:01:57 <anipbu> Do folks have any further concerns or questions?
16:02:19 <rovarga> anipbu: the full list will be quite a bit of work, it's like 60+ patches :-(
16:02:46 <anipbu> rovarga: could we state high level what was removed?
16:03:08 <rovarga> anipbu: sure, I'll dig through the logs
16:03:25 <rovarga> we really need jdiff for this
16:04:04 <rovarga> (i.e. BUG-5340)
16:04:07 <anipbu> Do folks have any further concerns or questions?  Otherwise I'm ready to move on
16:04:42 <jamoluhrsen> fine to move on with me
16:05:03 <anipbu> #action anipbu to look into https://bugs.opendaylight.org/show_bug.cgi?id=5340 for future enhancement
16:05:18 <anipbu> #info YANGTOOLS approved for Boron pending action items.  Congratulations!
16:05:43 <anipbu> #topic EMAN
16:06:00 <anipbu> george: can you provide links to the release notes and release review
16:06:34 <george> Do you mean a wiki link or a link to a gerrit update?
16:06:52 <anipbu> wiki link
16:07:05 <anipbu> did you prepare any release notes?
16:07:26 <anipbu> Projects must provide links to their release notes and release review template.
16:07:26 <anipbu> Release Note: https://wiki.opendaylight.org/view/Sample_Release_Notes
16:07:26 <anipbu> Release Review Template: https://wiki.opendaylight.org/view/Sample_Release_Review
16:07:26 <george> Release Notes will be here: https://wiki.opendaylight.org/view/Eman:Boron_Release_Notes
16:07:40 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/eman-dev/2016-August/000022.html <--- csit analysis email for EMAN
16:07:45 <george> That page is a stub ATM, will have it finished today
16:07:48 <jamoluhrsen> #info all features experimental
16:07:57 <anipbu> #info https://wiki.opendaylight.org/view/Eman:Boron_Release_Notes   <--- Release Notes
16:08:08 <anipbu> george: Do you have release review template?
16:08:16 <zxiiro> ChristineH_: are you still around? it seems this snmp4sdn patch broke our distribution jobs https://git.opendaylight.org/gerrit/#/c/44826/
16:08:59 <george> I do not have the release review completed, but I can also finish that today.
16:09:15 <colindixon> dow we hav e release review
16:09:16 <colindixon> ?
16:09:16 <anipbu> ChristineH_: we need to revert this patch it's way too big for bring in during RC2
16:09:40 <anipbu> george: we need to rescheudle eman if you do not have release review template available
16:10:04 <colindixon> I think we could do the eman release review over e-mail if need be
16:10:08 <george> ok, my apologies, I'm still quite new to this process.
16:10:16 <anipbu> #action george to generate release review template
16:10:17 <anipbu> #action EMAN to reschedule
16:10:30 <anipbu> Okay Let's move on.
16:10:44 <jamoluhrsen> sounds good.
16:11:01 <anipbu> #topic HONEYCOMB/VBD
16:11:05 <anipbu> #link https://wiki.opendaylight.org/view/Honeycomb/vbd:Boron:Release_Review   <--- Release Review
16:11:10 <anipbu> #link https://wiki.opendaylight.org/view/Honeycomb/vbd:Boron:Release_Notes <--- Release Notes
16:11:21 <anipbu> #info wojdec1 is representing YANGTOOLS
16:11:24 <anipbu> #undo
16:11:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x266ed50>
16:11:32 <anipbu> #info wojdec1 is representing HONEYCOMB/VBD
16:11:40 <anipbu> wojdec1: anything you would like to add?
16:12:01 <wojdec1> ack… No items to report really
16:12:03 <jamoluhrsen> #info no CSIT for honeycomb/vbd.  all features expiremental
16:12:19 <anipbu> wojdec1: 1) Have you tested against RC2 and were there any blockers?
16:12:47 <anipbu> wojdec1: do you have any adoc/rst documentation links?
16:13:09 <wojdec1> Yes, we had two issues; change of yang model (on VPP) and a bug around tunnel creation. All fixed, merged, and tested
16:13:21 <colindixon> there has been one patch
16:13:47 <colindixon> are there plans for more documentation than this: https://git.opendaylight.org/gerrit/#/c/43116/
16:14:01 <anipbu> wojdec1: could you please update this spreadsheet with the status of RC2 testing for VBD: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
16:14:32 <wojdec1> anipbu: no documentation yet, WIP.
16:14:34 <anipbu> wojdec1: so is your RC2 status now green with no problem found (after fixing the relevant issues)
16:14:49 <wojdec1> anipbu: correct
16:15:04 <anipbu> #info vbd has tested RC2.  RC2 status now green with no problem found.
16:15:21 <jamoluhrsen> wojdec1: any plans for CSIT going forward?
16:15:30 <jamoluhrsen> side question.
16:16:20 <wojdec1> jamoluhrsen: I don't think we'll make it with CSITs before the release. Definitely planning to do so after
16:16:53 <jamoluhrsen> wojdec1: cool, that's what I was asking.  for Carbon and going forward it would be great.
16:17:05 <vrpolak> zxiiro anipbu ChristineH_: Http failure in snmp4sdn merge job during the upload phase broke distribution. Remerge should help. The patch itself looks like a thing we want to have in Boron, but it is not a blocker fix.
16:17:37 <zxiiro> vrpolak: no remerge won't help. they are trying to push a non-SNAPSHOT version and Nexus is rightly rejecting it
16:17:39 <anipbu> #info all vbd features are maked as experimental
16:17:44 <anipbu> #undo
16:17:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2334390>
16:17:53 <anipbu> #info all vbd features are marked as experimental in boron
16:18:18 <vrpolak> zxiiro: Oh, alright. Revert is a must.
16:18:27 <anipbu> This is vbd's first release, so the sections under "Changes Since Previous Releases" are optional
16:18:33 <jamoluhrsen> vrpolak, zxiiro, anipbu: just fyi that snmp4sdn patch is a 20K! line patch going in to Boron on 8/31
16:18:57 <zxiiro> jamoluhrsen: yeah, it pulls in ad-sal. we're talking in #opendaylight-releng about reverting it. It's nto a good situation
16:20:08 <anipbu> VBD looks good to me
16:20:13 <anipbu> Do folks have any further concerns or questions?
16:20:25 <jamoluhrsen> anipbu: good with VBD for me
16:21:33 <anipbu> Okay Let's move on
16:21:45 <anipbu> #info HONEYCOMB/VBD approved for Boron pending action items.  Congratulations!
16:22:05 <anipbu> #info NIC has asked to reschedule
16:22:10 <anipbu> #action NIC to reschedule
16:22:25 <ChristineH> zxiiro, anipbu: Hi, I just saw you require to revert https://git.opendaylight.org/gerrit/#/c/44826/
16:22:38 <anipbu> #topic OPENFLOWPLUGIN
16:22:51 <colindixon> ChristineH: we should probably have this dicussion on the #opendaylight-releng channel
16:22:54 <colindixon> can you join there?
16:23:01 <anipbu> abhijitkumbhare: do you have the links to the release notes and the release review
16:23:03 <ChristineH> colindixon: ok
16:23:37 <abhijitkumbhare> Aah - we start already :)
16:23:51 <anipbu> Yes, We're little bit early :)
16:23:52 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2016-September/005943.html <--- email for boron csit analysis for openflowplugin
16:24:10 <abhijitkumbhare> https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Review
16:24:16 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Review
16:24:23 <anipbu> #undo
16:24:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2340d90>
16:24:35 <anipbu> link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Review   <--- Release Review
16:24:44 <abhijitkumbhare> One more: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Notes
16:25:00 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Notes   <--- Release Notes
16:25:13 <anipbu> #info abhijitkumbhare is representing OPENFLOWPLUGIN
16:25:16 <jamoluhrsen> anipbu, abhijitkumbhare: I think some more conversation needs to happen around CSIT analysis.  There is a lot going on there.
16:25:20 <anipbu> abhijitkumbhare: anything you would like to add?
16:25:46 <abhijitkumbhare> jamoluhrsen: LuisGomez & rest of us discussed this
16:25:54 <anipbu> abhijitkumbhare: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:25:56 <abhijitkumbhare> in the OpenFlow Plugin meeting
16:26:11 <jamoluhrsen> abhijitkumbhare: ok.  sorry I couldn't make it.  I was hanging out here with these guys
16:26:39 * colindixon reads
16:26:40 <abhijitkumbhare> LuisGomez thinks some of the issues are represented as the 3 blockers we have already
16:27:05 <anipbu> abhijitkumbhare: 1) Have you tested against RC2 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:27:07 <abhijitkumbhare> There are 3 blockers at the time (somewhat new)
16:27:15 <jamoluhrsen> abhijitkumbhare: ok.  so probably it's a good idea that we wait for the blockers to get fixed then re-analyze
16:27:21 <jamoluhrsen> what are the blocker bug ids?
16:27:43 <abhijitkumbhare> anipbu: those blockers are against RC2 if I am not mistaken
16:28:15 <anipbu> #info openflowplugin has tested RC2 and found 3 blockers
16:28:24 <abhijitkumbhare> jamoluhrsen: https://bugs.opendaylight.org/show_bug.cgi?id=6595 (shuva )
16:28:50 <abhijitkumbhare> https://bugs.opendaylight.org/show_bug.cgi?id=6554 (jozef bacigal)
16:29:29 <abhijitkumbhare> https://bugs.opendaylight.org/show_bug.cgi?id=6176 (probably andrej leitner or tomas slusny)
16:30:30 <jamoluhrsen> ok, good that you moved 6176 to blocker
16:30:39 <anipbu> #info the three blocker bugs found in RC2 is: https://bugs.opendaylight.org/show_bug.cgi?id=6595 (shuva ), https://bugs.opendaylight.org/show_bug.cgi?id=6554 (jozef bacigal), https://bugs.opendaylight.org/show_bug.cgi?id=6176 (probably andrej leitner or tomas slusny)
16:30:49 <abhijitkumbhare> Out of these - all should be fixed (even though the first one 6595 is intermittent)
16:30:54 <anipbu> abhijitkumbhare: Do you have any features that should be considered experimental?
16:31:18 <jamoluhrsen> anipbu, abhijitkumbhare: I think experimental label needs to wait.
16:31:19 <colindixon> I'll note that only limitied documentation has been merged on or around openflowplugin
16:31:37 <anipbu> #info only limitied documentation has been merged on or around openflowplugin
16:31:45 <abhijitkumbhare> LuisGomez thinks without https://bugs.opendaylight.org/show_bug.cgi?id=6554 fix - the clustering would be experimental
16:32:24 <abhijitkumbhare> But we should fix it - just that it is very tight with respect to the release date
16:32:44 <vrpolak> It would be nice to have a list of top-level features, as probably some of them will end up non-experimental, while others will remain experimental.
16:32:46 <anipbu> What about the other features besides clustering?
16:32:47 <jamoluhrsen> colindixon, anipbu: this is something I don't know how to handle.  there is technically no openflowplugin "clustering" feature.
16:33:04 <anipbu> abhijitkumbhare: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
16:33:08 <anipbu> #action abhijitkumbhare to update the release review with the list of features and their attributes
16:33:14 <jamoluhrsen> so we can't label some specific feature experimental in that case.  how would that be handled, I wonder?
16:33:49 <anipbu> Can we label the upper encapsulating feature of clustering as experimental?
16:34:03 <LuisGomez> In Release Note you can say an specific feature is experimental when run in cluster
16:34:15 <LuisGomez> as a minimum
16:34:16 <abhijitkumbhare> That’s a little tricky anipbu
16:34:24 <vrpolak> I believe only feature test on single node are sufficient for non-experimental status this release.
16:34:38 <LuisGomez> yes
16:34:47 <jamoluhrsen> vrpolak: that would be the best approach I think.
16:34:49 <abhijitkumbhare> that is good to know vrpolak
16:35:04 <anipbu> I think clustering test is too high of a requirement.  Most other projects don't even have it and they were marked as nonexperimental.
16:35:06 <jamoluhrsen> didn't we give clustering an experimental label in the controller project already?
16:35:29 <anipbu> I think clustering/scale/highavail/longevity should be requirements for stable features only
16:35:36 <colindixon> jamoluhrsen: I think we can say clustering is experimental for oepnflowplugin
16:35:38 <colindixon> and in non-clustered it's not
16:35:39 <colindixon> taht's fine
16:35:39 <anipbu> We cannot use a different ruler for openflowplugin
16:36:02 <LuisGomez> controller cluster is working fine after they fixed a blocker yesterday
16:36:04 <anipbu> We never reviewed controller
16:36:17 <anipbu> controller mdsal is pending release review
16:37:06 <anipbu> jamoluhrsen: abhijitkumbhare: have we come to an agreement on the experimental tags for openflowplugin.  if not, should we have an offline follow up?
16:37:17 <jamoluhrsen> anipbu: my CSIT email analysis for Controller was calling for clustering to be experimental
16:37:45 <jamoluhrsen> offline review needed after blockers are fixed and new csit jobs finished with that RC distro
16:38:01 <anipbu> abhijitkumbhare: ^^^^
16:38:48 <abhijitkumbhare> anipbu I am of course happy it is OK to have features called stable even if  clustering is experimental
16:39:50 <abhijitkumbhare> but it would be better for OpenFlow Plugin to fix the 6554 issue
16:39:55 <anipbu> jamoluhrsen: abhijitkumbhare: perhaps we can have a follow up on this?
16:40:04 <abhijitkumbhare> before the release
16:40:14 <jamoluhrsen> anipbu: agreed.  we really need to see CSIT results again after the blockers are fixed.
16:40:27 <anipbu> abhijitkumbhare: the sections on "Deprecation" seems to be missiing the part where we are removing He- design code
16:40:35 <abhijitkumbhare> probably next week will be better - to have a chance to see if we can get in the fix
16:40:45 <anipbu> #action jamoluhrsen: abhijitkumbhare: to follow up on CSIT tests and experimental tags for openflowplugin
16:41:28 <abhijitkumbhare> anipbu: will update that (technically we have not removed He design code)
16:41:35 <anipbu> abhijitkumbhare: In the "Compatibility", should we mentioned somthing that it is not compatible with applications using He design?
16:42:30 <anipbu> #action abhijitkumbhare to update the section under "Changes Since Previous Releases" including clarifying more content for "Migration", "Compatibility", "Deprecation" with some mention of the He design.
16:42:43 <abhijitkumbhare> shuva: anipbu LuisGomez I believe the apps continue to work with the He design - but not tested lately
16:43:09 <anipbu> abhijitkumbhare: please also update the release review template with the list of all top level features and their attributes (such as experimental, user-facing, tested, etc)
16:43:23 <anipbu> #action openflowplugin to follow up with action items
16:43:30 <abhijitkumbhare> OK
16:43:33 <anipbu> #action anipbu to follow up with openflowplugin
16:43:37 <anipbu> Do folks have any further concerns or questions?
16:44:08 <abhijitkumbhare> anipbu: will these list of the action items be in the release spreadsheet?
16:44:25 <abhijitkumbhare> Or only in the meeting minutes?
16:44:48 <anipbu> Yes, both in spreadsheet and meeting minutes
16:45:03 <abhijitkumbhare> OK - good anipbu
16:45:14 <anipbu> jamoluhrsen: anyother comments or questions?
16:45:55 <jamoluhrsen> anipbu: ok with me for now
16:46:02 <anipbu> We have covered all projects for today.
16:46:06 <anipbu> Okay that's it.  We're done for today.
16:46:11 <anipbu> Thanks rovarga vrpolak jamoluhrsen colindixon
16:46:19 <anipbu> #topic cookies
16:46:26 <anipbu> #endmeeting