17:30:34 <anipbu> #startmeeting boron release review
17:30:34 <odl_meetbot> Meeting started Wed Sep  7 17:30:34 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:30:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:30:34 <odl_meetbot> The meeting name has been set to 'boron_release_review'
17:30:40 <anipbu> #topic roll call
17:30:45 <anipbu> #info anipbu for release
17:32:31 <anipbu> #topic CONTROLLER
17:32:36 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Review <--- Release Review
17:32:40 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Notes  <--- Release Notes
17:32:49 <anipbu> #info rovarga is representing CONTROLLER
17:33:18 <anipbu> rovarga: anything you would like to add?
17:33:32 <anipbu> rovarga: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
17:34:56 <rovarga> aside from the troublesome 6540 we do not have blockers
17:35:14 <rovarga> I still have to catch up on the regression report to see what we need to do
17:35:23 <anipbu> #info rovarga states controller has no other blocker bugs in RC3 except for 6540
17:35:31 <rovarga> aside from that one, we should be ready to release
17:35:44 <anipbu> #action rovarga will catch up on regression report
17:36:12 <anipbu> rovarga: did controller update adoc/rst documentaton?
17:36:46 <anipbu> rovarga: could you please update this spreadsheet to reflect that controller has tested RC3 adn found no issues (besides 6540):  https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
17:36:52 <rovarga> not that I know of... this release the release management pretty much fell apart
17:37:49 <rovarga> so we delivered the code bits, but there were no resources to take care of the collateral
17:38:01 <rovarga> even sending out statuses was problematic
17:38:34 <anipbu> I believe controller maybe have chnaged the entity ownership API, so perhaps we can inform the end users by mkaing such a note in https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Notes#Deprecated.2C_End_of_Lifed.2C_and.2For_Retired_Features.2FAPI
17:39:00 <anipbu> #action rovarga to update the deprecated API section
17:39:19 <anipbu> rovarga: Do you have any features that should be considered experimental?
17:40:08 <rovarga> anipbu: I think all features are covered by CSIT of other projects, so aside from not being stable, they are not experimental
17:40:36 <anipbu> #link https://jenkins.opendaylight.org/releng/view/controller/   <--- Controller has system tests that are failing and therefore do not meet test expectations of being nonexperimental
17:40:55 <anipbu> #action rovarga to follow up with integration/test team on the experimental tag for controller
17:41:33 <anipbu> rovarga: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/Sample_Release_Review#Features
17:41:37 <anipbu> #action rovarga to update the release review with the list of features and their attributes
17:42:10 <rovarga> will do
17:42:13 <anipbu> rovarga: I think controller looks good to me.  Are there any other comments you would like to make regarding controller project?
17:43:16 <rovarga> #info project governance will need to be solved, I will take some time at the DDF to draft some options
17:43:40 <anipbu> #action rovarga to update the section on bugzilla: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Review#Bugzilla_.28summary_of_bug_situation.29
17:44:00 <rovarga> #info this will probably involve splitting up the live parts into a project and abandoning the rest
17:44:16 <anipbu> #info rovarga  states that controller delivered the code bits, but there were no resources to take care of the collateral.  even sending out statuses was problematic
17:44:32 <anipbu> Do folks have any further concerns or questions?
17:44:55 <anipbu> If rovarga has no other comments, I think we can move onto MDSAL
17:45:15 <rovarga> sure
17:45:44 <anipbu> #info CONTROLLER approved for Boron pending action items.  Congratulations!
17:45:54 <anipbu> #topic MDSAL
17:46:16 <anipbu> #link https://wiki.opendaylight.org/view/MD-SAL:Boron:Release_Review <--- Release Review
17:46:20 <anipbu> #link https://wiki.opendaylight.org/view/MD-SAL:Boron:Release_Notes  <--- Release Notes
17:46:27 <anipbu> #info rovarga is representing MDSAL
17:46:35 <anipbu> rovarga: anything you would like to add?
17:46:55 <anipbu> rovarga: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
17:47:36 <rovarga> #info the only blocker currently is the 6540 situation, otherwise we're good. It can be degraded to critical
17:48:07 <anipbu> rovarga: we are missing the release notes on "Add release notes for restconf response 200 to 201"
17:48:27 <anipbu> #action rovarga to update the release notes with a comment on "Add release notes for restconf response 200 to 201"
17:48:31 <rovarga> #info binding specification v2 is the experimental feature, as it is preview quality only and is not tested
17:49:32 <rovarga> anipbu: are you sure? that should be part of the netconf project
17:49:40 <rovarga> anipbu: I may be missing something, though :-/
17:50:01 <anipbu> rovarga: you're right, wrong list
17:50:04 <rovarga> #info we do not have any user-facing features
17:50:22 <anipbu> let me remove it from the action items.  hold on.
17:50:26 <anipbu> #undo
17:50:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x246d850>
17:50:28 <anipbu> #undo
17:50:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x257d350>
17:50:31 <anipbu> #undo
17:50:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x257df90>
17:50:36 <anipbu> #info binding specification v2 is the experimental feature, as it is preview quality only and is not tested
17:50:40 <anipbu> #info we do not have any user-facing features
17:51:25 <anipbu> #action rovarga to update the release review template to state that binding specification v2 is the *experimental* feature
17:52:27 <anipbu> #info MDSAL received a system test waiver for Boron:https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Waiver/System_Test#MD-SAL
17:52:30 <jamoluhrsen> hi
17:53:08 <anipbu> jamoluhrsen: MDSAL received a system test waiver, so I think it's features can be marked as noneperimental.  would you agree?
17:53:19 <anipbu> jamoluhrsen: even though there are no system tests
17:53:54 <jamoluhrsen> anipbu: fine by me.
17:54:19 <anipbu> jamoluhrsen: okay thanks
17:54:55 <jamoluhrsen> test coverage for mdsal comes from everywhere :)
17:55:30 <anipbu> #info all mdsal features are nonexperimental
17:55:53 <anipbu> rovarga: please update the release review with the list of features and their attributes such as experimental, user-facing, tested.  Please see this sample: https://wiki.opendaylight.org/view/
17:56:00 <anipbu> #action rovarga to update the release review with the list of features and their attributes
17:56:29 <anipbu> #action rovarga to update the release review template with the links to the adoc/rst documentation guides
17:58:10 <anipbu> rovarga: mdsal looks good to me.  do you have any additional comments?
17:58:53 <rovarga> I am not sure about the docs part -- that will take some time, but I'll try to do it
17:59:28 <anipbu> Do folks have any further concerns or questions?
17:59:29 <rovarga> and the same thing about governance applies here as well, but I think we have better options in the project
17:59:34 <hideyuki> anipbu: I think VTN project had a release review last week, but VTN project has not got the approval for Boron yet. Should we do something here now?
18:00:06 <anipbu> hideyuki: I believe there are follow up items for VTN?  Let's talk offline.  I will send email.
18:00:30 <hideyuki> anipbu: Thank you! Yeah, there are some follow-up items.
18:00:37 <anipbu> #info rovarga states that same thing about governance applies here as well, but I think we have better options in the project
18:00:41 <hideyuki> anipbu: Yeah, let's do offline.
18:01:16 <anipbu> If rovarga has no other comments, I think we can move on.
18:01:31 <anipbu> #info MDSAL approved for Boron pending action items.  Congratulations!
18:01:53 <anipbu> Thanks rovarga jamoluhrsen
18:01:53 <rovarga> thanks
18:02:07 <jamoluhrsen> cool.  any others anipbu ?
18:02:11 <anipbu> That's it folks, thanks for joining.
18:02:19 <anipbu> jamoluhrsen: nope that's it, we're done
18:02:36 <anipbu> #topic cookies
18:02:42 <anipbu> #endmeeting