16:03:09 <colindixon> #startmeeting kernel projects
16:03:09 <odl_meetbot> Meeting started Tue Oct 11 16:03:09 2016 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:09 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:09 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:03:14 <colindixon> #topic agenda bashing
16:03:26 <colindixon> #link https://wiki.opendaylight.org/view/Kernel_Projects_Call the call page
16:05:29 <colindixon> #link https://wiki.opendaylight.org/index.php?title=Kernel_Projects_Call&oldid=50863#Upcoming_Agenda_Topics today's agenda in it's usual place (with a permanent link)
16:07:15 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/46531/1 this patch was merged to Lithium-SR4
16:08:10 <colindixon> #topic changes that have been waiting for a while
16:08:15 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/44099/
16:08:22 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/46479/
16:08:26 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/46534/
16:08:38 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/46684/
16:09:05 <colindixon> #info Michael Vorburger asks what's going on with the above patches and how to proceed from there
16:11:02 <colindixon> #info TomP says his biggest complaint was adding more xtend to the project, which we have been trying to push back on
16:18:43 <colindixon> #info Michael says that this is usable without any xtend, you can do assertEqualBeans() with two objects and you don't need to understand, read, or write xtend
16:19:45 <colindixon> #link https://docs.google.com/presentation/d/1bnwj8CrFGo5KekONYSeIHySdkoXZiewJxkHcZjXnzkQ/edit#slide=id.g17d8ae4d92_0_225 specifically, line 43 here
16:22:14 <colindixon> #info to be clear, michael says that he'd rather do this a test-driven development, but this is trying to help get test coverage higher without having to write your own test code
16:25:40 <colindixon> #Info TomP asks that the commit message make it clear what this is trying to do, specifically, to get better assert output
16:27:47 <colindixon> #Info the other question is: where should this go? mdsal? infrautils?
16:31:06 <colindixon> #info it looks like it has to introduce a dependency on yangtools because it has special code for DataObjects to work correctly
16:31:20 <colindixon> #Info colindixon says that it probably belongs in mdsal, infrautils seems like the wrong place
16:33:01 <colindixon> #action vorburger1 to send e-amil to figure out if 44099 would be taken to the MD-SAL, if so then he'll rework it
16:39:10 <colindixon> #info looking at the last 3 patches (46479, 46534, 46684) are all around trying to make more convient code for constructing inputs for transactions, e.g., IIDs and DataObjects
16:44:10 <colindixon> #Info vorburger1 says that this is because it's really common pattern in OpenDaylight which basically creates a triple of an InstanceIdentifier, DataObject, and DataStoreType (operation vs. config) and then tries to define common patterns that would make code more idiomatic and easier to use
16:45:40 <colindixon> #info it seems like TomP's complaint is mostly the number of new overrides on put, merge in the WriteTransation in 46434
16:47:43 <adetalhouet> we still have 10 mn in the meeting, with the respect to current topic, can move forward on the agenda?
16:47:52 <adetalhouet> rgoulding: �
16:49:40 <colindixon> #action vorburger1 and skitt to work with TomP to figure out how to pick some subset of the put/merge variants and then work on getting it pushed, likely to mdsal
16:49:58 <colindixon> #topic bouncycastle pkix library
16:50:21 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/46577/ rgoulding coudl use skitt's input on this patch to get it merged
16:50:31 <colindixon> #topic YANG 1.1
16:50:34 <colindixon> #link https://lists.opendaylight.org/pipermail/yangtools-dev/2016-October/001611.html see this thread
16:50:39 <skitt> #action skitt to review https://git.opendaylight.org/gerrit/#/c/46577/
16:51:02 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-10-04-16.04.html notes from some meeting
16:51:28 <colindixon> #info rashmi says she'd like to be included in the YANG 1.1 discussions
16:51:46 <colindixon> #Info mostly tracked through bugzilla and most of them have a YANG 1.1 prefix for it
16:52:05 <colindixon> #info martin ciglan says that the plan is to use bugzilla not a trello board
16:54:55 <colindixon> #info vorburger1 asks if there's a dependency or relationship between binding spec v2 and YANG 1.1
16:55:31 <colindixon> #info colindixon and martin ciglan say mostly no, but it's important that the binding spec v2 work for almosta all (and ideally all) possible YANG 1.1 models
16:55:50 <colindixon> #topic karaf features generation
16:56:30 <colindixon> #link https://git.opendaylight.org/gerrit/39539 this patch tries to avoid us having to define both pom.xml and features.xml instead having features.xml generated from the pom file
16:57:05 <colindixon> #info adetalhouet asks some questions, skitt and vorburger1 point out that this is optional and doesn't require any changes
16:57:45 <colindixon> #info the big win from this (from skitt) is to be able to import features in your pom files to focus on features instead of bundles (which are harder)
16:58:24 <colindixon> #info this lets us move more toward features, which sounds good overall
16:58:41 <colindixon> #topic MD-SAL cleanup
16:58:45 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/46503/
16:59:13 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/message:6859 there are more patches in this bug
16:59:34 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=6859 the relevant bug
16:59:41 <colindixon> #endmeeting