#opendaylight-meeting: kernel projects

Meeting started by colindixon at 16:13:10 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:13:22)
    1. many of the people in Slovakia are out because of a national holiday (colindixon, 16:13:46)
    2. ACTION: vorburger and rovarga to talk about how to manage oomph plugins and Eclipse builds over e-mail (colindixon, 16:15:15)
    3. ACTION: Ryan Goulding to come up with a bugs query to do a bug scrub in the future (colindixon, 16:15:45)
    4. https://lists.opendaylight.org/pipermail/netconf-dev/2016-November/000760.html Ryan gave a list of jersey 2 upgrade bugs (colindixon, 16:17:30)

  2. SR1 (colindixon, 16:17:37)
    1. anipbu asks rovarga to check that yangtools bugs have been fixed in the latest build (colindixon, 16:18:22)
    2. anipbu asks colindixon to check in on l2switch for sai and adetalhouet to work on dlux (which is actually an l2switch issue) (colindixon, 16:21:44)

  3. karaf 4 upgrade (colindixon, 16:21:54)
    1. we wil not get karaf 4 on boron (colindixon, 16:22:11)

  4. reviewing patches (colindixon, 16:26:49)
    1. https://git.opendaylight.org/gerrit/#/c/46914/ makes it easier to do findbugs with lots of checking (colindixon, 16:27:21)
    2. a bunch of controller patches are fixing findbugs and checkstyle issues are waiting for review (colindixon, 16:30:04)
    3. for now there's a bug in findbugs that gives issues on a pattern for serialization we use (colindixon, 16:31:33)
    4. we filed a bug with findbugs and suppressed the warning for now (colindixon, 16:31:59)
    5. rovarga and tpantelis are discussing whether or not we should enforce findbugs (colindixon, 16:36:45)
    6. rovarga comments that he wants to avoid adding time to runs, but tpantelis says that it's really hard to enforce things without a run on each time (colindixon, 16:48:08)

  5. findbugs/sonar across projects (colindixon, 16:48:16)
    1. long, long discussion about why we do or don't have requirements about checkstyle/sonar/findbugs (colindixon, 16:48:35)
    2. colindixon points out that really the issue here is that we haven't had anyone find a comfortable middle ground there in terms of minimizing pain vs. improving code quality (colindixon, 16:49:12)
    3. and then drive it across things (colindixon, 16:49:23)
    4. we've removed a bunch of protobufs stuff (colindixon, 16:57:55)


Meeting ended at 17:02:15 UTC (full logs).

Action items

  1. vorburger and rovarga to talk about how to manage oomph plugins and Eclipse builds over e-mail
  2. Ryan Goulding to come up with a bugs query to do a bug scrub in the future


People present (lines said)

  1. colindixon (24)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.