17:05:42 <colindixon> #startmeeting kernel projects
17:05:42 <odl_meetbot> Meeting started Tue Nov  8 17:05:42 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:05:42 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:42 <odl_meetbot> The meeting name has been set to 'kernel_projects'
17:05:49 <colindixon> #topic agenda bashing
17:06:43 <colindixon> vorburger: we can hear you
17:07:16 <colindixon> #info no major topics for today
17:07:32 <colindixon> #topic bugs query to do bug scrub going forward
17:07:40 <colindixon> #info ryan did this
17:07:52 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?list_id=46270&order=product%2Cchangeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- all bugs in kernel projects
17:08:03 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- critical/major bugs in kernel projects
17:09:00 <vorburger> https://github.com/vorburger/opendaylight-eclipse-setup
17:10:02 <colindixon> #topic using oomph to manage maven projects
17:10:14 <colindixon> #link https://github.com/vorburger/opendaylight-eclipse-setup#how-to-add-additional-m2e-lifecycle-mapping information about how it can be done and made relatively easy
17:12:35 <colindixon> #info it sounds like the next steps are getting things to work so that eclipse can build in a separate environment with a separate target so eclipse actually works
17:12:58 <colindixon> #info vorburger says that he's done out about 8 gerrits that fix this and it should all work now
17:14:16 <colindixon> #link as far as vorburger knows, this is all done and working as of about 4 hours ago: https://lists.opendaylight.org/pipermail/dev/2016-November/002896.html
17:14:44 <colindixon> #info many, many kudos to vorburger for doing all this hard work
17:16:12 <colindixon> #info colindixon asks why vorburger uses Eclipse over IntelliJ, he answers 1.) it's what he's used to and 2.) philosophically Eclipse is much more open source and community oriented
17:19:04 <colindixon> #topic config filtering parent
17:19:22 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/44561/ vrpolak says that this should be ready to merge it
17:20:07 <colindixon> #info skitt asks why we want to add a new parent to stable/boron, is there some fetures that we need to backport that depend on this
17:21:55 <colindixon> #info vrpolak says that this is really a way to get a better way to specify the version that the distribution reports
17:23:47 <colindixon> https://git.opendaylight.org/gerrit/#/q/project:controller+status:merged+NOT+owner:%22Tom+Pantelis+%253Ctpanteli%2540brocade.com%253E%22
17:25:40 <skitt> colindixon, check https://git.opendaylight.org/gerrit/#/q/project:controller+status:merged+NOT+owner:%22Tom+Pantelis+%253Ctpanteli%2540brocade.com%253E%22,50 out for an alternative view ;-)
17:26:46 <colindixon> skitt: is that a view you like :p
17:26:50 <colindixon> careful what you wish for
17:26:56 <vorburger> skitt: how do you do that query in gerrit minus the "Mechanical code cleanup"
17:27:05 <skitt> vorburger, exactly
17:27:27 <colindixon> #topic log messages database
17:27:29 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/39410/
17:27:30 <adetalhouet> haha looks like skitt deserve that way more that me
17:27:42 * skitt cheated a bit there
17:27:51 <skitt> scripted git FTW
17:28:10 * adetalhouet not good with gerrit search tool
17:28:39 <colindixon> #link https://lists.opendaylight.org/pipermail/dev/2016-November/002894.html colindixon's mail picking up this thread
17:28:47 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/39410/
17:29:01 <colindixon> #undo
17:29:01 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2986750>
17:30:58 <colindixon> #info vorburger says that first stage is to get this patch to run everywhere so that we can actaully have a catalog we can use going forward
17:31:38 <colindixon> #info vorburger says that we have this extraction checker that isn't running everywhere because it's in the yangtools checkstyle logging and in the odlparent checkstyle we're not allowed to depend on them
17:32:30 <colindixon> #info vorburger had been planning to submit the checkstyle rules to the public checkstyle so that we could deal with it in a sane way
17:34:30 <colindixon> #action vorburger will push the yangtools publicly usable checkstyle things into the upstream checkstyle rules so that it also works for IDEs
17:35:11 <colindixon> #info in the long run, vorburger argues that the "right" way to get stable log messages would be to use some new facade that would give unique IDs to each log message, e.g., JBOSS logging
17:35:36 <colindixon> #info skitt says this hasn't succeeded in his experience except at IBM in a closed environment because it makes logging hard
17:37:23 <colindixon> #info skitt says that using gettext-based methods to use the english text as the log message ID + some lightweight translation to deal with when you edit it or translate it into other languages
17:39:12 <colindixon> #info skitt says that there are cool things he's used where logstash lets you click on surprising error messages in logstash to file a bug, that would be cool here
17:41:07 <vorburger> #link https://github.com/sevntu-checkstyle/sevntu.checkstyle/issues/461 is what I'll have to start on picking up - I had dropped the ball on that. If anyone has capacity to help with that, please contact me!
17:41:35 <colindixon> #info ryan also says that if there are particular log messages that annoy us, we should open bugs for it
17:43:17 <colindixon> #info adetalhouet points out that many of the most annoying log messages come from the config subsystem, which is slowly being phased out
17:44:08 <colindixon> #topic deprecating or removing config subsystem
17:44:44 <colindixon> #info colindixon asks if we can remove config subsystem in carbon, adetalhouet says that ~2/3s of ODL still uses the config subsystem
17:45:24 <colindixon> #info adetalhouet says that his point of view is that it might be bettter to deprecate the config subsystem in nitroget with better messaging now
17:45:27 <colindixon> #undo
17:45:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a9ccd0>
17:47:43 <colindixon> #action colindixon will bring up the issue of maybe deprecating the config subsystem in carbon and/or saying we will do it in the future
17:49:02 <colindixon> #info skitt says that a lot of projects fall into one of two bits: so inactive they don't even merge patches even if you give them for free, and so active that people ignore things until they're actually removed
17:49:18 <colindixon> #info a good example of the second one is the Data Tree Change Listener
17:51:42 * rovarga reads the transcription and does not understand the last info ..
17:52:49 <colindixon> rovarga: basically despite DCLs being deprecated for 2 releases
17:53:03 <colindixon> we haven't seen much progress
17:53:38 <colindixon> #action colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
17:53:42 <rovarga> colindixon: part of that is that conversions is a lot of work
17:53:51 <colindixon> #topic patch review
17:54:29 <vorburger> #link https://github.com/awaitility/awaitility
17:54:47 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/48109/ both skitt and vorburger say that awaitility is really nice and it's already introduced and can be used
17:56:46 <colindixon> #chair vorburger
17:56:46 <odl_meetbot> Current chairs: colindixon vorburger
17:56:53 <adetalhouet> vorburger: cannot find it in NETCONF: https://github.com/opendaylight/netconf/search?utf8=%E2%9C%93&q=awaitility
17:57:38 <vorburger> adetalhouet: I saw it somewhere yesterday; let me check again
17:57:47 <adetalhouet> greping autorelease
17:58:19 <adetalhouet> I think it was removed already, along with abstract-topology
17:59:09 <colindixon> adetalhouet: you seem to be right
17:59:21 <colindixon> spectre:autorelease ckd$ grep -r --include=*.xml awaitility .
17:59:22 <colindixon> ./odlparent/odlparent/pom.xml:        <groupId>org.awaitility</groupId>
17:59:23 <colindixon> ./odlparent/odlparent/pom.xml:        <artifactId>awaitility</artifactId>
17:59:24 <colindixon> spectre:autorelease ckd$
17:59:54 <adetalhouet> :)
18:00:14 <skitt> so basically we can claim anything in commit messages ;-)
18:00:28 <skitt> I see com.jayway.awaitility in netconf
18:00:38 <vorburger> adetalhouet: yep. It was in netconf/netconf-topology/pom.xml in a non-latest master I looked at, but it's gone from there
18:00:58 <skitt> but that's in the Boron stable branch
18:01:42 <colindixon> #topic lots of people talking about query and depth parameters with patches come in
18:01:46 <colindixon> #undo
18:01:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2980d90>
18:01:52 <colindixon> #info lots of people talking about query and depth parameters with patches come in
18:01:55 <colindixon> #endmeeting