#opendaylight-meeting: kernel_projects

Meeting started by Sai__ at 16:58:44 UTC (full logs).

Meeting summary

  1. - Agenda (Sai__, 17:00:24)
    1. - 1. Review Action Items (Sai__, 17:00:43)
    2. - 2. mdsal-trace debugging utility (Sai__, 17:01:21)
    3. - 3. Review the code change dashboards (Sai__, 17:01:47)

  2. - Review Action Items (Sai__, 17:02:05)
    1. - [DONE] - colindixon will bring up the issue of maybe deprecating the config subsystem in carbon and/or saying we will do it in the future (Sai__, 17:05:16)
    2. - to be deprecated in carbon, debate is on to when to remove. (Sai__, 17:06:16)
    3. ACTION: - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things (Sai__, 17:06:47)
    4. - [DONE] - Ryan / colindixon to reach out AG regarding Netconf SourceException Synopsis (Sai__, 17:07:04)
    5. - email sent and will be presented in the December AG meeting (Sai__, 17:07:13)
    6. https://lists.opendaylight.org/pipermail/controller-dev/2016-November/012859.html e-mail thread on deprecating the config subsystem (colindixon, 17:07:33)
    7. - [DONE] - vorburger will push the yangtools publicly usable checkstyle things into the upstream checkstyle rules so that it also works for IDEs (Sai__, 17:07:45)
    8. - Michael has re-engaged with the Checksystle community last week, and am currently waiting for https://github.com/sevntu-checkstyle/sevntu.checkstyle/issues/461 (Sai__, 17:08:08)
    9. ACTION: - rgoulding to move the tool to change passwords to /bin insead of /etc Bug 7265 (Sai__, 17:09:04)
    10. ACTION: - rgoulding to move the idmlight.db (actual DB) from a top-level place to a better location Bug 7090 (Sai__, 17:09:26)
    11. https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/SR4/Release_Notes (colindixon, 17:09:48)
    12. - colin explain how we generates the releas enotes in to the docs. (Sai__, 17:11:16)
    13. https://github.com/opendaylight/docs/blob/master/docs/user-guide/authentication-and-authorization-services.rst (colindixon, 17:11:56)
    14. http://docs.opendaylight.org/en/stable-boron/user-guide/authentication-and-authorization-services.html (colindixon, 17:12:18)

  3. - mdsal-trace debugging utility (Sai__, 17:12:58)
    1. - proper project location and controller dependencies (https://git.opendaylight.org/gerrit/#/c/46870/) (Sai__, 17:13:11)
    2. - It advertises services with BP with a higher priority (Sai__, 17:14:54)
    3. - Intended for data broker (Sai__, 17:17:13)
    4. - #info - Robert initially suggested to move it to MD-SAL (Sai__, 17:19:03)
    5. - Seems that was a general opinion and after talking to TomP seems controller is the right place (Sai__, 17:19:33)

  4. - Guava vs JDK8 Optionals (Sai__, 17:23:06)
    1. - Guava doesn't allow functional style, move towards java Optionals (Sai__, 17:24:02)
    2. - Michael asks - Are we considering moving overall from Guava to Java Optional ? (Sai__, 17:24:36)
    3. - Stephen says we are awaiting Guava v21 (Sai__, 17:25:07)
    4. - once it is available , stephen thinks we may have to figure out the API (Sai__, 17:26:29)
    5. - Robert says migration path is merged in Guava v21 , hence we may need to wait for v21 (Sai__, 17:27:18)
    6. - Michael isn't convinced about new guava v21 would help us in solving the issue in future. (Sai__, 17:29:59)
    7. https://groups.google.com/forum/#!topic/guava-discuss/ZRmDJnAq9T0 (rovarga, 17:31:43)
    8. - https://groups.google.com/forum/#!topic/guava-discuss/ZRmDJnAq9T0 (Sai__, 17:32:19)

  5. - Opinions about (optionally) using JDT ECJ instead of javac (Sai__, 17:32:24)
    1. - https://git.opendaylight.org/gerrit/#/c/47370/ (Sai__, 17:32:39)
    2. - Michael asks if it is completely crazy or something to explore ? (Sai__, 17:33:43)
    3. - gerrit introduces a maven profile, when active runs additional null safety checks (Sai__, 17:36:07)
    4. - Michael says we can decide on when to activate this (compiler/runtime/locally) (Sai__, 17:36:38)
    5. - Robert thinks the utility of current analysis is close to zero, using multiple compiler will explode the testing matrix (Sai__, 17:40:04)

  6. - Review the code change dashboards (Sai__, 17:40:49)
    1. - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:me (Sai__, 17:41:07)
    2. - Patches - https://git.opendaylight.org/gerrit/#/c/48441/ & https://git.opendaylight.org/gerrit/#/c/48440/ deal with Persist log entries asycnhronously and Adding persistAsync method to DataPersistenceProvider (Sai__, 17:49:11)
    3. - performnace improvement is expected (Sai__, 17:49:34)
    4. https://datatracker.ietf.org/doc/draft-ietf-netconf-restconf/ (colindixon, 17:51:19)
    5. - state of data tracker - https://datatracker.ietf.org/doc/draft-ietf-netconf-restconf/ (Sai__, 17:51:43)
    6. https://www.rfc-editor.org/current_queue.php current RFC Editor queue (rovarga, 17:51:43)
    7. - https://www.rfc-editor.org/current_queue.php current RFC Editor queue (Sai__, 17:52:05)
    8. - Modified Patches for last 7 days (Sai__, 17:53:33)
    9. - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+a (Sai__, 17:53:36)
    10. - Robert requests TomP to rebase the patches for review (Sai__, 17:57:37)
    11. - Alexis asks Netconf committers to join to the call for questions and discussions (Sai__, 17:58:19)

  7. - Participants (Sai__, 18:00:13)
    1. - Sai / Ryan / Alexis / Colin / Martin / Michael / Oren / Robert / Stephen / TomP (Sai__, 18:00:24)


Meeting ended at 18:00:27 UTC (full logs).

Action items

  1. - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
  2. - rgoulding to move the tool to change passwords to /bin insead of /etc Bug 7265
  3. - rgoulding to move the idmlight.db (actual DB) from a top-level place to a better location Bug 7090


Action items, by person

  1. colindixon
    1. - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
  2. UNASSIGNED
    1. - rgoulding to move the tool to change passwords to /bin insead of /etc Bug 7265
    2. - rgoulding to move the idmlight.db (actual DB) from a top-level place to a better location Bug 7090


People present (lines said)

  1. Sai__ (57)
  2. colindixon (14)
  3. rovarga (7)
  4. odl_meetbot (6)


Generated by MeetBot 0.1.4.