16:57:58 <Sai_> #startmeeting kernel_projects
16:57:58 <odl_meetbot> Meeting started Tue Dec 13 16:57:58 2016 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:57:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:57:58 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:58:12 <Sai_> #topic - Agenda
16:58:31 <Sai_> #undo
16:58:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x273f250>
16:58:40 <Sai_> #Topic - previous-meeting-minutes
16:59:05 <Sai_> #link -  https://meetings.opendaylight.org/opendaylight-meeting/2016/kernel_projects/opendaylight-meeting-kernel_projects.2016-12-06-16.56.html
16:59:12 <Sai_> #topic - Agenda
16:59:42 <Sai_> #info - Action items
16:59:55 <Sai_> #info - Call for any topics to be added
17:00:15 <Sai_> #info - BUG-5902 API Explorer does not work
17:00:32 <Sai_> #info - Core dashboards
17:03:23 <Sai_> #topic - Call for any topics to be added
17:03:27 <Sai_> #chair colindixon
17:03:27 <odl_meetbot> Current chairs: Sai_ colindixon
17:03:43 <Sai_> #topic - Review action items
17:05:47 * rovarga just jumped in ... whom are we nuking? :)
17:05:51 <Sai_> #Action - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
17:06:52 <Sai_> #topic - BUG-5902 API Explorer does not work
17:07:08 <Sai_> #info - BUG-5902 API Explorer does not work if started as http://admin:admin@localhost:8181/apidoc/explorer/index.html
17:07:31 <Sai_> #Action - ryan to check with Martin offline wrt Bug 5902
17:07:54 <Sai_> #topic - odlparent SingleFeatureTest improvement
17:08:06 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/48901/
17:08:58 <Sai_> #Info - SingleFeatureTest now fails if diag CLI command would have failed
17:09:22 <Sai_> #info - The patch will help us detect a whole range of issues, notably any blueprint related problems, much earlier in our development cycle than we currently are.
17:10:09 <Sai_> #info - Stephen points that karaf4 might be useful here.
17:11:42 <Sai_> #Action - Michael to discuss with Stephen regarding karaf 4 distribution wrt gerrit  https://git.opendaylight.org/gerrit/#/c/48901/
17:15:56 <Sai_> #info - Michael requests someone to volunteer for css work
17:16:33 <Sai_> #info - Alexis volunteers to help Micheal with css work.
17:17:22 <Sai_> #info - Michael points that it won't increase any build time.
17:17:32 <Sai_> #topic - infrautils Caches infra
17:17:43 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/48920/
17:19:08 <Sai_> #info - Ideally, It should be faster to go ahead and read cache rather than reading in MD-SAL
17:20:13 <Sai_> #info - colin points that currently there is no caching in MD-SAL binding aware, If you have clustering enabled all reads will end up as local reads
17:24:16 <Sai_> #info - Robert asks that how does read trigger ? rather than reading , can we do it ahead of time by DTCL.
17:25:31 <Sai_> #info - Micheal points that caches already exists in some projects (Genius)
17:26:24 <colindixon> #info basically, there are two ways this would likely help: (1) avoid the serialization from BindingIndependent to BindingAaware classes tha thappens on ever DataStore read, (2) it could allow for (possibly stale) local reads from the cache instead of reading from the shard leader
17:26:56 <colindixon> #info lotos of discussion here about what might make sense in the longer run, but colindixon would like to note that shoudln't stop progress now
17:31:12 <Sai_> #topic - Review code change dashboards
17:32:12 <Sai_> #info - Robert asks if there is any update on karaf4
17:33:02 <Sai_> #Info - Stephen is working on it, requested help from controller project in mailing list.
17:35:01 <Sai_> #info - All projects (possibly) need work on features.xml augmentation.
17:35:56 <Sai_> #info - since it is not a part of feature freeze, it should be ok.
17:37:03 <Sai_> #info - Ryan volunteers to help on projects wrt changing features.xml
17:38:36 <Sai_> #info - Robert points colindixon to add this topic in this week TSC meeting.
17:41:15 <Sai_> #info - Patch wrt Call-Home functionality exists (not merged yet) in controller project, pushed by Bala.
17:41:47 <Sai_> #info - Alexis is interested in providing feedback
17:42:26 <Sai_> #Info - Robert asks if is integrated wrt AAA, Ryan volunteers to review
17:42:54 <Sai_> #info - TomP / Alexis request to breakdown the patch in to several patches
17:45:07 <Sai_> #Action - Bala to add notes (or breakdown patches in to several patches) for patch change id  - 49253
17:48:27 <Sai_> #info - Alexis requests one of the netconf committer to review the patch
17:49:28 <adetalhouet> Sai_: request is a bit rough, I'm more asking gently
17:49:30 <adetalhouet> :)
17:49:54 <adetalhouet> But once we have some doc and more digestible patches
17:50:15 <Sai_> @adetalhouet: sorry for the wrong word
17:50:37 <adetalhouet> it's ok, but I don't want to sound like I'm dictating anything here.
17:50:40 <Sai_> #topic - Participants
17:51:42 <Sai_> #info - Sai / Ryan / Alexis / Bala / Colin / Igor / Michael / Robert / Stephen / TomP / Viera / Vratko
17:51:48 <Sai_> #endmeeting