#opendaylight-meeting: kernel_projects

Meeting started by Sai_ at 16:51:52 UTC (full logs).

Meeting summary

    1. - previous_meeting_minutes (Sai_, 16:52:47)

  1. - previous_meeting_minutes (Sai_, 16:54:13)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/kernel_projects/opendaylight-meeting-kernel_projects.2016-12-13-16.57.html (Sai_, 16:54:34)

  2. - Agenda (Sai_, 16:54:41)
    1. - 1. Call for any topics (Sai_, 16:55:11)
    2. - 2. Review action items (Sai_, 16:55:24)
    3. 3. Ttp project discussion (Sai_, 16:56:31)
    4. 4. odlparent SingleFeatureTest (Sai_, 16:56:46)
    5. 5. Review the code change dashboards (Sai_, 16:56:58)

  3. - Call for any topics (Sai_, 16:58:42)
    1. - Karaf 4 (Sai_, 17:03:49)

  4. - Review action items (Sai_, 17:04:21)
    1. ACTION: - Michael to discuss with Stephen regarding karaf 4 distribution wrt gerrit https://git.opendaylight.org/gerrit/#/c/48901 (Sai_, 17:06:06)
    2. - [DONE] Bala to add notes (or breakdown patches in to several patches) for patch change id - 49253 (Sai_, 17:07:56)
    3. - [DONE] - closing for now, will open action items as need for Bug 5902. note mciglan: assigned, replicated & in progress - might need new solution - code re-done (Sai_, 17:10:38)

  5. - Ttp project (Sai_, 17:11:33)
    1. - https://lists.opendaylight.org/pipermail/ttp-dev/2016-December/thread.html (Sai_, 17:11:44)
    2. - vorburger requesting guidance how to make ttp project move on ignored email ? If no reaction, what do I do? What's our process in such cases, where would I raise a motion to get ttp removed from autorelease? As of now it still is in. (Sai_, 17:12:07)
    3. - colindixon asks if there is any existing patch. (Sai_, 17:12:34)
    4. - Micheal to update patch in ttp project and add colin as reviewer (Sai_, 17:14:03)
    5. https://lists.opendaylight.org/pipermail/ttp-dev/2016-December/000168.html (rgoulding, 17:15:37)

  6. - odlparent SingleFeatureTest (Sai_, 17:16:30)
    1. - https://git.opendaylight.org/gerrit/#/c/48901/ odlparent SingleFeatureTest ready, just waiting for 1 (?) project to fix up. Merge when, now, or first thing Jan 9th when vorburger is back from vacation? Or Jan 2nd when others pick up? (Sai_, 17:16:41)
    2. - Stephen asks if it makes karaf 4 update more harder ? (Sai_, 17:17:33)
    3. - Stephen says karaf 4 update requires more time, hence better to get in odlparent singlefeature Test either early or push it after karaf update (Sai_, 17:19:21)
    4. - https://git.opendaylight.org/gerrit/#/c/48901/ (Sai_, 17:20:43)
    5. - https://git.opendaylight.org/gerrit/#/c/48901/25/features-test/src/main/java/org/opendaylight/odlparent/featuretest/SingleFeatureTest.java (Sai_, 17:23:40)
    6. - some features in BLACKLISTED_BROKEN_FEATURES are not working , need further attention. (Sai_, 17:25:18)
    7. - colin suggests using multi patch test job (Sai_, 17:27:14)

  7. - Karaf 4 Update (Sai_, 17:28:04)
    1. - it runs singlefeaturetest , fixes all missing dependencies (example patch exists in yangtools). (Sai_, 17:30:28)
    2. - all the projects' missing bundles are to be figured out to make sure karaf 4 update is done. (Sai_, 17:31:31)
    3. - colin suggests waiting till january first week to push karaf 4 update. (Sai_, 17:33:01)
    4. - karaf 3 has known security issues, it requires java 7. (Sai_, 17:35:02)
    5. - when upgraded to karaf 4, some bundles needs updation. (Sai_, 17:36:36)
    6. - if karaf 3 & 4 are allowed parallel, there is a possibility that most projects may not move to karaf 4. (Sai_, 17:37:50)
    7. - RC0 deadline is April 13. (Sai_, 17:38:34)
    8. - Stephen says it cannot be prepared in advance , since it requires all the dependent projects to be moved to karaf 4 , before updating the parent projects. (Sai_, 17:40:58)
    9. - Michael says it sounds scary, since the parent projects have to wait till all dependent projects are ready. (Sai_, 17:43:02)
    10. - Michael volunteers to help Stephen in preparing patches for karaf 4 upgrade (Sai_, 17:44:53)
    11. - odlparent / controller / yangtools / md-sal are the projects for which patches are ready as of now. (Sai_, 17:47:01)
    12. - Colin suggests to present karaf topic in TSC with patches and instructions (doc) on how to upgrade to karaf 4. (Sai_, 17:50:40)
    13. - Vrakto suggests to create karaf 4 in parallel to karaf 3 by distribution projects / check jobs etc., and then test the patches. (Sai_, 17:55:07)
    14. https://wiki.opendaylight.org/view/Integration/Test/Running_System_Tests#Running_System_Tests_Using_Custom_Distribution_Built_From_Multiple_Patches multiple-patch test job docs (colindixon, 17:57:19)
    15. https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-carbon/1 (jamoluhrsen, 17:58:16)
    16. https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-carbon/ multi-patch test job in jenkins, was used once by honeycompb + gbp recently for carbon (colindixon, 17:58:59)
    17. - Michael says implementing odlparent SingleFeatureTest earlier than karaf 4 upgrade would be better. (Sai_, 18:04:00)

  8. - participants (Sai_, 18:05:06)
    1. - Sai / Ryan / Colin / Igor / Michael / Stephen / TomP / Tomas / Vratko (Sai_, 18:05:51)


Meeting ended at 18:05:58 UTC (full logs).

Action items

  1. - Michael to discuss with Stephen regarding karaf 4 distribution wrt gerrit https://git.opendaylight.org/gerrit/#/c/48901


People present (lines said)

  1. Sai_ (54)
  2. colindixon (12)
  3. jamoluhrsen (8)
  4. odl_meetbot (6)
  5. vorburger (2)
  6. rgoulding (1)
  7. skitt (1)


Generated by MeetBot 0.1.4.