#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 17:00:25 UTC (full logs).

Meeting summary

  1. agenda bashing (Sai, 17:02:00)
    1. - last meeting actions items - (Sai, 17:02:18)
    2. - Action items - ryan opens a bug to deal with upgradability of netconf clustering anipbu to add reporting whether you have moved to the new YANG tools versioning as part of Boron readouts (Sai, 17:02:39)
    3. - last meeting notes https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-01-12-17.01.html (Sai, 17:03:21)
    4. - Todays likely agenda - - MD-SAL release interview with An Ho; - Bug 4577 patch is ready for review/merge [1] ; netconf master branch test failures (not present in stable/beryllium) ; RC0 issues (Sai, 17:04:35)

  2. bug 4577 patches (colindixon, 17:06:51)
    1. this fixes the revisionless import issues by having a custom schemaPath for mounted NETCONF devices (colindixon, 17:07:11)

  3. failing tests in NETCONF on master (not seen on stable/beryllium) (colindixon, 17:07:28)
    1. tomas cere says that the fix should have been merged by tony an things should be good now (colindixon, 17:07:52)
    2. - Ryan says regarding Netconf - revision-less import and spawn a separate schema - changes in stable lithium - going to beryllium - netconf master brnach has failing tests - to be reviewed - Tony just moved to branch - so should be fine now. (Sai, 17:07:57)
    3. - An Ho says capturing features which end users look for. Going to each individual project and asking for representative to deliver in beryllium. (Sai, 17:09:12)
    4. ACTION: - AnHo & ttkacik will meet at 9:30 PST (Sai, 17:10:55)

  4. - Bug 4577 patch is ready for review/merge [1] (Sai, 17:11:20)
    1. - robert says - he needs the patch need to be reviewed by one more. (Sai, 17:12:00)

  5. - Bug 4925 (Sai, 17:12:21)
    1. - Robert says - ready to be merged, but it is still level 1 type event. (Sai, 17:12:49)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=4925 (colindixon, 17:12:57)
    3. ACTION: - robert will send out a mail regarding the patch and details of bug (Sai, 17:13:08)
    4. https://git.opendaylight.org/gerrit/#/c/26853/ (colindixon, 17:13:42)
    5. - Robert says they were able to analyze the issue and proceed further. (Sai, 17:13:55)
    6. - Ryan asks for any concerns wrt bug 4925 (Sai, 17:15:04)
    7. - Colin asks for 2 min details (Sai, 17:15:36)
    8. it's 4295, not 4925 (colindixon, 17:15:36)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=4295 real bug (ignore previous link to a bug) (colindixon, 17:16:02)
    10. - Robert says the bug has to deal with refactoring the lazy expansion, now it has better memory and overall characteristics, how it is being represented in data tree. (Sai, 17:17:16)
    11. - Robert says they have been working on it for past 2 months (Sai, 17:18:05)
    12. - Robert says they dont have any explicit performance numbers. (Sai, 17:18:29)
    13. says his memory is that it's 20% more memory effiicient (colindixon, 17:19:48)
    14. - Robert not able to run the bench mark tests, but did some analysis on xml files and skipping all the merge operations. In memory usage of 20% is observed, but it should not affect any performance report. (Sai, 17:19:57)
    15. - 20% more efficient (Sai, 17:20:18)
    16. - Ryan asks for is there any standard test tool for bench marking performace test wrt to netconf. (Sai, 17:20:48)
    17. - Robert says he has no idea where it resides. (Sai, 17:21:10)

  6. - rc0 issues (Sai, 17:21:54)
    1. - Ryan is not aare of any escalated issues (Sai, 17:22:09)
    2. - aware (Sai, 17:22:19)
    3. - RC0 is thursday - Please feel free to reach out for any issues. (Sai, 17:22:57)
    4. - Ryan asks for any other issues/topics (Sai, 17:23:16)
    5. https://bugs.opendaylight.org/buglist.cgi?columnlist=product%2Ccomponent%2Cbug_severity%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate&list_id=45615&order=bug_severity%2Cchangeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=mdsal&product=yangtools&product=netconf&product=controller&query_based_on=&query_format=advanced&resolution=--- bugs in controller, mdsal, yangtools, and netconf (colindixon, 17:25:27)

  7. - Bug 4823 - Data store unrecoverable failure (Sai, 17:26:28)
    1. - TomP says they discussed the same in other clustering call. They are doing stress testing. (Sai, 17:27:03)
    2. - Colin asks if it is going to be fixed in beryllium (Sai, 17:27:16)
    3. - TomP Says they are trying to push through. Colin says is it critical. TomP replies these are not critical. (Sai, 17:28:04)
    4. ACTION: - Colin asks Ryan for downgrade of severity (Sai, 17:28:35)

  8. - Bug 4684 (Sai, 17:28:49)
    1. - robert says it will be addressed in RC1 (Sai, 17:29:08)

  9. - Bug 4664 - clustering bug (Sai, 17:29:25)
    1. - ttkacik says it is openflow related bug. (Sai, 17:30:18)
    2. - Robert says it is using litium/helium plugin. Colin asks there is a duplicate of the same bug (Sai, 17:31:13)
    3. - TomP please close this as duplicate. (Sai, 17:31:33)
    4. - The other bug is 4665 (Sai, 17:32:08)
    5. - TomP says no (Sai, 17:32:47)
    6. - Colin says they want to make sure if it is duplicate and prioritize accordingly. (Sai, 17:33:20)
    7. - Robert says - Has gone through the bugs overview - bugs has to deal with openflow - they leaves empty child in data store - fixed in beryllium . (Sai, 17:34:52)
    8. - Colin asks if they can be reproduced in beryllium (Sai, 17:35:33)
    9. - Robert says he has to check the emails from november. (Sai, 17:36:02)
    10. - https://bugs.opendaylight.org/show_bug.cgi?id=4665 (Sai, 17:36:35)
    11. - https://bugs.opendaylight.org/show_bug.cgi?id=4664 (Sai, 17:36:43)
    12. ACTION: - Colin to follow up with Anil about these bugs (Sai, 17:37:11)

  10. bug 2974 (Sai, 17:37:20)
    1. - ttkacik says - targeted for RC1 , aims to fix the revisionless input mechanism. (Sai, 17:38:25)
    2. - Ryan says looks good for beryllium release (Sai, 17:38:54)

  11. - bug 4574 (Sai, 17:39:12)
    1. - TomP - May be Moiz / Sanjiv have better idea (Sai, 17:39:52)
    2. -https://bugs.opendaylight.org/show_bug.cgi?id=4574 (Sai, 17:39:56)
    3. - TomP says Sanjiv in India/ Moiz tried to follow up, this is from lithium SR2. this is 5 node clustering. (Sai, 17:41:07)
    4. ACTION: - Colin says they have to reach out to Ericsson/Fujitsu wrt 4664/4665/4108 (Sai, 17:42:36)

  12. - Bug 4108 (Sai, 17:42:47)
    1. bugs 4664, 4574, 4572, 4484, 4164 are all seemingly related to Ericsson testing of OpenFlow clsutering, someody will reach out to see if they're still real (colindixon, 17:43:25)
    2. - TomP - it is wrt to RPC stuff, he doesn't have more knowledge. need to reach Moiz (Sai, 17:43:44)
    3. ACTION: - adds Jamo to the list wrt bug 4108 to see if it is still relavent to beryllium (Sai, 17:45:15)
    4. - Colin says needs to go through all bugs and fix them if they are critical. (Sai, 17:46:43)
    5. - Ryan asks about any other issues / bugs critical for release (Sai, 17:47:58)
    6. - log people (Sai, 17:48:19)


Meeting ended at 17:48:40 UTC (full logs).

Action items

  1. - AnHo & ttkacik will meet at 9:30 PST
  2. - robert will send out a mail regarding the patch and details of bug
  3. - Colin asks Ryan for downgrade of severity
  4. - Colin to follow up with Anil about these bugs
  5. - Colin says they have to reach out to Ericsson/Fujitsu wrt 4664/4665/4108
  6. - adds Jamo to the list wrt bug 4108 to see if it is still relavent to beryllium


People present (lines said)

  1. Sai (68)
  2. colindixon (19)
  3. odl_meetbot (5)


Generated by MeetBot 0.1.4.