16:58:44 <Sai_> #startmeeting MD-SAL Interest Call
16:58:44 <odl_meetbot> Meeting started Tue Feb  2 16:58:44 2016 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:44 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:58:57 <Sai_> #chair colindixon
16:58:57 <odl_meetbot> Warning: Nick not in channel: colindixon
16:58:57 <odl_meetbot> Current chairs: Sai_ colindixon
17:01:07 <Sai_> #topic last-meeting-notes
17:01:19 <Sai_> #link #topic https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-01-26-16.59.html
17:02:02 <Sai_> #topic Agenda-bashing
17:02:43 <Sai_> #info - followup of previous meeting action items- - marked as duplicate of 5019. Anil will reach out when it is fixed. - Ryan will follow up on bug 5099 Ryan follows up with Robert on bug 5103 - regarding opening a new bug in openflow plugin. Tony needs to follow up Bug 5096 with MD-SAl netconf commiters - Ryan will capture the notes ahead of meeting for boron planning
17:02:53 <Sai_> #info - today's agenda
17:03:11 <Sai_> Call for any other topics, Bug 4948 Discussion, Review any outstanding major or critical bugs RC-0 Issues.
17:03:19 <Sai_> #info - Call for any other topics, Bug 4948 Discussion, Review any outstanding major or critical bugs RC-0 Issues.
17:05:34 <Sai_> #Action - Ryan will followup with Anil wrt 5019
17:06:26 <Sai_> #info - Ryan requests Tony to update the Bug 5099
17:07:06 <Sai_> #info - Robert says Bug 5103 is boron work.
17:08:02 <Sai_> #info - Bug 5096 - No update from Joseph - Updated comments in bugjilla
17:09:40 <Sai_> #Action - Ryan ensures there will boron planning discussion in next week's meeting. Requests users to come up with any list of plan for Boron planning.
17:10:54 <Sai_> #info - Robert says discussion should be generic through email list and then dig in to details. He is not sure whether we can dive in to individual points at this point.
17:11:53 <Sai_> #info - Robert says we nee to build an agenda for developer summit.
17:12:08 <Sai_> #info - Ryan agrees to it.
17:13:33 <Sai_> #topic Review critical bugs
17:13:57 <Sai_> #link - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46894&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_format=advanced&resolution=---
17:14:12 <Sai_> #topic - Bug-4948
17:14:42 <Sai_> #info - Bala is original author and consensus is required on pushing the patch.
17:15:18 <Sai_> #info - Bala says tested against both lithium / beryllium and works good.
17:16:33 <Sai_> #info - Bala says we are at the mercy of netconf - it is a benign fix.
17:17:19 <Sai_> #info - Bala explained the patch in detail and followed up the comments in git.
17:19:37 <Sai_> #info - Bala is unclear which exact runtime exception is being thrown by the code.
17:20:18 <Sai_> #info - Tony says having specific exceptions from device is better.
17:21:49 <Sai_> #info - Colindixon says everyone agrees on long term plan. Bala's patch preserves behaviour.
17:22:37 <Sai_> #info - Bala says the current code is well tested against devices
17:23:04 <Sai_> @info - colindixon requests Tony to open a bug against catching runtime specific exceptions
17:23:34 <Sai_> #info - Colindixon says bugs against SR1
17:25:48 <Sai_> #Action - Tony pushes the fix provided a comment in the patch of 4948 is added which ensures how and where the fix against particular devices is done.
17:26:40 <Sai_> #action - Wrt Bug 4948 - Bala opens a new bug against Beryllium SR1 so as to satisfy the comments in the git.
17:28:00 <Sai_> #info - Bala says he is not clear why the code is specific against all particular devices, but it should be generic to all devices.
17:28:36 <Sai_> #info - Tony says this was the MD-SAL proposal last year, he was against it. This is the consequence of it.
17:29:48 <Sai_> #topic Bug5019
17:30:36 <Sai_> #TomP just moved to Lithium SR4
17:30:46 <Sai_> #topic 2916
17:30:55 <Sai_> #tony didn;t get a chance to go through
17:31:01 <Sai_> #info tony didn;t get a chance to go through
17:31:10 <Sai_> #topic 3866
17:31:27 <Sai_> #info - Tony will update the bug
17:31:39 <Sai_> #topic Bug 5135
17:32:46 <Sai_> #info - Tony says it is related to clustering.
17:33:24 <Sai_> #Action - Ryan will followup with Anil wrt Bug 5135
17:33:39 <Sai_> #undo
17:33:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x20d8c90>
17:34:15 <Sai_> #Action - Ryan will followup with Anil & others (please go through comments section in bugzilla) wrt Bug 5135
17:34:26 <Sai_> #topic Bug-5153
17:35:21 <Sai_> #info - TomP haven't see this. Clustering call is dominated with performance issues.
17:35:52 <Sai_> #Action - Ryan will followup on Bug 5153
17:36:13 <Sai_> #topic - revisionless import Bug 2974
17:37:00 <Sai_> #info - Tony says it is still in progress. Decreased priority to major , since we have a workaround.
17:38:23 <Sai_> #topic - Bug 4032
17:39:18 <Sai_> #undo
17:39:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1fe7f50>
17:39:28 <Sai_> #topic - Bug 1435
17:39:32 <Sai_> #info - Tony requests TomP to look in to it.
17:39:40 <Sai_> #info - updated status to blocker
17:40:03 <anipbu> https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1798258463
17:40:16 <Sai_> #topic RC1 issue
17:40:24 <Sai_> #link https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1798258463
17:41:16 <Sai_> #info - Anibu requests everyone to go through the two controller bugs
17:42:16 <Sai_> #info TomP thinks these are sporadic, should be fine with a re-run.
17:45:08 <Sai_> #link -https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-all-beryllium/101/
17:45:35 <Sai_> #link - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/540/
17:46:49 <Sai_> #Action - Ryan will follow up with Luis wrt  https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-all-beryllium/101/
17:48:38 <Sai_> #topic controller bootup and restconf calls
17:48:42 <Sai_> #info - Colindixon is it safe to make to make the RESTconf calls as soon as the controller shows up. Adding jjust timeout is not the solution.
17:49:51 <Sai_> #info - Robert says it is long standing discussion, (how do we know when is the controller completely installed / initialized).
17:50:40 <rovarga> #link https://lists.opendaylight.org/pipermail/discuss/2016-January/006127.html
17:50:52 <Sai_> #Action - Ryan goes through archive wrt controller completely being installed/initialized and comes up with a plan
17:52:07 <Sai_> #info - participants -  Ryan, Sai, Abhijit, Alexis, An Ho, Bala, Colin, Gary Wu, Robert Varga, Stephen Kitt, Tcere, Tom P , Tony, Viera
17:52:24 <Sai_> #endmeeting
17:52:31 <Sai_> #endmeeting