17:13:21 <Sai> #startmeeting MD-SAL Interest Call
17:13:21 <odl_meetbot> Meeting started Tue Feb  9 17:13:21 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:13:21 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:13:21 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
17:13:26 <LuisGomez> oflibMichal, it would be good to release note the ovs 2.4 ofjava error messages either in ofjava or ofplugin, maybe the second.
17:13:26 <colindixon> the MD-SAL meeting should start in this IRC channel now
17:13:27 <Sai> #chair colindixon
17:13:27 <odl_meetbot> Current chairs: Sai colindixon
17:14:03 <Sai> #topic Agenda
17:14:14 <Sai> #info - Agenda Items - 0. Previous meeting Action items  1. Hash over the Action Items for February 2, 2016 Meeting 2. Beryllium Blockers/Issues 3. Developers Forum Query 4. Boron Planning 5. Possibility of Deprecating DataChangeListener in favor of DataTreeChangeListener? 6. Possibility of Deprecating Netconf mount through config subsystem
17:14:19 <phrobb> jamoluhrsen will reach out to you offline
17:14:24 <oflibMichal> LuisGomez: I would prefer to put it into ofplugin - as the fix should take place there + it is probably more visited wiki page
17:14:34 <Sai> #topic Previous meeting Action items
17:14:42 <Sai> #info - Bug 5135 - Ryan asks Tony if this is an actual issue ? Tony says we need to confirm if it is a duplicate.
17:14:43 <LuisGomez> i agree oflibMichal
17:14:47 <jamoluhrsen> phrobb, ack
17:14:48 <Sai> #Action - Bug 5135 Ryan followup with Anil
17:14:54 <Sai> #info - Bug 5153 - Luis not able to reproduce.
17:15:02 * colindixon is joining webex now
17:17:07 <Sai> #info - uncommon scenario - TomP needs counters for debugging but not Tx Id
17:18:36 <Sai> #info - TomP says he can use UUID and try to fix (not to overkill)
17:19:33 <Sai> #info - Targeted not for Be. Bug exists from Day1. It is not a blocker.
17:20:54 <LuisGomez> Bug 5135 only shows in one of the plugin cluster suites, i could not reproduce locally so it is not blocker for now.
17:21:06 <Sai> #topic - Beryllium Blockers/Issues
17:22:07 <LuisGomez> sorry i meant 5153
17:22:10 <Sai> #info -Bug4866 - Anil/TomP have added patches
17:22:26 <Sai> Thanks Luis
17:22:42 <Sai> #info - Bug5153 - Luis says it is not a blocker
17:23:32 <Sai> #link for critical bugs - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46894&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_format=advanced&resolution=---
17:27:05 <Sai> #info - Bug4866 - decreased priority of 4866 - because several bugs others are created. Change status to Waiting for Review. Anil fix in openflowplugin bypasses the new RPC (missing retries & changing routing table)
17:27:37 <Sai> #info - Ryan requests TomP to create a new bug wrt Bug4866
17:28:17 <Sai> #Action - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed)
17:29:36 <Sai> #info - Bug5247 - It has a patch for master.
17:30:01 <Sai> #info - TomP waiting since it says -1 from jenkins.
17:30:16 <Sai> #info - Tony says  TomP & Robert needs to figure it out.
17:31:41 <Sai> #Action - Robert updates Bug5247
17:32:17 <Sai> #info - Bug1435 - Tony says not aimed for Be.
17:33:25 <Sai> #info - Ryan changes milestone to Be-1
17:34:25 <Sai> #info - Bug2912 - Tony fixes comments
17:34:40 <Sai> #Action - Tony fixes Bug2912
17:35:13 <Sai> #topic - Developers Forum Query
17:36:46 <Sai> #info - Ryan requests everyone to take atleast one action item on the project they work on so that we can prepare better for developer forum.
17:37:27 <Sai> #info - colindixon says there are complications in splitting core MD-SAl - we should discuss the advantages of splitting in forum.
17:39:46 <Sai> #info - colindixon says it helps users in resolving ambiguity about the importance and reasoning behind splitting projects.
17:40:13 <Sai> #topic - Boron Planning
17:40:26 <Sai> #subtopic - Possibility of Deprecating DataChangeListener in favor of DataTreeChangeListener?
17:40:36 <Sai> #info - Possibility of Deprecating DataChangeListener in favor of DataTreeChangeListener?
17:42:53 <Sai> #info - TomP & Tony echos people find it easy with DTCL  (much deeper access)
17:44:02 <Sai> #info - Ryan asks how do we document to make it to easier for people who are trying to use DTCL
17:44:19 <Sai> #info - Tony says he needs to checkout the patches
17:44:56 <Sai> #info - colindixon says we need have this where ONOS seems better.
17:45:46 <Sai> #Action - colindixon opens an improvement bug wrt improving usability of DTCL
17:46:33 <Sai> #subtopic - Possibility of Deprecating Netconf mount through config subsystem
17:46:41 <Sai> #info - Possibility of Deprecating Netconf mount through config subsystem
17:48:19 <Sai> #Action - Ryan follows up with Tony wrt Possibility of Deprecating Netconf mount through config subsystem
17:49:05 <Sai> #topic - Java8 features
17:49:33 <Sai> #info - colindixon says we can use java8 features in master
17:50:31 <Sai> #info - An Ho says patch has been merged.
17:51:28 <Sai> #info - colindixon says it is a really good example for fixing downstream/upstream issues.
17:54:04 <Sai> #topic attendees - Ryan/Phil/An Ho/Carol/Colin/Gary/Lisa/Sai/Stephen Kitt/ Tom P/ Tony
17:54:15 <Sai> #undo
17:54:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x21bba50>
17:54:24 <Sai> #topic attendees
17:54:26 <Sai> Ryan/Phil/An Ho/Carol/Colin/Gary/Lisa/Sai/Stephen Kitt/ Tom P/ Tony
17:54:43 <Sai> #endmeeting