17:00:01 <Sai> #startmeeting MD-SAL Interest Call
17:00:01 <odl_meetbot> Meeting started Tue Feb 16 17:00:01 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:01 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:01 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
17:00:06 <Sai> #chair colindixon
17:00:06 <odl_meetbot> Current chairs: Sai colindixon
17:00:16 <colindixon> #topic agenda bashing
17:00:18 <Sai> #topic Agenda
17:00:22 <colindixon> #unod
17:00:25 <colindixon> #undo
17:00:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x203cb50>
17:00:28 <colindixon> sorry
17:01:39 <Sai> #info - last meeting notes/action items - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-02-09-17.13.html
17:03:04 <Sai> #info - possible topics
17:03:25 <Sai> #info 1. Beryllium Blockers Bug 5345 - Unable to use get-schema RPC due to unsafe class casting
17:03:36 <Sai> #info 2. Possibility of Deprecating Netconf mount through config subsystem
17:06:05 <Sai> #topic - previous minute action items followup
17:06:33 <Sai> #action - Ryan follows up on last meeting action item - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed)
17:07:55 <Sai> #action - colindixon fixes Bug2912
17:09:05 <Sai> #action - colindixon opens an improvement bug wrt improving usability of DTCL
17:10:54 <Sai> #info -Deprecating netconf mount through config subsystem - We are missing a mechanism - to be followed up in Boron .
17:11:48 <Sai> #info - rgoulding asks for more info about deprecating netconf mount through config subsystem. Tony says currently not much info.
17:12:52 <Sai> #info - Tony says some deployment time logic would help here
17:13:45 <Sai> #Action - rgoulding opens an enhancement bug wrt  possibility of deprecating netconf mount through config subsystem
17:14:23 <Sai> #topic - Bug5345 - Unable to use get-schema RPC due to unsafe class casting
17:15:46 <Sai> #info - Api doc doesn't use restconf directly - it uses schema context
17:17:08 <Sai> #info - Tony says seems nobody argues that rest interfaces are used less internally.
17:18:46 <Sai> #info - colindixon & Tony agrees on the work around that we can use yang files to get RPCs
17:21:07 <Sai> #info - rgoulding changes target milestone to Be-1 with importance as critical
17:21:48 <Sai> #topic - Bug3987 - Unable to add dlux feature to a new md-sal based application
17:23:00 <Sai> #info - rgoulding asks if this is a blocker
17:23:16 <Sai> #info - Alexis says it is not a blocker
17:24:08 <Sai> #info - colindixon says it cannot be a blocker since it is by definition it is not against this release.
17:24:46 <Sai> #info - Tony echoes with colindixon
17:25:07 <Sai> #info - Alexis says this feature doesn't exist in Beryllium.
17:27:26 <Sai> #topic - bug5345 - (again )
17:27:46 <Sai> #info - it sounds like there is a workaround where you do a get on restconf/modules and then parse it for RPCs
17:29:13 <Sai> #topic - Boron Release
17:30:16 <Sai> #Action - Tony comes up with a plan for Boron release - wrt controller & MD-SAl projects.
17:32:14 <Sai> #info - Mechanism to make sure that controller is up & running - more complicated problem that anticipated.
17:36:31 <Sai> #info - rgoulding asks could we provide a hook for applications to implement themselves ?
17:39:49 <Sai> #info - binding config susbsystem to  lifecycle state / Making sure that application is up/ Adding things to subtree and everything is expected to behave normally are some of the issues which needs attention.
17:42:51 <Sai> #info - TomP says blueprint advertises each module as a service , When each bundle comesup it process blueprint .xml and publishes it
17:43:31 <Sai> #info TomP says initialization doesn't mean it is ready
17:44:17 <Sai> #info - TomP thinks how about advertising to a service registry ?
17:44:46 <Sai> #info - colindixon thinks OSGI really needs a third life cycle state.
17:45:10 <Sai> #info - Tony & TomP thinkd that is the reason because it is application specific
17:46:24 <Sai> #info - colindixon  says only semantics are application specifics but patterns are not.
17:47:02 <Sai> #info -TomP things how about puclishing an event to osgi event component?
17:48:15 <Sai> #topic Cluster bugs
17:48:37 <Sai> #Info - AnHo says failing jenkins is not a problem
17:50:07 <Sai> #Action - rgoulding requests TomP to followup on jenkins failure build of 3nodeclustering-only-beryllium-590 build - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/
17:50:10 <Sai> #link - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/
17:50:47 <Sai> #info - AnHo requests TomP to mark it as non-blocking if it so.
17:53:01 <Sai> #Action - rgoulding follows up with Luis & TomP on clsutering & netconf bugs - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/
17:57:12 <Sai> #topic  - How to determine controller is up ? (Again)
18:00:29 <Sai> #info - colindixon divides in to three phases. 1. Need to have a karaf feature / some mode (yang/css) which should determine the up condition. 2. On typing the feature we should be able to determine 'up' ness 3.Need to prioritize the importance of having this feature and be implemented in all applications.
18:01:34 <Sai> #info - colindixon thinks it face two problems - Implementation of feature itself & bundle implementation of the up service
18:01:53 <Sai> #topic participants
18:02:01 <Sai> #info - Sai/Ryan/Abhijit/Alexis/An Ho/Colin/Gary/Lori/Tom P/ Tony
18:02:05 <colindixon> thanks
18:02:13 <Sai> #endmeeting