#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 15:56:37 UTC (full logs).

Meeting summary

  1. Previous Meeting Minutes (Sai, 15:57:08)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-03-22-16.02.html (Sai, 15:57:42)

  2. Agenda (Sai, 15:57:49)
    1. - 1. Call for any topics to be added to the agenda that people didn't get around to adding. (Sai, 15:58:52)
    2. 2. Review the existing action items (Sai, 15:59:00)
    3. 3. Bug 5504 - Controller crashes with OOM. (Sai, 15:59:24)
    4. 4. Karaf Upgrades (Sai, 15:59:37)
    5. 5. Blueprint Update (Sai, 15:59:48)

  3. Review the existing action items (Sai, 16:05:40)
    1. - Ryan & Bala will link the Bug (behavioral constraints in Be 5484) to Bug 5396 - Done (Sai, 16:06:12)
    2. - Tony will sync up with Peter wrt Bug 5396 - Done (Sai, 16:06:24)
    3. - Dynamic Filter Injection Documentation - Done (Sai, 16:06:34)
    4. - https://wiki.opendaylight.org/view/AAA:DynamicFilterFramework (Sai, 16:06:45)

  4. - Bug5504 Controller crashes with OOM. (Sai, 16:07:07)
    1. - https://bugs.opendaylight.org/show_bug.cgi?id=5504 (Sai, 16:07:17)
    2. - itr was a blocker at one point for beryllium SR1 (Sai, 16:07:28)
    3. - Ryan asks if it is fixed in master ? (Sai, 16:08:17)
    4. - Ryan asks if it is fixed in master ? (Sai, 16:08:22)
    5. - it is done (Sai, 16:08:41)
    6. - Robert says old/root is no more there. (Sai, 16:09:32)
    7. - changed to toString() (Sai, 16:09:41)
    8. - TomP has an idea the next steps wrt BluePrint (Sai, 16:10:19)
    9. - Followup patch exists in git (Sai, 16:11:50)
    10. - git patch Change id 36812 (Sai, 16:12:16)
    11. - https://git.opendaylight.org/gerrit/#/c/36812/1 (Sai, 16:12:39)
    12. - TomP sees it happening if config yang file fails to push (Sai, 16:13:11)
    13. ACTION: - TomP opens a bug to track the potential bug ( config yang change - fails to push - reproducible in local box ) (Sai, 16:15:05)

  5. - Karaf Upgrades (Sai, 16:15:17)
    1. - Stephen says he prefers Karaf 4.0, but it breaks a bunch of code (Sai, 16:15:52)
    2. - Stephen says he needs to figure out how to deal with karaf 3.0 (Sai, 16:16:33)
    3. - Ryan has a patch for KARAF-4457 in upstream karaf 3.X stream to update pax-web (Sai, 16:16:54)
    4. - https://issues.apache.org/jira/browse/KARAF-4457 (Sai, 16:17:06)
    5. - Ryan is Working with Jamie Goodyear and team to get some movement here (Sai, 16:17:30)
    6. - probably not until .6 or .7 release (Sai, 16:17:49)
    7. - TomP refers to startup properties , requests Ryan to check with stephen (Sai, 16:19:08)
    8. - Stephen says we can do it without waiting for karaf release (Sai, 16:19:25)
    9. - TomP says empty one install all features, we are missing admin bundle (which BluePrint needs). ODL karaf installs everything but no the the empty one. (Sai, 16:20:30)
    10. - TomP asks is there any preference for ODL karaf over empty one ? (Sai, 16:20:54)
    11. - TomP says changing karaf configurations is not a really good solution (Sai, 16:21:57)
    12. - We need not upgrade entire containers, since karaf team is good at having revision based upgrades (Sai, 16:23:18)
    13. ACTION: - Ryan to followup with TomP regarding upstream karaf 3.X stream to update pax-web (Sai, 16:24:13)
    14. - Stephen says rebuilding the distribution is current issue with karaf 4.X (Sai, 16:24:59)
    15. - Stephen says it is time consuming since we need to figure out each build fail (Sai, 16:25:29)
    16. - Ryan volunteers to help Stephen (Sai, 16:25:59)

  6. - Blueprint Update (Sai, 16:27:41)
    1. - TomP poiont to change id 35867 and wades through the blueprint implementation details (Sai, 16:29:59)
    2. - TomP explains the toaster example in context with BluePrint (Sai, 16:30:44)
    3. - TomP emphasis on proxy mechanism and why it is double edged sword (Sai, 16:35:17)
    4. - TomP - points to "restart dependant on updates" - it walks the service hierarchies - same as config system like atomic restarts (Sai, 16:36:41)
    5. - TomP says there is a default for all reference type, (default means user will land up in CDS) (Sai, 16:38:33)
    6. - TomP says toaster is also compatible with config system (Sai, 16:44:00)
    7. - AutoColsable in Remote RPC broker Module might be a good example for users to check out the different between both (Sai, 16:47:15)
    8. - TomP says it works with both Restconf & Netconf (Sai, 16:47:41)
    9. - Blueprint theoretically should be possible to do with same feature config in the order of the feature hierarchy (Sai, 16:50:23)
    10. - Implicit dependencies in blueprint are done via service or blueprint advertiser. it makes possible to add an extension which solves the dependencies problem. (think about OVSDB dependent on OF) (Sai, 16:53:16)
    11. ACTION: - TomP will make sure to have a wiki on how Blueprint is implemented / how it works (Sai, 16:54:22)
    12. - TomP waiting on patch "Improve config system shutdown" to be reviewed by Robert / Tony (Sai, 16:55:31)
    13. - TomP says he is waiting on code reviews from other committers in the controller project (Sai, 16:58:36)
    14. -Robert says he would be very careful wrt to config admin (single point of failure) when blueprint is completely switches over to. (Sai, 16:59:51)
    15. - TomP says it is little harder to do right now, but have plans to implement (Sai, 17:01:16)
    16. - TomP wades through toaster-provider-impl in change id 36405 - showing the user facing config & actual code wiring. (Sai, 17:02:47)
    17. - TomP says in short we have to make user config system as an option to do user operation (Sai, 17:05:08)
    18. - colin says we have to more consolidate the user interfering way and how much we should allow user to make changes. (Sai, 17:06:35)
    19. - Robert says Netty configs using the datastore implementation should be considered (Sai, 17:07:38)
    20. - Robert says using sharding we can overcome some issues (Sai, 17:08:02)
    21. rovarga says what worries him the most is the fragmentation of configuration state (colindixon, 17:08:26)
    22. Robert says this is excellent progress but only he is worried about framentation of configuration state (Sai, 17:08:32)
    23. - Robert says devices don't have yang representation , and when we ask everyone to jump on to blueprint .. there may be a problem since we don't have ready made configs (Sai, 17:09:37)
    24. is there a compelling reason to store configuration outside the data store (colindixon, 17:10:11)
    25. - TomP says use config system side by side , bridge netconf to config admin are the possible options (Sai, 17:10:26)
    26. ACTION: rgoulding to add things about user config and making sure we have ideally one option to the next week's agenda (colindixon, 17:10:39)
    27. thanks colindixon (Sai, 17:10:55)


Meeting ended at 17:11:08 UTC (full logs).

Action items

  1. - TomP opens a bug to track the potential bug ( config yang change - fails to push - reproducible in local box )
  2. - Ryan to followup with TomP regarding upstream karaf 3.X stream to update pax-web
  3. - TomP will make sure to have a wiki on how Blueprint is implemented / how it works
  4. rgoulding to add things about user config and making sure we have ideally one option to the next week's agenda


People present (lines said)

  1. Sai (75)
  2. odl_meetbot (5)
  3. colindixon (5)


Generated by MeetBot 0.1.4.