#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 16:00:11 UTC (full logs).

Meeting summary

  1. last-meeting-minutes (Sai, 16:00:56)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-03-29-15.56.html (Sai, 16:00:59)

  2. Agenda (Sai, 16:01:09)
    1. 1. Call for any topics to be added to the agenda that people didn't get around to adding. (Sai, 16:02:02)
    2. 2. Review the existing action items (Sai, 16:02:10)
    3. 3.Infrastructure Issues and Compilation Problems this Week (Sai, 16:02:18)
    4. 4. DCL Deprecation [3] (Sai, 16:02:26)
    5. 5. Documentation of necessary changes to support YANG 1.1 [4] (Sai, 16:02:37)
    6. 6. Update on Blueprint (Sai, 16:02:51)

  3. Action items (Sai, 16:05:10)
    1. - Ryan to followup with TomP regarding upstream karaf 3.X stream to update pax-web - Active conversation going on (Sai, 16:05:39)
    2. - some progress but we can't cross it off (Sai, 16:06:04)
    3. - TomP opens a bug to track the potential bug ( config yang change - fails to push - reproducible in local box ) -- Merged to beryllium (Sai, 16:06:29)
    4. - TomP will make sure to have a wiki on how Blueprint is implemented / how it works - Work in progress (Sai, 16:07:06)

  4. - Infrastructure Issues and Compilation Problems this Week (Sai, 16:07:56)
    1. - cert problem was solved to use correct cert (Sai, 16:08:09)
    2. - https://lists.opendaylight.org/pipermail/dev/2016-April/001874.html (Sai, 16:08:17)
    3. - javax.xml.bind.UnmarshalException (s) (Sai, 16:08:31)
    4. - https://lists.opendaylight.org/pipermail/controller-dev/2016-April/011830.html (Sai, 16:08:39)
    5. - Ryan is not alone who is facing issue with xmls, Stephen too. (Sai, 16:09:10)
    6. - colindixon asks to mail to release (Andy) , open a ticket using helpdesk. (Sai, 16:10:05)
    7. - Tony says it seems xml being downloaded from internet, issue may be dealing with the place where we store. (it expects xml but it downloads html) (Sai, 16:11:42)
    8. - Tony says target/features of individual repo will have more explanation on errors (Sai, 16:12:20)
    9. we think they're really infrastructure failures, then we should report them to helpdesk or on #opendaylight-releng here (colindixon, 16:12:47)
    10. - colindixon says migration of nexus / other stuff shouldn't be ideally affecting these builds (Sai, 16:13:49)
    11. colindixon says jenkins pulls from local mirror of nexus, if public nexus has any issues that explains it. (Sai, 16:14:43)
    12. ACTION: - Ryan sends out mail / open ticket using helpdesk wrt javax.xml.bind.UnmarshalException (s) (Sai, 16:15:31)

  5. DCL Deprecation (Sai, 16:16:10)
    1. - https://git.opendaylight.org/gerrit/#/c/36970/ (Sai, 16:16:23)
    2. - Ryan says we need to deprecate the ACL deprecation as well (Sai, 16:16:42)
    3. ACTION: - Ryan to followup with DCL Deprecation [3] (Sai, 16:17:25)
    4. - Api's are used, Tony tries to deprecate all the old Api's so that it is easier for new changes / new Api (Sai, 16:18:57)
    5. - Tony says If they are deprecated in Boron , they could be deleted in Boron. But with previous release experience it takes 2-3 releases in general (Sai, 16:19:57)
    6. - Tony suggests to deal with deprecation after carbon (Sai, 16:20:22)
    7. - colindixon supports it too. (Sai, 16:20:47)
    8. - TomP suggests Nitrogen and Tony agrees. (Sai, 16:21:17)

  6. - Documentation of necessary changes to support YANG 1.1 (Sai, 16:22:04)
    1. - https://git.opendaylight.org/gerrit/#/c/37081/ (Sai, 16:22:11)
    2. - Ryan requests for time frame (Sai, 16:22:27)
    3. - The patch i just a small list, other part yang1.1 affects MD-SAl, given that we are close to M2, most likely in carbon. (Sai, 16:23:11)
    4. - Tony says it introduces lot features , so it will be carbon. (Sai, 16:23:44)
    5. - Ryan volunteers for any help here (Sai, 16:24:15)

  7. - Update on Blueprint (Sai, 16:24:52)
    1. - TomP says - there are no new updates, bu there is progress in work wrt to apache karaf with help of Stephen (Sai, 16:26:12)
    2. - Improve config subsystem Change 36777 - is a precursor and it is ready to go. (Sai, 16:28:11)
    3. - TomP asks Tony/other commiters to review the patch (Sai, 16:28:37)
    4. - TomP has several other patches to be merged and requests for volunteers to review / merge (Sai, 16:29:56)
    5. - Stephen is interested, Tony requests to add Milos. (Sai, 16:30:42)
    6. ACTION: - TomP will start to work on a wiki page to state how to move from config system to BluePrint (Sai, 16:34:35)
    7. - Ryan offers help from AAA side. (Sai, 16:35:32)
    8. - TomP suspects Netconf will be more harder wrt user configuration. (Sai, 16:36:04)
    9. - Ryan asks if there are any people concerns , requests to raise sooner than later. (Sai, 16:37:33)

  8. - new topics (Sai, 16:38:17)
    1. - question on patch 37009 wrt data tree consumers / data tree producers (Sai, 16:39:21)
    2. - colindixon says it would be very confusing to developers, say OFP could be both consumer/producer in case of writing a flow . (Sai, 16:40:12)
    3. - colindixon asks if there is any reason we can't do it in the context. (Sai, 16:41:46)
    4. - Robert says we are throwing away standalone one way transactions. (Sai, 16:42:20)
    5. - Robert says it is a consistency win as well as performace win. (Sai, 16:43:18)
    6. - colin summarizes that data tree producer is a transacation factory and it is little bit more than that because it is a transaction chain (Sai, 16:44:27)
    7. - colindixon requests not to introduce new terminology which will confuse developers (Sai, 16:44:59)
    8. - Robert says since these are new concepts (not similar to data broker) we need to come up with new names. (Sai, 16:46:04)
    9. - Robert is open for contribution (Sai, 16:46:44)
    10. - Robert says with this patch we are moving readwritetransaction entirely (Sai, 16:48:05)
    11. - colindixon says there are somethings (like increment values) are no more possible with this approach. (Sai, 16:49:32)
    12. - Robert says we still have exclusive ability to write to a subtree (Sai, 16:50:01)
    13. - Robert says we can have an another producer to write to subtree (Sai, 16:50:56)
    14. - Muthu asks will the cardinality of 1:1 will be be enforced on a subtree (Sai, 16:51:54)
    15. - Robert says Yes, At any given time only one producer can write to subtree. (Sai, 16:52:14)
    16. - TOny says using locking mechanism it is possible. (Sai, 16:52:50)
    17. - colindixon summarizes if a data tree is claimed by a procuder , you will be unable to write using netconf/restconf (Sai, 16:53:28)
    18. - Robert says it is true, but it doesn't mean we can't negotiate mechanism, but it is out of the scope of these APIs (Sai, 16:54:49)
    19. - colindixon says there are currently applications which usess single data tree where two producers are writing at same time. (Sai, 16:56:38)
    20. - colindixon says in an application logical part & updation of status is an example (Sai, 16:57:19)
    21. - Robert says intrinsic race condition comes in to picture. (Sai, 16:57:55)
    22. - Robert says the main reason to do is pushing intent in to config and pushing status in to operational (Sai, 16:59:53)
    23. - colindixon refers to difference between networking and Software way of looking at it. (Sai, 17:00:26)
    24. - Robert says the system is never designed or architect-ed for these purposes (Sai, 17:01:39)
    25. - colindixon says when write transaction is done it will fail when if sub tree is gone away or moved. (Sai, 17:05:21)
    26. - Robert requests for use case / applications so that we can move ahead (Sai, 17:05:48)
    27. - Tony rephrases Robert and asks is there is any application in odl which does listening / writing to the same subtree at same time. (Sai, 17:07:23)
    28. ACTION: - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time. (Sai, 17:08:12)

  9. - participants (Sai, 17:08:22)
    1. - Sai / Ryan / Ajay Lele / Alexis / Andrej / Aolin / Martin Ciglan / Muthu / Robert /Shuva Kar / Stephen / Tom P / Tomas Cere / Tony / Vaclav / Viera / Vratko (Sai, 17:09:54)


Meeting ended at 17:09:58 UTC (full logs).

Action items

  1. - Ryan sends out mail / open ticket using helpdesk wrt javax.xml.bind.UnmarshalException (s)
  2. - Ryan to followup with DCL Deprecation [3]
  3. - TomP will start to work on a wiki page to state how to move from config system to BluePrint
  4. - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time.


Action items, by person

  1. colindixon
    1. - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time.
  2. UNASSIGNED
    1. - Ryan sends out mail / open ticket using helpdesk wrt javax.xml.bind.UnmarshalException (s)
    2. - Ryan to followup with DCL Deprecation [3]
    3. - TomP will start to work on a wiki page to state how to move from config system to BluePrint


People present (lines said)

  1. Sai (85)
  2. odl_meetbot (4)
  3. colindixon (1)


Generated by MeetBot 0.1.4.