#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 15:59:38 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai, 16:01:08)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-04-12-16.00.html (Sai, 16:01:12)
    2. - 1.Call for any topics to be added to the agenda that people didn't get around to adding. (Sai, 16:02:00)
    3. 2. Review the existing action items (Sai, 16:02:13)
    4. 3. Modify config Module impls to co-exist with blueprint Patch (Sai, 16:02:26)
    5. 4. Binding v2 spec status binding-v2.adoc - Textual description by Tony; Patch for Bug 1411: Design Binding specification v2 (Sai, 16:02:50)
    6. 5. Akka bump to 2.4.4 Patch (Sai, 16:03:00)
    7. 6. Bug 3866 RESTCONF PATCH Patch (Sai, 16:03:10)

  2. - Review the existing action items (Sai, 16:04:22)
    1. - rgouldin to followup Bug 2515 if it is related to security fix and open bugs as needed. - Done (Sai, 16:04:53)
    2. - Ryan will followup with colin wrt checking out an application in odl where it listens / writes to the same subtree at same time (Sai, 16:05:26)
    3. - wrt Bug 2515 several bugs opened by Ryan - groupbasedpolicy Bug 5750 sfc Bug 5751 tsdr Bug 5752 alto Bug 5753 sdninterfaceapp Bug 5754 centinel Bug 5755 neutron Bug 5757 faas Bug 5758 usecplugin Bug 5759 aaa Bug 5760 snmp4sdn This patch removes the unused references to jersey/jaxrs (Sai, 16:06:20)
    4. ACTION: - Ryan will Will follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) - Ryan will follow up with security folks. (Sai, 16:07:23)

  3. - Modify config Module impls to co-exist with blueprint Patch (Sai, 16:07:52)
    1. - https://git.opendaylight.org/gerrit/#/c/36714/25 (Sai, 16:08:07)
    2. - TomP waiting for Tony for status/consensus on above mentioned patch (Sai, 16:08:51)
    3. - Tony couldn't find time last week, will go through it tomorrow. (Sai, 16:09:17)
    4. - Tony suggests TomP to look in to OpenflowJava / Openflowconfig projects (Sai, 16:18:31)
    5. - TomP asks tony if the comment mentioned by Tony blocks the patch (Sai, 16:20:04)
    6. - Tony says it depends on the projects consuming it. (Sai, 16:20:41)
    7. Robert says he is pretty sure BGP (may be openflow ) uses global config (Sai, 16:21:16)
    8. ACTION: - Tom P to look through downstream consumers to ensure they aren't spinning up their own netty threadgroups (Sai, 16:22:30)

  4. - Binding v2 spec status (Sai, 16:25:15)
    1. - binding-v2.adoc - Textual description by Tony (Sai, 16:25:25)
    2. - https://git.opendaylight.org/gerrit/#/c/37176/1/docs/analysis/binding-v2.adoc (Sai, 16:25:35)
    3. - Tony says that patch is still in draft, not final. (Sai, 16:26:05)
    4. - Patch for Bug 1411: Design Binding specification v2 (Sai, 16:26:54)
    5. - https://git.opendaylight.org/gerrit/#/c/37735/ (Sai, 16:27:03)
    6. - Tony is working on it (Sai, 16:27:23)

  5. - Akka bump to 2.4.4 Patch (Sai, 16:27:46)
    1. - Robert says it should not affect any downstream projects. (Sai, 16:28:08)
    2. - https://git.opendaylight.org/gerrit/#/c/37742/ (Sai, 16:28:18)

  6. - Bug 3866 (Sai, 16:29:08)
    1. - Bug 3866 RESTCONF PATCH (Sai, 16:29:17)
    2. - https://git.opendaylight.org/gerrit/#/c/30554/ (Sai, 16:29:25)
    3. - Martin says they are developing new restconf, so diffferent solution for boron expected when compared to beryllium (Sai, 16:30:04)
    4. -TomP asks if it works for mounted netconf devices (Sai, 16:30:17)
    5. - Tony says it should work (Sai, 16:30:25)
    6. - Robert says it allows to specify RPC request in multiple ways. (Sai, 16:32:00)

  7. - Question on Yangtools (Sai, 16:33:16)
    1. - David karr asks when he seacrhes m2e in eclipse he finds old snapshots (2013), recent ones are there only in md-sal and looking forward to know the difference between two . (Sai, 16:34:06)
    2. - Tony says bundle is always a jar file (Sai, 16:34:31)
    3. - Tony says changing of type shouldn't change anything. (Sai, 16:35:03)
    4. - David Karr sends any additional questions on md-sal (Sai, 16:35:36)

  8. - participants (Sai, 16:36:26)
    1. - Sai/Ryan/Alexis/Andrej/DavidKArr/Filip Gregor/ Martin / Robert/Shuva Kar/ Stephen Kitt/TomP/Tomas/Tony/Vaclav/Viera/Vratko (Sai, 16:37:29)


Meeting ended at 16:37:51 UTC (full logs).

Action items

  1. - Ryan will Will follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) - Ryan will follow up with security folks.
  2. - Tom P to look through downstream consumers to ensure they aren't spinning up their own netty threadgroups


People present (lines said)

  1. Sai (51)
  2. odl_meetbot (4)
  3. colindixon (0)


Generated by MeetBot 0.1.4.