#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 16:00:33 UTC (full logs).

Meeting summary

  1. - last meeting minutes (Sai, 16:00:57)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-04-26-15.59.html (Sai, 16:01:01)

  2. - Agenda (Sai, 16:01:18)
    1. - Call for any topics to be added to the agenda that people didn't get around to adding. (Sai, 16:01:48)
    2. 2. Review the existing action items (Sai, 16:01:58)
    3. 3. Bug 5830 - Mandatory leaf enforcement is not correct with presence container (Sai, 16:02:13)
    4. 4. Bug 5484: Fix of Yang statement lexer (Sai, 16:02:21)
    5. 5. Ubuntu 16.04 LTS - default jdk (Sai, 16:02:39)
    6. 6. Upgrade Jetty 8.1.14.v20131031 -> 8.1.19.v20160209 (Sai, 16:02:49)
    7. 7. RESTCONF Draft upgrade. (Sai, 16:02:59)
    8. 8. Change opendaylight-karaf-distro-archetype to use karaf-parent (Sai, 16:03:11)

  3. - Call for any topics to be added to the agenda that people didn't get around to adding. (Sai, 16:03:54)
    1. - no extra topics as of now (Sai, 16:05:33)

  4. - Review the existing action items (Sai, 16:05:54)
    1. ACTION: - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time. - continue from last week's action item - Ryan digging in to ovsdb stuff, will followup next week. (Sai, 16:06:20)
    2. - Robert to complete Controller M2 status (Sai, 16:06:40)
    3. ACTION: - Tony to send reports regarding controller M2 status (Sai, 16:07:01)
    4. - Ryan will continue to follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) - Done (Sai, 16:07:14)
    5. - Ryan will followup with regarding cluster failures wrt Beryllium-SR2 Test Failures - Done (Sai, 16:07:24)
    6. - Done by Luis & Ryan (Sai, 16:07:42)
    7. ACTION: - Ryan will pull odl-integration-all & update the progress on https://git.opendaylight.org/gerrit/#/c/26323 - Re-evaluating based on later karaf release. (Sai, 16:08:22)
    8. - TomP looks in to error related to https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/756/robot/report/log.html with help of Ryan - DONE by Luis Gomez (Sai, 16:08:40)
    9. - Ryan opens a bug (wrt non-equal objects return) and will file corresponding patch - DONE Bug for transparency/visibility: Bug 5837. (Sai, 16:08:58)
    10. - The change was a blocker for OVSDB; will it affect the outside community who is building their own applications on top of Beryllium? (Sai, 16:09:08)
    11. - Tony says it depends on use case of application (Sai, 16:10:38)
    12. - Downstream customers may be affected. (Sai, 16:11:00)
    13. - colindixon suggests to put it in release notes (Sai, 16:11:20)
    14. ACTION: - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch (Sai, 16:12:18)
    15. ACTION: - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward (Sai, 16:12:32)

  5. - Bug 5837 (Sai, 16:13:22)
    1. - colin asks if it is a API change ? (Sai, 16:13:36)
    2. - Tony says it is a behaviour change but not API change (Sai, 16:14:02)
    3. - colindixon pushes the idea of adding it in release notes. Again. (Sai, 16:14:42)

  6. - Bug 5830 - Mandatory leaf enforcement is not correct with presence container (Sai, 16:14:57)
    1. - https://bugs.opendaylight.org/show_bug.cgi?id=5830 (Sai, 16:15:28)
    2. - if you don't have mandatory leaf node, if closest ancestor exists, then leaf node also should exists. (Sai, 16:16:38)
    3. - Tony agrees that it is a bug (Sai, 16:19:47)
    4. - Please refer to the comments here https://bugs.opendaylight.org/show_bug.cgi?id=5830 (Sai, 16:22:51)
    5. - Robert says at run time we don't have a wait consistently, constraints span across modules. (Sai, 16:26:07)
    6. - If augmentation is used - when someone runs before you run it will blow up. (Sai, 16:28:07)
    7. - Robert says the mandatory leaf should be enforced, whether it is a list item , case, presence container. (Sai, 16:30:25)
    8. - TomP says Robert explanation is logical and proceed further (Sai, 16:32:03)
    9. - Robert thinks it is document in commit or release notes. (Sai, 16:32:28)
    10. ACTION: - Robert to document (release notes ? ) wrt to bug 5830 (Sai, 16:33:05)

  7. - Bug 5484: Fix of Yang statement lexer (Sai, 16:33:54)
    1. - https://git.opendaylight.org/gerrit/#/c/38190/ (Sai, 16:34:03)
    2. https://git.opendaylight.org/gerrit/#/c/28666/ the behavior of mandatory enforcement is described in this comment message as "The presence of mandatory leaves which do not have any ancestors other than structural containers are not enforced as mandatory. The reason for this is that the first transaction on such a DataTree would have to introduce all mandatory leaves, as their non-presence would make other transactions fail consistency chec (colindixon, 16:34:27)
    3. - Fixing of Yang statement lexer (Sai, 16:34:42)
    4. - using regular expressions and quotes we relaxed the yang statement usages (Sai, 16:36:16)

  8. - Ubuntu 16.04 LTS (Sai, 16:36:25)
    1. ACTION: - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu (Sai, 16:37:03)
    2. - TOny says if it is the case then we won't be able to compile. (Sai, 16:37:59)
    3. - Stephen says default package is just a meta package. (Sai, 16:38:44)
    4. - Stephen asks colin to publish or advertise the changing the dynamics of ubuntu / java wrt opendaylight (Sai, 16:41:20)
    5. ACTION: - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight (Sai, 16:42:13)

  9. - Upgrade Jetty 8.1.14.v20131031 -> 8.1.19.v20160209 (Sai, 16:42:32)
    1. - https://git.opendaylight.org/gerrit/#/c/27529/ (Sai, 16:42:42)

  10. - RESTCONF Draft upgrade (Sai, 16:43:24)
    1. - Ryan asks if downstream consumers have to worry about this ? (Sai, 16:43:47)
    2. - TOny says there are lot of difference in uri, existing use cases should continue to work out even if the new draft is rolled out. (Sai, 16:44:34)
    3. - https://git.opendaylight.org/gerrit/#/q/project:netconf+%22Bug+5526%22 (Sai, 16:44:42)
    4. - Tony says payload is similar, but may be the rendering of api may change. (Sai, 16:45:04)

  11. - Change opendaylight-karaf-distro-archetype to use karaf-parent (Sai, 16:46:00)
    1. - https://git.opendaylight.org/gerrit/#/c/38092 (Sai, 16:46:07)
    2. - Patch includes changes to karaf distro to use karaf parent (Sai, 16:46:44)
    3. - TomP says we should not be having any issues when people uses karaf parent in future (Sai, 16:48:09)
    4. - colin suggests the directin may be something like other projects are expected to use karaf parent. (Sai, 16:49:17)
    5. - TomP says we cannot control it, but probably using archetypes maybe lot easier. (Sai, 16:50:00)
    6. https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout (colindixon, 16:50:45)
    7. ACTION: - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc., (Sai, 16:50:51)
    8. - may be here ? https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout (Sai, 16:51:23)
    9. - colindixon suggests everyone should feel free to change the wiki pages (except main pages (only with certain permissions)) so as to have the most updated info at wiki opendaylight. (Sai, 16:53:44)
    10. - weather page has more details regarding karaf parent upgraded to use karaf plugin (Sai, 16:56:02)
    11. - https://wiki.opendaylight.org/view/Weather#Karaf-parent_upgraded_to_use_karaf-plugin (Sai, 16:56:04)
    12. - colindixon asks reason behid why karaf parent shouldn't be a odl-parent ? (Sai, 16:57:18)
    13. - Stephen says he is not aware of it. (Sai, 16:57:49)

  12. - Karaf 3.0.3 to Karaf 3.0.6 (Sai, 16:58:37)
    1. - Stephen moving from 3.0.3 to 4, 5, 6. (Sai, 16:58:53)
    2. - Stephen says he is rebuilding controller, Luis is helpful in fixing distribution (Sai, 16:59:52)
    3. - Stephen says 3.0.6 is released in feb (Sai, 17:00:19)
    4. - 3.0.6 is the latest release of karaf as of now. (Sai, 17:01:34)
    5. - Stephen tries to make the karaf upgrades for Boron as well. (Sai, 17:02:13)

  13. - participants (Sai, 17:02:23)
    1. - Sai /Ryan/Alexis/Colin/ jeff/ Martin / Shuva / Stephen / TomP / Tony / Vaclav Demcak (Sai, 17:03:17)


Meeting ended at 17:03:22 UTC (full logs).

Action items

  1. - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time. - continue from last week's action item - Ryan digging in to ovsdb stuff, will followup next week.
  2. - Tony to send reports regarding controller M2 status
  3. - Ryan will pull odl-integration-all & update the progress on https://git.opendaylight.org/gerrit/#/c/26323 - Re-evaluating based on later karaf release.
  4. - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch
  5. - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward
  6. - Robert to document (release notes ? ) wrt to bug 5830
  7. - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu
  8. - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight
  9. - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc.,


Action items, by person

  1. colindixon
    1. - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time. - continue from last week's action item - Ryan digging in to ovsdb stuff, will followup next week.
    2. - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight
  2. UNASSIGNED
    1. - Tony to send reports regarding controller M2 status
    2. - Ryan will pull odl-integration-all & update the progress on https://git.opendaylight.org/gerrit/#/c/26323 - Re-evaluating based on later karaf release.
    3. - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch
    4. - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward
    5. - Robert to document (release notes ? ) wrt to bug 5830
    6. - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu
    7. - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc.,


People present (lines said)

  1. Sai (87)
  2. colindixon (5)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.