16:00:30 <colindixon> #startmeeting MD-SAL Interest Call
16:00:30 <odl_meetbot> Meeting started Tue Jun 28 16:00:30 2016 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:30 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:00:37 <colindixon> #topic agenda bashing
16:00:48 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-06-21-16.01.html previous week's minutes
16:01:58 <colindixon> #info 1.) Upgrade ietf-{inet,yang}-types to 2013-07-15
16:02:10 <colindixon> #info 2.) Infrastructure Issues; are they solved or ongoing?
16:02:21 <colindixon> #info 3.) Review the new Dashboards
16:02:35 <colindixon> #info 4.) Karaf 3.0.7 upgrade
16:03:49 <colindixon> #topic action items from last week
16:05:37 <colindixon> #action Ryan will followup with Tony regarding M3 status. Tony said it would be done by 06/14/2016
16:06:16 <rgoulding> #link https://wiki.opendaylight.org/view/Using_Blueprint#Application_configuration
16:06:48 <colindixon> #action Alexis and Ryan to update blueprint guide for migration - [IN PROGRESS] - TomP suggests toaster example should be documented. - TomP to work this week and update the progress. (see above link about Application configuration)
16:07:16 <colindixon> #Undo
16:07:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2460c90>
16:07:55 <colindixon> #info Alexis and Ryan updated the blueprint guide for migration with information about the toaster (see above link about Application configuration)
16:08:19 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=6121 LazyDataObject bug opened by Ryan
16:08:32 <colindixon> #action TomP to document in wiki regarding "specific-reference-list" blueprint extension.- corresponding gerrit patch - https://git.opendaylight.org/gerrit/#/c/40267
16:11:06 <rgoulding> #link https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit
16:11:12 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=5973
16:11:45 <colindixon> #info the above two links are about trying to remove very old dependenceis from controller
16:12:05 <colindixon> #action skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we thnk are erroneous at this point)
16:12:36 <colindixon> #topic Upgrade ietf-{inet,yang}-types to 2013-07-15
16:12:47 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Upgrade_ietf-.7Binet.2Cyang.7D-types_to_2013-07-15
16:13:03 <colindixon> #info we need to start merging these patches since M5 is coming
16:13:34 <colindixon> #info e-mail thread has trailed off with no dissent
16:13:59 <colindixon> #Info anipbu asks if there is an order to this, if it needs to be coordinated or can be spread over a few weeks
16:15:57 <colindixon> #info the weahter event expresses dependencies, but people seem unsure if merging earlier patches will break downstream peopel that depend on them, colindixon suspects it will
16:16:41 <colindixon> #info anipbu says it might be easier to have them all +2ed by committers, and then submitted by Thanh relatively all-at-once
16:17:28 <colindixon> #action anipbu to help track this and make sure that we have buy in from everyone
16:17:40 <colindixon> #topic infrastructure instability
16:18:04 <colindixon> #info rgoulding, rovaraga, skitt, and tpantelis all say they're having issues with jenkins jobs being erratic
16:18:28 <colindixon> #info skitt says that single feature tests are taking too long and hitting timeouts
16:18:42 <colindixon> #info that seems to be causing the most of the errorenous issues
16:19:57 <colindixon> #info skitt doesn't know if it's hitting issues because of (a) the more complete karaf we're using since moving to blueprint taking too long to come up, (b) just having feautres repos that are too large and/or, (c) slower CPUs in the private cloud than the public cloud
16:20:28 <colindixon> #info skitt notes that (a) didn't seem to start when that change was made, but it was something that changed
16:21:38 <rgoulding> #link https://lists.opendaylight.org/pipermail/discuss/2016-June/006706.html
16:23:29 <colindixon> #info rgoulding and tpantelis say they're seeing random failures, they could be traced back to slower things and timing issues
16:27:45 <colindixon> #info skitt and tpantelis both note (as well as colindixon) that it seems to be taking up to 10+ minutes to clone occasionally
16:34:12 <colindixon> #link https://jenkins.opendaylight.org/releng/job/controller-distribution-check-beryllium/110/console tpantelis notes that this seems to be failing after the "Reactor Summary:", which is odd
16:34:46 <colindixon> #info rgoulding asks about the timing of this, it's hit just before offset 0 M5, which was pretty brutal, waiting might have been better
16:36:27 <colindixon> #info colindixon says that the past experience is that the only real lull is right after the release for 2-6 weeks
16:37:07 <colindixon> #info colindixon asks people to please send constructive feedback on errors we're seeing and why we think it's infrastructure related, not just assume that zxiiro and tykeal are on it necessarily
16:37:16 <colindixon> #topic Karaf 3.0.7 upgrade
16:37:44 <colindixon> #info skitt says it looks good, he's going to run CSIT on it soon, but it should be merged in Boron, but likely not a few a few weeks
16:38:55 <colindixon> #info skitt says that unless somebody else wants to run with it, skitt would like to not merge it this week (since it's already Tuesday) and he's out on PTO for 3 weeks
16:39:50 <colindixon> #topic new code merge dashboards
16:40:08 <colindixon> #link
16:40:09 <colindixon> https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:mer
16:40:09 <colindixon> NOT+age:7d
16:40:18 <colindixon> #link
16:40:20 <colindixon> #link
16:40:21 <colindixon> #link
16:40:21 <colindixon> #link
16:40:24 <colindixon> #link
16:40:26 <colindixon> #link
16:40:27 <colindixon> #link
16:40:29 <colindixon> #link
16:40:30 <colindixon> #link
16:40:32 <colindixon> #link
16:40:33 <colindixon> #link
16:40:35 <colindixon> #link
16:40:36 <colindixon> #link
16:40:38 <colindixon> #link
16:40:39 <colindixon> #link
16:40:40 <colindixon> #link
16:40:41 <colindixon> #link
16:41:13 <colindixon> #link
16:41:24 <colindixon> test
16:41:26 <colindixon> #link #link
16:41:27 <colindixon> #link #link
16:41:28 <colindixon> #link #link
16:41:30 <colindixon> #link #link
16:41:31 <colindixon> #link #link
16:41:33 <colindixon> #link #link
16:41:34 <colindixon> #link #link
16:41:36 <colindixon> #link #link
16:41:37 <colindixon> #link #link
16:41:39 <colindixon> #link #link
16:41:40 <colindixon> #link #link
16:41:42 <colindixon> #link #link
16:41:43 <colindixon> #link
16:41:45 <colindixon> #link
16:41:46 <colindixon> #link
16:41:48 <colindixon> #link
16:41:49 <colindixon> #link
16:41:51 <colindixon> #link
16:41:52 <colindixon> #link
16:41:54 <colindixon> #link
16:41:55 <colindixon> #link
16:41:57 <colindixon> #link
16:41:58 <colindixon> #link
16:42:00 <colindixon> #link
16:42:01 <colindixon> #link
16:42:03 <colindixon> #link
16:42:04 <colindixon> #link
16:42:06 <colindixon> #link
16:42:07 <colindixon> #link
16:42:08 <colindixon> #link
16:42:09 <colindixon> #link
16:43:03 <colindixon> #info trying to send the links into IRC seems to have massively blown up my IRC client's sending messages
16:44:02 <colindixon> #link https://wiki.opendaylight.org/index.php?title=MD-SAL_Weekly_Call&oldid=47278#Upcoming_Agenda_Topics the querieis are in the "This Week" section here
16:45:21 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/40520
16:45:43 <colindixon> #info there's some interesting patches coming across, that allow for minimial local builds to save time, also hot redeploys
16:48:15 <rgoulding> #info from Martin: only 36 seconds build time for Yangtools with -Pq active :)
17:01:41 <colindixon> #info lots of discussion of pathces, mostly inofrmational about new cool things available now
17:01:43 <colindixon> #endmeeting